Kirjoittaja Aihe: [Ratkaistu] Gambas ei käynnisty Xubuntulla  (Luettu 465 kertaa)

Snufkin

  • Käyttäjä
  • Viestejä: 263
    • Profiili
[Ratkaistu] Gambas ei käynnisty Xubuntulla
« : 29.09.21 - klo:14.17 »
Moi!

Haluaisin kokeilla tuota Gambas - visual basicia, mutta ei lähde lainkaan käytniin Xubuntussa (20.04).  Onkohan mulla vika jossain asetuksissa vai eikö vain toimi tässä jakelussa?
« Viimeksi muokattu: 29.09.21 - klo:19.06 kirjoittanut Snufkin »

nm

  • Käyttäjä
  • Viestejä: 14998
    • Profiili
Vs: Gambas ei käynnisty Xubuntulla
« Vastaus #1 : 29.09.21 - klo:14.35 »
Eli gambas3-ide on nyt asennettuna Ubuntun pakettilähteestä? Se varmaankin herjaa puuttuvasta komponentista "gb.form.print", jos yrität käynnistää päätteen kautta komennolla gambas3?

Koodia: [Valitse]
gambas3
Lainaus
gbr3: unable to load component: gb.form.print

Korjaa vika asentamalla puuttuva paketti:

Koodia: [Valitse]
sudo apt install gambas3-gb-form-print

Bugi on korjattu Ubuntu 20.10:ssä ja uudemmissa jakeluissa, mutta 20.04:ään korjausta ei ole tuotu.
https://bugs.launchpad.net/ubuntu/+source/gambas3/+bug/1876450
https://forum.gambas.one/viewtopic.php?t=894

Jos kehitysympäristössä ilmenee muita ongelmia, kannattanee kokeilla uudempaa versiota tästä PPA:sta: https://launchpad.net/~gambas-team/+archive/ubuntu/gambas3
« Viimeksi muokattu: 29.09.21 - klo:14.36 kirjoittanut nm »

Snufkin

  • Käyttäjä
  • Viestejä: 263
    • Profiili
Vs: Gambas ei käynnisty Xubuntulla
« Vastaus #2 : 29.09.21 - klo:14.46 »
Joo, kiitos neuvoista. Nyt lähti pelaamaan. Se ei tuo graafinen käynnistys herjannut mitään, mutta komentoriviltä sitten kyllä juuri noin.