Kirjoittaja Aihe: KMahjong ei toimi mun Ubuntu 20.04:ssa [Ratkaistu]  (Luettu 467 kertaa)

Samanta

  • Käyttäjä
  • Viestejä: 59
    • Profiili
Latasin/asensin Ubuntu 20.04 LTS koneelle Ubuntu Software:sta KMahjong (Solitaire) lautapelin, 88 Mt. Peli ei toimi Ubuntu-koneella ollenkaan. Ubuntu-koneessa tulee ruutuun vain pelin tyhjä aloitusraami, mutta siinä pystyy asetuksissa laitamaan vain kielen, mikään muu ei toimi ja peli ei lataudu. Sama peli mun Manjaro koneella toimii Ok,  latasin sen Manjaron virallisista pakettilähteistä.

Yritin Ubuntu-koneella ratkaista tätä ongelmaa näillä ohjeilla https://www.linuxquestions.org/questions/linux-newbie-8/i-recently-installed-ubuntu-20-04-and-need-the-kmahjongg-library-to-activate-game-4175674915/ ,muta tulos oli negatiivinen.

Yksi tähän vastanneista (ehertman) arveli, että: ''... KMahjong sounds like it needs (at least parts of) the KDE/Plasma desktop to be installed, Which isn't installed by default in Ubuntu (though probably is in Kubuntu, the version with the KDE/Plasma DE). I'm not familiar enough with Ubuntu to know how to pull that in, but it is possible to install it alongside the gdm/gnome Ubuntu one.
Real Ubuntu users will have to help you further with this. ...''

Tämä pulma on ollut minulla ennekin. Joskus sain sen ladattua Ubuntu 18.04:een KDE Games:n sivuilta osana isompaa pelipakettia, josta sitten poistin muut, mutta nyt en enää löydä sitä pelipakettia. Samapeli on vieläkin KDE Games:n listoilla ja ladattavissa .git pakettina, joka vaatii koostamista ja porttaamista, kts. https://games.kde.org/download/.

Mutta löytyisikö helpompaa konstia, kun tämä peli kuitenkin on Ubuntu Software:n listalla ?



« Viimeksi muokattu: 01.04.21 - klo:18.51 kirjoittanut Samanta »

Outolintu

  • Käyttäjä
  • Viestejä: 139
    • Profiili
Vs: KMahjong ei toimi mun Ubuntu 20.04:ssa
« Vastaus #1 : 27.03.21 - klo:17.35 »
Sama juttu Ubuntu 20.10 versiossa, pelkkä tyhjä ikkuna.
Groovy

SuperOscar

  • Käyttäjä
  • Viestejä: 3686
  • Tänään täällä, huomenna poissa
    • Profiili
    • Legisign.org
Vs: KMahjong ei toimi mun Ubuntu 20.04:ssa
« Vastaus #2 : 27.03.21 - klo:18.31 »
Lähdin kokeilemaan Ubuntu 20.04 -virtuaalikoneessa. Ainakaan kirjastoista ei pitäisi jäädä puuttumaan, koska  tavaraa asentuu 254 megatavua.

Käy mielessä, olisiko Wayland/X-ongelma. Ajatteko Gnomea(?) Waylandissä?

Koodia: [Valitse]
tn@ullmann% sudo apt install kmahjongg
[sudo] tn-käyttäjän salasana:
Luetaan pakettiluetteloita... Valmis
Muodostetaan riippuvuussuhteiden puu       
Luetaan tilatiedot... Valmis       
Seuraavat lisäpaketit asennetaan:
  docbook-xsl kdegames-mahjongg-data-kf5 kdoctools5 keditbookmarks khelpcenter
  kinit kio kpackagelauncherqml kpackagetool5 kwayland-data
  kwayland-integration libaribb24-0 libbasicusageenvironment1 libcddb2
  libdbusmenu-qt5-2 libdc1394-22 libdca0 libdouble-conversion3 libdvbpsi10
  libebml4v5 libfaad2 libfam0 libgrantlee-templates5 libgroupsock8 libixml10
  libkate1 libkf5archive5 libkf5attica5 libkf5auth-data libkf5authcore5
  libkf5bookmarks-data libkf5bookmarks5 libkf5codecs-data libkf5codecs5
  libkf5completion-data libkf5completion5 libkf5config-bin libkf5config-data
  libkf5configcore5 libkf5configgui5 libkf5configwidgets-data
  libkf5configwidgets5 libkf5coreaddons-data libkf5coreaddons5 libkf5crash5
  libkf5dbusaddons-bin libkf5dbusaddons-data libkf5dbusaddons5
  libkf5declarative-data libkf5declarative5 libkf5doctools5
  libkf5globalaccel-bin libkf5globalaccel-data libkf5globalaccel5
  libkf5globalaccelprivate5 libkf5guiaddons5 libkf5i18n-data libkf5i18n5
  libkf5iconthemes-bin libkf5iconthemes-data libkf5iconthemes5 libkf5idletime5
  libkf5itemviews-data libkf5itemviews5 libkf5jobwidgets-data
  libkf5jobwidgets5 libkf5js5 libkf5kdegames-data libkf5kdegames7
  libkf5khtml-bin libkf5khtml-data libkf5khtml5 libkf5kiocore5 libkf5kiogui5
  libkf5kiontlm5 libkf5kiowidgets5 libkf5kirigami2-5 libkf5kmahjongglib-data
  libkf5kmahjongglib5 libkf5newstuff-data libkf5newstuff5 libkf5newstuffcore5
  libkf5notifications-data libkf5notifications5 libkf5package-data
  libkf5package5 libkf5parts-data libkf5parts-plugins libkf5parts5
  libkf5quickaddons5 libkf5service-bin libkf5service-data libkf5service5
  libkf5solid5 libkf5solid5-data libkf5sonnet5-data libkf5sonnetcore5
  libkf5sonnetui5 libkf5textwidgets-data libkf5textwidgets5 libkf5wallet-bin
  libkf5wallet-data libkf5wallet5 libkf5waylandclient5
  libkf5widgetsaddons-data libkf5widgetsaddons5 libkf5windowsystem-data
  libkf5windowsystem5 libkf5xmlgui-bin libkf5xmlgui-data libkf5xmlgui5
  libkwalletbackend5-5 liblivemedia77 liblua5.2-0 libmad0 libmatroska6v5
  libmpcdec6 libopenal-data libopenal1 libopenmpt-modplug1 libpcre2-16-0
  libphonon4qt5-4 libphonon4qt5-data libplacebo7 libpolkit-qt5-1-1
  libprotobuf-lite17 libproxy-tools libqt5core5a libqt5dbus5 libqt5gui5
  libqt5network5 libqt5printsupport5 libqt5qml5 libqt5quick5
  libqt5quickcontrols2-5 libqt5quicktemplates2-5 libqt5quickwidgets5
  libqt5svg5 libqt5test5 libqt5texttospeech5 libqt5waylandclient5
  libqt5waylandcompositor5 libqt5widgets5 libqt5x11extras5 libqt5xml5
  libresid-builder0c2a libsdl-image1.2 libsdl1.2debian libsidplay2 libsndio7.0
  libspatialaudio0 libsrt1 libssh2-1 libupnp13 libusageenvironment3
  libva-wayland2 libvlc-bin libvlc5 libvlccore9 libxapian30 libxcb-xinerama0
  libxcb-xinput0 libxml2-utils phonon4qt5 phonon4qt5-backend-vlc
  qml-module-org-kde-kirigami2 qml-module-org-kde-kquickcontrolsaddons
  qml-module-org-kde-newstuff qml-module-qtgraphicaleffects
  qml-module-qtqml-models2 qml-module-qtquick-controls2
  qml-module-qtquick-templates2 qml-module-qtquick-window2 qml-module-qtquick2
  qt5-gtk-platformtheme qttranslations5-l10n qtwayland5 sonnet-plugins
  vlc-data vlc-plugin-base vlc-plugin-video-output
Ehdotetut paketit:
  dbtoepub docbook-xsl-doc-html | docbook-xsl-doc-pdf | docbook-xsl-doc-text
  | docbook-xsl-doc docbook-xsl-saxon fop libsaxon-java libxalan2-java
  libxslthl-java xalan fam libportaudio2 qt5-image-formats-plugins
  qt5-qmltooling-plugins sndiod xapian-tools phonon4qt5-backend-gstreamer
  hspell libdvdcss2
Seuraavat UUDET paketit asennetaan:
  docbook-xsl kdegames-mahjongg-data-kf5 kdoctools5 keditbookmarks khelpcenter
  kinit kio kmahjongg kpackagelauncherqml kpackagetool5 kwayland-data
  kwayland-integration libaribb24-0 libbasicusageenvironment1 libcddb2
  libdbusmenu-qt5-2 libdc1394-22 libdca0 libdouble-conversion3 libdvbpsi10
  libebml4v5 libfaad2 libfam0 libgrantlee-templates5 libgroupsock8 libixml10
  libkate1 libkf5archive5 libkf5attica5 libkf5auth-data libkf5authcore5
  libkf5bookmarks-data libkf5bookmarks5 libkf5codecs-data libkf5codecs5
  libkf5completion-data libkf5completion5 libkf5config-bin libkf5config-data
  libkf5configcore5 libkf5configgui5 libkf5configwidgets-data
  libkf5configwidgets5 libkf5coreaddons-data libkf5coreaddons5 libkf5crash5
  libkf5dbusaddons-bin libkf5dbusaddons-data libkf5dbusaddons5
  libkf5declarative-data libkf5declarative5 libkf5doctools5
  libkf5globalaccel-bin libkf5globalaccel-data libkf5globalaccel5
  libkf5globalaccelprivate5 libkf5guiaddons5 libkf5i18n-data libkf5i18n5
  libkf5iconthemes-bin libkf5iconthemes-data libkf5iconthemes5 libkf5idletime5
  libkf5itemviews-data libkf5itemviews5 libkf5jobwidgets-data
  libkf5jobwidgets5 libkf5js5 libkf5kdegames-data libkf5kdegames7
  libkf5khtml-bin libkf5khtml-data libkf5khtml5 libkf5kiocore5 libkf5kiogui5
  libkf5kiontlm5 libkf5kiowidgets5 libkf5kirigami2-5 libkf5kmahjongglib-data
  libkf5kmahjongglib5 libkf5newstuff-data libkf5newstuff5 libkf5newstuffcore5
  libkf5notifications-data libkf5notifications5 libkf5package-data
  libkf5package5 libkf5parts-data libkf5parts-plugins libkf5parts5
  libkf5quickaddons5 libkf5service-bin libkf5service-data libkf5service5
  libkf5solid5 libkf5solid5-data libkf5sonnet5-data libkf5sonnetcore5
  libkf5sonnetui5 libkf5textwidgets-data libkf5textwidgets5 libkf5wallet-bin
  libkf5wallet-data libkf5wallet5 libkf5waylandclient5
  libkf5widgetsaddons-data libkf5widgetsaddons5 libkf5windowsystem-data
  libkf5windowsystem5 libkf5xmlgui-bin libkf5xmlgui-data libkf5xmlgui5
  libkwalletbackend5-5 liblivemedia77 liblua5.2-0 libmad0 libmatroska6v5
  libmpcdec6 libopenal-data libopenal1 libopenmpt-modplug1 libpcre2-16-0
  libphonon4qt5-4 libphonon4qt5-data libplacebo7 libpolkit-qt5-1-1
  libprotobuf-lite17 libproxy-tools libqt5core5a libqt5dbus5 libqt5gui5
  libqt5network5 libqt5printsupport5 libqt5qml5 libqt5quick5
  libqt5quickcontrols2-5 libqt5quicktemplates2-5 libqt5quickwidgets5
  libqt5svg5 libqt5test5 libqt5texttospeech5 libqt5waylandclient5
  libqt5waylandcompositor5 libqt5widgets5 libqt5x11extras5 libqt5xml5
  libresid-builder0c2a libsdl-image1.2 libsdl1.2debian libsidplay2 libsndio7.0
  libspatialaudio0 libsrt1 libssh2-1 libupnp13 libusageenvironment3
  libva-wayland2 libvlc-bin libvlc5 libvlccore9 libxapian30 libxcb-xinerama0
  libxcb-xinput0 libxml2-utils phonon4qt5 phonon4qt5-backend-vlc
  qml-module-org-kde-kirigami2 qml-module-org-kde-kquickcontrolsaddons
  qml-module-org-kde-newstuff qml-module-qtgraphicaleffects
  qml-module-qtqml-models2 qml-module-qtquick-controls2
  qml-module-qtquick-templates2 qml-module-qtquick-window2 qml-module-qtquick2
  qt5-gtk-platformtheme qttranslations5-l10n qtwayland5 sonnet-plugins
  vlc-data vlc-plugin-base vlc-plugin-video-output
0 päivitetty, 182 uutta asennusta, 0 poistettavaa ja 8 päivittämätöntä.
Noudettavaa arkistoa 52,1 Mt/52,1 Mt.
Toiminnon jälkeen käytetään 254 M t lisää levytilaa.
Haluatko jatkaa? [K/e]
openSUSE Leap 15.2 (pöytäkone 1, kannettavat 1, 2 & 3), openSUSE Tumbleweed (pöytäkone 2), LibreELEC 8.2.5 (RPi 1), Ubuntu 20.04 LTS (RPi 2)

juyli

  • Käyttäjä / moderaattori
  • Viestejä: 503
    • Profiili
Vs: KMahjong ei toimi mun Ubuntu 20.04:ssa
« Vastaus #3 : 27.03.21 - klo:19.10 »
Latasin/asensin Ubuntu 20.04 LTS koneelle Ubuntu Software:sta KMahjong (Solitaire) lautapelin, 88 Mt. Peli ei toimi Ubuntu-koneella ollenkaan.
KMahjong on nimenomaan KDE-työpöydälle tarkoitettu versio. Sen toki pitäisi toimia muillakin työpöydillä, mutta tuolloin ladataan paljon KDE-sälää riippuvuuksina.
Muita vaihtoehtojakin olisi tarjolla:
gnome-mahjongg tai xmahjongg
Aihetta voi myös lähestyä:
https://packages.ubuntu.com/search?keywords=mahjong&searchon=names&suite=focal&section=all
Itse en asentaisi Ubuntu-versioon KMahjong -versiota.

SuperOscar

  • Käyttäjä
  • Viestejä: 3686
  • Tänään täällä, huomenna poissa
    • Profiili
    • Legisign.org
Vs: KMahjong ei toimi mun Ubuntu 20.04:ssa
« Vastaus #4 : 27.03.21 - klo:21.04 »
Hieman kauan kesti virtuaalikoneessa asennus (ei pakettien haku vaan nimenomaan purkaminen), mutta sen jälkeen KMahjongg toimi Ubuntu 20.04:ssa ongelmitta. Luulisin että ensiksi kannattaa tarkistaa, että kaikki tarvittavat paketit on asennettu. aptilla asennettaessa tosin niiden pitäisi tulla automaattisesti.
openSUSE Leap 15.2 (pöytäkone 1, kannettavat 1, 2 & 3), openSUSE Tumbleweed (pöytäkone 2), LibreELEC 8.2.5 (RPi 1), Ubuntu 20.04 LTS (RPi 2)

Samanta

  • Käyttäjä
  • Viestejä: 59
    • Profiili
Vs: KMahjong ei toimi mun Ubuntu 20.04:ssa [Ratkaistu]
« Vastaus #5 : 01.04.21 - klo:18.47 »
@SuperOskar, Kiitos neuvosta ! En ehtinyt tämän kimppuun aiemmin. Oikein toimivan version asennus aptilla onnistui eli sudo apt install kmahjongg asensi 69 pakettia yht 109 Mt. Kun poistin Ubuntu Softwaren ei-toimivan paketin (88 Mt), niin lisätilaa tarvittiin tähän 21 Mt.  :) :) :)

Ps. En käytä Waylandia tässä Ubuntu 20.04 koneessa.

« Viimeksi muokattu: 02.04.21 - klo:10.24 kirjoittanut Samanta »