Kirjoittaja Aihe: Clamtk asentaminen  (Luettu 1258 kertaa)

liptus32

  • Käyttäjä
  • Viestejä: 12
    • Profiili
Clamtk asentaminen
« : 04.02.21 - klo:17.29 »
Kuinka hitossa tuon ClamTKn saa asennettua. Netistä löytyy pilvin pimein komentoja joita olen kokeillut. Ei ole vielä onnistanut. Löytyy myös Ubuntun pakettivarastosta, mutta ei sieltäkään suostu asentumaan. Voisiko joku joka tietää vääntää ohjeen ihan rautalangasta.

toivoo Artsi

nm

  • Käyttäjä
  • Viestejä: 14639
    • Profiili
Vs: Clamtk asentaminen
« Vastaus #1 : 04.02.21 - klo:17.44 »
Koodia: [Valitse]
sudo apt install clamtk
Jos ei heti ilmesty sovellusvalikkoon, käynnistyy komentoriviltä:

Koodia: [Valitse]
clamtk

ClamAV ei sitten välttämättä ole kovin kattava virustutka, vaikka onkin paras (ja melkeinpä ainoa) avoin vaihtoehto. Parempaa suojaa saa kaupallisilla tai suljetuilla sovelluksilla. Esimerkiksi Sophos Antivirus for Linux on ilmainen ja toimiva vaihtoehto.

Pendeli

  • Käyttäjä
  • Viestejä: 646
    • Profiili
Vs: Clamtk asentaminen
« Vastaus #2 : 04.02.21 - klo:21.41 »
Ajoin uteliaisuuttani Clamtk-tarkistuksen. Se löysi muutamia kohteita kotikansiossa /.cache/mozilla/firefox
joiden kaikkien statukseksi oli merkattu:
pua.win.exploit.cve_2012_1461-1
Googlettamalla selviää tuon olevan melko yleinen tulos
ja jossain mainittiin niiden tulevan uBlock Originin käyttämisestä.
Ei liene mitään vaaraa noista?

liptus32

  • Käyttäjä
  • Viestejä: 12
    • Profiili
Vs: Clamtk asentaminen
« Vastaus #3 : 05.02.21 - klo:09.48 »
Tuota sudo apt install clamtk komentoa luonnollisesti käytin aivan ensin. Ei onnistu Ilmoittaa mm. että joitakin paketteja ei voitu asentaa. On kuulemma vaadittu mahdottomia tai käytetty epävakaata jakelua. Paketteja ei ole vielä luotu tai siirretty  Incoming-kansiosta?? Ilmoittaa myös, että libsjon perl ei ole asennuskelpoinen.?? Pulmia ei voi korjata, rikkinäisiä paketteja on pysytetty??
Miksi ClamTk on Ubuntun pakettivalikoimass ku asennus ei onnistu?

nm

  • Käyttäjä
  • Viestejä: 14639
    • Profiili
Vs: Clamtk asentaminen
« Vastaus #4 : 05.02.21 - klo:10.35 »
Tuota sudo apt install clamtk komentoa luonnollisesti käytin aivan ensin. Ei onnistu Ilmoittaa mm. että joitakin paketteja ei voitu asentaa. On kuulemma vaadittu mahdottomia tai käytetty epävakaata jakelua. Paketteja ei ole vielä luotu tai siirretty  Incoming-kansiosta?? Ilmoittaa myös, että libsjon perl ei ole asennuskelpoinen.?? Pulmia ei voi korjata, rikkinäisiä paketteja on pysytetty??

Järjestelmässäsi on jokin ongelma, joka saattaa johtua epävirallisista pakettilähteistä tai aiemmin pieleen menneestä jakelupäivityksestä. Kopioi tuo koko listaus päätteestä tänne, niin on helpompi hahmottaa, mistä on kyse.

Mitä apt herjaa, jos yrität asentaa libjson-perlin?

Koodia: [Valitse]
sudo apt install libjson-perl
Mikä Ubuntun versio on kyseessä?


Miksi ClamTk on Ubuntun pakettivalikoimass ku asennus ei onnistu?

Kohtaamasi asennusongelma koskee omaa järjestelmääsi, eikä yleisesti Ubuntua.

liptus32

  • Käyttäjä
  • Viestejä: 12
    • Profiili
Vs: Clamtk asentaminen
« Vastaus #5 : 05.02.21 - klo:11.20 »
Ilmoittaa, että pakettia libjson ei löydy.
Käyttämäni versio on Ubuntu 20.04.1 LTS

nm

  • Käyttäjä
  • Viestejä: 14639
    • Profiili
Vs: Clamtk asentaminen
« Vastaus #6 : 05.02.21 - klo:11.25 »
Ilmoittaa, että pakettia libjson ei löydy.

Varmista, että kirjoitat paketin nimen oikein. libjson-perl väliviivalla ilman välilyöntejä.

Komennot voi myös kopioida suoraan täältä selaimesta päätteeseen, niin ei tule virhelyöntejä. Päätteessä liittäminen onnistuu valikon kautta tai näppäinyhdistelmällä Shift+Ctrl+V
Kopiointi tapahtuu maalaamalla teksti hiirellä ja painamalla sitten Shift+Ctrl+C
Selaimessa toimii normaalit Ctrl+C ja Ctrl+V -näppäinkomennot.
« Viimeksi muokattu: 05.02.21 - klo:11.28 kirjoittanut nm »

liptus32

  • Käyttäjä
  • Viestejä: 12
    • Profiili
Vs: Clamtk asentaminen
« Vastaus #7 : 05.02.21 - klo:12.02 »
Kopiointia en saanut onnistumaan joten kirjoitan vastauksen jonka sain tuohon komentoon.
Muodostetaan riippuvuussuhteiden puu
"Luetaan tilatiedot... Valmis
Joitakin paketteja ei voitu asentaa. On ehkä vaadittu mahdottomia tai,
jos käytetään epävakaata jakelua, joitakin vaadittuja paketteja ei ole
vielä luotu tai siirretty Incoming-kansiosta.
Seuraavista tiedoista voi olla hyötyä selvitettäessä tilannetta:
Näillä paketeilla on tyydyttämättömiä riippuvuuksia:
clamtk : Riippuvuudet. libjson-perl mutta ei ole asennuskelpoinen
Pulmia ei voi korjata, rikkinäisiä paketteja on pysytetty"

Ganymedes

  • Käyttäjä
  • Viestejä: 3915
    • Profiili
Vs: Clamtk asentaminen
« Vastaus #8 : 05.02.21 - klo:12.39 »
Auttaisiko tämä?

https://www.maketecheasier.com/fix-broken-packages-ubuntu/

Heti alussa on korjailuneuvoja.

matsukan

  • Käyttäjä
  • Viestejä: 2126
    • Profiili
Vs: Clamtk asentaminen
« Vastaus #9 : 05.02.21 - klo:12.41 »
Virtustorjunta softat kuten clamtk on tarkoitettu etupäässä sähköpostipalvelimien käyttöön joissa se seuloo viruksia pois windows käyttäjiä silmällä pitäen.

Linux:ssa ja Ubuntun desktop käyttäjiä varten tätä on turha asentaa.
Pohjois-pohjanmaa
-- motto:  backupin tarve huomataan aina liian myöhään

mpiso

  • Käyttäjä
  • Viestejä: 551
    • Profiili
Vs: Clamtk asentaminen
« Vastaus #10 : 05.02.21 - klo:13.17 »
Ajoin uteliaisuuttani Clamtk-tarkistuksen. Se löysi muutamia kohteita kotikansiossa /.cache/mozilla/firefox
joiden kaikkien statukseksi oli merkattu:
pua.win.exploit.cve_2012_1461-1
Googlettamalla selviää tuon olevan melko yleinen tulos
ja jossain mainittiin niiden tulevan uBlock Originin käyttämisestä.
Ei liene mitään vaaraa noista?

Ainakin minulla ClamTk löydökset ovat olleet yksinomaan vääriä. Kannattaa tarkistaa löydetyt netissä muillakin virustutkilla.

https://virusscan.jotti.org/

nm

  • Käyttäjä
  • Viestejä: 14639
    • Profiili
Vs: Clamtk asentaminen
« Vastaus #11 : 05.02.21 - klo:13.38 »
Kopiointia en saanut onnistumaan joten kirjoitan vastauksen jonka sain tuohon komentoon.

Eli ensin maalataan kopioita teksti hiirellä, ja sitten näppäimistöllä sormiakrobatiaa, eli painetaan ensin Shift pohjaan, sitten Ctrl, pitäen edelleen Shift painettuna, ja sitten vielä C pitäen pienen hetken kaikki kolme samaan aikaan painettuna. Liittäminen selaimeen onnistuu ilman shiftiä tavallisella Ctrl ja V -näppäinyhdistelmällä.

Voit myös kopioida päätteen valikon kautta, kun kopioitava teksti on ensin maalattu.

Muodostetaan riippuvuussuhteiden puu
"Luetaan tilatiedot... Valmis
Joitakin paketteja ei voitu asentaa. On ehkä vaadittu mahdottomia tai,
jos käytetään epävakaata jakelua, joitakin vaadittuja paketteja ei ole
vielä luotu tai siirretty Incoming-kansiosta.
Seuraavista tiedoista voi olla hyötyä selvitettäessä tilannetta:
Näillä paketeilla on tyydyttämättömiä riippuvuuksia:
clamtk : Riippuvuudet. libjson-perl mutta ei ole asennuskelpoinen
Pulmia ei voi korjata, rikkinäisiä paketteja on pysytetty"

Niin tämä tuli ilmeisesti clamtk:n asennusyrityksestä. Ongelman selvittämiseksi pitää seurata riippuvuuksia eteenpäin, eli koska libjson-perlin asentamisessa on jotain vikaa, yritetään asentaa se seuraavaksi suoraan apt:llä, niin saadaan pykälän verran tarkempaa tietoa ongelmasta.

Poista ensin vajaasti asentunut clamtk:

Koodia: [Valitse]
sudo apt purge clamtk
Ja yritä sitten asentaa libjson-perl. Mitä apt herjaa tästä:

Koodia: [Valitse]
sudo apt install libjson-perl
« Viimeksi muokattu: 05.02.21 - klo:13.42 kirjoittanut nm »

liptus32

  • Käyttäjä
  • Viestejä: 12
    • Profiili
Vs: Clamtk asentaminen
« Vastaus #12 : 05.02.21 - klo:17.04 »
Ilmoittaa, että" pakettia libjson-perl ei ole saatavilla, mutta toinen paketti viittaa siihen.
Tämä voi tarkoittaa paketin puuttuvan, olevan vanhentunut tai
saatavilla vain jostain muusta lähteestä
Paketille libjson-perl ei löydy ehdotettavia asennettavia versioita"

matsukan

  • Käyttäjä
  • Viestejä: 2126
    • Profiili
Vs: Clamtk asentaminen
« Vastaus #13 : 05.02.21 - klo:17.42 »

Sinulla on mahdollisesti käytössä jokin kolmannen osapuolen ppa lähde olemassa mistä tuo riippuvuus ?
Pohjois-pohjanmaa
-- motto:  backupin tarve huomataan aina liian myöhään

nm

  • Käyttäjä
  • Viestejä: 14639
    • Profiili
Vs: Clamtk asentaminen
« Vastaus #14 : 05.02.21 - klo:18.05 »
Ilmoittaa, että" pakettia libjson-perl ei ole saatavilla, mutta toinen paketti viittaa siihen.
Tämä voi tarkoittaa paketin puuttuvan, olevan vanhentunut tai
saatavilla vain jostain muusta lähteestä
Paketille libjson-perl ei löydy ehdotettavia asennettavia versioita"

libjson-perl kuuluu Ubuntun main-repositorioon, joten virheilmoitus viittaa siihen, että päärepositorio on poistettu käytöstä järjestelmässäsi.

Avaa sovellus Ohjelmistot ja päivitykset ja varmista, että ensimmäisellä välilehdellä (Ubuntu-ohjelmistot) on valittuna "Canonicalin tukemat vapaat ja avoimen lähdekoodin ohjelmistot (main)". Samalla välilehdellä myös universe, restricted  ja multiverse -lähteet kannattaa kytkeä käyttöön, jos eivät jo ole.

Poista valinta kohdasta "Asennettavissa CD-/DVD-levyllä", jotta kaikki paketit haetaan internetistä, eikä yritetä käyttää Ubuntun asennuslevyä.


Tässä netistä löytynyt kuvakaappaus vanhasta Ubuntu 14.04:stä. Nykyisissä versioissa on kuitenkin samat asetukset:

« Viimeksi muokattu: 05.02.21 - klo:18.08 kirjoittanut nm »

liptus32

  • Käyttäjä
  • Viestejä: 12
    • Profiili
Vs: Clamtk asentaminen
« Vastaus #15 : 05.02.21 - klo:19.09 »
Vihdoin onnistui. Lötyivät livepatch-asetuksista. Kohdasta Canonicalin tukemat... puuttui ruksi.
Kiitoksia kovasti avusta. Ilman ClamTk:takin olisin varmaan pärjännyt, mutta alkoi ärsytäämään kun
en saanut asennettua. Olen aloitteleva Linux-käyttäjä jolla on vielä paljon opittavaa. Meillä oli
vanha jo käytöstä poistettu Lenovo, jonka palautin hyötykäyttöön asentamalla siihen Ubuntun.

jekku

  • Käyttäjä
  • Viestejä: 2624
    • Profiili
Vs: Clamtk asentaminen
« Vastaus #16 : 06.02.21 - klo:08.09 »
Jos haluat hoitaa nuo ylläpitohommat helposti, niin kahlaapa nuo läpi :)

https://www.linux.fi/wiki/Komentorivin_perusteet
https://linux.fi/wiki/Komentorivikomennot