Kirjoittaja Aihe: Ubuntun asennusongelma asus x541u läppäriin RATKAISTU  (Luettu 699 kertaa)

karimarkku66

  • Käyttäjä
  • Viestejä: 136
    • Profiili
Koetan asentaa uusinta ubuntuversiota kyseiseen läppäriin ja asentuminen tyssää update and other software osioon. Asensin ubuntun kahdelle eri usb tikulle,kun oletin toisen olevan rikki, mutta kummallakin asennus pysähtyy tuohon, ensin yritin wifi verkon kautta, mutta aikansa pyörittyään kadotti sen ja asennus ei edennyt.
Sitten laitoin netin kaapelin välityksellä ja asennus jumittuu siltikin tuohon osioon.

Koneessa toimii vain sininen usb portti, eli usb 3.0. usb 2 on pimeänä,sillä windowatilassa se herjasi ettei laite toimi oikein.

Onko tuolla portin valinnalla merkitystä asennukseen?
« Viimeksi muokattu: 25.03.21 - klo:11.50 kirjoittanut karimarkku66 »

nm

  • Käyttäjä
  • Viestejä: 14265
    • Profiili
Vs: Ubuntun asennusongelma asus x541u läppäriin
« Vastaus #1 : 23.03.21 - klo:09.48 »
Kokeile asentaa ilman nettiyhteyttä.

karimarkku66

  • Käyttäjä
  • Viestejä: 136
    • Profiili
Vs: Ubuntun asennusongelma asus x541u läppäriin
« Vastaus #2 : 23.03.21 - klo:14.36 »
Ei auttanut asiaan ilman nettiäkään, asennus kyllä eteni aina käyttäjänimen ja salasan luontiin asti ja sitten jumittui.
Huomasin kyllä sellaisen seikan, ettei usb tikkua voinut käyttää livetikkuna, tuli vain mustalle ruudulle pitkä litania pcierror jotain, teki saman myös toisella tikulla.
Olisiko dvd asennus vaihtoehto tuohon, kun normi usb portti ei toimi?

nm

  • Käyttäjä
  • Viestejä: 14265
    • Profiili
Vs: Ubuntun asennusongelma asus x541u läppäriin
« Vastaus #3 : 23.03.21 - klo:17.27 »
Ei auttanut asiaan ilman nettiäkään, asennus kyllä eteni aina käyttäjänimen ja salasan luontiin asti ja sitten jumittui.
Huomasin kyllä sellaisen seikan, ettei usb tikkua voinut käyttää livetikkuna, tuli vain mustalle ruudulle pitkä litania pcierror jotain, teki saman myös toisella tikulla.
Olisiko dvd asennus vaihtoehto tuohon, kun normi usb portti ei toimi?

Jumiutuminen ja se, ettei livetila käynnisty, viittaavat näytönohjaimen ajurin vikaan. Koneessa taitaa olla Intelin prosessoriin integroidun näytönohjaimen lisäksi Nvidian näytönohjain, jolloin avoin Nouveau-ajuri voi hyvinkin aiheuttaa tuollaisia ongelmia.

Tässä tilanteessa kannattaa kokeilla kytkeä nouveau-ajuri pois käytöstä. Se tapahtuu GRUB-käynnistysvalikon kautta, eli siitä mustavalkoisesta valikosta, joka ilmaantuu heti kun kone alkaa käynnistää asennusta tikulta.

1. Käynnistä kone Ubuntun asennustikulla
2. Paina GRUB-valikossa näppäintä e
3. Siirry nuolinäppäimillä "linux"-riville, jonka lopussa lukee "quiet splash". Kirjoita perään välilyönti ja nomodeset (tai nouveau.modeset=0)
4. Hyväksy ja jatka käynnistämistä painamalla näppäintä F10 tai Ctrl+X

Jos tuon asetuksen kanssa on hankaluuksia, kerro missä kohdassa menee pieleen.

Tässä vielä satunnainen Youtube-video nomodeset-valitsimen lisäämisestä GRUB-valikon kautta: https://youtu.be/Tg4fWsFPzSE?t=17
« Viimeksi muokattu: 23.03.21 - klo:17.29 kirjoittanut nm »

karimarkku66

  • Käyttäjä
  • Viestejä: 136
    • Profiili
Vs: Ubuntun asennusongelma asus x541u läppäriin
« Vastaus #4 : 24.03.21 - klo:09.09 »
Kokei?lin nyt ensin tuolla ykkösvaihtoehdolla ja kuvasuhde muuttui niin isoksi ettei asennusosiossa pystynyt enää update and other kohdassa liikuttamaan continueen kursoria, voiko tuota kuvan kokoa muuttaa jollain komennolla?

edit,, toinen komentokehote käynnisti normaaliin ikkunaan, mutta asennus pysähtyy viimeistään who are you sivulle.

Tein kokeeksi dvd levylle ulkoisella asemalla ubuntumedian ja livetilassa tuli hetken pcierror herjja ja sen jälkeen käynnistyi livetilaan. Tätäkään kautta ei asennus etene.

Ainoa ero usb tikulta ja dvd, ltä asentaessa oli ettei levyasennus herjannut virheistä, mutta usb asennu herjasi 17 osion virheestä.
« Viimeksi muokattu: 24.03.21 - klo:14.29 kirjoittanut karimarkku66 »

karimarkku66

  • Käyttäjä
  • Viestejä: 136
    • Profiili
Vs: Ubuntun asennusongelma asus x541u läppäriin RATKAISTU
« Vastaus #5 : 25.03.21 - klo:11.49 »
Elikkä ongelma ratkaistu,netin syövereistäl löytyi ohje, jonka mukaan toimin ja asennusongelma sujui kivuitta.

Ratkaisu oli seuraava: GRUB valikossa kohtaan johon nuo edelliset ohjeetkin kirjoitettiin, kirjoitetaan nyt pci=nomsi.
ja f10 näppäimellä hyväksyntä ja hienosti asentuu..