Kirjoittaja Aihe: Audio änkyttää (20.04) [RATKAISTU]  (Luettu 2098 kertaa)

USakari

  • Käyttäjä
  • Viestejä: 197
    • Profiili
Audio änkyttää (20.04) [RATKAISTU]
« : 29.12.20 - klo:20.00 »
Elokuvan katselua Yle Areenasta rupesi häiritsemään äänen eräänlainen änkytys. Ilmiötä on vähän vaikea kuvata, mutta yritetään. Silloin tällöin, käsittääkseni epäsäännöllisin välein (minuutin tai allekin), ääneen eli audioon tulee nopea toisto. Sanan "Tampere" sijaan  kuuluukin "Tamamampere". Sekunnin murto-osan pituinen pätkä ääntä toistuu (luullakseni) 3 kertaa. Voi olla, että pätkä videotakin toistuu, mutta sitä on luultavasti vaikeampi havaita.

Ilmiö ei rajoitu Yle Areenaan, vaan näkyy tai oikeastaan kuuluu myös katseltaessa MP4-videoita. Mikähän tässä on vikana? Onko kukaan muu tällaista havainnut?
« Viimeksi muokattu: 08.01.21 - klo:11.56 kirjoittanut USakari »

epiphone

  • Käyttäjä
  • Viestejä: 724
    • Profiili
Vs: Audio änkyttää (20.04)
« Vastaus #1 : 29.12.20 - klo:23.01 »
Minkälainen kone sinulla on käytössä?
Mikä käyttöjärjestelmä on kyseessä?
Kahvi on väkevin juomani

USakari

  • Käyttäjä
  • Viestejä: 197
    • Profiili
Vs: Audio änkyttää (20.04)
« Vastaus #2 : 30.12.20 - klo:00.02 »
Minkälainen kone sinulla on käytössä?
Mikä käyttöjärjestelmä on kyseessä?
Kone on muutaman vuoden ikäinen pöytä-PC. Käyttöjärjestelmä on Lubuntu 20.04, asennettu muutama päivä sitten. uname -a ilmoittaa
Lainaus
Linux tietokone 5.4.0-58-generic #64-Ubuntu SMP Wed Dec 9 08:16:25 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux

epiphone

  • Käyttäjä
  • Viestejä: 724
    • Profiili
Vs: Audio änkyttää (20.04)
« Vastaus #3 : 30.12.20 - klo:00.06 »
Mitä selainta käytät? Millä muilla ohjelmilla pätkii?
Kahvi on väkevin juomani

epiphone

  • Käyttäjä
  • Viestejä: 724
    • Profiili
Vs: Audio änkyttää (20.04)
« Vastaus #4 : 30.12.20 - klo:00.18 »
Kahvi on väkevin juomani

USakari

  • Käyttäjä
  • Viestejä: 197
    • Profiili
Vs: Audio änkyttää (20.04)
« Vastaus #5 : 30.12.20 - klo:11.41 »
Mitä selainta käytät? Millä muilla ohjelmilla pätkii?
Selain on firefox, jota käytän esimerkiksi Yle Areenaan ja YouTubeen. Video-ohjelma on mpv, joka taisi tulla 20.04:n mukana.

USakari

  • Käyttäjä
  • Viestejä: 197
    • Profiili
Vs: Audio änkyttää (20.04)
« Vastaus #6 : 30.12.20 - klo:11.54 »
https://unix.stackexchange.com/questions/604397/jittery-sound-fixed-by-reboot-with-ubuntu-20-04-1-lts
Tuolla on ollut samantyyppistä ongelmaa, kannattaa lukea.
Kiitos vihjeestä, mutta ainakaan siellä päällimmäisenä oleva
Lainaus
sudo apt-get install --reinstall alsa-base pulseaudio
pulseaudio -k && sudo alsa force-reload
ei auttanut. Pitää lukea lisää.

Täytyy kyllä huomauttaa, etten oikein ymmärrä, mitä on jitter. Kuten yritin kuvata, kuulen toistoa tai änkytystä: "norsu"n sijasta kuulen "norsorsorsu". Onko tämä jitteriä? Jotenkin stutter tuntuu oikeammalta, jos englantia käytetään.

USakari

  • Käyttäjä
  • Viestejä: 197
    • Profiili
Vs: Audio änkyttää (20.04)
« Vastaus #7 : 30.12.20 - klo:19.52 »
Täytyy kyllä huomauttaa, etten oikein ymmärrä, mitä on jitter. Kuten yritin kuvata, kuulen toistoa tai änkytystä: "norsu"n sijasta kuulen "norsorsorsu". Onko tämä jitteriä? Jotenkin stutter tuntuu oikeammalta, jos englantia käytetään.
Juu, kyllä se taitaa olla stutteria tämä ongelma. Nimittäin sillä sanalla hakien löytyi https://askubuntu.com/questions/1044552/audio-stuttering-in-ubuntu-18-04 ja sieltä  tällainen konsti:

1. Tiedostoon /etc/pulse/default.pa rivi
Koodia: [Valitse]
load-module module-udev-detect tsched=02. Aja
Koodia: [Valitse]
pulseaudio --kill
pulseaudio --start

Nyt olen noin tunnin pitänyt erilaisia äänilähteitä päällä eikä änkytystä ole esiintynyt. Olisiko ongelma nyt ratkaistu? No, katsotaan – ei kun siis kuunnellaan – vielä pari päivää...

Postimies

  • Käyttäjä
  • Viestejä: 2530
    • Profiili
Vs: Audio änkyttää (20.04)
« Vastaus #8 : 06.01.21 - klo:13.13 »
Itsellä LUbuntu mediakoneessa eikä ihmeempiä ongelmia. Mitähän ulostuloa käytät? Firefox ei toimi ilman pulsea mikä ärsyttää itseä. Myös näytönohjaimmissa äänikortti jos HDMI käytössä sen kautta. Resamplauksesta harvemmin ongelmaa, mutta itse suosin äänen pistämistä suoraan ALSAlle ja sieltä vahvistimelle purettavaksi.

USakari

  • Käyttäjä
  • Viestejä: 197
    • Profiili
Vs: Audio änkyttää (20.04)
« Vastaus #9 : 08.01.21 - klo:11.58 »
Itsellä LUbuntu mediakoneessa eikä ihmeempiä ongelmia. Mitähän ulostuloa käytät?
Käytössä on kuulokeliitäntä.

[Merkitsin nyt tämän jutun RATKAISTUksi], koska tässä on jo viikko mennyt ilman änkytystä.]