Kirjoittaja Aihe: openSUSE Leap 15.2 kotoistus  (Luettu 1654 kertaa)

qwertyy

  • Käyttäjä
  • Viestejä: 5195
    • Profiili
openSUSE Leap 15.2 kotoistus
« : 14.10.20 - klo:18.28 »
Moi pitkästä aikaa.

Käyttelin tuossa yhdellä koneella tovin XFCE:llä openSUSE:a ja päädyin laittaan sen myös pääkoneelle, mutta KDE:lla. Hiukan yllättäen XFCE vaikutti olevan käännetty lähes kokonaan, mutta KDE:llä jostain syystä esim. Dolphin on englanniksi. Onko kellään ajatuksia, miksi KDE:n paketeista on jäänyt kielet sekalaiseksi? Ihan kuin valikoiden ns. ensimmäinen taso olisi käännetty, mutta kaikki alemmat tasot olisi jääneet englanniksi?

epiphone

  • Käyttäjä
  • Viestejä: 771
    • Profiili
Vs: openSUSE Leap 15.2 kotoistus
« Vastaus #1 : 14.10.20 - klo:18.54 »
Nimimerkki SuperOscar tietää varmasti paremmin.

Mutta kyse on kaiketi periaatteessa pienistä eroista erilaisissa ohjelma ja kirjasto versioissa.

Kun tulee uusia pieniä versiopäivityksiä niin se rikkoo käännökset. Eli periaatteessa käännökset on tehty ja valmiina, mutta sitten tulee pieni päivitys, joka sitten ei pelitä suomennetun po.filun kanssa.
Kahvi on väkevin juomani

SuperOscar

  • Käyttäjä
  • Viestejä: 3814
  • Tänään täällä, huomenna poissa
    • Profiili
    • Legisign.org
Vs: openSUSE Leap 15.2 kotoistus
« Vastaus #2 : 14.10.20 - klo:19.04 »
Onko kellään ajatuksia, miksi KDE:n paketeista on jäänyt kielet sekalaiseksi? Ihan kuin valikoiden ns. ensimmäinen taso olisi käännetty, mutta kaikki alemmat tasot olisi jääneet englanniksi?

Aivan ensimmäiseksi: oletko käynyt järjestelmäasetusten kohdassa Alueasetukset > Kieli, lisännyt suomen kielen luetteloon ja vetänyt sen ylimmäksi? Jostain syystä tämä ei tapahdu Plasmassa automaattisesti vaan pitää aina muistaa tehdä. Ilman sitä osa Plasmaa on kyllä suomeksi Linux-järjestelmän asetusten mukaisesti mutta ei koko järjestelmä.

Toinen juttu on sitten se, mitä epiphone sanoi: kun jakeluun koostetaan Plasmasta jokin versio, siihen ei välttämättä tule ajantasaista käännöstä juuri siitä versiosta. Tämä on ikävä tilanne jolle ei oikein kukaan voi mitään. Itse yleensä teen niin, että katson ohjelma ohjelmalta missä käännös on pettänyt ja haen Plasman käännösten SVN-reposta paremman version. Tämä on kuitenkin täysin käsityötä, jota ei voi suositella kaikille.

Lisäksi nimenomaan openSUSEn uusimmassa versiossa (Leap 15.2) on pari paikkaa jostain syystä toteutettu siten, että niitä tuntuu olevan mahdotonta saada käännetyksi. Näitä ovat mm. KMailin ohjattu tilin asetus (jossa dialogien painikkeet ovat pysyvästi englanniksi) ja järjestelmäasetusten verkkotilien luonti.
openSUSE Leap 15.3 (pöytäkone 1 & kannettavat 1–3), openSUSE Tumbleweed (pöytäkone 2), Ubuntu 20.04 LTS (RPi 2 B), LibreELEC 10 (RPi 4 B), Windows 10 (työkannettava)

qwertyy

  • Käyttäjä
  • Viestejä: 5195
    • Profiili
Vs: openSUSE Leap 15.2 kotoistus
« Vastaus #3 : 14.10.20 - klo:19.39 »
Juu, käsittääkseni olen kyllä laittanut tarvittavat asetukset oikein.

Ihmetystä aiheuttaa, että myös mm. Firefox on englanniksi? Tuossa on liitekuva jos siitä saisi vähän käsitystä minkälainen tilanne on.
https://ibb.co/BVSkrmZ

*Edit*
Tosiaan siis ainakin XFCE:ssä mm. Firefox on kotimaisella. Jopa YaST on siinä suomeksi, tosin päävalikosta otettavat pikakuvakkeet kuitenkin vielä englanniksi. Mutta tuo on XFCE:ssä ainoita paikkoja missä olen tuollaista sekamelskaa nähnyt ylipäätään. En myöskään äkkiseltään muista, että kannettavani Fedoran KDE:ssä olisi oikein pahasti vastaavia näkyvissä.

*Edit*
Piti oikein tarkistaa kannettavasta ja KDE:n sama plasmaversio Fedora 32:ssa ja kaikki kuvassa näkyvät on kotimaisella. Mutta pisti silmään sellainen erikoisuus, että Fedorassa kieli asetuksessa on pelkkä Amercan English oletuksena ja silti kaikki suomeksi?? Mielenkiintoista. Kokeilin lisätä suomen siihen ja login ruutu taisi vaihtua suomeksi. Minusta se oli ennen englanniksi.
« Viimeksi muokattu: 14.10.20 - klo:19.58 kirjoittanut qwertyy »

qwertyy

  • Käyttäjä
  • Viestejä: 5195
    • Profiili
Vs: openSUSE Leap 15.2 kotoistus
« Vastaus #4 : 14.10.20 - klo:20.04 »
Saatoin löytää jotain erikoista openSUSE:sta. Kokeilin pakottaa päätteestä sudo yast language ja päätteeseen tulee virhe "Failed to set locale. Fix your system."

*edit*
Todella huono ratkaisu, mutta IRC:ssä tuli vastaan, että joku kokeili tehdä uuden käyttäjän ja sillä ongelma näytti häipyvän ja käännökset tuli kutakuinkin täysin Fedoran vastaavaksi. Keksisi vain josko saisi tuon käyttäjän vielä muutettua. Jos ei niin pitänee vain jatkaa uudella käyttäjätilillä. Onneksi ei oikein paljoa ole kerennyt käyttää tuolla alkuperäisellä tilillä konetta.

Mutta ehdottomasti jonkinlainen bugi kyseeessä.
« Viimeksi muokattu: 14.10.20 - klo:20.57 kirjoittanut qwertyy »

SuperOscar

  • Käyttäjä
  • Viestejä: 3814
  • Tänään täällä, huomenna poissa
    • Profiili
    • Legisign.org
Vs: openSUSE Leap 15.2 kotoistus
« Vastaus #5 : 14.10.20 - klo:21.37 »
Ihmetystä aiheuttaa, että myös mm. Firefox on englanniksi?

Firefoxin käännös on eri juttu. Onko paketti MozillaFirefox-translations-common asennettu? (Oletusarvoisesti kyllä pitäisi olla.)

Lainaus
Jopa YaST on siinä suomeksi, tosin päävalikosta otettavat pikakuvakkeet kuitenkin vielä englanniksi.

YaST on jo kolmas juttu ;D Olen kyllä tehnyt senkin käännöstä, mutta se on työpöytäympäristöstä riippumaton ja käännös löytyy paketista yast-trans-fi. Siinä on tosin käsittämättömiä puutteita jopa niissä kohdin, jotka tiedän ja voin tarkistaa kertaalleen kääntäneeni.

Onko sinulla YaSTin Järjestelmä > Kieli -työkalussa ensisijaisena kielenä suomi?
openSUSE Leap 15.3 (pöytäkone 1 & kannettavat 1–3), openSUSE Tumbleweed (pöytäkone 2), Ubuntu 20.04 LTS (RPi 2 B), LibreELEC 10 (RPi 4 B), Windows 10 (työkannettava)

qwertyy

  • Käyttäjä
  • Viestejä: 5195
    • Profiili
Vs: openSUSE Leap 15.2 kotoistus
« Vastaus #6 : 14.10.20 - klo:22.11 »
Moi, tosiaan tein uuden käyttäjän ja ongelma ratkesi sillä. Selkeästi jonkinmoinen ikävämpi bugi tullut asennuksen aikana vastaan. Tosiaan päätteessä kun antoi tuon sudo yast2 language komennon, niin sain päätteeseen tuon "Failed to set locale. Fix your system." ilmoituksen. Sitten kun teki uuden käyttäjän, niin kaikki tuli välittömästi normaalin näköiseksi ja en saa nyt enää laukaistua tuota virhettä. Onneksi en ollut vielä paljoa käyttänyt tuota käyttäjätiliä, eli aika helppo ratkaisu. Tosin todella yllättävä sellainen kyllä.

Meinasin jo kokeilla tehdä uuden asennuksenkin, koska uuden käyttäjän kirjautuessa järjestelmä jäätyi jonkinlaiseen dbus2 not connected tai jokin sen tapainen, mutta uudelleen käynnistyksen jälkeen ja kun tein YaST:lla uuden käyttäjän kaikki alkoi toimia normaalisti. Yritin siis ensin tehdä käyttäjän pääkäyttäjäominaisuuksilla tuolla KDE:n työkalulla, joka sekin sekoitti jotain.

Olisi kyllä mielenkiintoista tietää mikä tarkalleen ottaen oli mennyt pieleen asennuksessa. Tosiaan niin nyt mm. Firefox-valikot on kaikki suomennettuna.

*edit*
Tuossa XFCE:ssä YaST:n käännökset on oikein itse YaST-työkalussa. Mutta XFCE:n pikavalikossa, jostain syystä logot on kääntämättä. Sinänsä erikoinen kun sehän mielestäni sisältää nuo jo tehdyt käännökset. Tuo on varmasti jokin XFCE-spesifistinen juttu.

Mutta nyt kaikki toimii tosiaan oikein hienosti KDE:ssä.
« Viimeksi muokattu: 14.10.20 - klo:22.13 kirjoittanut qwertyy »