Kirjoittaja Aihe: Älä päivitä just nyt - tarvittaisiinko tällaista varoitusta näille sivuille  (Luettu 1739 kertaa)

elohope

  • Käyttäjä
  • Viestejä: 102
    • Profiili
Ubuntun päivitykset ovat yleensä turvallisia ja ne kannattaa asentaa saman tien. Joskus harvoin kuitenkin päivityksiin liitty ongelmia, joita havaitaan vasta, kun päivitys on jo jaossa.

Pitäisikö silloin varoittaa niitä, jotka eivät ole vielä päivitelleet?

Perjantaista lähtien monia Linux-jakeluja on vaivannut Grub2-päivitys, jonka jälkeen kone ei käynnisty:

https://wiki.ubuntu.com/SecurityTeam/KnowledgeBase/GRUB2SecureBootBypass

Päivityksellä koetettiin suojata Boothole-nimistä uhkaa vastaan, mutta päivitys aiheutti siis ongelmia. Korjausta päivitykseen ei ole vielä saatavissa, joten taitaa olla hyvä ajatus välttää päivittämistä siihen asti, kunnes asia on korjattu.

Ongelma ilmeisesti kohdistuu etenkin Bios-käynnisteisiin koneisiin, ei niinkään Uefi-koneisiin.
Jos komento

Koodia: [Valitse]
ls /sys/firmware/efi
ei löydä mitään, käytät Bios-konetta.

Samoin ongelmiin joutunevat koneet, joissa on kaksi tai useampi käyttöjärjestelmää.

Lisätieto olisi tervetullutta!
« Viimeksi muokattu: 02.08.20 - klo:09.25 kirjoittanut elohope »

AimoE

  • Käyttäjä
  • Viestejä: 2018
    • Profiili
Minä luin tuon niin että ongelmia aiheuttanut päivitys julkaistiin keskiviikkona ja perjantaina siihen julkaistiin (ainakin osittainen) korjaus; ESM-versiolle korjaus on tulossa maanantaina.

elohope

  • Käyttäjä
  • Viestejä: 102
    • Profiili
Totta, näinhän tuolla sanotaan:

Lainaus
2020 Jul 31: Ubuntu published updated grub and grub2-signed packages for Ubuntu 20.04 LTS, 18.04 LTS, and 16.04 LTS to address a regression on incorrectly-configured legacy boot systems, and reverted the packages for Ubuntu 14.04 ESM. Updated packages for Ubuntu 14.04 ESM will be published on Mon, Aug 3rd, 2020.

Joten Ubuntun uusien versioiden osalta tilanne näyttäisi olevan korjattu, jos oikein ymmärrän. Ja jatkettujen turvallisuuspäivitysten versiolle 14.04 päivitys olisi tulossa maanantaina.

Jos ongelmia ei raportoida, kaikki on hyvin (tai koneet eivät käynnisty ... noh, kyllä kai sentään.)

AimoE

  • Käyttäjä
  • Viestejä: 2018
    • Profiili
Ei ihan kaikki ole kunnossa, koska uusia allekirjoituksia tipahtaa eri julkaisuista eri tahtiin. Eli jos koneella on useita käyttiksiä, niiden turvapäivitykset eivät ole synkassa. Perjantain korjauksella vain varmistettiin että jos päivitys kaatuu, palataan vanhaan versioon. Näin luulen sen ymmärtäneeni.

SuperOscar

  • Käyttäjä
  • Viestejä: 3691
  • Tänään täällä, huomenna poissa
    • Profiili
    • Legisign.org
Uskalsin tänään päivittää openSUSE Tumbleweedin, eikä käynnistysvaikeuksia enää ilmennyt eli ilmeisesti korjauspäivityskin on saapunut. Leap-koneilla vähän vielä arvuuttelisin, jos Grub2 näkyisi päivitettävissä.
openSUSE Leap 15.2 (pöytäkone 1, kannettavat 1, 2 & 3), openSUSE Tumbleweed (pöytäkone 2), Ubuntu 20.04 LTS (RPi 2 B)

HannuK

  • Käyttäjä
  • Viestejä: 267
    • Profiili
Tähän päivitykseenköhän liittyy nyt meikäläisen ongelma, kun sain koneeni sekoamaan ( HP Stream, Ubuntu 16.04)
- Kone pari päivää sitten muistaakseni ensin jumittui ( saattoi olla, etä ajoin päivityksen ensin) ja käynnistin sen uudelleen. Käynnistyksen jälkeen vasemman reunan telakka ja yläreunan otsikot olivat kadonneet ja hiiri oli muuttunut isohkoksi vinoristiksi. Vain työpöydän kaksi ikonia olivat näkyvissä. Käynnistelin konetta useita kertoja, mutta aina sama lopputulos. Kone ilmoitti seuraavasta virheestä: ExecutablePath
/usr/lib/x86_64-linux-gnu/unity/compiz-config-profile-setter
Tulin siihen tulokseen, että kone toimi jotenkuten oikein, paitsi Unityn osalta.
- hiiren oikealla sain näkyviin valikon, missä pystyi vaihtamaan taustakuvaa, siis pääsin Järjestelmäasetuksiin ja sitä kautta Ohjelmistot ja päivitykset sivulle, mistä (omasta mielestäni älykkäästi keksin ), että voin "Tarkistetaan päivitykset" kohtaa klikata.
Sain ilmoitusken, että päivityksiä on saatavissa ja niin hyväksyin sen ja ohjelmapäivitys ajettiin läpi.
Ilmassa oli toivon kipinä ja käynnistin koneen.
Ja lopputulos oli se, että en enää edes pääse Ubuntuun vaan kone ilmoittaa seuraavaa:
GNU GRUB version 2.02 beta2-36 ubuntu 3.27
Minimal BASH-like line editing is supported. For thefirst word, TAB lists possible command completions. Anywhere else TAB lists possible device or file copletions.
grub>
Ja tästä eteenpäin ei meikäläisen ymmärrys riitä.
MUUTIN VIESTIÄ TÄSTÄ ETEENPÄIN
Täytyy tunnustaa, että tuli hiukan sekoiltua ( yritin asentaa Ubuntua tyhjältä tikulta).
Onneksi oli vanha 16.04 USB-tikku tallessa ja sillä asensin uudestaan Ubuntun ja sen jälkeen DejaDubilla varmuuskopio takaisin ja kas, kone oli jälleen entisensä. Mitä tästä opimme:
1.Vanha USB-lataustikku kannattaa pitää tallessa
2. Varmuuskopiointi DejaDubilla esim. kerran viikossa
3. Ilmeisesti ei kannata heti tehdä päivitystä ( jos se ei toimikkaan)
4. Varmuuskopiointi ennen päivitystä
Ja elämä jatkuu
« Viimeksi muokattu: 03.08.20 - klo:13.24 kirjoittanut HannuK »
Motto: Monimutkaista on helppo tehdä.
2 kpl HP Stream 14" 2 Gt/32 Gt, 1 kpl HP 250-G5 15" 8 Gt/120 Gt, Ubuntu 20.04 LTS  ja Linux Mint 20.1 Cinnamon , ei Windowsia.  Acer 17" Ubuntu Mate+Win XP

Pendeli

  • Käyttäjä
  • Viestejä: 608
    • Profiili
Päivitin viime viikolla 18.04-version sydän kylmänä mutta kaikki meni hyvin.
Pari vanhempaa konetta odottaa vielä tilanteen kehitystä.

Eikö tuohon ongelmaan auta Boot-Repair? Se näkyy olevan sovellusvalikoimassa mutta ei näy pakettivarastossa. Miksi ei näy?

Pendeli

  • Käyttäjä
  • Viestejä: 608
    • Profiili
Ubuntun päivitykset ovat yleensä turvallisia ja ne kannattaa asentaa saman tien. Joskus harvoin kuitenkin päivityksiin liitty ongelmia, joita havaitaan vasta, kun päivitys on jo jaossa.

Pitäisikö silloin varoittaa niitä, jotka eivät ole vielä päivitelleet?




Ihan hyvä ajatus olisi luoda joku erillinen varoitusosio tai -palsta, mitä nopeasti vilkaisemalla näkisi heti jos varoituksiin on aihetta , olipa sitten päivityksistä tai muista haitakkeista kysymys.
« Viimeksi muokattu: 03.08.20 - klo:15.10 kirjoittanut Pendeli »

elohope

  • Käyttäjä
  • Viestejä: 102
    • Profiili

Ja elämä jatkuu

... vaikka on vaikea säilyttää toiveikkuutensa, kun kone jumittaa puolilta öin. No, tuloksena oli ainakin jännityskertomus, johon oli helppo samaistua.

Eesaurus

  • Käyttäjä
  • Viestejä: 3167
    • Profiili
Eikö tuohon ongelmaan auta Boot-Repair? Se näkyy olevan sovellusvalikoimassa mutta ei näy pakettivarastossa. Miksi ei näy?

Boot-Repair ei ole muistaakseni koskaan ollut saatavilla suoraan pakettivarastoista, vaan se on pitänyt asentaa ulkopuolelta lisäämällä PPA, tai asentamalla se deb -tiedostosta.

LeHiX

  • Käyttäjä
  • Viestejä: 530
    • Profiili
Olisi ehkä hyvä kertoa sen ongelmia vaivaavan päivityksen versio? Nyt näitä lukiessa poistin valinnat neljästä päivityksestä, versio 2.02.-2ubuntu8.17 ja päivitin muut.
Tarjosi kyllä heti perään uudelleen blokkaamani päivitykset
« Viimeksi muokattu: 04.08.20 - klo:04.00 kirjoittanut LeHiX »
| Pros. AMD Phemon(tm) 9950 :) (4cores) | Emo: ASUS M3A78 | Mem 8GT
| x86_64, gnome, ubuntu 20.04  | GeForce GTX 750 Ti/PC

LeHiX

  • Käyttäjä
  • Viestejä: 530
    • Profiili
Hm, mitenkähän.... minulla ei ole ollut melkein vuoteen biossissa patteria tai siis on mutta se on virraton eli kone käynnistyy oletuksilla ja hakee myöhemmin ajan netistä, yleensä minulla on pitkät uptime:t nytkin 11d 17h :O
| Pros. AMD Phemon(tm) 9950 :) (4cores) | Emo: ASUS M3A78 | Mem 8GT
| x86_64, gnome, ubuntu 20.04  | GeForce GTX 750 Ti/PC

elohope

  • Käyttäjä
  • Viestejä: 102
    • Profiili
Vihdoin alkaa tulla lisää tietoa koneita jumittaneen Boothole-haavoittuvuuden korjauksen korjauksista:

https://www.zdnet.com/article/the-fixes-to-the-linux-boothole-fixes-are-in/

Canonicalilta ei ole ilmeisesti tullut uusia ohjeita tuon jo aiemmin esitetyn ohjeen jälkeen, eli linkki oli siis

https://wiki.ubuntu.com/SecurityTeam/KnowledgeBase/GRUB2SecureBootBypass

Boothole-haavoittuvuuden vaarallisuutta on ilmeisesti liioiteltu, niin taidettiin tehdä alla olevassa linkissäkin, josta pääsee myös NSA:n alustaviin selviytymisohjeisiin (jotka on tarkoitettu Isojen Organisaatioiden Hepuille):

https://gcn.com/articles/2020/08/03/boothole-nsa-mitigation-guidance.aspx




elohope

  • Käyttäjä
  • Viestejä: 102
    • Profiili
Nyt vasta törmäsin Canonicalin turvallisuusteemaiseen postituslistaan, ja sen tiedotteeseen:

https://lists.ubuntu.com/archives/ubuntu-security-announce/2020-August/005549.html

Canonical pahoittelee sählinkiä ja minä tätä tietämättömyyttäni. Eli tuo kyseinen lista on sellainen, jonka voi tilata jos haluaa olla ajan tasalla Ubuntun turvallisuuteen liittyvistä asioista.

Yhteenveto tiedotteen sisällöstä, myös siitä, mitkä Grub-versionumerot ovat turvallisia, saa sivulta

https://9to5linux.com/grub2-boot-failure-issues-fixed-in-debian-and-ubuntu-update-now

AimoE

  • Käyttäjä
  • Viestejä: 2018
    • Profiili
Jep, eli vain grubiin on julkaistu korjaus  ja korjauksen korjaus, mutta varsinaisen ongelman lopullinen ratkaisu puuttuu vielä, niin Ubuntusta kuin monista muistakin jakeluista. Ratkaisuehdokkaan voi asentaa jos ei halua odottaa virallista julkaisua, jota ei ole vielä loppuun asti testattu.

LeHiX

  • Käyttäjä
  • Viestejä: 530
    • Profiili
Siis onko tuo 2.02-2ubuntu8.17 versio jo turvallinen valinta? Olen pitkittänyt sen asennusta jo jonkin aikaa

Koodia: [Valitse]
Koskee grub2-common versioita:
Asennettu versio: 2.02-2ubuntu8.15
Viimeisin versio: 2.02-2ubuntu8.17
| Pros. AMD Phemon(tm) 9950 :) (4cores) | Emo: ASUS M3A78 | Mem 8GT
| x86_64, gnome, ubuntu 20.04  | GeForce GTX 750 Ti/PC

AimoE

  • Käyttäjä
  • Viestejä: 2018
    • Profiili
Siis onko tuo 2.02-2ubuntu8.17 versio jo turvallinen valinta? Olen pitkittänyt sen asennusta jo jonkin aikaa

Jos sinulla on Bionic, niin kyllä, tuo on oikea versio. Jos sinulla on jokin muu Ubuntu-versio, katso

Yhteenveto tiedotteen sisällöstä, myös siitä, mitkä Grub-versionumerot ovat turvallisia, saa sivulta

https://9to5linux.com/grub2-boot-failure-issues-fixed-in-debian-and-ubuntu-update-now