Kirjoittaja Aihe: DaVinci Resolve 16.2 asentui ohjeiden mukaan, vaan ei käynnistynyt (RATKAISTU)  (Luettu 1042 kertaa)

Pontus12

  • Käyttäjä
  • Viestejä: 1459
    • Profiili
DaVinci Resolve 16.2  asentui päätteen kautta ja sen kuvake ilmestyi Kubuntun ohjelmavalikkoon. Kun klikkasin sitä, se ei kuitenkaan käynnistynyt. Minulla on mielestäni viimeisin versio Nvidia ajuria, mutta DV ei käynnisty. Haluan kokeilla sitä, ennen kuin teen lopullisen päätöksen joko Lightworksin tai DaVincin ostamisesta.
Olen myös miettinyt, onko minun järkevämpää ostaa Windows versio, sillä ainakin Lightworksissa voi käyttää jommassakummassa järjestelmässä vapaata versiota. DaVincista en vielä tiedä, kun en ole saanut asennettua sitä Kubuntuuni. Päätöksen teen vasta, kun 20.04 on ilmestynyt, sillä nykyinen Lightworks (14.5) ei asennu Ubuntuun eikä Kubuntuun. Tulossa on versio 14.6.
Jos joku tuntee DaVinci Resolve ohjelman, olisin kiitollinen asennusavusta sen suhteen. Opetusohjelmia katseltuani DaVinci näyttää hyvin mielenkiintoiselta ja kätevältä.
« Viimeksi muokattu: 10.04.20 - klo:15.56 kirjoittanut Pontus12 »

SuperOscar

  • Käyttäjä
  • Viestejä: 3520
  • Tänään täällä, huomenna poissa
    • Profiili
    • Legisign.org
Kannattaa yrittää käynnistää ohjelma komentoriviltä, jolloin näkee virheilmoitukset.
openSUSE Tumbleweed (pöytäkone 1), openSUSE Leap 15.1 (pöytäkone 2, kannettava 1), Debian GNU/Linux 10 (kannettava 2), LibreELEC 8.2.5 (RPi 1), Raspbian GNU/Linux 10 (RPi 2)

nm

  • Käyttäjä
  • Viestejä: 13469
    • Profiili
DaVinci Resolve 16.2  asentui päätteen kautta ja sen kuvake ilmestyi Kubuntun ohjelmavalikkoon.

Minkä ohjeen mukaan asensit, ja menivätkö kaikki vaiheet läpi virheettömästi?

DaVinci Resolve on varsinaisesti tuettu vain CentOS 7 ja Red Hat Enterprise Linux 7 -jakeluissa. Ubuntuun asentaessa kannattaa seurata vaikkapa tätä ohjeistusta: https://www.linuxuprising.com/2018/06/how-to-install-davinci-resolve-15-in.html

Ohjeen mukaan näytönohjain ja näytönohjaimen ajuri saattavat olla myös esteenä:

Lainaus
> DaVinci Resolve 16.2 requires a recent, powerful Nvidia graphics card which supports CUDA 3.0; there are reports that AMD graphics may work now, but I can't try this myself as I don't have AMD graphics.

> Proprietary Nvidia graphics drivers are required (a recent version - try to install the latest drivers if possible, especially when using the latest version of DaVinci Resolve)
« Viimeksi muokattu: 06.04.20 - klo:13.06 kirjoittanut nm »

Pontus12

  • Käyttäjä
  • Viestejä: 1459
    • Profiili
Kiitos tiedoista. Selailin verkkoa ja ilmeisesti paras tapa asentaa DaVinci on tehdä siitä deb-paketti. Minä en kuitenkaan taida tehdä sitä ja korostan tässä sanaa "taida" eli en osaa edes ohjeiden mukaan. Olen kyllä yrittäessäni mestari sekoittamaan koneen. Asensin DaVincin Windowsiin ja voin siellä opetella käyttämään sitä. Kai se deb-paketti tulee jossain vaiheessa.
Lyhyen kokemukseni perusteella DaVInci Resolve 16 näyttäisi helpommalta ja kätevämmältä kuin Lightrworks. Mutta en ole vielä käyttänyt sitä kunnolla, joten en tiedä, onko se yhtä kranttu tiedostojen suhteen kuin Lightworks.

Pontus12

  • Käyttäjä
  • Viestejä: 1459
    • Profiili
Yritin tehdä deb tiedostoa, mutta en onnistunut. Kopioin yritykseni tähän:

Koodia: [Valitse]
jotaarkka@jotaarkka-OMEN:~/DaVInci$ ./makeresolvedeb_16.2-3.sh

 Usage: ./makeresolvedeb_16.2-3.sh <studio|lite>

jotaarkka@jotaarkka-OMEN:~/DaVInci$ sudo ./makeresolvedeb_16.2-3.sh
[sudo] salasana henkilölle jotaarkka:

 Usage: ./makeresolvedeb_16.2-3.sh <studio|lite>

jotaarkka@jotaarkka-OMEN:~/DaVInci$ ./makeresolvedeb_16.2-3.sh <studio|lite>
bash: lauseoppivirhe lähellä odottamatonta avainsanaa ”newline”
jotaarkka@jotaarkka-OMEN:~/DaVInci$ file:///home/jotaarkka/DaVInci/makeresolvedeb_16.2-3.sh.tar.gz
bash: file:///home/jotaarkka/DaVInci/makeresolvedeb_16.2-3.sh.tar.gz: Tiedostoa tai hakemistoa ei ole
jotaarkka@jotaarkka-OMEN:~/DaVInci$ ./makeresolvedeb_16.2-3.sh.tar.gz
bash: ./makeresolvedeb_16.2-3.sh.tar.gz: Lupa evätty
jotaarkka@jotaarkka-OMEN:~/DaVInci$ sudo ./makeresolvedeb_16.2-3.sh.tar.gz
sudo: ./makeresolvedeb_16.2-3.sh.tar.gz: komentoa ei löytynyt
jotaarkka@jotaarkka-OMEN:~/DaVInci$

nm

  • Käyttäjä
  • Viestejä: 13469
    • Profiili
Lite-versiota olet varmaankin asentamassa:

Koodia: [Valitse]
./makeresolvedeb_16.2-3.sh lite

Pontus12

  • Käyttäjä
  • Viestejä: 1459
    • Profiili
Kiitos. Tähän asti pääsin neuvollasi. Ohjelma ilmoitti tarvitsevansa "file:///home/jotaarkka/DaVInci/DaVinci_Resolve_16.2_Linux.run" tiedoston ja siirsin sen samaan haklemistoon. Seuraavaksi tuli tämä:
Koodia: [Valitse]
~$ cd DaVInci
jotaarkka@jotaarkka-OMEN:~/DaVInci$ ./makeresolvedeb_16.2-3.sh lite
Preparing DaVinci Resolve version 16.2
Sorry. Need 'DaVinci_Resolve_16.2_Linux.run' to continue. Download the archive from www.blackmagicdesign.com
jotaarkka@jotaarkka-OMEN:~/DaVInci$ ./makeresolvedeb_16.2-3.sh lite
Preparing DaVinci Resolve version 16.2
[CREATE DIRECTORY] ./unpack-DaVinci_Resolve_16.2_Linux
Sorry. Need 'xorriso' to continue.

Tähän asti pääsin, mutta en tiedä, missä on xorriso tiedosto.

Roberto

  • Käyttäjä
  • Viestejä: 94
    • Profiili
Ehkä tämä auttaa?
Koodia: [Valitse]
sudo apt install xorriso libssl1.0.0 ocl-icd-opencl-dev fakeroot

Pontus12

  • Käyttäjä
  • Viestejä: 1459
    • Profiili
Yritin vielä viimeksi saamani ohjeen mukaan asentaa xorrisoa ja tuli seuraava palaute:
Koodia: [Valitse]
le jotaarkka:
Luetaan pakettiluetteloita... Valmis
Muodostetaan riippuvuussuhteiden puu       
Luetaan tilatiedot... Valmis       
Pakettia libssl1.0.0 ei ole saatavilla, mutta toinen paketti viittaa siihen.
Tämä voi tarkoittaa paketin puuttuvan, olevan vanhentunut tai
saatavilla vain jostain muusta lähteestä

E: Paketille ”libssl1.0.0” ei löydy ehdotettavia asennettavia versioita

Ilmeisesti minun on järkevintä odottaa Ubuntun tai Kubuntun seuraavaa versiota, jota kuvittelisin DaVincin tukevan. Nyt olen kokeillut sitä Windowsissa ja näyttää lupaavalta. Jos saan sen toimimaan valitsen sen Lightworksin sijaan ja jätän koneelleni Vain DaVincin ja Kdenliven. Maksetun hankin vasta, kun olen saanut asennettua sen molempiin järjestelmiini

Pontus12

  • Käyttäjä
  • Viestejä: 1459
    • Profiili
Oikeastaan olisin voinut muuttaa otsikon vaikkapa tällaiseksi: Kyllä sokeakin kana (tässä tapauksessa kukko) jyvän löytää. Selailin nettiä löytääkseni ohjeen, joka toimisi koneessani. Katselin Debiania ja DaVinci Resolvea. Debianin sivuilta huomasin ohjeen, jota sovelsin parhaani mukaan, vaikka en sitä  kovin paljoa ymmärtänyt:

Koodia: [Valitse]
sudo apt install libssl1.1 ocl-icd-opencl-dev fakeroot xorriso
.

Ja sen jälkeen:
Koodia: [Valitse]
sudo apt update
Debian ohjeet olivat varsinaisesti tarkoitetut DaVinci deb-tiedoston tekemiseen, mutta koska minulla oli jo ohjelma asennettuna, käynnistin vain koneeni uudelleen ja avasin DaVinci Resolven ja se avautui nätisti.

Kaikki muu mielestäni toimi, mutta en kuitenkaan saanut ääntä kuulumaan. Kokeilin erilaisia asetuksia Videoeditorissa ja tarkistin koneeni ääniasetukset, mutta kaikki näytti olevan kunnossa. Sitten älysin kokeilla toista videotiedostoa ja ääni toimi. Jyvä löytyi sittenkin!

HYVÄÄ PÄÄSIÄISTÄ KAIKILLE!