Kirjoittaja Aihe: LAMP + skandit  (Luettu 3809 kertaa)

Spiderbait

  • Käyttäjä
  • Viestejä: 24
    • Profiili
LAMP + skandit
« : 21.09.06 - klo:20.49 »
Ongelma on että nettisivut on tehty ISO 8859-1 skandeilla ja ubuntu käyttää UTF-8:ia. Eli ääkköset ei näy oikein. Miten olette korjanneet ongelman? Ei auttanut vaikka Apache.conf laittoi Latin1 tai ISO 8859-1

eliasj

  • Käyttäjä
  • Viestejä: 4075
    • Profiili
Re: LAMP + skandit
« Vastaus #1 : 21.09.06 - klo:20.52 »
Laita Firefoxista asetus että näyttää sivut ISO 8859-1 merkistöllä. View -> Character Encoding

Muoks. Hups, eihän tässä tästä ollut kysymys. :)
alias vililikku

janne

  • Käyttäjä
  • Viestejä: 5150
    • Profiili
Re: LAMP + skandit
« Vastaus #2 : 21.09.06 - klo:20.53 »
Ongelma on että nettisivut on tehty ISO 8859-1 skandeilla ja ubuntu käyttää UTF-8:ia.

tuo ei ole mikään ongelma. sillä mitä ubuntu käyttää ei ole mitään väliä nettisivujen suhteen.

Eli ääkköset ei näy oikein. Miten olette korjanneet ongelman?

asettanut apachen kertomaan mitä koodausta sivuilla käytetään.

Ei auttanut vaikka Apache.conf laittoi Latin1 tai ISO 8859-1

olet laittanut jotain väärin. onko antaa URL:ia josta tuota pääsisi tarkastelemaan?
Janne

Spiderbait

  • Käyttäjä
  • Viestejä: 24
    • Profiili
Re: LAMP + skandit
« Vastaus #3 : 21.09.06 - klo:21.00 »
Lainaus
olet laittanut jotain väärin. onko antaa URL:ia josta tuota pääsisi tarkastelemaan?

Tuossa esim.

http://80.222.50.138:8080/phpbb/

Sellainen kumma homma vielä että tuossa toimii ä/ö http://80.222.50.138:8080/

Tuplanolla

  • Käyttäjä
  • Viestejä: 1420
  • Reg. Linux user #423604
    • Profiili
Re: LAMP + skandit
« Vastaus #4 : 21.09.06 - klo:21.03 »
phpBB on ilmeisesti koodattu iso 8859-1:llä ja tuo sinun sivusi utf-8:lla?
Lisää [ratkaistu] ketjun ensimmäisen viestin otsikkoon, kun ongelma ratkeaa!

janne

  • Käyttäjä
  • Viestejä: 5150
    • Profiili
Re: LAMP + skandit
« Vastaus #5 : 21.09.06 - klo:21.03 »
Tuossa esim.

http://80.222.50.138:8080/phpbb/

Sellainen kumma homma vielä että tuossa toimii ä/ö http://80.222.50.138:8080/

palvelin kertoo sisällön olevan utf-8-muotoista:
Koodia: [Valitse]
$ HEAD http://80.222.50.138:8080/phpbb/
200 OK
Cache-Control: no-cache, pre-check=0, post-check=0
Connection: close
Date: Thu, 21 Sep 2006 18:02:35 GMT
Pragma: no-cache
Server: Apache/2.0.55 (Ubuntu) PHP/5.1.2
Content-Type: text/html; charset=utf-8
Expires: 0
Client-Date: Thu, 21 Sep 2006 18:02:35 GMT
Client-Peer: 80.222.50.138:8080
Client-Response-Num: 1
Set-Cookie: phpbb2mysql_data=a%3A2%3A%7Bs%3A11%3A%22autologinid%22%3Bs%3A0%3A%22%22%3Bs%3A6%3A%22userid%22%3Bi%3A-1%3B%7D; expires=Fri, 21-Sep-2007 18:02:35 GMT; path=/phpbb/; domain=.80.222.50.138:8080/
Set-Cookie: phpbb2mysql_sid=923b8af5259645b901a47f4665db3b92; path=/phpbb/; domain=.80.222.50.138:8080/
X-Powered-By: PHP/5.1.2

siksi selain yrittää näyttää merkit "väärin".
Janne

Spiderbait

  • Käyttäjä
  • Viestejä: 24
    • Profiili
Re: LAMP + skandit
« Vastaus #6 : 21.09.06 - klo:21.09 »
Eli Apache.conf tiedostoon muutan Defaulcharset ISO-8859-1? Kokeilin tätä mielestäni eilen, mutta ei toiminut. Nyt olen töissä ja en pääse kokeilemaan tuota mutta kokeilen kunhan pääsen kotiin. Tarviiko MySQL:ään muuttaa noita charset asetuksia?

janne

  • Käyttäjä
  • Viestejä: 5150
    • Profiili
Re: LAMP + skandit
« Vastaus #7 : 21.09.06 - klo:22.08 »
Eli Apache.conf tiedostoon muutan Defaulcharset ISO-8859-1?

mielummin:
Koodia: [Valitse]
AddDefaultCharset ISO-8859-1
ja jos nyt vielä tarkkoja ollaa, niin ei mieluiten tiedostoon Apache.conf vaan mielummin vaikka itse luotuun tiedostoon conf.d:n alle tai vaikkapa siihen virtual hostin omaan konffitiedostoon. tuo Apache.conf kun tulee asennuksen mukana ja sitä saatetaan päivittää automaattisesti apachen päivittyessä.

Kokeilin tätä mielestäni eilen, mutta ei toiminut.

tuon jälkeen pitää tietysti käynnistää apache uusiksi.
Janne

Spiderbait

  • Käyttäjä
  • Viestejä: 24
    • Profiili
Re: LAMP + skandit
« Vastaus #8 : 02.10.06 - klo:15.04 »
Nyt taas pitkän ajan jälkeen ryhdyin serverin kimppuun. Nyt kävi näille skandeille näin:
http://80.222.50.138:8080/phpbb/

Eli forumissa näkyy valikon teksteissä Ä/Ö mutta leipäteksteissä ja otsikoissa ei näy. Muutin Apacheen ISO-8859-1 ja restarttia. Miten noihin loppuihin sais vielä ääkköset?

EDIT: ongelma korjattu, laitoin addcharset latin9
« Viimeksi muokattu: 02.10.06 - klo:16.45 kirjoittanut Spiderbait »

janne

  • Käyttäjä
  • Viestejä: 5150
    • Profiili
Re: LAMP + skandit
« Vastaus #9 : 02.10.06 - klo:16.52 »
EDIT: ongelma korjattu, laitoin addcharset latin9

en tiedä mikä ongelma sinulla varsinaisesti oli, mutta latin9 (ISO-8859-15) on skandien suhteen täysin identtinen latin1:en kanssa (ISO-8859-1).
Janne

Spiderbait

  • Käyttäjä
  • Viestejä: 24
    • Profiili
Re: LAMP + skandit
« Vastaus #10 : 02.10.06 - klo:18.00 »
Huomasin jälkeenpäin että toimii myös tuolla ISO-8859-1. Se ei vaan muuta niitä aikaisemmin kirjoitettuja tekstejä forumiin. En vaan tajunnut tätä heti  :D
« Viimeksi muokattu: 02.10.06 - klo:18.02 kirjoittanut Spiderbait »