Kirjoittaja Aihe: Mistä löydän ääniin liittyvät asetustiedostot?  (Luettu 3302 kertaa)

Juhhe1

  • Käyttäjä
  • Viestejä: 1062
    • Profiili
    • Valokuva albumini
Ongelma on sellainen, etten saa mikkiä toimimaan skypessä millään konstilla (joskus se toimisi hyvin, muttei enää muutamaan kuukauteen).
Olen koittanut puukottaa /etc/asound.conf tiedostoa ja poistanutkin sen kokonaan, säätänyt mikseriä ties mihin malliin ja ei. Eli mikki toimii kun otan muten pois niin kuuluu kaiuttimista ääni mitä siihen höpötän, mutta esim Ääninauhuri ei nauhoita siitä mitään ja audacity kaatuu aina kun rupeaa nauhoittamaan mikistä.
Koitin Ubuntun ja Kubuntun live levyillä ja niillä mikki toimi skypessä ilman mitään säätöä ja en viitsisi tuollaisen takia ruveta asentamaan muuten hyvin toimivaa järjestelmää uudelleen. Takana on kyllä dist-upgradet Hoary-->Breezy-->Dapper jos niillä nyt jotain vaikutusta asiaan on?
Koitin tuossa jonkin aikaa sitten erillisellä äänikortilla ja sillä mikki toimi, mutten saanut siinä toimimaan softamiksausta niin ei ollut oikein mukava käyttää tuota korttia (se oli joku vanha ensoniqin SB yhteensopiva kortti).
Tässä vielä jotain tietoja laitteistosta (ja äänipiiri on emolle integroitu)

lspci
Koodia: [Valitse]
0000:00:11.5 Multimedia audio controller: VIA Technologies, Inc. VT8233/A/8235/8237 AC97 Audio Controller (rev 60)
cat /dev/sndstat
Koodia: [Valitse]
Sound Driver:3.8.1a-980706 (ALSA v1.0.10rc3 emulation code)
Kernel: Linux dsl-tregw3ii23 2.6.15-27-k7 #1 SMP PREEMPT Sat Sep 16 02:35:20 UTC 2006 i686
Config options: 0

Installed drivers:
Type 10: ALSA emulation

Card config:
VIA 8237 with CMI9739 at 0xc400, irq 201

Audio devices:
0: VIA 8237 (DUPLEX)

Synth devices: NOT ENABLED IN CONFIG

Midi devices: NOT ENABLED IN CONFIG

Timers:
7: system timer

Mixers:
0: C-Media Electronics CMI9739

lsmod |grep snd
Koodia: [Valitse]
snd_seq_dummy           4164  0
snd_seq_oss            37632  0
snd_seq_midi            9888  0
snd_seq_midi_event      8064  2 snd_seq_oss,snd_seq_midi
snd_seq                58832  6 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_midi_event
snd_via82xx            31256  1
gameport               17032  1 snd_via82xx
snd_ac97_codec         99296  1 snd_via82xx
snd_ac97_bus            2688  1 snd_ac97_codec
snd_pcm_oss            56352  0
snd_mixer_oss          20800  1 snd_pcm_oss
snd_pcm                96772  3 snd_via82xx,snd_ac97_codec,snd_pcm_oss
snd_timer              27204  2 snd_seq,snd_pcm
snd_page_alloc         11592  2 snd_via82xx,snd_pcm
snd_mpu401_uart         8896  1 snd_via82xx
snd_rawmidi            27552  2 snd_seq_midi,snd_mpu401_uart
snd_seq_device          9548  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq,snd_rawmidi
snd                    60068  13 snd_seq_oss,snd_seq,snd_via82xx,snd_ac97_codec,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer,snd_mpu401_uart,snd_rawmidi,snd_seq_device
soundcore              11040  1 snd

Lisätietoa annetaan jos sitä tarvitaan.

Tlp-WS (Workstation) - .:Ubuntu 10.10:.
Xenophobic (Laptop) - .:Ubuntu 10.04:.
Xenophobic-II (Laptop) - .:Ubuntu 10.10:.
TlpEEE (Asus EEE) - .:Crunchbang 10 Statle

janne

  • Käyttäjä
  • Viestejä: 5150
    • Profiili
Re: Mistä löydän ääniin liittyvät asetustiedostot?
« Vastaus #1 : 20.09.06 - klo:18.11 »
Eli mikki toimii kun otan muten pois niin kuuluu kaiuttimista ääni mitä siihen höpötän, mutta esim Ääninauhuri ei nauhoita siitä mitään ja audacity kaatuu aina kun rupeaa nauhoittamaan mikistä.

jos mikrofonista tulevaa signaalia haluaa saada jonnekin muualle kuin kaiuttumille, niin mikserissä pitää olla sen kohdalla capture päällä. samoin järjestelmänlaajuinen capture saatetaan tarvita jos sellaista tarjotaan.
Janne

Juhhe1

  • Käyttäjä
  • Viestejä: 1062
    • Profiili
    • Valokuva albumini
Re: Mistä löydän ääniin liittyvät asetustiedostot?
« Vastaus #2 : 20.09.06 - klo:21.00 »
Eli mikki toimii kun otan muten pois niin kuuluu kaiuttimista ääni mitä siihen höpötän, mutta esim Ääninauhuri ei nauhoita siitä mitään ja audacity kaatuu aina kun rupeaa nauhoittamaan mikistä.

jos mikrofonista tulevaa signaalia haluaa saada jonnekin muualle kuin kaiuttumille, niin mikserissä pitää olla sen kohdalla capture päällä. samoin järjestelmänlaajuinen capture saatetaan tarvita jos sellaista tarjotaan.

Kyllä mä olen koittanut mikseriin laittaa täppiä captureen päälle vähän joka paikkaan, mutta ei vaikuta.
Yritin nyt hakea tällä että missä noita alsan ym ääniin liittyviä asetustiedostoja on? (ihan siis teksti conffeja)? Jos sieltä vaikka löytyisi jotain hämärää.
Tässä muutama kuvakaappaus jos niistä on jotain iloa:



Tlp-WS (Workstation) - .:Ubuntu 10.10:.
Xenophobic (Laptop) - .:Ubuntu 10.04:.
Xenophobic-II (Laptop) - .:Ubuntu 10.10:.
TlpEEE (Asus EEE) - .:Crunchbang 10 Statle

tn

  • Käyttäjä
  • Viestejä: 472
    • Profiili
Re: Mistä löydän ääniin liittyvät asetustiedostot?
« Vastaus #3 : 20.09.06 - klo:23.34 »
Kokeile ottaa ruksit (ainakin oikeanpuoleinen) pois ensimmäisen kuvan Tallennus -kohdasta. Jos ei auta, valitse Tiedosto -> Vaihda laitetta -> ??? (OSS Mixer) ja kokeile laittaa capturea päälle taas sieltä kaappaus-kohdasta.

Juhhe1

  • Käyttäjä
  • Viestejä: 1062
    • Profiili
    • Valokuva albumini
Re: Mistä löydän ääniin liittyvät asetustiedostot?
« Vastaus #4 : 21.09.06 - klo:21.23 »
Kokeile ottaa ruksit (ainakin oikeanpuoleinen) pois ensimmäisen kuvan Tallennus -kohdasta. Jos ei auta, valitse Tiedosto -> Vaihda laitetta -> ??? (OSS Mixer) ja kokeile laittaa capturea päälle taas sieltä kaappaus-kohdasta.

Ei auta vaikka noita rukseja koittaa säädellä miten hyvänsä, eikä auttanut sekään että kävi OSS puolelta säätämässä. Todella kummallista :(

Tlp-WS (Workstation) - .:Ubuntu 10.10:.
Xenophobic (Laptop) - .:Ubuntu 10.04:.
Xenophobic-II (Laptop) - .:Ubuntu 10.10:.
TlpEEE (Asus EEE) - .:Crunchbang 10 Statle

Juhhe1

  • Käyttäjä
  • Viestejä: 1062
    • Profiili
    • Valokuva albumini
Re: Mistä löydän ääniin liittyvät asetustiedostot?
« Vastaus #5 : 24.09.06 - klo:22.00 »
Koitin tuossa juuri ekigaa ja siinä tulee se asetusvelho ja äänilaitteiden valinnassa on kokeile asetuksia (pitäisi puhua mikkiin niin se soittaa sen takaisin) niin siinä kuului vaan ihme sirinää ja kun painoi OK niin koko ohjelma jämähti. Sama tapahtuu myös ääninauhurilla jos yritän nauhoittaa jotain.
Voisikohan jossain udev:n asetuksissa tms olla jotain häikkää? Tai /etc/modprobe.d/alsa-base tiedostossa?

Tlp-WS (Workstation) - .:Ubuntu 10.10:.
Xenophobic (Laptop) - .:Ubuntu 10.04:.
Xenophobic-II (Laptop) - .:Ubuntu 10.10:.
TlpEEE (Asus EEE) - .:Crunchbang 10 Statle

peran

  • Vieras
Re: Mistä löydän ääniin liittyvät asetustiedostot?
« Vastaus #6 : 24.09.06 - klo:22.47 »
Koitin tuossa juuri ekigaa ja siinä tulee se asetusvelho ja äänilaitteiden valinnassa on kokeile asetuksia (pitäisi puhua mikkiin niin se soittaa sen takaisin) niin siinä kuului vaan ihme sirinää ja kun painoi OK niin koko ohjelma jämähti. Sama tapahtuu myös ääninauhurilla jos yritän nauhoittaa jotain.
Voisikohan jossain udev:n asetuksissa tms olla jotain häikkää? Tai /etc/modprobe.d/alsa-base tiedostossa?


Saattaa olla todellisia ongelmia Kovo-puolella. Säädin pari päivää porukoiden Linuxia, kun särisi ikävästi. No yritin säätää XP:n puolella, mutta säma ongelma -> kovo siis rikki. No kyselin kavereilta vanhoja kortteja (SoundBlastereita), niin löytyihän yksi toimiva kortti, ja on taatusti parempaa rautaa kuin intekroidut AC 97 sirittimet. No kannettavassani on AC 97-siritin, ja häviää sille, mutta sen vaihtaminen kunnolliseen onkin jo kalliimpaa.
Mutta säätämälläkin voi saada jotain aikaiseksi. Volumea ei yleisesti ottaen kannata pitää tapissaan kaikkialla, vaikka mic boost-onkin hyvä pitää päällä. Tosin boosti aiheuttaa lievää sirinää.

Juhhe1

  • Käyttäjä
  • Viestejä: 1062
    • Profiili
    • Valokuva albumini
Re: Mistä löydän ääniin liittyvät asetustiedostot?
« Vastaus #7 : 25.09.06 - klo:16.37 »
Koitin tuossa juuri ekigaa ja siinä tulee se asetusvelho ja äänilaitteiden valinnassa on kokeile asetuksia (pitäisi puhua mikkiin niin se soittaa sen takaisin) niin siinä kuului vaan ihme sirinää ja kun painoi OK niin koko ohjelma jämähti. Sama tapahtuu myös ääninauhurilla jos yritän nauhoittaa jotain.
Voisikohan jossain udev:n asetuksissa tms olla jotain häikkää? Tai /etc/modprobe.d/alsa-base tiedostossa?


Saattaa olla todellisia ongelmia Kovo-puolella. Säädin pari päivää porukoiden Linuxia, kun särisi ikävästi. No yritin säätää XP:n puolella, mutta säma ongelma -> kovo siis rikki. No kyselin kavereilta vanhoja kortteja (SoundBlastereita), niin löytyihän yksi toimiva kortti, ja on taatusti parempaa rautaa kuin intekroidut AC 97 sirittimet. No kannettavassani on AC 97-siritin, ja häviää sille, mutta sen vaihtaminen kunnolliseen onkin jo kalliimpaa.
Mutta säätämälläkin voi saada jotain aikaiseksi. Volumea ei yleisesti ottaen kannata pitää tapissaan kaikkialla, vaikka mic boost-onkin hyvä pitää päällä. Tosin boosti aiheuttaa lievää sirinää.

Raudassa ei vika voi olla kun dapperin (ubuntu ja kubuntu) ja edgyn (ubuntu) live levyillä mikki toimii hyvin (skypessä ja ääninauhurissa). Ja tuo sirinä oli sellaista "robottimaista" ääntä, eli ei sitä sirinää muuten kuulu mutta tuossa ekigassa se piti sellaista kun yritti testata mikki ja ääniasetuksia.
Aika hämärä vika, joka luultavasti johtuu jostain asetuksista/alsasta tms. Ja niinkuin jo ennen sanoin niin olen dist-upgreidanut hoarysta breezyyn ja siitä dapperiin, mutten viitsisi tuollaisen takia ruveta asentamaan uudelleen. Pitää varmaan odottaa hetki vielä että voi päivitellä edgyyn jos sitten vaikka vika lähtisi pois.

Tlp-WS (Workstation) - .:Ubuntu 10.10:.
Xenophobic (Laptop) - .:Ubuntu 10.04:.
Xenophobic-II (Laptop) - .:Ubuntu 10.10:.
TlpEEE (Asus EEE) - .:Crunchbang 10 Statle