Kirjoittaja Aihe: Nvidia ajuri ei toimi oikein koneen Kde Neon palatessa valmiustilasta (RATKAISTU  (Luettu 1452 kertaa)

Pontus12

  • Käyttäjä
  • Viestejä: 1546
    • Profiili
Nvidia ajuri ei toimi oikein koneen palatessa valmiustilasta (Kde Neon 5.16), Hain myös netistä apua sekä suomeksi että englanniksi, mutta en löytänyt siihen parannusta paitsi pienillä kikoilla kuten kirjoittajat kertoivat. Tällaisen kikan sain jo Vaihtoehtoisissa työpöytäympäristöissä, ennen kuin minulle kerrottiin Kde Neonin kuuluvan tänne. Kikat auttavat, mutta välillä ainakin minun koneeseeni on tullut häiriöitä, kuten esim. piti sammuttaa kone virtakatkaisimesta.

Perimmäisesti kysymys on ilmeisesti Nvidian ajurista ja sen yhteensopivuudesta koneen näytönohjaimen kanssa. ( HP- Omen). Nyt pärjäilen siten, että kirjaudun ensin ulos ja panen vasta sitten koneen valmiustilaan. Kun palaan siitä, kirjautumisikkuna on rakeinen, mutta kirjauduttuani sisään näyttö on normaali. Toinen kikka on pieni ohjelma, jonka sain Vaihtoehtoiset työpöytäympäristöt keskustelualueelta. Ajan komennot ohjelmana, joka sisältää:
"
#!/bin/bash
kquitapp5 plasmashell; kstart5 plasmashell
"
Eli jos vähäiselllä ymmärrykselläni olen käsittänyt oikein, ohjelma tappaa tai lopettaa plasmashellin ja käynnistää sen sitten uudelleen. Se toimii, mutta aina joskus näyttö jumittuu. En tiedä varmasti johtuuko se ohjelmasta vai tästä yleisestä ongelmasta. Olen myös miettinyt Kubuntu 19.04 asentamista, kun se valmistuu. Mutta korjaisiko se mahdollisesti ongelman? Voisiko sitä kokeilla ilman, että panen kotihakemistoni uusiksi?
« Viimeksi muokattu: 23.09.19 - klo:14.37 kirjoittanut Pontus12 »

jekku

  • Käyttäjä
  • Viestejä: 2432
    • Profiili
Kai sinulla on kotihakemisto eri osiolla?

mpiso

  • Käyttäjä
  • Viestejä: 460
    • Profiili
Oletko perehtynyt tuohon alla olevaan ketjuun lähettämääni viestiin? Jos koet komentorivin käytön vaikeaksi, niin voit käyttää tiedoston tutkimiseen ja muuttamiseen Dolphinia ja Katea. Dolphinissa piilotiedostot ja samalla piilokansiot näkyviin. Katella voit tutkia ja tallentaa toisella nimellä kopion. Avaa alkuperäinen uudelleen, teet muutokset ja tallennat. Parhaassa tapauksessa siellä (~/.config/kdeglobals) on jo kohta [QtQuickRendererSettings] ja sen alla GraphicsResetNotifications=false. Sinun pitää vain vaihtaa tila eli true (GraphicsResetNotifications=true). Ellei niitä ole, niin lisäät ne. Lopuksi uudelleen käynnistys.

https://forum.ubuntu-fi.org/index.php?topic=54605.0

Lisäys: Tarkoitan sitä viimeistä viestiä, ei ensimmäistä.
« Viimeksi muokattu: 23.09.19 - klo:13.10 kirjoittanut mpiso »

Pontus12

  • Käyttäjä
  • Viestejä: 1546
    • Profiili
Minulla on järjestelmä ja kotihakemisto samalla osiolla. Koska minulla on doubleboot windows ja linux, niin kaikki tärkeät tiedostoni ovat windows levyilla. Silloin voin tarvittaessa käyttää niitä molemissa järjestelmissä, sillä Windows ei lue linux osioita.

Mutta kiitos vastauksista. Katselin Mpison vanhaa viestiä sekä uudempaa. Tein ohjeiden mukaan ja nyt minulla on piilohakemistossa .config/kdeglobals/[QtQuickRendererSettings]GraphicsResetNotifications=true

Kokeilin kerran ja kone palasi  käynnistyksen jälkeen valmiustilasta oikein. Palaan asiaan, jos se oli vain sattumaa. Muuten  vain paljon kiitoksia.

Pontus12

  • Käyttäjä
  • Viestejä: 1546
    • Profiili
Palautin koneen nyt toisen kerran valmiustilasta, Mpison ohje tuntuu toimivan. Kiitos paljon. Merkitsen ongelman ratkaistuksi, mutta jos kone jostain syystä rupeaa jälleen kenkkuilemaan, otan "RATKAISTU" merkinnän pois ja palaan asiaan.

juyli

  • Käyttäjä / moderaattori
  • Viestejä: 323
    • Profiili
Palautin koneen nyt toisen kerran valmiustilasta, Mpison ohje tuntuu toimivan. Kiitos paljon. Merkitsen ongelman ratkaistuksi, mutta jos kone jostain syystä rupeaa jälleen kenkkuilemaan, otan "RATKAISTU" merkinnän pois ja palaan asiaan.
Jos ongelmasi on edes osin/tilapäisesti ratkaistu, älä poista [RATKAISTU] -merkintää.
Aloita mieluummin uusi viesti (ja viittaa vanhaa viestiisi ja sen ratkaisu -ehdotukseen).