Kirjoittaja Aihe: Brother  (Luettu 1236 kertaa)

Ax

  • Käyttäjä
  • Viestejä: 16
    • Profiili
Brother
« : 28.04.19 - klo:15.39 »
Mitä töissä on tullut kokeiltua, niin Brotherin tulostimet toimivat yleensä moitteettomasti plug and play Ubuntun kanssa. Sitävastoin, miksi ko. merkin skannerit pitää hankalasti asentaa? Onko tälle nysväämiselle mitään järkevää selitystä. Eikö monitoimilaitteiden skannerit muka voisi samalla kertaa asentua kuin tulostimen. Tarkennettuna, puhun Brotherin monitoimikoneista.

Onko kyse taas jostain lapsellisesta kädenväännöstä?

Tomin

  • Palvelimen ylläpitäjä
  • Käyttäjä / moderaattori+
  • Viestejä: 10768
    • Profiili
    • Tomin kotisivut
Vs: Brother
« Vastaus #1 : 28.04.19 - klo:17.03 »
Oma kokemus on ollut, että Brotherin laitteille pitää noutaa ajuripaketit valmistajan nettisivuilta (löytyy suhteellisen helposti) ja asentaa ne. Tarvitsee lpr-ajurin, cupswrapper-paketin ja skanneriajurin. Kun nuo on asennettu ja mahdollisesti käynnistelty laitteet uudestaan, niin toimii ihan hyvästi.

Tuo miksi skannaus on erillinen tulostuksesta johtuu siitä, että ne hoidetaan erikseen. Tulostus ja kuvanluku ovat tekniseltä puoleltaan hyvin vastakkaisia toimenpiteitä, ja jos sitä vähän järjellä miettii, niin onhan se ihan ymmärrettävää. Toisessa tuotetaan kuva, joka pitää siirtää monitoimilaitteelle tulostettavaksi, ja toisessa sitten luetaan kuva skannerilla, eli siirretään skannattu kuva monitoimilaitteelta tietokoneelle. Linuxissa tulostuksen hoitaa CUPS ja skannauksen SANE.
« Viimeksi muokattu: 28.04.19 - klo:17.05 kirjoittanut Tomin »
Automaattinen allekirjoitus:
Lisäisitkö [RATKAISTU] ketjun ensimmäisen viestin aiheeseen ongelman ratkettua, kiitos.

hokale

  • Käyttäjä
  • Viestejä: 4
    • Profiili
Vs: Brother
« Vastaus #2 : 19.08.19 - klo:11.07 »
Eikö tähän kirjoitin/skanneriongelmaan joku voisi kehittää valmiin paketin?  Kaikki käyttäjät (kuten minä) eivät ole kykeneviä tekemään ohjelmointia ja asennuksia. Eikä muutoin ole haluakaan. Tehköön ne jotka osaavat ja ovat asiasta innostuneita. Windowsissa asiat ovat toisin kaikkeen löytyy valmista. Itselläni on ongelmana Brother DCP-L2530DW

kamara

  • Käyttäjä
  • Viestejä: 2117
    • Profiili
Vs: Brother
« Vastaus #3 : 19.08.19 - klo:11.59 »
Eikö tähän kirjoitin/skanneriongelmaan joku voisi kehittää valmiin paketin?  Kaikki käyttäjät (kuten minä) eivät ole kykeneviä tekemään ohjelmointia ja asennuksia. Eikä muutoin ole haluakaan. Tehköön ne jotka osaavat ja ovat asiasta innostuneita. Windowsissa asiat ovat toisin kaikkeen löytyy valmista. Itselläni on ongelmana Brother DCP-L2530DW

Kyllä ne Windowsin "valmiit" viritykset ovat myös valmistajien tekemiä. Verrattuna Linuxiin siinä (Windowsin kernelissä) on paljon vähemmän ajuripuolta tehntynä MikroSoftin puolelta kuin Linuxissa yhteisön puolelta. Valmistajat eivät vain ole kiinnostuneet Linuxista, ja siksi useat ajurit on tehty "hutiloiden".

SuperOscar

  • Käyttäjä
  • Viestejä: 3456
  • Tänään täällä, huomenna poissa
    • Profiili
    • Legisign.org
Vs: Brother
« Vastaus #4 : 19.08.19 - klo:14.23 »
Kuikuilin vähän ostoaikeissa noita Brothereita. Joku ehkä osaisi vahvistaa, mutta näyttää siltä, että ajurit ovat 32-bittisiä, mikä tulevaisuutta ajatellen on vähän uhkaavaa?
openSUSE Leap 15.1 (pöytäkone 1, kannettava 1), Debian GNU/Linux 10 (kannettava 2), openSUSE Tumbleweed (pöytäkone 2, kannettava 3), LibreELEC 8.2.5 (RPi 1), Raspbian GNU/Linux 10 (RPi 2)

kamara

  • Käyttäjä
  • Viestejä: 2117
    • Profiili
Vs: Brother
« Vastaus #5 : 19.08.19 - klo:14.47 »
Kuikuilin vähän ostoaikeissa noita Brothereita. Joku ehkä osaisi vahvistaa, mutta näyttää siltä, että ajurit ovat 32-bittisiä, mikä tulevaisuutta ajatellen on vähän uhkaavaa?

Itseltäni ei ole kokemusta kovin tuoreesta Brotherista, mutta ainakaan silloin ei BRScript (Olisikohan ollut vuonna 2010) ollut täysin yhteensopiva PostScriptille. Toisin sanoen joutui joidenkin sivujen kanssa tappelemaan, jotta sai sivut tulostettua.

SuperOscar

  • Käyttäjä
  • Viestejä: 3456
  • Tänään täällä, huomenna poissa
    • Profiili
    • Legisign.org
Vs: Brother
« Vastaus #6 : 19.08.19 - klo:15.07 »
Itseltäni ei ole kokemusta kovin tuoreesta Brotherista, mutta ainakaan silloin ei BRScript (Olisikohan ollut vuonna 2010) ollut täysin yhteensopiva PostScriptille. Toisin sanoen joutui joidenkin sivujen kanssa tappelemaan, jotta sai sivut tulostettua.

Noiden halvimpien Brotherien tulostuskieli näkyy olevan ”Windows GDI” eli ne ovat täysin ajurista riippuvaisia.

Halvinkin sopiva HP maksaa kaksi kertaa enemmän, mutta olisihan siinä sitten PCL6 ja Postscript.
openSUSE Leap 15.1 (pöytäkone 1, kannettava 1), Debian GNU/Linux 10 (kannettava 2), openSUSE Tumbleweed (pöytäkone 2, kannettava 3), LibreELEC 8.2.5 (RPi 1), Raspbian GNU/Linux 10 (RPi 2)

kamara

  • Käyttäjä
  • Viestejä: 2117
    • Profiili
Vs: Brother
« Vastaus #7 : 19.08.19 - klo:16.31 »
Halvinkin sopiva HP maksaa kaksi kertaa enemmän, mutta olisihan siinä sitten PCL6 ja Postscript.

Halvalla ei saa hyvää, vaikkakin mun oma PS HP:n sain 40 € posteineen, mutta se oli käytetty. Tosin siinä MV-laserissa oli valmiina netti+kaksipuoleinen tulostus.

Varoitus, että käytetyn koneen ostaessa pitää tietää, minkä ostaa, ja silloinkin voi saada huonon arpalipun.

Itselläni se on ollut kyllä paras tulostin, minkä olen koskaan omistanut, vaikka juuri nyttemmin on alkanutkin tehdä pikkaisen suttua. Onko vika likaantuneessa laitteessa vai rummussa, en tiedä.

No sanotaan nyt mallikin ... HP Laserjet P2055dn

Eli jos tollaisen kultakimpaleen saa halvalla, ja on toimiva, niin kannattaa ostaa. Ei tosin tullut ohjekirjaa, ja verkon NAT piti laittaa samaan avaruuteen tulostimen kanssa, kun en osannut tulostimesta valita IP:tä.

Tossa on sama tulostin ilman nettiä...
https://www.huuto.net/kohteet/hp-laserjet-p2055d-mustavalkoinen-lasertulostin/502679990

... ja on muutenkin epäilyttävän paljon tulostettu.

Tässä saman myyjän vähempi tulostettu.
https://www.huuto.net/kohteet/hp-laserjet-p2055d-mustavalkoinen-lasertulostin/502995952

... mutta siinä pompsahtaa jo hinta korkeammalle.

Vähän turhan paljon ylisanoja, ja korkeahko hinta.

SuperOscar

  • Käyttäjä
  • Viestejä: 3456
  • Tänään täällä, huomenna poissa
    • Profiili
    • Legisign.org
Vs: Brother
« Vastaus #8 : 19.08.19 - klo:17.02 »
Halvalla ei saa hyvää,

Ehkä tähän väliin pitää panna oma tarinani, mutta ei tähän säikeeseen. Aloitan uuden ja linkitän sitten tähän.

Muoks: Tässä tuota tarinantynkää.
« Viimeksi muokattu: 19.08.19 - klo:17.11 kirjoittanut SuperOscar »
openSUSE Leap 15.1 (pöytäkone 1, kannettava 1), Debian GNU/Linux 10 (kannettava 2), openSUSE Tumbleweed (pöytäkone 2, kannettava 3), LibreELEC 8.2.5 (RPi 1), Raspbian GNU/Linux 10 (RPi 2)