Kirjoittaja Aihe: Ubuntu 18.04 LTS:n pakettivarasto  (Luettu 2460 kertaa)

Pendeli

  • Käyttäjä
  • Viestejä: 511
    • Profiili
Ubuntu 18.04 LTS:n pakettivarasto
« : 02.06.19 - klo:19.25 »
Testailin 18-versiota ja tulin siihen tulokseen, että eipä  ole mitään syytä hosua
vanhasta ja hyvin toimivasta 16.04:stä uudempaan ainakaan vielä. En pikaisella
ja lyhyellä käytöllä huomannut mitään etuja sillä verrattuna nykyiseen.

Eniten ihmetytti pakettivaraston köyhyys ja suppeus. Onko tosiaan niin, että se on karsittu
lähes olemattomiin vai enkö löytänyt jostain syystä kaikkea sieltä? 16-versiossa sentään löytyy ohjelmistoa moneen lähtöön, vaikkakin vanhentunutta ja toimimatontakin  iso osa ainakin niistä mitä itse suosin.

En ole mikään tietokoneiden  tehokäyttäjä muutenkaan, joten ehkä odottelen ainakin ensi vuoteen. Silloinhan saadaan jo versio 20 ulos.

mrl586

  • Käyttäjä
  • Viestejä: 4496
    • Profiili
Vs: Ubuntu 18.04 LTS:n pakettivarasto
« Vastaus #1 : 02.06.19 - klo:20.30 »
Asenna synaptic Ubuntuun, niin näet koko pakettivalikoiman. Tämän lisäksi voit ottaa myös käyttöön PPA-repoja tarvittaessa. Lisäksi monista ohjelmista on saatavilla myös snap- tai flatpak-paketoitu versio, jollaisia voi myös asentaa Ubuntuun.

HannuK

  • Käyttäjä
  • Viestejä: 146
    • Profiili
Vs: Ubuntu 18.04 LTS:n pakettivarasto
« Vastaus #2 : 02.06.19 - klo:23.37 »
Asenna synaptic Ubuntuun, niin näet koko pakettivalikoiman. Tämän lisäksi voit ottaa myös käyttöön PPA-repoja tarvittaessa. Lisäksi monista ohjelmista on saatavilla myös snap- tai flatpak-paketoitu versio, jollaisia voi myös asentaa Ubuntuun.
Mielestäni on väärä periaate, että pitää "keksiä" keinot, millä saadaan jotakin näkymään uudessa OS versiossa. Eihän sellaisia asioita uudet käyttäjät tiedä. Liian nörttimäistä. Homma pitää hoitaa niin, että asiat ovat heti automaattisesti nähtävissä/asennettavissa, eikä kikkailujen kautta. Itse pidän 16.04 ää vielä oikein hyvänä versiona, tosin jotkin asiat tuntuvat olevan paremmin 18.04:ssä. Suo siellä, vetelä täällä.

epiphone

  • Käyttäjä
  • Viestejä: 412
    • Profiili
Vs: Ubuntu 18.04 LTS:n pakettivarasto
« Vastaus #3 : 02.06.19 - klo:23.45 »
Mä olen samoilla linjoilla sun kanssa, kyllä tuo synaptic saisi olla perusasennuksessa mukana. Synaptic on se toiseksi paras keino asentaa ohjelmia heti apt:n jälkeen.



Muoks. Typoja korjattu
« Viimeksi muokattu: 03.06.19 - klo:00.46 kirjoittanut epiphone »
Kahvi on väkevin juomani

juylii

  • Käyttäjä
  • Viestejä: 92
    • Profiili
Vs: Ubuntu 18.04 LTS:n pakettivarasto
« Vastaus #4 : 03.06.19 - klo:21.35 »
Eniten ihmetytti pakettivaraston köyhyys ja suppeus. Onko tosiaan niin, että se on karsittu lähes olemattomiin vai enkö löytänyt jostain syystä kaikkea sieltä?
Virallisista ohjelmavarastoista tarjollaolevat ohjelmat kyllä löytyvät helposti sivulta:
https://packages.ubuntu.com
Ubuntu 18.04 LTS ei ole enää edes mikään uusi, vaan ollut tarjolla jo vuoden. Tuskin kovin laajalti on ohjelmia karsittu, eikä toimimattomia varmastikaan ole juuri tarjolla.
Kerropa, mitkä ohjelmat on ohjelmalähteistä jääneet saamatta.  Jos tarvitset joitakin erityisohjelmia etsi sopiva PPA-repo tai nouda ohjelma tekijöiden kotisivuilta.
Yhden ohjelman näemmä tiedän, jota ei enää ole tarjolla: https://packages.ubuntu.com/search?keywords=youtube-dl&searchon=names&suite=disco&section=all
Tuota ei näemmä enää tarjota kuin uusimmalle 19.04 Disco jakeluun.
Synaptic on toki ihan kätevä asennusohjelma, mutta ei välttämättä pakko asennella.
Ubuntu 16.04 LTS on toki yhä tuettu, mutta hissuksiin se on "vanhentunut", eikä siihen ole tarjolla aina uusimpia versioita ohjelmistoista.

Tomin

  • Palvelimen ylläpitäjä
  • Käyttäjä / moderaattori+
  • Viestejä: 10666
    • Profiili
    • Tomin kotisivut
Vs: Ubuntu 18.04 LTS:n pakettivarasto
« Vastaus #5 : 03.06.19 - klo:22.56 »
Yhden ohjelman näemmä tiedän, jota ei enää ole tarjolla: https://packages.ubuntu.com/search?keywords=youtube-dl&searchon=names&suite=disco&section=all
Tuota ei näemmä enää tarjota kuin uusimmalle 19.04 Disco jakeluun.

Mistä näin päättelet? Sivulla on linkki Bionicin (18.04) lähteistä löytyvään versioon.
Automaattinen allekirjoitus:
Lisäisitkö [RATKAISTU] ketjun ensimmäisen viestin aiheeseen ongelman ratkettua, kiitos.

mrl586

  • Käyttäjä
  • Viestejä: 4496
    • Profiili
Vs: Ubuntu 18.04 LTS:n pakettivarasto
« Vastaus #6 : 04.06.19 - klo:02.59 »
Yhden ohjelman näemmä tiedän, jota ei enää ole tarjolla: https://packages.ubuntu.com/search?keywords=youtube-dl&searchon=names&suite=disco&section=all
Tuota ei näemmä enää tarjota kuin uusimmalle 19.04 Disco jakeluun.

Mistä näin päättelet? Sivulla on linkki Bionicin (18.04) lähteistä löytyvään versioon.
Youtube-dl kannattaa asentaa Ubuntuun snap-pakettina, sillä näin tarjolla on aina mahdollisimman tuore versio siitä.
Koodia: [Valitse]
sudo snap install youtube-dl --edge

juylii

  • Käyttäjä
  • Viestejä: 92
    • Profiili
Vs: Ubuntu 18.04 LTS:n pakettivarasto
« Vastaus #7 : 04.06.19 - klo:19.33 »
Mistä näin päättelet? Sivulla on linkki Bionicin (18.04) lähteistä löytyvään versioon.
Hupsista, sattui tuollainen pikku kömmähdys :( Etsin oletuksena vain Disco (19.04) version ohjelmasta.
https://packages.ubuntu.com/search?keywords=youtube-dl&searchon=names&suite=all&section=all
Mutta jotkin noista youtube-dl -sovellutuksista oli liian vanhoja toimiakseen youtube.com:ssa. Koskapa minulla ei ole ollut enää aikoihin Bionic-versiota, en tiedä tuon youtube-dl 2018.03.14-1: all. 

Postimies

  • Käyttäjä
  • Viestejä: 2235
    • Profiili
Vs: Ubuntu 18.04 LTS:n pakettivarasto
« Vastaus #8 : 19.06.19 - klo:22.04 »
Yksi harmitus itselle on kauko-ohjain. Oli rikki ubuntu 18 lts.
Päivittelin sitten testiasennuksen uusimpaan ja amarok katosi..
Pysynpä vielä tässä 16 lts varsiossa jossa Amarok soittaa musaa ja Kodi toimii kauko-ohjaimella.
Kauko-ohjain ongelman voi kiertää asentamalla lirc paketin Ubuntu 16 pakettivarastosta.
Tiedän, että Kodi toimii ilman lirc, mutta  vdr-sxfe ei ja TV-tallenteita on kiva leikata sohvalta käsin.
Tiedän, että löytyy niitä kännykkä apseja. Kapula vaan niin paljon helpompi kädessä. Napit löytyy
katsomatta. Pidän Amarok soittimen tilastotiedoista ja hyvistä hakuominaisuuksista.
Pitkään sinnittelin myös FireFoxin vanhalla selaimella. Se kun osasi äännehtiä ilman
pulsea. Uudet vaativat pulsen. On sentään selaimia jotka eivät sitä pulsea tarvitse.
Lirc poistunee joskus kokonaan kun suuri osa kauko-ohjainten koodista siirtynyt kerneliin.
X tuntuu myös monet kauko-ohjaimat tunnistavan näppäimistöksi. Siitä tulee taas tuplia kun
näppäimen tunnistaa X ja lirc. Arvatkaa kuinka kivaa se on. Kun painaa '1' niin saa kanavan '11'.
Ei minulla mitään ongelmia ole - kunhan en päivitä. 

nm

  • Käyttäjä
  • Viestejä: 12920
    • Profiili
Vs: Ubuntu 18.04 LTS:n pakettivarasto
« Vastaus #9 : 19.06.19 - klo:22.10 »
Tiedän, että Kodi toimii ilman lirc, mutta  vdr-sxfe ei ja TV-tallenteita on kiva leikata sohvalta käsin.

VDR:n remote-plugin ei tarvitse Lirciä väliin.

Postimies

  • Käyttäjä
  • Viestejä: 2235
    • Profiili
Vs: Ubuntu 18.04 LTS:n pakettivarasto
« Vastaus #10 : 21.06.19 - klo:14.01 »
Tiedän, että Kodi toimii ilman lirc, mutta  vdr-sxfe ei ja TV-tallenteita on kiva leikata sohvalta käsin.

VDR:n remote-plugin ei tarvitse Lirciä väliin.
Tuota en ole kokeillut vaikka ollut mietinnässä.  vdr-sxfe tullut muutenkin vähän epävakaaksi. Valikot katoilee ja saa olla iloinen, että mainoskatkot ym pois.
Vähän sitä tulee enää käytettyä ja samoin vdr kun Areena tarjoaa katsottavaa tyydyttävällä laadulla.  Helpommalla pääsen kun käytän toimivaa ja en päivitä.
Tempasin koko systeemistä levykuvan että pääsee halposti takasin jos sählää jotain.