Kirjoittaja Aihe: Resoluutio väärin käynnistyksessä  (Luettu 1030 kertaa)

kx

  • Käyttäjä
  • Viestejä: 636
    • Profiili
Resoluutio väärin käynnistyksessä
« : 09.04.19 - klo:21.53 »
Ubuntu 18.04lts arpoo ilmeisesti näytönohjainta? Aikaisemmin on toiminut hyvin, mutta nyt joka toinen käynnistys onnistuu ja Nvidia Gt730 jää päälle, mutta joka toinen taas tulee isolla reloluutiolla. Luulen, että sisäinen näytönohjain menee päälle. Mitenkäs pääsen virhelistaa katsomaan?
HP Compaq 6300 sff intel i3-3220 core 2  3,3,Hz RAM 12 Gb+Kingston 240Gt SSD+ nVidia Gt730+Ubuntu 20.04 lts + W10Pro64-bit ja Samsung ML-2165 sekä CanoScan Lide300
HP Compaq DC7900 sff Intel Core 2 duo E7300  RAM 8 Gb + Kingston 240GT SSD +  Ubuntu 20.04 lts +

nm

  • Käyttäjä
  • Viestejä: 13553
    • Profiili
Vs: Resoluutio väärin käynnistyksessä
« Vastaus #1 : 09.04.19 - klo:22.54 »
Ubuntu 18.04lts arpoo ilmeisesti näytönohjainta? Aikaisemmin on toiminut hyvin, mutta nyt joka toinen käynnistys onnistuu ja Nvidia Gt730 jää päälle, mutta joka toinen taas tulee isolla reloluutiolla. Luulen, että sisäinen näytönohjain menee päälle.

Tuossa koneessa ei ole hybridinäytönohjainsysteemiä. Jos sisäinen näytönohjain tulisi käyttöön GeForcen sijaan, GeForcen ulostulossa ei näkyisi mitään.


Mitenkäs pääsen virhelistaa katsomaan?

Olennaisin loki on tiedostossa /var/log/Xorg.0.log

Kannattaa ottaa se talteen sekä onnistuneesta että epäonnistuneesta käynnistyksestä ja verrata sitten sisältöä.

kx

  • Käyttäjä
  • Viestejä: 636
    • Profiili
Vs: Resoluutio väärin käynnistyksessä
« Vastaus #2 : 13.05.19 - klo:09.30 »
No pitkään sain odotella, että virhe resoluutio taas ilmestyi. Eli kuukauden verran kone toimi hyvin. Nyt on tuohon alle kopioitu kummankin tapauksen logit.
Hyvin käynnistynyt ja hyvä resoluutio:

Koodia: [Valitse]
amilo@amilo-Amilo-Desktop-PI3410A:~$ tail -n 3300 /var/log/Xorg.0.log
[     8.533] (--) Log file renamed from "/var/log/Xorg.pid-897.log" to "/var/log/Xorg.0.log"
[     8.534]
X.Org X Server 1.19.6
Release Date: 2017-12-20
[     8.534] X Protocol Version 11, Revision 0
[     8.534] Build Operating System: Linux 4.4.0-138-generic x86_64 Ubuntu
[     8.534] Current Operating System: Linux amilo-Amilo-Desktop-PI3410A 4.15.0-47-generic #50-Ubuntu SMP Wed Mar 13 10:44:52 UTC 2019 x86_64
[     8.534] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-4.15.0-47-generic root=UUID=31f0f2b6-669b-4974-9086-2c687932cddb ro quiet splash vt.handoff=1
[     8.535] Build Date: 25 October 2018  04:11:27PM
[     8.535] xorg-server 2:1.19.6-1ubuntu4.2 (For technical support please see http://www.ubuntu.com/support)
[     8.535] Current version of pixman: 0.34.0
[     8.535] Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
[     8.535] Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[     8.544] (==) Log file: "/var/log/Xorg.0.log", Time: Wed Apr 10 10:10:21 2019
[     8.545] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[     8.545] (==) No Layout section.  Using the first Screen section.
[     8.545] (==) No screen section available. Using defaults.
[     8.545] (**) |-->Screen "Default Screen Section" (0)
[     8.545] (**) |   |-->Monitor "<default monitor>"
[     8.546] (==) No monitor specified for screen "Default Screen Section".
Using a default monitor configuration.
[     8.546] (==) Automatically adding devices
[     8.546] (==) Automatically enabling devices
[     8.546] (==) Automatically adding GPU devices
[     8.546] (==) Automatically binding GPU devices
[     8.547] (==) Max clients allowed: 256, resource mask: 0x1fffff
[     8.547] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[     8.547] Entry deleted from font path.
[     8.547] (WW) The directory "/usr/share/fonts/X11/100dpi/" does not exist.
[     8.547] Entry deleted from font path.
[     8.547] (WW) The directory "/usr/share/fonts/X11/75dpi/" does not exist.
[     8.547] Entry deleted from font path.
[     8.548] (WW) The directory "/usr/share/fonts/X11/100dpi" does not exist.
[     8.620] Entry deleted from font path.
[     8.620] (WW) The directory "/usr/share/fonts/X11/75dpi" does not exist.
[     8.620] Entry deleted from font path.
[     8.620] (==) FontPath set to:
/usr/share/fonts/X11/misc,
/usr/share/fonts/X11/Type1,
built-ins
[     8.620] (==) ModulePath set to "/usr/lib/xorg/modules"
[     8.620] (II) The server relies on udev to provide the list of input devices.
If no devices become available, reconfigure udev or disable AutoAddDevices.
[     8.620] (II) Loader magic: 0x5575ecd32020
[     8.620] (II) Module ABI versions:
[     8.620] X.Org ANSI C Emulation: 0.4
[     8.620] X.Org Video Driver: 23.0
[     8.620] X.Org XInput driver : 24.1
[     8.620] X.Org Server Extension : 10.0
[     8.624] (++) using VT number 1

[     9.139] (II) systemd-logind: took control of session /org/freedesktop/login1/session/_31
[     9.140] (II) xfree86: Adding drm device (/dev/dri/card0)
[     9.143] (II) systemd-logind: got fd for /dev/dri/card0 226:0 fd 12 paused 0
[     9.148] (**) OutputClass "nvidia" ModulePath extended to "/usr/lib/x86_64-linux-gnu/nvidia/xorg,/usr/lib/xorg/modules"
[     9.152] (--) PCI:*(0:2:0:0) 10de:1287:1043:84f5 rev 161, Mem @ 0xfd000000/16777216, 0xf0000000/134217728, 0xfa000000/33554432, I/O @ 0x0000ec00/128, BIOS @ 0x????????/131072
[     9.153] (II) LoadModule: "glx"
[     9.154] (II) Loading /usr/lib/x86_64-linux-gnu/nvidia/xorg/libglx.so
[     9.227] (II) Module glx: vendor="NVIDIA Corporation"
[     9.227] compiled for 4.0.2, module version = 1.0.0
[     9.227] Module class: X.Org Server Extension
[     9.227] (II) NVIDIA GLX Module  390.116  Sun Jan 27 06:24:32 PST 2019
[     9.227] (II) Applying OutputClass "nvidia" to /dev/dri/card0
[     9.228] loading driver: nvidia
[     9.228] (==) Matched nvidia as autoconfigured driver 0
[     9.228] (==) Matched nouveau as autoconfigured driver 1
[     9.228] (==) Matched nouveau as autoconfigured driver 2
[     9.228] (==) Matched modesetting as autoconfigured driver 3
[     9.228] (==) Matched fbdev as autoconfigured driver 4
[     9.228] (==) Matched vesa as autoconfigured driver 5
[     9.229] (==) Assigned the driver to the xf86ConfigLayout
[     9.229] (II) LoadModule: "nvidia"
[     9.229] (II) Loading /usr/lib/x86_64-linux-gnu/nvidia/xorg/nvidia_drv.so
[     9.230] (II) Module nvidia: vendor="NVIDIA Corporation"
[     9.230] compiled for 4.0.2, module version = 1.0.0
[     9.230] Module class: X.Org Video Driver
[     9.230] (II) LoadModule: "nouveau"
[     9.230] (II) Loading /usr/lib/xorg/modules/drivers/nouveau_drv.so
[     9.231] (II) Module nouveau: vendor="X.Org Foundation"
[     9.231] compiled for 1.19.3, module version = 1.0.15
[     9.232] Module class: X.Org Video Driver
[     9.232] ABI class: X.Org Video Driver, version 23.0
[     9.232] (II) LoadModule: "modesetting"
[     9.232] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[     9.232] (II) Module modesetting: vendor="X.Org Foundation"
[     9.232] compiled for 1.19.6, module version = 1.19.6
[     9.233] Module class: X.Org Video Driver
[     9.233] ABI class: X.Org Video Driver, version 23.0
[     9.233] (II) LoadModule: "fbdev"
[     9.233] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
[     9.233] (II) Module fbdev: vendor="X.Org Foundation"
[     9.233] compiled for 1.19.3, module version = 0.4.4
[     9.234] Module class: X.Org Video Driver
[     9.234] ABI class: X.Org Vi

Ja huono resolutio:

Koodia: [Valitse]
amilo@amilo-Amilo-Desktop-PI3410A:~$ tail -n 3300 /var/log/Xorg.0.log
[     8.846] (--) Log file renamed from "/var/log/Xorg.pid-907.log" to "/var/log/Xorg.0.log"
[     8.859]
X.Org X Server 1.19.6
Release Date: 2017-12-20
[     8.859] X Protocol Version 11, Revision 0
[     8.859] Build Operating System: Linux 4.4.0-138-generic x86_64 Ubuntu
[     8.859] Current Operating System: Linux amilo-Amilo-Desktop-PI3410A 4.15.0-48-generic #51-Ubuntu SMP Wed Apr 3 08:28:49 UTC 2019 x86_64
[     8.859] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-4.15.0-48-generic root=UUID=31f0f2b6-669b-4974-9086-2c687932cddb ro quiet splash vt.handoff=1
[     8.859] Build Date: 25 October 2018  04:11:27PM
[     8.859] xorg-server 2:1.19.6-1ubuntu4.2 (For technical support please see http://www.ubuntu.com/support)
[     8.859] Current version of pixman: 0.34.0
[     8.859] Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
[     8.859] Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[     8.860] (==) Log file: "/var/log/Xorg.0.log", Time: Mon May 13 07:30:14 2019
[     8.860] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[     8.860] (==) No Layout section.  Using the first Screen section.
[     8.861] (==) No screen section available. Using defaults.
[     8.861] (**) |-->Screen "Default Screen Section" (0)
[     8.861] (**) |   |-->Monitor "<default monitor>"
[     8.861] (==) No monitor specified for screen "Default Screen Section".
Using a default monitor configuration.
[     8.861] (==) Automatically adding devices
[     8.861] (==) Automatically enabling devices
[     8.861] (==) Automatically adding GPU devices
[     8.861] (==) Automatically binding GPU devices
[     8.861] (==) Max clients allowed: 256, resource mask: 0x1fffff
[     8.861] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[     8.861] Entry deleted from font path.
[     8.861] (WW) The directory "/usr/share/fonts/X11/100dpi/" does not exist.
[     8.861] Entry deleted from font path.
[     8.861] (WW) The directory "/usr/share/fonts/X11/75dpi/" does not exist.
[     8.861] Entry deleted from font path.
[     8.861] (WW) The directory "/usr/share/fonts/X11/100dpi" does not exist.
[     8.861] Entry deleted from font path.
[     8.861] (WW) The directory "/usr/share/fonts/X11/75dpi" does not exist.
[     8.861] Entry deleted from font path.
[     8.861] (==) FontPath set to:
/usr/share/fonts/X11/misc,
/usr/share/fonts/X11/Type1,
built-ins
[     8.861] (==) ModulePath set to "/usr/lib/xorg/modules"
[     8.861] (II) The server relies on udev to provide the list of input devices.
If no devices become available, reconfigure udev or disable AutoAddDevices.
[     8.861] (II) Loader magic: 0x556231c07020
[     8.861] (II) Module ABI versions:
[     8.861] X.Org ANSI C Emulation: 0.4
[     8.861] X.Org Video Driver: 23.0
[     8.861] X.Org XInput driver : 24.1
[     8.861] X.Org Server Extension : 10.0
[     8.863] (++) using VT number 1

[     8.866] (II) systemd-logind: took control of session /org/freedesktop/login1/session/_31
[     8.874] (--) PCI:*(0:2:0:0) 10de:1287:1043:84f5 rev 161, Mem @ 0xfd000000/16777216, 0xf0000000/134217728, 0xfa000000/33554432, I/O @ 0x0000ec00/128, BIOS @ 0x????????/131072
[     8.882] (II) LoadModule: "glx"
[     8.890] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[     8.898] (II) Module glx: vendor="X.Org Foundation"
[     8.898] compiled for 1.19.6, module version = 1.0.0
[     8.898] ABI class: X.Org Server Extension, version 10.0
[     8.898] (==) Matched nouveau as autoconfigured driver 0
[     8.898] (==) Matched modesetting as autoconfigured driver 1
[     8.898] (==) Matched fbdev as autoconfigured driver 2
[     8.898] (==) Matched vesa as autoconfigured driver 3
[     8.898] (==) Assigned the driver to the xf86ConfigLayout
[     8.898] (II) LoadModule: "nouveau"
[     8.898] (II) Loading /usr/lib/xorg/modules/drivers/nouveau_drv.so
[     8.914] (II) Module nouveau: vendor="X.Org Foundation"
[     8.915] compiled for 1.19.3, module version = 1.0.15
[     8.917] Module class: X.Org Video Driver
[     8.917] ABI class: X.Org Video Driver, version 23.0
[     8.920] (II) LoadModule: "modesetting"
[     8.921] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[     8.922] (II) Module modesetting: vendor="X.Org Foundation"
[     8.922] compiled for 1.19.6, module version = 1.19.6
[     8.922] Module class: X.Org Video Driver
[     8.922] ABI class: X.Org Video Driver, version 23.0
[     8.922] (II) LoadModule: "fb

Ero käynnistyksissä löytyy kohdalta noin 8.882 / 9,15   jossa LoadModule . "glx"   

Eli mennään lukemaan väärä ajuri  ?  Onkohan joku ajoitusjuttu?  Ja voiko jotain tehdä.  Eihän tuo haittaa, jos kerraqn viikossa temppuilee, mutta kuitenkin.
HP Compaq 6300 sff intel i3-3220 core 2  3,3,Hz RAM 12 Gb+Kingston 240Gt SSD+ nVidia Gt730+Ubuntu 20.04 lts + W10Pro64-bit ja Samsung ML-2165 sekä CanoScan Lide300
HP Compaq DC7900 sff Intel Core 2 duo E7300  RAM 8 Gb + Kingston 240GT SSD +  Ubuntu 20.04 lts +

nm

  • Käyttäjä
  • Viestejä: 13553
    • Profiili
Vs: Resoluutio väärin käynnistyksessä
« Vastaus #3 : 13.05.19 - klo:09.55 »
Nvidian suljettu ajuri puuttuu tuossa alemman lokin tilanteessa, jolloin järjestelmä käyttää sen sijaan avointa Nouveau-ajuria.

Ilmeisesti kernelin päivittyessä Nvidian ajurimoduuli ei ole kääntynyt automaattisesti. DKMS saattaa joskus temppuilla noin, ellei kyse ole jostain oikeasta bugista. Saitko ongelman korjattua?

kx

  • Käyttäjä
  • Viestejä: 636
    • Profiili
Vs: Resoluutio väärin käynnistyksessä
« Vastaus #4 : 13.05.19 - klo:12.18 »
Siis en tehnyt ensimmöisen viestin jälkeen mitään korjausta, vaan jäin odottamaan, että virhe tulisi uudelleen ja saan sen login muistiin. Eli kone toimi kuukauden verran virheittä, mutta tänä aamuna käynnistys meni "väärälle ajurille".

Eihän se haitta iso ole, jos kerran kuussa joutuu sammuttamaan ja käynnistämään uudelleen. Uusi käynnistys näyttää tepsivan kyllä ja saadaan oikea resolutio.
Mutta jos korjaus olisi helppo, niin voisihan sen tehdä.  Miksi se ei joka kerta löydä Nvidian ajuria?  Voisiko olla joku ajoitus...
HP Compaq 6300 sff intel i3-3220 core 2  3,3,Hz RAM 12 Gb+Kingston 240Gt SSD+ nVidia Gt730+Ubuntu 20.04 lts + W10Pro64-bit ja Samsung ML-2165 sekä CanoScan Lide300
HP Compaq DC7900 sff Intel Core 2 duo E7300  RAM 8 Gb + Kingston 240GT SSD +  Ubuntu 20.04 lts +

nm

  • Käyttäjä
  • Viestejä: 13553
    • Profiili
Vs: Resoluutio väärin käynnistyksessä
« Vastaus #5 : 13.05.19 - klo:15.45 »
Eli korjautui itsestään, kun käynnistit järjestelmän uudelleen? Siinä tapauksessa erikoisempi juttu, ja saattaa olla hankalaa jäljittää syytä, ellei netistä löydy vastaavaa tapausta, jonka joku on onnistunut ratkomaan.

kx

  • Käyttäjä
  • Viestejä: 636
    • Profiili
Vs: Resoluutio väärin käynnistyksessä
« Vastaus #6 : 14.05.19 - klo:08.50 »
Joo, laitetaan resolutio-asiaa ikäänkuin seurantaan ellei ala useammin vaivaamaan.

 Jotenkin ongelma liittyy   1½ kuukautta sitten ilmenneisiin ongelmiin käynnistyksessä.  Kun koneessa oli 16.04 lts vielä toissa keväänä, niin kone toimi loistavasti koko 2 vuoden ajan. Siirryin vuosi sitten päivittämällä 18.04 lts:ään ja sekin toimi noin  vuoden ongelmitta. Sitten viime maaliskussa alkoi käynnistys tökkiä ja jouduin asentamaan kokonaan uudelleen ubuntu 18.04 lts:n.

Ja nyt ajoittain sitten käynnistys eksyy kerran kuussa väärään ajuriin.
« Viimeksi muokattu: 14.05.19 - klo:08.52 kirjoittanut kx »
HP Compaq 6300 sff intel i3-3220 core 2  3,3,Hz RAM 12 Gb+Kingston 240Gt SSD+ nVidia Gt730+Ubuntu 20.04 lts + W10Pro64-bit ja Samsung ML-2165 sekä CanoScan Lide300
HP Compaq DC7900 sff Intel Core 2 duo E7300  RAM 8 Gb + Kingston 240GT SSD +  Ubuntu 20.04 lts +