Kirjoittaja Aihe: mount point does not exist  (Luettu 920 kertaa)

pemo

  • Käyttäjä
  • Viestejä: 103
    • Profiili
mount point does not exist
« : 25.01.19 - klo:14.43 »
Ubuntu 18.10 serveri on Synology 110j

Tällainen rivi lisätty fstab tiedostoon.
# /etc/fstab: static file system information.
172.138.2.222:/volume1/video /home/installer/Elokuva nfs users,rw,auto,intr 0 0
mount -a, antaa tällaisen virhe ilmoituksen, en tiedä mikä menee pieleen.
mount.nfs: mount point /home/installer/Elokuva does not exist

Elokuva kansion mountaus luo, mutta jos sitä klikkaa antaa virhe ilmoituksen.
mount:/home/installer//Elokuva: Tiedostoa tai hakemistoa ei ole
Olen yrittänyt etsiä netistä ohjetta, mutta en ole löytänyt mitään lääkettä tähän vaivaan.
Lisäksi englannin kielen taidoissa on paljon toivomisen varaa.

fdisk -l
Laite               Alku     Loppu  Sektorit   Koko Tyyppi
/dev/nvme0n1p1      2048   1023999   1021952   499M Windows recovery environment
/dev/nvme0n1p2   1024000   1228799    204800   100M EFI System
/dev/nvme0n1p3   1228800   1261567     32768    16M Microsoft reserved
/dev/nvme0n1p4   1261568 295317503 294055936 140,2G Microsoft basic data
/dev/nvme0n1p5 295317504 500117503 204800000  97,7G Linux filesystem

retu

  • Käyttäjä
  • Viestejä: 904
    • Profiili
Vs: mount point does not exist
« Vastaus #1 : 25.01.19 - klo:16.44 »
Elokuva kansion mountaus luo, mutta jos sitä klikkaa antaa virhe ilmoituksen.
???
Luulen että sinun pitäisi kyllä luoda se ennen mounttausta.
Koodia: [Valitse]
mkdir /home/installer/Elokuva

pemo

  • Käyttäjä
  • Viestejä: 103
    • Profiili
Vs: mount point does not exist
« Vastaus #2 : 25.01.19 - klo:17.16 »
Ajatus olisi, että fstab tiedosto luo kansiot ja mount ne
käynnistyksen yhteydessä tai ainakin niin kuvittelen.

Nyt saan serveriin yhteyden luomalla se joka kerta erikseen,
antamalla käyttäjän ja salasanan.

nm

  • Käyttäjä
  • Viestejä: 12946
    • Profiili
Vs: mount point does not exist
« Vastaus #3 : 25.01.19 - klo:18.44 »
Ajatus olisi, että fstab tiedosto luo kansiot ja mount ne
käynnistyksen yhteydessä tai ainakin niin kuvittelen.

Nyt saan serveriin yhteyden luomalla se joka kerta erikseen,
antamalla käyttäjän ja salasanan.

Aloitusviestissäsi näkyvä virheilmoitus "mount.nfs: mount point /home/installer/Elokuva does not exist" kertoo, että liitoshakemisto ei ole olemassa. Se pitää luoda erikseen, kuten retu neuvoi. Riittää kuitenkin, että hakemisto luodaan yhden kerran.


pemo

  • Käyttäjä
  • Viestejä: 103
    • Profiili
Vs: mount point does not exist
« Vastaus #4 : 26.01.19 - klo:14.30 »
Käynnistin koneen ja kokeilin klikata Elokuva kansiota ja hups se toimi niinkuin pitikin.

Tein uuden rivin nimellä Music kansio
installer-desktop:/etc# leafpad fstab
172.138.2.222:/volume1/music /home/installer/Music nfs users,rw,auto,intr 0 0
Tallensin sen /etc fstab tiedostoon.
Suoritin seuraavaksi mount komennon,
installer-desktop:/etc# mount -a

Klikkasin Musicn kansiota ja antoi saman virhe-ilmoituksen.
mount:/home/installer//Music: Tiedostoa tai hakemistoa ei ole

Käynnistin koneen uudestaan ja homma pelitti niinkuin pitikin,
mount -a ei vastaa uudelleen käynnistämistä niinkuin olin ajatellut.

Loppu hyvin kaikki hyvin.