Kirjoittaja Aihe: zynadsubfx fusion  (Luettu 1624 kertaa)

redu

  • Käyttäjä
  • Viestejä: 450
    • Profiili
zynadsubfx fusion
« : 11.12.18 - klo:09.01 »
Ubuntu 18.04:n repositoryssa on ZynAddSubFX-versio
3.0.3-1
Sen käyttöliittymä on perinteinen "Paul Nasca"-tyyppinen. Aloituskynnys on paha, jos haluaa tehdä omia soundeja.

Mutta Ubuntulle saa myös kolmannen tahon jatkokehitelmän ZynAddSubFX-Fusion. Myös Windows-versio Fusionista on saatavilla - maksullisena 45€.

Kokeilin Fusion:in Ubuntuversiota kuukausi sitten, ja huomasin, että se on täysin yhteensopiva vanhan Nasca-version kanssa, mutta käyttöliittymä on täysin erilainen. En tiedä, kumpi versio on uudemman Ubuntun (18.10)  repositoryssä?
Uusi käyttöliittymä saattaa olla uuskäyttäjä-ystävällisempi, mutta vanha käyttäjä huomaa siinä huononnuksiakin.

Fusion:issa näyttää olevan myös uutuusbugeja. Esimerkiksi tiedostohallinta töpeksii. Mutta toimii kuitenkin jotenkin kieroilemalla.

Millainen lie 45 euron Windows-versio? Onko joku kokeillut? Demoversionkin voi imuroida, mutta se toimii ymmärtääkseni niin lyhyen ajan, ettei mitään ehdi testata näin monien mahdollisuuksien syntetisaattorissa.
Ubuntua 98%, Winkua 2%

nm

  • Käyttäjä
  • Viestejä: 12885
    • Profiili
Vs: zynadsubfx fusion
« Vastaus #1 : 11.12.18 - klo:12.08 »
Ubuntu 18.04:n repositoryssa on ZynAddSubFX-versio
3.0.3-1
Sen käyttöliittymä on perinteinen "Paul Nasca"-tyyppinen. Aloituskynnys on paha, jos haluaa tehdä omia soundeja.

Mutta Ubuntulle saa myös kolmannen tahon jatkokehitelmän ZynAddSubFX-Fusion. Myös Windows-versio Fusionista on saatavilla - maksullisena 45€.

Kokeilin Fusion:in Ubuntuversiota kuukausi sitten, ja huomasin, että se on täysin yhteensopiva vanhan Nasca-version kanssa, mutta käyttöliittymä on täysin erilainen. En tiedä, kumpi versio on uudemman Ubuntun (18.10)  repositoryssä?

18.10:ssä on täsmälleen sama vanhalla käyttöliittymällä varustettu ZynAddSubFX 3.0.3 kuin 18.04:ssä: https://packages.ubuntu.com/cosmic/zynaddsubfx


Millainen lie 45 euron Windows-versio? Onko joku kokeillut? Demoversionkin voi imuroida, mutta se toimii ymmärtääkseni niin lyhyen ajan, ettei mitään ehdi testata näin monien mahdollisuuksien syntetisaattorissa.

>45 dollarin 64-bittiset Linux-binäärit ovat myös saatavilla samasta paikasta kuin Windows-versio: http://zynaddsubfx.sourceforge.net/download.html

Ellei käyttämässäsi paketoinnissa ole tehty virheitä, sen pitäisi olla samanlainen kuin tuo maksullinen käännös. Voit toki kääntää myös itse: https://github.com/zynaddsubfx/zyn-fusion-build/wiki/Building-on-Linux
« Viimeksi muokattu: 11.12.18 - klo:12.09 kirjoittanut nm »

redu

  • Käyttäjä
  • Viestejä: 450
    • Profiili
Vs: zynadsubfx fusion
« Vastaus #2 : 11.12.18 - klo:13.58 »
nm,
käänsin Fusion:n n. kuukausi sitten tämän allaolevan rautalankamallin mukaan. Toimii, mutta pikkubugeja on löytynyt, kuten aiemmin sanoin. Liekö sittemmin tehty  vähäbugisemmat sourcet?

Curiositeetin vuoksi olisi kiinnostavaa ostaa Windoosaversio 55 taalalla.

Build Zyn-Fusion:
https://github.com/zynaddsubfx/zyn-fusion-build/wiki/Building-on-Linux

The following has been tested on a fresh Ubuntu 16.04 (64-bit) install.
NOTE: If you have zynaddsubfx (or similar) package installed, you should remove it before executing the last command.


$ sudo apt-get install build-essential git ruby libtool libmxml-dev automake cmake libfftw3-dev libjack-jackd2-dev liblo-dev libz-dev libasound2-dev mesa-common-dev libgl1-mesa-dev libglu1-mesa-dev libcairo2-dev libfontconfig1-dev bison
$ git clone https://github.com/zynaddsubfx/zyn-fusion-build
$ cd zyn-fusion-build
$ ruby build-linux.rb
$ tar -jxvf zyn-fusion-linux-64bit-3.0.3-patch1-release.tar.bz2
$ cd zyn-fusion
$ sudo bash ./install-linux.sh
« Viimeksi muokattu: 11.12.18 - klo:14.00 kirjoittanut redu »
Ubuntua 98%, Winkua 2%

redu

  • Käyttäjä
  • Viestejä: 450
    • Profiili
Vs: zynadsubfx fusion
« Vastaus #3 : 11.12.18 - klo:14.11 »
Tuota noin:
Olen tehnyt läppärin näyttöön ikoneita, joita klikkaamalla voin nopeasti vaihtaa Zyn:in soundeja. Tässä hommassa kosketusnäyttö olisi mannaa. Pahaksi onneksi toimiva kosketusnäyttö vaatii Linuksissa toimiakseen viimeisimmän Torvalds-kernelin, jota ei ole 18.04:ssä eikä 18.10:ssa. Eri valmistajien kosketusnäyttöläppäreissä on sitäpaitsi omia Linux-haasteitaan.

Windoosassahan kosketusnäyttöläppäri taas varmasti toimisi. Ehkä pitää tosiaankin hankkia Windoosaversio?
Ubuntua 98%, Winkua 2%