Kirjoittaja Aihe: Verkkokortti katosi  (Luettu 6447 kertaa)

mauriter

  • Käyttäjä
  • Viestejä: 77
    • Profiili
Verkkokortti katosi
« : 13.05.16 - klo:13.48 »
Viimeisimmän päivityksen (13.05.2016) jälkeen katosi verkkokortti. Läppäri on Lenovo B50-30 ja käyttis Ubuntu 14.04LTS. Yritin Lenovon sivuilta löytää verkkokortin tyypin, mutten onnistunut.
Tarvitsisin siis apua. Eli koneessa olevaa verkkokorttia käyttis ei tällä hetkellä tunnista. Mistä ja miten voisin löytää kortin tiedot ja tarvittavan ajurin tai miten palautan päivitystä edeltäneen tilan?
Terhon Mauri

oh2ir

  • Käyttäjä
  • Viestejä: 447
    • Profiili
Vs: Verkkokortti katosi
« Vastaus #1 : 13.05.16 - klo:14.53 »
Minulla kävi samalla tavalla, ensin katosi win10:ssä ja sen jälkeen ubuntussa.

Ratkaisu oli että uusi asennus ubuntu 16.04 LTS, kaikki toimii jopa win10:ssä,
syytä miksi näin kävi en ymmärrä, mutta nyt kaikki on hyvin.

Joten asenna ubuntu uudelleen niin toimii.
73's de Kari OH2BNE

Cristian

  • Käyttäjä
  • Viestejä: 6
    • Profiili
Vs: Verkkokortti katosi
« Vastaus #2 : 13.05.16 - klo:15.18 »
Sama ongelma täällä viimeisimmän päivityksen jälkeen,.

raimo

  • Käyttäjä
  • Viestejä: 3704
    • Profiili
Vs: Verkkokortti katosi
« Vastaus #3 : 13.05.16 - klo:15.41 »
Kannattaa vilkaista mitkä paketit on päivittyneet, se ehkä auttaa vian selvittämisessä.
Koodia: [Valitse]
cat /var/log/apt/history.log
So long and thanks for all the fish!

mauriter

  • Käyttäjä
  • Viestejä: 77
    • Profiili
Vs: Verkkokortti katosi
« Vastaus #4 : 13.05.16 - klo:15.56 »
Tällaista kertoi history.log

Start-Date: 2016-05-13  11:36:10
Commandline: aptdaemon role='role-commit-packages' sender=':1.94'
Install: libgsl2:amd64 (2.1+dfsg-2ubuntu1~trusty)
Upgrade: libnl-genl-3-200:amd64 (3.2.21-1, 3.2.21-1ubuntu1), enfuse:amd64 (4.1.4+dfsg-1ubuntu1~trusty, 4.1.5+dfsg-1ubuntu1~trusty), my-weather-indicator:amd64 (0.8.1-0extras16.04.0, 0.8.1-0extras16.04.1), google-chrome-stable:amd64 (50.0.2661.94-1, 50.0.2661.102-1), hugin-data:amd64 (2015.0.0+dfsg-0ubuntu2~trusty, 2016.0.0+dfsg-1ubuntu1~trusty), enblend:amd64 (4.1.4+dfsg-1ubuntu1~trusty, 4.1.5+dfsg-1ubuntu1~trusty), flashplugin-installer:amd64 (11.2.202.616ubuntu0.14.04.1, 11.2.202.621ubuntu0.14.04.1), hugin:amd64 (2015.0.0+dfsg-0ubuntu2~trusty, 2016.0.0+dfsg-1ubuntu1~trusty), libnl-3-200:amd64 (3.2.21-1, 3.2.21-1ubuntu1), klibc-utils:amd64 (2.0.3-0ubuntu1, 2.0.3-0ubuntu1.14.04.1), hugin-tools:amd64 (2015.0.0+dfsg-0ubuntu2~trusty, 2016.0.0+dfsg-1ubuntu1~trusty), libklibc:amd64 (2.0.3-0ubuntu1, 2.0.3-0ubuntu1.14.04.1), libnl-route-3-200:amd64 (3.2.21-1, 3.2.21-1ubuntu1)
Remove: libgsl0ldbl:amd64 (1.16+dfsg-1ubuntu1)
End-Date: 2016-05-13  11:41:06

Mauri
Terhon Mauri

mauriter

  • Käyttäjä
  • Viestejä: 77
    • Profiili
Vs: Verkkokortti katosi
« Vastaus #5 : 13.05.16 - klo:16.15 »
Yritin pakettien hallinnan kautta asentaa tuon poistetun paketin takaisin, mutta eihän se onnistu ilman verkkoyhteyttä. Mistähän paketin löytäis niin että sen voisi asentaa vaikka usb-tikulta tai cd:ltä?
Terhon Mauri

raimo

  • Käyttäjä
  • Viestejä: 3704
    • Profiili
Vs: Verkkokortti katosi
« Vastaus #6 : 13.05.16 - klo:17.11 »
Yritin pakettien hallinnan kautta asentaa tuon poistetun paketin takaisin, mutta eihän se onnistu ilman verkkoyhteyttä. Mistähän paketin löytäis niin että sen voisi asentaa vaikka usb-tikulta tai cd:ltä?

Kyseessä on ehkä tämä bugi: https://bugs.launchpad.net/ubuntu/+source/libnl3/+bug/1511735
Eli tuo libnl paketin päivitys on särkenyt netin muiltakin, ketjun alimmat viestit on uunituoreita.

Korjaaminen ilman nettiä on hankalaa, tietenkin jollain toisella koneella voi ladata tarvittavat paketit,
kunhan ensin tietää mitä ne tarvittavat paketit on.

Eihän vaan proposed -lähde ole käytössä, sitä ei kannata ottaa käyttöön missään normaalitilanteessa jos haluaa vältää ongelmat.

edit: uusi bugi-ilmoitus samasta aiheesta https://bugs.launchpad.net/ubuntu/+source/libnl3/+bug/1581535
Ja korjausehdotus: http://askubuntu.com/questions/771627/14-04-network-manager-stopped-working
Ehkä toimii, en tiedä.
« Viimeksi muokattu: 13.05.16 - klo:17.14 kirjoittanut raimo »
So long and thanks for all the fish!

mauriter

  • Käyttäjä
  • Viestejä: 77
    • Profiili
Vs: Verkkokortti katosi
« Vastaus #7 : 13.05.16 - klo:17.32 »
Kiitos

Yritin korjausta, mutta

 1. sudo apt-get install libnl-3-200 libnl-3-dev libnl-3-dev \
                           libnl-genl-3-dev libnl-route-3-200 \
                           make gcc build-essential libnl1
vastaus oli:
"Luetaan pakettiluetteloita... Valmis
Muodostetaan riippuvuusduhteiden puu
Luetaan tilatiedot... Valmis
E: Pakettia libnl-genl-3-dev ei löydy
E: Pakettia make ei löydy"

Mitäs tuon puuttuvan paketin saisi ja miten ja mihin se pitäisi tallettaa?
Terhon Mauri

raimo

  • Käyttäjä
  • Viestejä: 3704
    • Profiili
Vs: Verkkokortti katosi
« Vastaus #8 : 13.05.16 - klo:17.46 »
Kiitos

Yritin korjausta, mutta

 1. sudo apt-get install libnl-3-200 libnl-3-dev libnl-3-dev \
                           libnl-genl-3-dev libnl-route-3-200 \
                           make gcc build-essential libnl1
vastaus oli:
"Luetaan pakettiluetteloita... Valmis
Muodostetaan riippuvuusduhteiden puu
Luetaan tilatiedot... Valmis
E: Pakettia libnl-genl-3-dev ei löydy
E: Pakettia make ei löydy"

Mitäs tuon puuttuvan paketin saisi ja miten ja mihin se pitäisi tallettaa?

Mistäpä tuollaisen ohjeen löysit, ei mitään dev -paketteja ole suinkaan tarkoitus asentaa vaan vanhempi tai vielä uudempi versio.
Etenkää ei ole tarvetta kääntää niitä paketteja itse, mihin viittaa tuo yrityksesi asentaa buid-essential ja gcc kamat.

Kannattaa varmaan seurata tuota bukiraporttia ja rauhassa odotella varmasti toimivaa ohjetta.
« Viimeksi muokattu: 13.05.16 - klo:17.49 kirjoittanut raimo »
So long and thanks for all the fish!

nm

  • Käyttäjä
  • Viestejä: 14970
    • Profiili
Vs: Verkkokortti katosi
« Vastaus #9 : 13.05.16 - klo:17.52 »
Lataa trusty-updatesin uusin NetworkManager, jossa on korjaus libnl-vikaan. Käytät näemmä 64-bittistä Ubuntua, joten ensimmäinen alla olevista tiedostoista on sinulle oikea.

64-bittinen paketti: http://se.archive.ubuntu.com/ubuntu/pool/main/n/network-manager/network-manager_0.9.8.8-0ubuntu7.3_amd64.deb

32-bittinen paketti: http://se.archive.ubuntu.com/ubuntu/pool/main/n/network-manager/network-manager_0.9.8.8-0ubuntu7.3_i386.deb

Asennus onnistuu kaksoisklikkaamalla tiedostoa tiedostoselaimessa. Voit ladata paketin toisella koneella, siirtää sen USB-muistitikulla ongelmakoneelle ja asentaa sitten.

Tämä päivitys ei ainakaan vie tilannetta huonompaan suuntaan, eli voit kokeilla turvallisesti.

atobee

  • Käyttäjä
  • Viestejä: 1
    • Profiili
Vs: Verkkokortti katosi
« Vastaus #10 : 14.05.16 - klo:05.56 »
Lataa trusty-updatesin uusin NetworkManager, jossa on korjaus libnl-vikaan. Käytät näemmä 64-bittistä Ubuntua, joten ensimmäinen alla olevista tiedostoista on sinulle oikea.

64-bittinen paketti: http://se.archive.ubuntu.com/ubuntu/pool/main/n/network-manager/network-manager_0.9.8.8-0ubuntu7.3_amd64.deb

32-bittinen paketti: http://se.archive.ubuntu.com/ubuntu/pool/main/n/network-manager/network-manager_0.9.8.8-0ubuntu7.3_i386.deb

Asennus onnistuu kaksoisklikkaamalla tiedostoa tiedostoselaimessa. Voit ladata paketin toisella koneella, siirtää sen USB-muistitikulla ongelmakoneelle ja asentaa sitten.

Tämä päivitys ei ainakaan vie tilannetta huonompaan suuntaan, eli voit kokeilla turvallisesti.
Itsellä tämä auttoi, kiitokset.

Piti rekisteröityä foorumille  jotta pääsi kiittämään avusta mutta eiköhän tälle foorumille ole myöhemminkin käyttöä.

mauriter

  • Käyttäjä
  • Viestejä: 77
    • Profiili
Vs: Verkkokortti katosi
« Vastaus #11 : 14.05.16 - klo:12.29 »
Terve

Kiitos, toimii!
Terhon Mauri

Jyrki L

  • Käyttäjä
  • Viestejä: 495
    • Profiili
Vs: Verkkokortti katosi
« Vastaus #12 : 15.05.16 - klo:10.06 »
Kiitos toimii.
oli outoa kun ei löytynyt koko verkkokuvaketta.

matsukan

  • Käyttäjä
  • Viestejä: 2136
    • Profiili
Vs: Verkkokortti katosi
« Vastaus #13 : 15.05.16 - klo:12.06 »

BC breakki Networkmanagerissa ? Vikaa esiintyy mulla myös joten kyseessä on isompikin epidemia ...
Pohjois-pohjanmaa
-- motto:  backupin tarve huomataan aina liian myöhään

Xnewbie

  • Käyttäjä
  • Viestejä: 126
  • Britney
    • Profiili
Vs: Verkkokortti katosi
« Vastaus #14 : 15.05.16 - klo:16.14 »

BC breakki Networkmanagerissa ? Vikaa esiintyy mulla myös joten kyseessä on isompikin epidemia ...

Taitaa olla aika laajakin ongelma.

En jaksanut yrittää korjailla (kun en osaa), otin tiedot talteen ja pistin puhtaan 16.04 tilalle.

höperö

  • Käyttäjä
  • Viestejä: 1
    • Profiili
Vs: Verkkokortti katosi
« Vastaus #15 : 18.05.16 - klo:11.04 »
 Juupa juu,lauantaista 14.5 tuskailin nettiyhteysongelman kanssa 13.5 päivityksen jälkeen. Vihdoin tänään  18.5 sain yhteyden toimimaan. Mutta kappas vain ,uutta päivitystä tarjottiin,hyväksyin pahoin aavistuksin päivityksen. Niinhän siinä sitten kävi että nettiyhteys katosi taas. Nyt olen jo sen verran harjaantunut jotta sain nettiyhteyden toimimaan parissa minuutissa.
Eli asensin tuon yllä olevan:
 Lataa trusty-updatesin uusin NetworkManager, jossa on korjaus libnl-vikaan. Käytät näemmä 64-bittistä Ubuntua, joten ensimmäinen alla olevista tiedostoista on sinulle oikea.
64-bittinen paketti: http://se.archive.ubuntu.com/ubuntu/pool/main/n/network-manager/network-manager_0.9.8.8-0ubuntu7.3_amd64.deb

Ja nyt en OTA toviin OHJELMISTOPÄIVITYKSIÄ (kun vaan tietäis milloin ne on turvallisia ilman bugeja) :)

KIITOS TÄMÄN KESKUSTELUALUEEN VINKEISTÄ KAIKILLE!!!!!!!!