Kirjoittaja Aihe: HP LaserJet Pro MFP M176n ja Ubuntu 15.04  (Luettu 2915 kertaa)

arise

  • Käyttäjä
  • Viestejä: 28
    • Profiili
HP LaserJet Pro MFP M176n ja Ubuntu 15.04
« : 22.07.15 - klo:22.39 »
Asensin ohjeiden mukaisesti HP Device Managerin, koska tulostus ei pelannut. Nyt kun yritän tulostaa testisivua, tulee ilmoitus, että Plug-In puuttuu. Kun sitä yrittää asentaa, tulee herja "file does not match its checksum. File may have been corrupted or altered".

Osaisiko joku auttaa?

AimoE

  • Käyttäjä
  • Viestejä: 1815
    • Profiili
Vs: HP LaserJet Pro MFP M176n ja Ubuntu 15.04
« Vastaus #1 : 23.07.15 - klo:10.31 »
Itselläni on ollut ihan sama ongelma, tulostinmalli vain on eri malli, mutta Ubuntu mulla on 15.04, ja hplip-asennussydeemi on ihan rikki. Sain korjatuksi sillä että poistin hplip-gui:n ja hplip:n ja hain sitten koko hplip-paketin HP:n sivustolta ja asensin siellä olevan ohjeen mukaan. Asennuksen jälkeen laitoin hplip-gui:ssa ruksin kohtaan kerro päivityksistä, mutta en ole vielä saanut aikaiseksi että asentaisin kaikkein uusimman version (tässä kuussa tullut), kun tulostin kumminkin toimii.

Asennusongelmia oli jo Ubuntu 14.x -versioissa, mutta silloin pääsin niiden yli helpommin, ei tarvinnut ladata HP:n sivustolta pakettia. Ne mun ongelmat, vanhat ja uudet, on täällä palstalla jossain kaikki raportoituna, mutta en nyt ihan yhtäkkiä löydä niitä, pitäisi vähän kaivaa. Jos löyddät, niin jatka vanhaan ketjuun, ei pitäisi olla vielä liian vanha.

Asennusbugi kumminkin on raportoituna Launchpadissa.

AimoE

  • Käyttäjä
  • Viestejä: 1815
    • Profiili
Vs: HP LaserJet Pro MFP M176n ja Ubuntu 15.04
« Vastaus #2 : 23.07.15 - klo:14.25 »
Sen verran vielä selvennän että vika on siinä osassa asennusta jota ylläpidetään Ubuntua varten, eli käsittääkseni vika on Canonicalin vastuulla eikä HP:n koodissa. Vika liittyy siihen millä tavalla pluginin gpg-allekirjoitus tarkistetaan. Aiemmin, 14.x-versioissa asennuksen gpg-asetukset olivat aika aloittelijamaisesti pielessä, mutta ongelman pystyi kiertämään. Nyt 15.04-versiossa vika on pahentunut niin että ainakaan minä en keksinyt miten sen voisi kiertää. Asennuksen ylläpitäjät tarvitsisivat pienen gpg-peruskurssin että lakkaisivat sotkemasta sitä.

nm

  • Käyttäjä
  • Viestejä: 13752
    • Profiili
Vs: HP LaserJet Pro MFP M176n ja Ubuntu 15.04
« Vastaus #3 : 26.07.15 - klo:14.52 »
Sen verran vielä selvennän että vika on siinä osassa asennusta jota ylläpidetään Ubuntua varten, eli käsittääkseni vika on Canonicalin vastuulla eikä HP:n koodissa. Vika liittyy siihen millä tavalla pluginin gpg-allekirjoitus tarkistetaan. Aiemmin, 14.x-versioissa asennuksen gpg-asetukset olivat aika aloittelijamaisesti pielessä, mutta ongelman pystyi kiertämään. Nyt 15.04-versiossa vika on pahentunut niin että ainakaan minä en keksinyt miten sen voisi kiertää. Asennuksen ylläpitäjät tarvitsisivat pienen gpg-peruskurssin että lakkaisivat sotkemasta sitä.

Kuten aiemmassa keskustelussa todettiin, vika on Ubuntu 15.04:n HPLIP-paketoinnin skriptien Python 3 -yhteensopivuudessa. 15.04:ssä HPLIPin skriptejä ajetaan Python 3:lla Python 2:n sijaan. Skriptejä on paikattu Python 3 -yhteensopivaksi, mutta tuo pluginien latauskoodi ei vielä toimi kunnolla. Vika on korjattu uusimmissa HPLIP-versioissa, mutta korjauksia ei ole tuotu Ubuntun paketointiin. 15.10:ssä todennäköisesti toimii suoraan. 15.04:n kanssa lienee helpointa poistaa Ubuntun paketti ja asentaa hplipin sivuilta uusin versio.


Jos joku törmää samaan Ubuntu 14.04:n kanssa, vika on jossain muualla. Yleisenä ongelmana tuntuu olevan se, että SourceForgen palvelimet ovat nurin tai lataus ei onnistu jostain muusta ulkoisesta tekijästä johtuen. HPLIP-versiota vastaavan plugin-paketin voi ladata myös selaimella ja ladatun tiedoston voi asentaa manuaalisesti hp-plugin -ohjelmalla. Linkit eri versioihin on listattu täällä: http://hplip.sourceforge.net/plugin.conf

Käynnistä hp-plugin näin:

Koodia: [Valitse]
sudo -i hp-plugin
« Viimeksi muokattu: 26.07.15 - klo:14.55 kirjoittanut nm »

AimoE

  • Käyttäjä
  • Viestejä: 1815
    • Profiili
Vs: HP LaserJet Pro MFP M176n ja Ubuntu 15.04
« Vastaus #4 : 26.07.15 - klo:17.46 »
Kuten aikaisemmassa ketjussa kerroin, Ubuntu 14.10:ssä vika oli nimenomaan siinä että asennus käytti gpg-komentoja väärin. Sain sen silloin kierretyksi sillä että latasin pluginiin itse ja tein myös gpg-tarkistukset itse.

Se että asennus käytti gpg:tä väärin ilmeni mm. siten että se loi tyhjän hakemiston ~/.hplip/.gnupg jota se ei sitten käyttänytkään (eli hakemisto jäi tyhjäksi). Tuossa vanhassa viestissä jäi mainitsematta sellainen pikkudetalji että Ubuntun tarjoama hplip-asennus on jokaisessa kokeilemassani versiossa aina jättänyt itse luomansa .gnupg-hakemiston väärin suojatuksi. Siitä aheutuvat varoitukset on vaan gpg-komennon piilotettu.

nm

  • Käyttäjä
  • Viestejä: 13752
    • Profiili
Vs: HP LaserJet Pro MFP M176n ja Ubuntu 15.04
« Vastaus #5 : 26.07.15 - klo:18.26 »
Se että asennus käytti gpg:tä väärin ilmeni mm. siten että se loi tyhjän hakemiston ~/.hplip/.gnupg jota se ei sitten käyttänytkään (eli hakemisto jäi tyhjäksi). Tuossa vanhassa viestissä jäi mainitsematta sellainen pikkudetalji että Ubuntun tarjoama hplip-asennus on jokaisessa kokeilemassani versiossa aina jättänyt itse luomansa .gnupg-hakemiston väärin suojatuksi. Siitä aheutuvat varoitukset on vaan gpg-komennon piilotettu.

Toimiiko HPLIPin nettisivulta ladattu versio eri tavalla? Launchpadiin bugiraporttia, niin ongelma saattaa joskus korjaantua. Esimerkiksi tuolla mainitsemasi aiempi HPLIPin bugi käyttäjän .gnupg-hakemiston luomisesta root-oikeuksin huomattiin ja raportoitiin nähdäkseni Ubuntussa ja korjaus vietiin upstreamiin. Jos vika esiintyy myös HP:n virallisessa versiossa, siitä kannattaa raportoida suoraan HPLIPin kehittäjille.
« Viimeksi muokattu: 26.07.15 - klo:18.30 kirjoittanut nm »

AimoE

  • Käyttäjä
  • Viestejä: 1815
    • Profiili
Vs: HP LaserJet Pro MFP M176n ja Ubuntu 15.04
« Vastaus #6 : 26.07.15 - klo:18.40 »
Kuten kerroin viestiketjussa johon sinä viittasit, HP:n sivustolta haettu versio toimii. Ja kun mainitsin .gnupg-hakemiston suojaukset, en tarkoittanut sitä ekaa vikaa jossa se oli rootin omistuksessa, vaan seuraavaa eli hakemistoon on liikaa oikeuksia. Se on ollut niin helppo korjata etten sitten isompien ongelmien keskellä maininnut sitä pienintä.

Koska näitä gpg:n käyttöön ja hakemistojen ja tiedostojen suojauksiin (siinä vanhemmassa ketjussahan mainitsin myös PPD-tiedoston väärän suojauksen) on ollut jo monessa versiossa peräkkäin, tuntuu siltä että asennuksen ylläpitäjä tarvitsisi peruskurssin suojauksista.

Mutta joo, kyllä vika tulee raportoitua heti kun se estää tulostimen käytön. Viimeksihän menin tuohon bugiraporttiin kommentoimaan jonka joku muu oli aloittanut ja sain sieltä sitten neuvon asentaa HP:n sivustolta. Ja kun se toimi, niin ei sitten ollut enää motivaatiota nipottaa.

Onko se rikkinäinen asennusskripti siis Canonicalin vai HP:n?

nm

  • Käyttäjä
  • Viestejä: 13752
    • Profiili
Vs: HP LaserJet Pro MFP M176n ja Ubuntu 15.04
« Vastaus #7 : 26.07.15 - klo:20.09 »
Kuten kerroin viestiketjussa johon sinä viittasit, HP:n sivustolta haettu versio toimii.

Tiedän, että liitännäisen lataus toimii siinä, mutta tekeekö se GPG:n hakemistot ja tiedostot eri oikeuksin kuin Ubuntun paketointi?


Onko se rikkinäinen asennusskripti siis Canonicalin vai HP:n?

15.04:n Python 3 -siirtymän ongelmat ovat Ubuntun paketin vikoja, jotka on korjattu uudemmissa HPLIP-julkaisuissa. Kyseiset skriptit kuuluvat siis alkuperäiseen HPLIPiin, ja Ubuntun paketoijat muuttivat niitä Pythonin uudempaa versiota varten. Liitännäisen lataus jäi kuitenkin bugiseksi 15.04:ssä julkaistuun versioon, eikä vikaa ole korjattu. Sillä välin alkuperäiseen HPLIPiin on toteutettu tarvittava Python 3 -tuki (todennäköisesti Ubuntun paikkausten pohjalta) ja myös liitännäisten latausongelmat on korjattu.

Arvaan, että GPG-tiedostojen väärät oikeudet ovat alkuperäisen HPLIPin bugi, mutta käyttöliittymän toimintaa on hankala kokeilla ilman sopivaa tulostinta.
« Viimeksi muokattu: 26.07.15 - klo:20.15 kirjoittanut nm »

AimoE

  • Käyttäjä
  • Viestejä: 1815
    • Profiili
Vs: HP LaserJet Pro MFP M176n ja Ubuntu 15.04
« Vastaus #8 : 26.07.15 - klo:20.40 »

Tiedän, että liitännäisen lataus toimii siinä, mutta tekeekö se GPG:n hakemistot ja tiedostot eri oikeuksin kuin Ubuntun paketointi?

Vaikea vastata. Tarkistin muistiinpanot, mutta en ole merkinnyt talteen siitä mitään. Joko olin jo niin tottunut korjaamaan suojauksia että korjasin suojauksen huomaamattani, tai sitten se on korjattu asennusskriptiin.

Olen kuitenkin merkinnyt muistiin että taaskin jouduin suorittamaan komennon
Koodia: [Valitse]
sudo chmod +r /etc/cups/ppd/HP_LaserJet_Professional_P_1102w.ppd
Siitä voisi päätellä että olisin kirjannut muistiin myös ~/.hplip/.gnupg -hakemiston suojauksen jos se olisi ollut pielessä, mutta varma en voi olla.

Vielä muoks: muistan kyllä poistaneeni (tai uudelleennimenneeni alta pois) hakemiston ~/.hplip ennen kuin asensin HP:n sivulta haetun paketin.
« Viimeksi muokattu: 26.07.15 - klo:20.42 kirjoittanut AimoE »

arise

  • Käyttäjä
  • Viestejä: 28
    • Profiili
Vs: HP LaserJet Pro MFP M176n ja Ubuntu 15.04
« Vastaus #9 : 09.08.15 - klo:13.26 »
Kiitos vastauksista! Tämä ratkesi vähän kuin itsestään. En tiedä mitä tein, mutta nyt yhtäkkiä alkoi toimimaan.

nm

  • Käyttäjä
  • Viestejä: 13752
    • Profiili
Vs: HP LaserJet Pro MFP M176n ja Ubuntu 15.04
« Vastaus #10 : 09.08.15 - klo:14.23 »
Kiitos vastauksista! Tämä ratkesi vähän kuin itsestään. En tiedä mitä tein, mutta nyt yhtäkkiä alkoi toimimaan.

Näemmä se aiempi Python 3 -ongelma on korjattu jo toukokuussa: https://bugs.launchpad.net/ubuntu/+source/hplip/+bug/1422004

Jos käytössä oli tuo päivitetty versio, liitännäisten latauspalvelussa oli varmaankin jotain muuta väliaikaista häikkää.