Kirjoittaja Aihe: OpenLieroX:ltä puuttuu jokin riippuvuus [Ratkaistu]  (Luettu 3579 kertaa)

Arello

  • Käyttäjä
  • Viestejä: 212
    • Profiili
Yritän siis asentaa OpenLieroX:ää miniläppärini Ubuntu Studio (xfce) 14.04:lle, mutta asennuskohdassa sanoo, että "riippuvuus ei täytettävissä: libgd2-xpm (>=2.0.33)"

Yritin jotain vastaavannimistä asentaa, mutta ei mitään apua.
« Viimeksi muokattu: 18.07.18 - klo:17.53 kirjoittanut Arello »
Läppäri Acer Swift 5 OS: Ubuntu Studio (xfce4) 16.04.02 LTS & Win10
Pöytis OS: Ubuntu Mate 16.04.02 LTS & WinXP

Aatos Rapula

  • Käyttäjä
  • Viestejä: 186
    • Profiili
Vs: OpenLieroX:ltä puuttuu jokin riippuvuus
« Vastaus #1 : 20.08.14 - klo:21.29 »
että "riippuvuus ei täytettävissä: libgd2-xpm (>=2.0.33)"

Näyttäis ettei ole Trustylle olemassa tuollaista pakettia:
http://packages.ubuntu.com/search?keywords=libgd2-xpm
Debian - Jessie - xfce

mrl586

  • Käyttäjä
  • Viestejä: 4427
    • Profiili
Vs: OpenLieroX:ltä puuttuu jokin riippuvuus
« Vastaus #2 : 20.08.14 - klo:21.47 »
Pelistä on olemassa myös Trusty-yhteensopiva binaariversio.
http://www.playdeb.net/game/OpenLieroX
« Viimeksi muokattu: 20.08.14 - klo:21.48 kirjoittanut mrl586 »

Arello

  • Käyttäjä
  • Viestejä: 212
    • Profiili
Vs: OpenLieroX:ltä puuttuu jokin riippuvuus
« Vastaus #3 : 20.08.14 - klo:22.01 »
Mitenhän tuo asentuu? Install now kohdasta kysyy jotain sovellusta, millä pitäisi aukaista, mutta ei ole hajuakaan. Enkä edes muista mistä hakemistosta sovellukset löytyisi...
Läppäri Acer Swift 5 OS: Ubuntu Studio (xfce4) 16.04.02 LTS & Win10
Pöytis OS: Ubuntu Mate 16.04.02 LTS & WinXP

mrl586

  • Käyttäjä
  • Viestejä: 4427
    • Profiili
Vs: OpenLieroX:ltä puuttuu jokin riippuvuus
« Vastaus #4 : 21.08.14 - klo:01.50 »
1. Ota pakettivarasto käyttöön (tämän ohjeen ykköskohta)
2. Aja komento sudo apt-get update
3. Nyt voit asentaa pelin komennolla sudo apt-get install openlierox

Arello

  • Käyttäjä
  • Viestejä: 212
    • Profiili
Vs: OpenLieroX:ltä puuttuu jokin riippuvuus
« Vastaus #5 : 21.08.14 - klo:21.49 »
Testasin pöytäkoneeni Trustyllä, niin ainakin sillä toimii. Kiitoksia.
Läppäri Acer Swift 5 OS: Ubuntu Studio (xfce4) 16.04.02 LTS & Win10
Pöytis OS: Ubuntu Mate 16.04.02 LTS & WinXP

Arello

  • Käyttäjä
  • Viestejä: 212
    • Profiili
Vs: OpenLieroX:ltä puuttuu jokin riippuvuus [Ratkaistu]
« Vastaus #6 : 18.07.18 - klo:17.49 »
Nekropostailuksi menee, mutta ongelma on uusiutunut ainakin Lubuntu 18.04 asennuksessa, jossa olen yrittänyt peliä asentaa.

Playdebin jälkeinen sudo apt-get update vaihe antaa nyt seuraavaa:
Koodia: [Valitse]
Löytyi:2 http://archive.canonical.com/ubuntu bionic InRelease                 
Löytyi:3 http://in.archive.ubuntu.com/ubuntu bionic InRelease                 
Löytyi:4 http://in.archive.ubuntu.com/ubuntu bionic-updates InRelease         
Löytyi:5 http://security.ubuntu.com/ubuntu bionic-security InRelease           
Löytyi:6 http://in.archive.ubuntu.com/ubuntu bionic-backports InRelease       
Siv:1 http://screenshots.getdeb.net bionic-getdeb InRelease             
Vrhe:7 http://screenshots.getdeb.net bionic-getdeb Release
  404  Not Found [IP: 104.28.24.125 80]
Luetaan pakettiluetteloita... Valmis               
E: The repository 'http://archive.getdeb.net/ubuntu bionic-getdeb Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
Oletettavasti tämän seurauksena sudo apt-get install openlierox ei löydä enää pakettia:
Koodia: [Valitse]
Luetaan pakettiluetteloita... Valmis
Muodostetaan riippuvuussuhteiden puu       
Luetaan tilatiedot... Valmis       
E: Pakettia openlierox ei löydy

EDIT: Ongelma näyttäisi ratkenneen sillä, että hoidin tuon playdeb-ohjeen ekan vaiheen manuaalisen kaavan kautta...
« Viimeksi muokattu: 18.07.18 - klo:17.54 kirjoittanut Arello »
Läppäri Acer Swift 5 OS: Ubuntu Studio (xfce4) 16.04.02 LTS & Win10
Pöytis OS: Ubuntu Mate 16.04.02 LTS & WinXP