Kirjoittaja Aihe: Kubuntu 14.04 SSD-buutti hidastuu käytössä  (Luettu 2851 kertaa)

raimo

  • Käyttäjä
  • Viestejä: 3304
    • Profiili
Kubuntu 14.04 SSD-buutti hidastuu käytössä
« : 12.06.14 - klo:14.29 »
Helou! ;)
Hankin pitkän säätämisen jälkeen OCZ Vertex 460 120Gt SSD-levyn jo vähän aikaa sitten. Ja heti innoissani testasin boottausnopeutta bootchartilla ja puhtaaseen päivitettyyn asennukseen se oli vain 13 sekuntia. Mikä nyt on melko makeeta minusta. Bootchart-kuvaa minulla ei ole enää tallessa. Mutta siis se oli kapea se kuva, verrattuna tähän eiliseen ~2.5 viikon käytön jälkeen napattuun kuvaan https://i.imgur.com/xOcETY7.png Tuossahan minusta näyttää että SSD-levy ei tee mitään ja prosessorikin huilailee enimmäkseen. Ei niile ainakaan hiki tule. No siitä sitten asiaa tutkittuani ja Gnome-disks ohjelman benchmarkilla (live-levyltä) luku ja kirjoitusnopeuksia testattuani totesin että levyssä ei ole vikaa, luku tapahtuu yli 500MB/s ja kirjoituskin yli 400 MB/s

Ollin/olen yhteydessä OCZ tukeenkin ja pitkän kirjeenvaidon jälkeen totesimme että jossain muussa on vika kuin raudassa. (Acer X3470, AMD A6-3600x4 2100Mhz SATA3 6GB/s ja 8Gt muistia), Tänään aamusella sitten asensin Kubuntun uudelleen, jälleen kerran, nyt yhdelle osiolle joka täyttää koko levyn. Asensin päivitykset ja ajoin trimmin ja otin kuvan https://i.imgur.com/V6T53iA.png
(luonnollisesti otin useammankin kuvan, tuo on keskiarvoinen) Nopeampaa, mutta ei tyydyttävää minusta. Eli vaikka tyhjensin levyn ko. 13 sekunnin haamuaikaan ei pääse enää lähellekään.
Ja systeemi huilailee minusta, ei edes yritä?

Vai onko tuo bootchart-systeemi järjissään, tosin näppituntumakin on se että kone käynnistyy hitaasti.
Ohjelmat aukeaa kyllä ihan OK, ja muutenkin esim. päivitysten asennus on paljon nopeampaa kuin kiintolevyllä.
Koodia: [Valitse]
raimo@kone:~$ time firefox
real    0m0.121s
user    0m0.033s
sys     0m0.029s
Jos tuo nyt mitään kertoo, ymmärrä en.

Kokeilin myös OpenSuse 13.1:tä (KDE) ja sama tahmatauti on sillä koneen käynnistyksessä.

ACHI on ON ja noatime /etc/fstab:ssa, scheluder tai mikä ikinään se onkaan on deadline.

Tietysti voisi kokeilla miten systeemi toimii Windowsilla (7), pitää kattoa jos jaksaa asentaa sen möhkäleen, voi olla että ei jaksa. Sitä ei voi edes harkita käyttävänsä päätoimisesti, vaikka kuinka nopeasti toimisi, YÄK! :)

Jos nyt tuosta sepustuksesta / noista kuvista joku selvää saa, niin olen ikikiitollinen.  :-*
So long and thanks for all the fish!

jniirane

  • Käyttäjä
  • Viestejä: 22
    • Profiili
Vs: Kubuntu 14.04 SSD-buutti hidastuu käytössä
« Vastaus #1 : 16.06.14 - klo:19.12 »
En osaa sano miksi koneesi käynnistyy hitaasti. Luulisi tuollaisen kokoonpanon käynnistyvän nopeammin. :) Voisiko biosissa jotkin asetukset vaikuttaa? Minulla ei ole bootchartia asennettuna, voisiko se vaikuttaa nopeuteen? Minulla on erilainen kokoonpano niin ei ole vertailukelpoinen, mutta minun koneessa kun painaa virtanappia niin siitä noin 2-3 sekunnin päästä tulee kirjautumis ruutu. Ja kun syöttää salasanan ja painaa entteriä niin samantien on työpöytä näkyvissä.

Minulla on tällainen kone:
emolevy Asus F2A85-M AMD A85 FM2
prosessori AMD A8 6600K Black Edition 4.3 GHz
muisti Kingston HyperX Genesis 8 GB (2 x 4 GB) 1600 MHz DDR3 CL9 XMP
kovalevy Kingston SSDNow V300 120 GB SSD 2.5"
Ubuntu 12.04 64-bit

Onko SSD-levy miten täysi? Olen jostain lukenut että se hidastuu jos on lähes täynnä. Mutta nuo luku ja kirjoitus nopeudet ei oikein tuohon viittaa. Toivottavasti joku viisaampi osaa neuvoa. :)

raimo

  • Käyttäjä
  • Viestejä: 3304
    • Profiili
Vs: Kubuntu 14.04 SSD-buutti hidastuu käytössä
« Vastaus #2 : 16.06.14 - klo:19.54 »
Juu, ei voi vertailla tuo sinun koneesi on paljon tykimpi. Mutta otin nyt sekkarilla aikaa:
Virtanapin painamisesta kirjautumisruutuun 20 sekuntia ja siitä 10 työpöydälle.
Tuosta ekasta ajasta pitää vähentää Grubin 2 sekunnin viive.
Eli joku mättää... BIOS-asetuksia olen muutellut, mielestäni olen kokeillut kaiken mahdollisen, eikä tässä BIOSissa paljon niitä olekkaan. ACHIa en ole kokeillut muuttaa muuksi.

Tuo bootchart ei näytä oikeita lukemia SSD-levyn kanssa kelloon verraten, näyttää liian pitkiä käynnistymisaikoja, poistin sen.

Kokeilin myös Windows 7:lla ja se kyllä pomppaa esille todella nopeasti, muutamassa sekunnissa. Enkä edes saanut siihen päivitettyä emon ajureita, enkä muitakaan kun Acerin sivut oli juuri H-hetkellä down.

Mutta Kubuntun asennus esimerkiksi kestää vain 9 minuuttia, ja siitäkin iso osa ajasta ladataan third-party kamoja netistä.

Levy ei ole täynnä, pikemminkin tyhjä, / osiosta on käytössä 30% ja /homesta peräti 1%

edit. sinänsä tämä ei nyt haittaa, kun kone on päällä yleensä koko päivän, mutta jossain kuitenkin on vikaavikaavikaa. :)
« Viimeksi muokattu: 16.06.14 - klo:20.08 kirjoittanut raimo »
So long and thanks for all the fish!

lompolo

  • Käyttäjä
  • Viestejä: 849
    • Profiili
Vs: Kubuntu 14.04 SSD-buutti hidastuu käytössä
« Vastaus #3 : 17.06.14 - klo:15.48 »
Laita /var/log/dmesg liitteenä.

raimo

  • Käyttäjä
  • Viestejä: 3304
    • Profiili
Vs: Kubuntu 14.04 SSD-buutti hidastuu käytössä
« Vastaus #4 : 17.06.14 - klo:16.00 »
Laita /var/log/dmesg liitteenä.

Kiitos, tässäpä se.
So long and thanks for all the fish!

nm

  • Käyttäjä
  • Viestejä: 12916
    • Profiili
Vs: Kubuntu 14.04 SSD-buutti hidastuu käytössä
« Vastaus #5 : 17.06.14 - klo:16.17 »
dmesgissä ei näy erityisiä viiveitä vaan kerneli ja ajurit latautuvat rivakasti. Vika lienee muissa palveluissa tai graafisen työpöydän puolella, X.org:ssa tai KDM:ssä. /var/log/syslog ja /var/log/Xorg.0.log saattaisivat kertoa enemmän.

raimo

  • Käyttäjä
  • Viestejä: 3304
    • Profiili
Vs: Kubuntu 14.04 SSD-buutti hidastuu käytössä
« Vastaus #6 : 17.06.14 - klo:16.31 »
dmesgissä ei näy erityisiä viiveitä vaan kerneli ja ajurit latautuvat rivakasti. Vika lienee muissa palveluissa tai graafisen työpöydän puolella, X.org:ssa tai KDM:ssä. /var/log/syslog ja /var/log/Xorg.0.log saattaisivat kertoa enemmän.

Kiitos, tässäpä ne.

Tuo syslog on iso, ei mahdu liitteeksi, laiton Dropboxiin:
https://www.dropbox.com/s/s70ij7y42cup9pp/syslog.txt
So long and thanks for all the fish!

lompolo

  • Käyttäjä
  • Viestejä: 849
    • Profiili
Vs: Kubuntu 14.04 SSD-buutti hidastuu käytössä
« Vastaus #7 : 17.06.14 - klo:18.14 »
Xorg.0.log mukaan fglrx modulia yritetään ladata, mutta sitä ei ole. Syslogin mukaan tulee kernel taint. Debuggaaminen vaikeutuu.

Whoopsien ilmoitukset näyttävät hieman oudoilta, mutta johtuukohan se verkkoon yhdistämisestä. Ainakin tuo omituinen "Failsafe of 120 seconds reached." taitaa johtua verkosta.
Koodia: [Valitse]
/etc/init/failsafe.confilmoitus taitaa tulla täältä, mutta ei tuossa ole mennyt 2 minuuttia  ???

Xorg.0.log näyttää 10s viiveen, mutten osaa sanoa syytä.

nm

  • Käyttäjä
  • Viestejä: 12916
    • Profiili
Vs: Kubuntu 14.04 SSD-buutti hidastuu käytössä
« Vastaus #8 : 17.06.14 - klo:19.05 »
Xorg.0.log mukaan fglrx modulia yritetään ladata, mutta sitä ei ole. Syslogin mukaan tulee kernel taint.

Fglrx:n kernelimoduuli on asennettuna, mutta X.org-ajuri ei ole.


Ainakin tuo omituinen "Failsafe of 120 seconds reached." taitaa johtua verkosta.
Koodia: [Valitse]
/etc/init/failsafe.confilmoitus taitaa tulla täältä, mutta ei tuossa ole mennyt 2 minuuttia  ???

Juu, tuo on aika erikoinen ilmoitus.


Xorg.0.log näyttää 10s viiveen, mutten osaa sanoa syytä.

Loppuosa viesteistä taitaa tulla vasta KDM:n latauduttua tai kirjautumisen yhteydessä.

raimo

  • Käyttäjä
  • Viestejä: 3304
    • Profiili
Vs: Kubuntu 14.04 SSD-buutti hidastuu käytössä
« Vastaus #9 : 17.06.14 - klo:19.55 »
Xorg.0.log mukaan fglrx modulia yritetään ladata, mutta sitä ei ole. Syslogin mukaan tulee kernel taint.

Fglrx:n kernelimoduuli on asennettuna, mutta X.org-ajuri ei ole.


Ainakin tuo omituinen "Failsafe of 120 seconds reached." taitaa johtua verkosta.
Koodia: [Valitse]
/etc/init/failsafe.confilmoitus taitaa tulla täältä, mutta ei tuossa ole mennyt 2 minuuttia  ???

Juu, tuo on aika erikoinen ilmoitus.


Xorg.0.log näyttää 10s viiveen, mutten osaa sanoa syytä.

Loppuosa viesteistä taitaa tulla vasta KDM:n latauduttua tai kirjautumisen yhteydessä.


Kokeilin tuota fglrx-ajuria, mutta poistin sen sitten. Miten ko. kernel-moduli poistetaan kummittelemasta, vai onko se sisäänrakennettu jotenkin. Käytän oletusajuria kun mitään etua ei enää minusta saa tuolla suljetulla ajurilla. Ennen se piti tässä koneessa olla HDMI-äänien takia, mutta nyt ne toimii avoimella ajurillakin.

Kubuntu  käyttää nykyisin LightDM:ää ei KDM:ää. (12.10 lähtien jo.)
So long and thanks for all the fish!

nm

  • Käyttäjä
  • Viestejä: 12916
    • Profiili
Vs: Kubuntu 14.04 SSD-buutti hidastuu käytössä
« Vastaus #10 : 17.06.14 - klo:20.39 »
Kokeilin tuota fglrx-ajuria, mutta poistin sen sitten. Miten ko. kernel-moduli poistetaan kummittelemasta, vai onko se sisäänrakennettu jotenkin.

Koodia: [Valitse]
sudo apt-get purge fglrx
Jos ei lähde tuolla, pitänee poistaa dkms:n avulla.

raimo

  • Käyttäjä
  • Viestejä: 3304
    • Profiili
Vs: Kubuntu 14.04 SSD-buutti hidastuu käytössä
« Vastaus #11 : 17.06.14 - klo:21.17 »
Koodia: [Valitse]
sudo apt-get purge fglrx
Jos ei lähde tuolla, pitänee poistaa dkms:n avulla.


Juuri tuolla komennolla sen poistinkin. Tuo dkms ei ollut oletuksena asennettu, outoako?
Koodia: [Valitse]
sudo dkms status fglrxEi näytä mitään, eikä myöskään pelkkä status.
Ja sitten kun yrittää
Koodia: [Valitse]
sudo dkms remove fglrx --allniin itkee että anna versio, mistä minä sen version näen?
En osaa käyttää tuota työkalua.

Mutta tämä syslogin 6 sekunnin viive kummastuttaa kun tässä koneessa ei ole tietääkseni minkäänlaista WiFiä:
Koodia: [Valitse]
Jun 17 20:44:44 kone dbus[569]: [system] Successfully activated service 'org.freedesktop.nm_dispatcher'
Jun 17 20:44:50 kone NetworkManager[854]: <info> WiFi hardware radio set enabled
Vai tuossako sitä verkkoa juuri sitten odotetaan muuten vain?

Kokeilin myös ottaa BIOSista koko verkkokortin pois käytöstä, ei mitään muutosta mihinkään.
« Viimeksi muokattu: 17.06.14 - klo:21.31 kirjoittanut raimo »
So long and thanks for all the fish!

raimo

  • Käyttäjä
  • Viestejä: 3304
    • Profiili
Vs: Kubuntu 14.04 SSD-buutti hidastuu käytössä
« Vastaus #12 : 17.06.14 - klo:22.40 »
Osaanhan minä sitä dkms:ää käyttää, heti näkyy kun asensin fglrx:n takaisin, eli se ei ollut kernelin moduleissa, joku muu ihmejuttu aiheuttaa nyt sen että X:n lokissa se näkyy ladattavana?
Koodia: [Valitse]
raimo@kone:~$ sudo dkms status fglrx
fglrx, 13.350.1, 3.13.0-29-generic, x86_64: installed
lsmod ei myöskään näyttänyt että ko. moduli olisi käytössä, nyt asennuksen jälkeen näyttää kyllä.

Edit: lisäsin /var/log/Xorg.0.log liitetiedoston fglrx ajurilla.
« Viimeksi muokattu: 17.06.14 - klo:23.02 kirjoittanut raimo »
So long and thanks for all the fish!

nm

  • Käyttäjä
  • Viestejä: 12916
    • Profiili
Vs: Kubuntu 14.04 SSD-buutti hidastuu käytössä
« Vastaus #13 : 17.06.14 - klo:23.07 »
Nyt kun luen lokia tarkemmin, huomaan, että fglrx oli mukana vain parissa käynnistyksissä puolen päivän aikaan -- ei enää sen jälkeen. Kokeilit sitä ilmeisesti siis aiemmin tänään ja poistit sitten kokonaan.

Aiemmassa X:n lokissa fglrx näkyy vain siksi, että se on määritelty X.org:n sisällä ensisijaiseksi ajuriksi näytönohjaimellesi. Kun ajuria ei löydy, X.org valitsee sen sijaan avoimen radeon-ajurin.
« Viimeksi muokattu: 17.06.14 - klo:23.10 kirjoittanut nm »

raimo

  • Käyttäjä
  • Viestejä: 3304
    • Profiili
Vs: Kubuntu 14.04 SSD-buutti hidastuu käytössä
« Vastaus #14 : 17.06.14 - klo:23.14 »
Nyt kun luen lokia tarkemmin, huomaan, että fglrx oli mukana vain parissa käynnistyksissä puolen päivän aikaan -- ei enää sen jälkeen. Kokeilit sitä ilmeisesti siis aiemmin tänään ja poistit sitten kokonaan.

Aiemmassa X:n lokissa fglrx näkyy vain siksi, että se on määritelty X.org:n sisällä ensisijaiseksi ajuriksi näytönohjaimellesi. Kun ajuria ei löydy, X.org valitsee sen sijaan avoimen radeon-ajurin.
OK, juu, tänäähän minä sitä kokeilin, ja poistinkin. Ja nyt taas asensin takaisin. :)

Nyt tuossa ylemmän viestin liitetiedostossa minua kummeksuttaa tämä:
Koodia: [Valitse]
[     6.509] (II) fglrx(0): Restoring Recent Mode via PCS is not supported in RANDR 1.2 capable environments
[    16.333] (II) fglrx(0): EDID vendor "PHL", prod id 0
Onko nuo etunumerot sekunteja, vaiko miksi on noin iso harppaus?
« Viimeksi muokattu: 17.06.14 - klo:23.23 kirjoittanut raimo »
So long and thanks for all the fish!

nm

  • Käyttäjä
  • Viestejä: 12916
    • Profiili
Vs: Kubuntu 14.04 SSD-buutti hidastuu käytössä
« Vastaus #15 : 18.06.14 - klo:01.58 »
Nyt tuossa ylemmän viestin liitetiedostossa minua kummeksuttaa tämä:
Koodia: [Valitse]
[     6.509] (II) fglrx(0): Restoring Recent Mode via PCS is not supported in RANDR 1.2 capable environments
[    16.333] (II) fglrx(0): EDID vendor "PHL", prod id 0

Tuo kymmenen sekunnin väli johtunee muiden palvelujen ja ohjelmien käynnistymisestä, ei X.org:sta tai ajureista. Jälkimmäinen rivi tulee lokiin joko siinä vaiheessa, kun LightDM käynnistyy tai kun kirjaudut työpöydälle.

raimo

  • Käyttäjä
  • Viestejä: 3304
    • Profiili
Vs: Kubuntu 14.04 SSD-buutti hidastuu käytössä
« Vastaus #16 : 18.06.14 - klo:12.49 »
Tuo kymmenen sekunnin väli johtunee muiden palvelujen ja ohjelmien käynnistymisestä, ei X.org:sta tai ajureista. Jälkimmäinen rivi tulee lokiin joko siinä vaiheessa, kun LightDM käynnistyy tai kun kirjaudut työpöydälle.
Jep, kiitos. Automaattisella kirjautumisella tuo aika lyhenee kahteen sekunttiin.
So long and thanks for all the fish!

raimo

  • Käyttäjä
  • Viestejä: 3304
    • Profiili
Vs: Kubuntu 14.04 SSD-buutti hidastuu käytössä
« Vastaus #17 : 06.07.14 - klo:10.48 »
Nyt tähän näyttäisi tulleen yllätyskorjaus. :)

Uudella 3.13.0-30 kernelillä kone pompsahtaa käyntiin huomattavasti nopeammin kuin edellisellä kernelillä.
So long and thanks for all the fish!