Kirjoittaja Aihe: locale taas ?  (Luettu 2882 kertaa)

Mistofelees

  • Käyttäjä
  • Viestejä: 548
    • Profiili
locale taas ?
« : 20.05.14 - klo:09.59 »
Aioin asentaa pari pikkuohjelmaa serverille. Ei onnistu, tulee virheilmoitus
"apt-get -f install" ei auta mitään

Osaako kukaan jeesata ?

apt-get install joe
->

Saatat haluta suorittaa "apt-get -f install" korjaamaan nämä:
Näillä paketeilla on tyydyttämättömiä riippuvuuksia:
 libc6 : Suosittelut: libc6-i686
         Rikkoo: locales (< 2.18)
E: Kaikkia riippuvuuksia ei ole tyydytetty. Kokeile "apt-get -f install" ilmanpaketteja (tai ratkaise itse).

nm

  • Käyttäjä
  • Viestejä: 13665
    • Profiili
Vs: locale taas ?
« Vastaus #1 : 20.05.14 - klo:12.21 »
Onko kyseessä Ubuntu vai Debian? Mitä tiedosto /etc/apt/sources.list sisältää?

Mitä tämä komento kertoo:

Koodia: [Valitse]
apt-cache policy libc6 libc6-i686 locales

Mistofelees

  • Käyttäjä
  • Viestejä: 548
    • Profiili
Vs: locale taas ?
« Vastaus #2 : 20.05.14 - klo:12.38 »
Onko kyseessä Ubuntu vai Debian? Mitä tiedosto /etc/apt/sources.list sisältää?

Mitä tämä komento kertoo:

Koodia: [Valitse]
apt-cache policy libc6 libc6-i686 locales


Kiitos vastauksesta
Ollisi mukava saada tämä serveri taas tottelemaan. Koneessa peuhaa monenlaista softaa, eikä tekisi mieli pistää sitä uudelleen asennukseen. Kaikesta on kyllä kopiot, mutta ...

lsb-release:
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=12.04
DISTRIB_CODENAME=precise
DISTRIB_DESCRIPTION="Ubuntu 12.04.4 LTS"


apt-cache policy libc6 libc6-i686 locales:
libc6:
  Asennettu: 2.18-5
  Ehdokas:   2.18-6
  Versiotaulukko:
     2.18-6 0
        500 http://ftp.fi.debian.org/debian/ sid/main i386 Packages
 *** 2.18-5 0
        100 /var/lib/dpkg/status
     2.15-0ubuntu10.5 0
        500 http://fi.archive.ubuntu.com/ubuntu/ precise-updates/main i386 Packages
        500 http://security.ubuntu.com/ubuntu/ precise-security/main i386 Packages
     2.15-0ubuntu10 0
        500 http://fi.archive.ubuntu.com/ubuntu/ precise/main i386 Packages
libc6-i686:
  Asennettu: (ei mitään)
  Ehdokas:   2.18-6
  Versiotaulukko:
     2.18-6 0
        500 http://ftp.fi.debian.org/debian/ sid/main i386 Packages
locales:
  Asennettu: 2.13+git20120306-3
  Ehdokas:   2.18-6
  Versiotaulukko:
     2.18-6 0
        500 http://ftp.fi.debian.org/debian/ sid/main i386 Packages
 *** 2.13+git20120306-3 0
        500 http://fi.archive.ubuntu.com/ubuntu/ precise/main i386 Packages
        100 /var/lib/dpkg/status

/etc/apt/sources.list:
deb http://fi.archive.ubuntu.com/ubuntu/ precise main restricted
deb-src http://fi.archive.ubuntu.com/ubuntu/ precise main restricted
deb http://fi.archive.ubuntu.com/ubuntu/ precise-updates main restricted
deb-src http://fi.archive.ubuntu.com/ubuntu/ precise-updates main restricted
deb http://fi.archive.ubuntu.com/ubuntu/ precise universe
deb-src http://fi.archive.ubuntu.com/ubuntu/ precise universe
deb http://fi.archive.ubuntu.com/ubuntu/ precise-updates universe
deb-src http://fi.archive.ubuntu.com/ubuntu/ precise-updates universe
deb http://fi.archive.ubuntu.com/ubuntu/ precise multiverse
deb-src http://fi.archive.ubuntu.com/ubuntu/ precise multiverse
deb http://fi.archive.ubuntu.com/ubuntu/ precise-updates multiverse
deb-src http://fi.archive.ubuntu.com/ubuntu/ precise-updates multiverse
deb http://fi.archive.ubuntu.com/ubuntu/ precise-backports main restricted universe multiverse
deb-src http://fi.archive.ubuntu.com/ubuntu/ precise-backports main restricted universe multiverse
deb http://security.ubuntu.com/ubuntu precise-security main restricted
deb-src http://security.ubuntu.com/ubuntu precise-security main restricted
deb http://security.ubuntu.com/ubuntu precise-security universe
deb-src http://security.ubuntu.com/ubuntu precise-security universe
deb http://security.ubuntu.com/ubuntu precise-security multiverse
deb-src http://security.ubuntu.com/ubuntu precise-security multiverse
deb http://ftp.fi.debian.org/debian sid main

nm

  • Käyttäjä
  • Viestejä: 13665
    • Profiili
Vs: locale taas ?
« Vastaus #3 : 20.05.14 - klo:12.45 »
deb http://ftp.fi.debian.org/debian sid main

Poista tuo Debianin pakettilähde sources.lististä. Debianin ja Ubuntun lähteet eivät tule keskenään toimeen samassa järjestelmässä.

Päivitä sitten pakettilistat komennolla:

Koodia: [Valitse]
sudo apt-get update

Mistofelees

  • Käyttäjä
  • Viestejä: 548
    • Profiili
Vs: locale taas ?
« Vastaus #4 : 20.05.14 - klo:23.43 »
deb http://ftp.fi.debian.org/debian sid main

Poista tuo Debianin pakettilähde sources.lististä. Debianin ja Ubuntun lähteet eivät tule keskenään toimeen samassa järjestelmässä.

Päivitä sitten pakettilistat komennolla:

Koodia: [Valitse]
sudo apt-get update

Tämä ei vielä auttanut. Samat virheilmoitukset :

root@kotipalvelin:/home/bin/temperature# apt-get -f install
Luetaan pakettiluetteloita... Valmis
Muodostetaan riippuvuussuhteiden puu
Luetaan tilatiedot... Valmis
Korjataan riippuvuuksia... Valmis
Seuraavat paketit POISTETAAN:
  language-pack-en language-pack-en-base language-pack-fi
  language-pack-fi-base locales ubuntu-minimal
0 päivitetty, 0 uutta asennusta, 6 poistettavaa ja 11 päivittämätöntä.
4 ei asennettu kokonaan tai poistettiin.
Toiminnon jälkeen vapautuu 19,0 M t levytilaa.
Haluatko jatkaa [K/e]?
E: Internal Error, No file name for libc6

Äh, inhoan tälläistä avun pyytämistä, mutta ehkä tästä on apua jollekin toiselle

ajaaskel

  • Palvelimen ylläpitäjä
  • Käyttäjä
  • Viestejä: 3394
    • Profiili
Autamme ilolla ja ilmaiseksi omalla ajallamme.  Ethän vaadi, uhoa tai isottele näin saamasi palvelun johdosta.

Mistofelees

  • Käyttäjä
  • Viestejä: 548
    • Profiili
Vs: locale taas ?
« Vastaus #6 : 24.05.14 - klo:20.29 »
Koodia: [Valitse]
dpkg --configure -a
http://askubuntu.com/questions/266450/how-to-fix-e-internal-error-no-file-name-for-libc6


Ihan uudenlaisia virheilmoituksia:

dpkg --configure -a
Setting up libc6 (2.18-5) ...
Checking for services that may need to be restarted...
Checking init scripts...
WARNING: init script for samba not found.
Restarting services possibly affected by the upgrade:
  webmin: restarting...done.
  cron: restarting...done.
  atd: restarting...done.
  apache2: restarting...done.

Services restarted successfully.
dpkg: dependency problems prevent configuration of locales:
 libc6 (2.18-5) breaks locales (<< 2.18) and is installed.
  Version of locales to be configured is 2.13+git20120306-3.
dpkg: error processing locales (--configure):
 dependency problems - leaving unconfigured
Setting up libnih1 (1.0.3-4.2+b1) ...
Setting up libnih-dbus1 (1.0.3-4.2+b1) ...
Processing triggers for libc-bin ...
ldconfig deferred processing now taking place
Errors were encountered while processing:
 locales

Yritin tätä vielä uudestaan:

dpkg --configure -a
dpkg: dependency problems prevent configuration of locales:
 libc6 (2.18-5) breaks locales (<< 2.18) and is installed.
  Version of locales to be configured is 2.13+git20120306-3.
dpkg: error processing locales (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 locales

Taitaa olla helpointa asentaa serveri uudestaan.
Vaikka datoista, lokikirjasta ja /etc:stä onkin backupit, aina huomaa, että jotain muutakin pitäisi panna talteen. Viimeksi jäin kaipaamaan /var/spool/cron/crontabs/.
Samaten käsin asennettu ohjelmat voisi kerätä scriptiin, jonka voisi käynnistää backupista, kun on päivittänyt järjestelmän.

Olisi mukava, jos Linuxissa olisi jonkinlainen restore-point.

jekku

  • Käyttäjä
  • Viestejä: 2409
    • Profiili
Vs: locale taas ?
« Vastaus #7 : 24.05.14 - klo:22.55 »
-----
Olisi mukava, jos Linuxissa olisi jonkinlainen restore-point.

Taitaa paras 'restore-point' muodostua kloonaamalla?
http://clonezilla.org/

En usein ole tarvinnut, mutta onpahan yksi usbitikku (ta tarvittavat muut lelut) käden ulottuvilla :)
Ei mikään salamnnopea, mutta kuten kerroin, ei usein tarvetta.


nm

  • Käyttäjä
  • Viestejä: 13665
    • Profiili
Vs: locale taas ?
« Vastaus #8 : 25.05.14 - klo:14.19 »
dpkg: dependency problems prevent configuration of locales:
 libc6 (2.18-5) breaks locales (<< 2.18) and is installed.
  Version of locales to be configured is 2.13+git20120306-3.
dpkg: error processing locales (--configure):
 dependency problems - leaving unconfigured

Kokeile ladata Ubuntun libc6 ja locales -pakettien deb-tiedostot ja asenna ne dpkg:llä.

Paketit voi hakea vaikkapa packages.ubuntu.com-sivuston kautta. Esimerkiksi sivulta
http://packages.ubuntu.com/precise/libc6 saa 32-bittisen libc6-paketin seuraamalla linkkiä i386.
« Viimeksi muokattu: 25.05.14 - klo:14.20 kirjoittanut nm »

ajaaskel

  • Palvelimen ylläpitäjä
  • Käyttäjä
  • Viestejä: 3394
    • Profiili
Vs: locale taas ?
« Vastaus #9 : 26.05.14 - klo:22.52 »
Lainaus
Olisi mukava, jos Linuxissa olisi jonkinlainen restore-point.
Kieltämättä. Vaikka tämä ei varsinaisesti ole restore-point niin jotain helpotusta ajoittain mahdollistaa "rsnapshot", päivä/viikko/kuukausivarmistukset eli tuo toimii eräänlaisena aikakoneena jolla pääsee takaisin eilisen tilanteeseen, sitä eilisen tilanteeseen, jne. etenkin jos systeemiasetuksiin liittyvä on määritetty talletettavaksi.  Yksinkertainen jokamiehen työkalu "rsnapshot" ei kuitenkaan ole systeemiasetusten peruuttamisessa kuten tuollainen restore-point rakenne mahdollisesti olisi.
Autamme ilolla ja ilmaiseksi omalla ajallamme.  Ethän vaadi, uhoa tai isottele näin saamasi palvelun johdosta.