Kirjoittaja Aihe: [Ratkaistu] Trusty, Qt ja qwt toimimaan?  (Luettu 1891 kertaa)

teele

  • Käyttäjä
  • Viestejä: 528
    • Profiili
[Ratkaistu] Trusty, Qt ja qwt toimimaan?
« : 18.05.14 - klo:20.52 »
Tarkoituksena olisi saada Qt ja qwt toimimaan Trustyssä niin, että esimerkiksi Oscilloscope -esimerkkiohjelman (-projektin ?)  voisi kääntää.

Latasin Qt:n ja qwt:n ja esimerkkiohjelmat Ubuntun Ohjelmistokeskuksesta, ja voi olla, että niiden keskinäisessä versioinnissa on jotain häikkää, mutta en osaa sitä selvittää.

Onko kellään kokemusta asiasta. Olisi mukava testailla vähän jotain muutakin kuin Hello -ohjelmaa.

teele

« Viimeksi muokattu: 21.05.14 - klo:19.56 kirjoittanut teele »

mrl586

  • Käyttäjä
  • Viestejä: 4535
    • Profiili
Vs: Trusty, Qt ja qwt toimimaan?
« Vastaus #1 : 18.05.14 - klo:22.23 »
Kubuntussa on toimiva Qt. Kääntämiseen tarvitset -dev-päätteisiä paketteja.

teele

  • Käyttäjä
  • Viestejä: 528
    • Profiili
Vs: Trusty, Qt ja qwt toimimaan?
« Vastaus #2 : 20.05.14 - klo:09.29 »

Selvä, yritän laittaa Kubuntun koneeseen jossain vaiheessa.

Mutta olisiko vielä joku "metapaketti" tai komentojonosarja, jolla saan kaikki tarvittavat tiedostot mukaan lukien esimerkit niin, että pakettivalintavirheet ainakin jäävät pois.

Aiheen sivusta: En ole koskaan vielä kokeillut Kubuntua, ja tässä koneessa on alun perin ollut Windows 8. Laitoin viime kesänä Ubuntu 12.04:n, ja sitä varten piti uefi vaihtaa legacy modeen. Jos uefia ei laittanut pois päältä, kone käynnistyi aina Windowsiin. Nyt kun uefi on pois päältä, Windowsiin ei pääse, vaikka aloitusvalikosta yrittäisi. Nyt varmaan Kubuntu 14.04 osaa asentua uefin kanssakin?

nm

  • Käyttäjä
  • Viestejä: 13375
    • Profiili
Vs: Trusty, Qt ja qwt toimimaan?
« Vastaus #3 : 20.05.14 - klo:13.56 »
Kubuntussa on toimiva Qt.

Täsmälleen samat paketit latautuvat Ubuntuunkin, kun Qt:n ja qwt:n asentaa apt-getillä.


Tarkoituksena olisi saada Qt ja qwt toimimaan Trustyssä niin, että esimerkiksi Oscilloscope -esimerkkiohjelman (-projektin ?)  voisi kääntää.

Asenna tarvittavat paketit:

Koodia: [Valitse]
sudo apt-get install build-essential g++ libqwt-dev libqwt-doc

Kopioi esimerkkikoodi kotihakemistoosi:

Koodia: [Valitse]
cp -r /usr/share/doc/libqwt-doc/examples ~/qwt-examples

Muokkaa projektin parametreja tiedostossa ~/qwt-examples/examples.pri. Alkuperäinen koodi on tarkoitettu käännettäväksi qwt:n lähdekoodipuussa, mutta sitä ei tarvitse asentaa, jos vain säätää polut oikeiksi. Muuta siis tiedoston alussa olevat rivit:

Lainaus
QWT_ROOT = $${PWD}/..
include( $${QWT_ROOT}/qwtconfig.pri )
include( $${QWT_ROOT}/qwtbuild.pri )

TEMPLATE     = app

INCLUDEPATH += $${QWT_ROOT}/src
DEPENDPATH  += $${QWT_ROOT}/src
DESTDIR      = $${QWT_ROOT}/examples/bin

-->

Lainaus
QWT_ROOT = $${PWD}
include( /usr/share/qt4/mkspecs/features/qwtconfig.pri )

TEMPLATE     = app

INCLUDEPATH += /usr/include/qwt
DESTDIR      = $${QWT_ROOT}/bin


Käännä oscilloscope-esimerkkiohjelma:

Koodia: [Valitse]
cd ~/qwt-examples/oscilloscope
qmake
make

(Jos käännöksessä tulee virheitä, kopioi listaus tänne.)


Käynnistä käännetty esimerkkiohjelma:

Koodia: [Valitse]
~/qwt-examples/bin/oscilloscope

teele

  • Käyttäjä
  • Viestejä: 528
    • Profiili
Vs: Trusty, Qt ja qwt toimimaan?
« Vastaus #4 : 21.05.14 - klo:07.55 »

Esimerkit ovat nyt kotihakemistossani. qtAddLibrary() pitäisi korvata ilmeisestikin, mutta en ole vielä löytänyt missä.

Koodia: [Valitse]
tm@tm:~$ cp -r /usr/share/doc/libqwt-doc/examples ~/qwt-examples
tm@tm:~$ cd ~/qwt-examples/oscilloscope
tm@tm:~/qwt-examples/oscilloscope$ qmake
Project WARNING: qtAddLibrary() is deprecated. Use QT+= instead.
Project ERROR: No module matching library 'qwt' found.
tm@tm:~/qwt-examples/oscilloscope$

nm

  • Käyttäjä
  • Viestejä: 13375
    • Profiili
Vs: Trusty, Qt ja qwt toimimaan?
« Vastaus #5 : 21.05.14 - klo:10.24 »
Koodia: [Valitse]
tm@tm:~$ cp -r /usr/share/doc/libqwt-doc/examples ~/qwt-examples
tm@tm:~$ cd ~/qwt-examples/oscilloscope
tm@tm:~/qwt-examples/oscilloscope$ qmake
Project WARNING: qtAddLibrary() is deprecated. Use QT+= instead.
Project ERROR: No module matching library 'qwt' found.
tm@tm:~/qwt-examples/oscilloscope$

Sinulla on näemmä asennettuna Qt4:n lisäksi myös Qt5-kehitysympäristö, jonka qmake (tai oikeastaan qtchooser) valitsee oletuksena. Ubuntun Qwt-paketointi toimii vain Qt4:n kanssa. Käytä siis komentoa qmake -qt=qt4

Koodia: [Valitse]
cd ~/qwt-examples/oscilloscope
qmake -qt=qt4
make
« Viimeksi muokattu: 21.05.14 - klo:10.27 kirjoittanut nm »

teele

  • Käyttäjä
  • Viestejä: 528
    • Profiili
Vs: Trusty, Qt ja qwt toimimaan?
« Vastaus #6 : 21.05.14 - klo:19.55 »

Kiitos, nyt kääntyy!