Kirjoittaja Aihe: Adobe flash  (Luettu 22043 kertaa)

nm

  • Käyttäjä
  • Viestejä: 14204
    • Profiili
Vs: Adobe flash
« Vastaus #20 : 01.01.14 - klo:17.11 »
Kiitos nyt toimii kaikki muu paitsi live streamit kun sain asennettua tuon vanhan flashin.
Kun kirjoittaa google chrome niin ei sano pääte mitään. Koitin uudestaan tuota pipelightia ja sain päätteeseen herjauksen "ValueError: cannot convert float NaN to integer"

Tämäkin johtunee SSE2-tuen puuttumisesta, tai siitä että johonkin Python-moduuliin eksynyt bugi rikkoo toimintaa vanhemmilla prosessoreilla:
https://bugs.launchpad.net/ubuntu/+source/pycurl/+bug/1063350

Korjauksena voit varhentaa python-software-properties -paketin versiota:

Koodia: [Valitse]
sudo apt-get install python-software-properties=0.82.7
Mutta ei ehkä kannata lähteä leikkimään Pipelightilla, jos Flash toimii nyt riittävän hyvin etkä tarvitse Silverlightia. Uudemman Flash Playerin saa toimimaan vanhoillakin prosessoreilla Chromen kautta.


[0101/164036:ERROR:nacl_helper_linux.cc(233)] NaCl helper process running without a sandbox!

Onnistuit sitten löytämään vielä yhden uuden SSE2-bugin: https://code.google.com/p/chromium/issues/detail?id=318646

Pitäisi varmaan käyttää vanhempaa versiota kunnes vika korjataan. Versio 30.0.1599.114 toiminee vielä. Tässä linkki jollain satunnaisella peilipalvelimella olevaan pakettiin (käyttö omalla vastuulla): http://95.31.35.30/chrome/pool/main/g/google-chrome-stable/google-chrome-stable_30.0.1599.114-1_i386.deb

Leinsa

  • Käyttäjä
  • Viestejä: 22
    • Profiili
Vs: Adobe flash
« Vastaus #21 : 01.01.14 - klo:17.27 »
Kiitos nyt toimii kaikki muu paitsi live streamit kun sain asennettua tuon vanhan flashin.
Kun kirjoittaa google chrome niin ei sano pääte mitään. Koitin uudestaan tuota pipelightia ja sain päätteeseen herjauksen "ValueError: cannot convert float NaN to integer"

Tämäkin johtunee SSE2-tuen puuttumisesta, tai siitä että johonkin Python-moduuliin eksynyt bugi rikkoo toimintaa vanhemmilla prosessoreilla:
https://bugs.launchpad.net/ubuntu/+source/pycurl/+bug/1063350

Korjauksena voit varhentaa python-software-properties -paketin versiota:

Koodia: [Valitse]
sudo apt-get install python-software-properties=0.82.7
Mutta ei ehkä kannata lähteä leikkimään Pipelightilla, jos Flash toimii nyt riittävän hyvin etkä tarvitse Silverlightia. Uudemman Flash Playerin saa toimimaan vanhoillakin prosessoreilla Chromen kautta.


[0101/164036:ERROR:nacl_helper_linux.cc(233)] NaCl helper process running without a sandbox!

Onnistuit sitten löytämään vielä yhden uuden SSE2-bugin: https://code.google.com/p/chromium/issues/detail?id=318646

Pitäisi varmaan käyttää vanhempaa versiota kunnes vika korjataan. Versio 30.0.1599.114 toiminee vielä. Tässä linkki jollain satunnaisella peilipalvelimella olevaan pakettiin (käyttö omalla vastuulla): http://95.31.35.30/chrome/pool/main/g/google-chrome-stable/google-chrome-stable_30.0.1599.114-1_i386.deb

Tarkemmin kun katsoin niin jotkin streamit toimii ja jotkut ei, tämä riittää mulle en tee enää mitään. Kiitos avusta!

rähmä

  • Käyttäjä
  • Viestejä: 113
    • Profiili
Vs: Adobe flash
« Vastaus #22 : 01.01.14 - klo:21.47 »
=)

mä asensin androidiin täältä suoraan

aatelin ehottaa et koittaisit tota linuxi versiota mut jos jo toimii ja oot tyytyväinen nii sit ok

http://www.adobe.com/support/flashplayer/downloads.html

ja androidiin
http://helpx.adobe.com/flash-player/kb/archived-flash-player-versions.html

nm

  • Käyttäjä
  • Viestejä: 14204
    • Profiili
Vs: Adobe flash
« Vastaus #23 : 01.01.14 - klo:23.14 »
aatelin ehottaa et koittaisit tota linuxi versiota mut jos jo toimii ja oot tyytyväinen nii sit ok

http://www.adobe.com/support/flashplayer/downloads.html

Tuolta saa saman 11.2:n, jonka flashplugin-installer asentaa. Asennus vain on manuaalinen ja päivitykset joutuu hoitamaan aina itse lataamalla ja asentamalla uuden version. Ei auta Leinsan yhteensopivuusongelmaan.

salai

  • Käyttäjä
  • Viestejä: 2126
    • Profiili
Vs: Adobe flash
« Vastaus #24 : 02.01.14 - klo:12.01 »
2).
Versiota 11.2 uudemman natiivin Flash Playerin saa Ubuntuun ja muihin Linux-jakeluihin vain Google Chromen mukana ja kyseinen liitännäinen toimii ainoastaan Chromessa ja muissa Chromiumiin perustuvissa selaimissa. Firefoxissa ja useimmissa muissa selaimissa on käytettävä versiota 11.2, johon julkaistaan vain tietoturvapäivityksiä.
Pipelightin avulla saa Flashplayeristä käyttöön Adoben viimeisimmän version muissakin selaimissa.
Adobe Flashin Windows-versio ei ole natiivi linux-sovellus. Se voi olla tietoturvariski, sillä ajettaessa Windows-sovelluksia linuxissa niihin mahdollisesti sisältyviä aukkoja voi hyödyntää.
Samasta sylttytehtaastahan (Adobe) nuo kuitenkin ladataan - ei niitä natiivejakaan kai kukaan Linuxin puolella tee?

Minusta on kuitenkin hyvä, että joku etsii ratkaisuja flashplugin toiminnan jatkumiselle Linuxissakin, kun Adobella ei näytä oikein resurssit ja mielenkiinto riittävän. Kun flash on kuitenkin toistaiseksi aivan ylivoimaisesti eniten käytetty videoitten streemaussysteemi, siis verkkosivustojen lukumäärällä laskettuna.

Pipelightin kehittäjillä näkyy muuten olevan jo alustavissa testeissä versio, jossa plugineita ajetaan hiekkalaatikossa:
pipelight-experimental : “Pipelight Dev Team” team.

PS. Tuo Windows-versio flashpluginista näyttää kaatuvan aina joissakin BBC:n videoissa.

nm

  • Käyttäjä
  • Viestejä: 14204
    • Profiili
Vs: Adobe flash
« Vastaus #25 : 02.01.14 - klo:13.59 »
Adobe Flashin Windows-versio ei ole natiivi linux-sovellus. Se voi olla tietoturvariski, sillä ajettaessa Windows-sovelluksia linuxissa niihin mahdollisesti sisältyviä aukkoja voi hyödyntää.
Samasta sylttytehtaastahan (Adobe) nuo kuitenkin ladataan - ei niitä natiivejakaan kai kukaan Linuxin puolella tee?

Google ja Adobe tekevät natiivia Flash Playeriä Chromium-pohjaisiin selaimiin (tai mihin tahansa Pepper-liitännäisrajapintaa tukevaan ohjelmaan). Tarjolla on sama versio kuin Windowsiin ja OS X:ään.

Mielestäni Lightspark on myös tärkeä projekti, koska vaihtoehtoinen avoin Flash-toteutus olisi pitkällä tähtäimellä kaikkien (paitsi ehkä Adoben) etu.

Karvameduusa

  • Käyttäjä
  • Viestejä: 1055
    • Profiili
Vs: Adobe flash
« Vastaus #26 : 02.01.14 - klo:20.46 »
Adobe lupasi tietoturvapäivitykset viideksi vuodeksi 11.2 versioon.

salai

  • Käyttäjä
  • Viestejä: 2126
    • Profiili
Vs: Adobe flash
« Vastaus #27 : 02.01.14 - klo:21.55 »
Adobe lupasi tietoturvapäivitykset viideksi vuodeksi 11.2 versioon.
Kukas lupaa yhteensopivuuden ja toiminnallisuuden 5 vuodeksi?

Testasin flashpluginien toimivuutta Firefoxilla osoitteessa
http://www.newgrounds.com/portal/view/465908

1. viimeisin natiivi Linux-versio 11.2.202.332
You scored bad 4433!

http://imgur.com/ajQ7dqy

2. Pipelightin asentama uusin Shockwave Flash 11.9 r900
You scored ok 8776!

http://imgur.com/qDqajFR

Melkoinen ero ainakin tuossa testissä.

EDIT: Tässä vielä Google Chrome stable samassa koneessa (Peppermint 4)
You scored awesome 51399!

http://imgur.com/zbRRbvp
« Viimeksi muokattu: 02.01.14 - klo:22.28 kirjoittanut salai »

Karvameduusa

  • Käyttäjä
  • Viestejä: 1055
    • Profiili
Vs: Adobe flash
« Vastaus #28 : 02.01.14 - klo:22.43 »
Kukas lupaa yhteensopivuuden ja toiminnallisuuden 5 vuodeksi?

Luultavasti Adobe. Tuskin tuovat mitään uutta enää 11.2 versioon. Lähinnä tietoturvapäivityksiä.

Oma tulokseni (vsync + opensuse 13.1 KDE + Flash 11.2.202.332 + Nvidia ajuri versio 331.20):



http://zr.fi/NkdnYK

welmar

  • Käyttäjä
  • Viestejä: 1582
    • Profiili
Vs: Adobe flash
« Vastaus #29 : 02.01.14 - klo:22.49 »
Toiminnallisuus ja turvallisuus on kuitenkin eri asia. Olen törmännyt flash-videoihin jotka ei ole toiminut 11.2 mutta Chromella on toiminut. Harvoin muutenkaan olenkaan päivityksiä tehnyt ensijaisesti turvallisuus syistä mutta usein toiminnallisuuden vuoksi. ikävää on jos flash videoita ei voi katsoa kuin googlen avulla, vaikka en varsinaisesti mikään foliohattu olekkaan.       

salai

  • Käyttäjä
  • Viestejä: 2126
    • Profiili
Vs: Adobe flash
« Vastaus #30 : 03.01.14 - klo:03.08 »
Jotain tuon sivuston testissä on kyllä vialla. Sen mukaanhan tämä vanha Asus M2N emolevyn kone AMD 4850e -prosessorilla, 2 gigan DDR2-muistilla ja halvimmalla Nvidian näytönohjaimella olisi ylivoimaisesti nopein (Chromen slashillä 51399) noista testatuista!

Ei anna tosin tallettaa tulosta sinne listaan - johtuneeko siitä, että kiinteä yhteys on ollut eilisestä lähtien poikki ja olen mokkulareitittimen varassa.

Leinsa

  • Käyttäjä
  • Viestejä: 22
    • Profiili
Vs: Adobe flash
« Vastaus #31 : 10.01.14 - klo:16.48 »
Pitäisi varmaan käyttää vanhempaa versiota kunnes vika korjataan. Versio 30.0.1599.114 toiminee vielä. Tässä linkki jollain satunnaisella peilipalvelimella olevaan pakettiin (käyttö omalla vastuulla): http://95.31.35.30/chrome/pool/main/g/google-chrome-stable/google-chrome-stable_30.0.1599.114-1_i386.deb
Saisinko ohjeet tuon asennukseen? Ja pitääkö minun poistaa sitä ennen tuo google chromen uusin versio ja mitenköhän se tehdään? Avuton olen tiedän mutta vasta pari viikkoa käyttänyt linuxia :)

mrl586

  • Käyttäjä
  • Viestejä: 4561
    • Profiili
Vs: Adobe flash
« Vastaus #32 : 10.01.14 - klo:17.03 »
Koodia: [Valitse]
wget http://www.example.com/file.name # editoi tähän oikea osoite
sudo dpkg -i file.name # korvaa file.name tiedoston oikealla nimellä

Leinsa

  • Käyttäjä
  • Viestejä: 22
    • Profiili
Vs: Adobe flash
« Vastaus #33 : 10.01.14 - klo:17.27 »
Koodia: [Valitse]
wget http://www.example.com/file.name # editoi tähän oikea osoite
sudo dpkg -i file.name # korvaa file.name tiedoston oikealla nimellä

Kiitos tulipahan nyt tuokin kokeiltua, virhesanoma tuli "adobe flash on vanhentunut" chromessa.

nm

  • Käyttäjä
  • Viestejä: 14204
    • Profiili
Vs: Adobe flash
« Vastaus #34 : 10.01.14 - klo:17.45 »
Pitäisi varmaan käyttää vanhempaa versiota kunnes vika korjataan. Versio 30.0.1599.114 toiminee vielä. Tässä linkki jollain satunnaisella peilipalvelimella olevaan pakettiin (käyttö omalla vastuulla): http://95.31.35.30/chrome/pool/main/g/google-chrome-stable/google-chrome-stable_30.0.1599.114-1_i386.deb
Saisinko ohjeet tuon asennukseen?

Pääteasennus on varsin helppo soveltamalla mrl586:n esimerkkiä, mutta vaihtoehtoisesti deb-paketin voi myös ladata selaimella kotihakemistoon (oletuksena se menee yleensä Lataukset-alihakemistoon). Käynnistä sitten asennus kaksoisklikkaamalla tiedostoa tiedostoselaimessa. Järjestelmän pitäisi avata Ubuntun sovellusvalikoima (Software Center), jossa painat vain "Asenna" ja syötät salasanan kysyttäessä.


Ja pitääkö minun poistaa sitä ennen tuo google chromen uusin versio ja mitenköhän se tehdään?

Ehkä, jos asennat sovellusvalikoiman kautta, eikä se suostu varhentamaan paketin versiota.

Eli avaa sovellusvalikoima ja kirjoita hakukenttään google-chrome, valitse hakutuloksista rivi jossa on vihreä merkki (tarkoittaa että paketti on asennettu) ja paina rivin oikeassa reunassa olevaa "Poista" -painiketta.


Lisäksi joudut asennustavasta riippumatta poistamaan ohjelmalähteistä google-chrome repositorion. Muuten Chrome päivittyy takaisin uudempaan versioon seuraavassa päivityksessä. Repositorion poistaminen onnistuu ohjelmalähteiden asetuksista (Ubuntun sovellusvalikoimassa Muokkaa->Ohjelmalähteet...->Muut ohjelmistot, valitse rivi http://dl.google.com/linux/chrome/deb/ ja klikkaa Poista). Tai päätteessä komennoilla:

Koodia: [Valitse]
sudo rm /etc/apt/sources.list.d/google-chrome.list
sudo apt-get update
« Viimeksi muokattu: 10.01.14 - klo:17.54 kirjoittanut nm »

nm

  • Käyttäjä
  • Viestejä: 14204
    • Profiili
Vs: Adobe flash
« Vastaus #35 : 10.01.14 - klo:18.13 »
Kiitos tulipahan nyt tuokin kokeiltua, virhesanoma tuli "adobe flash on vanhentunut" chromessa.

Kokeilin nyt itsekin Chromea vanhassa koneessa. Näemmä myös Chromen Flash-liitännäinen on kytketty pois käytöstä, jos prosessorissa ei ole SSE2-tukea. Eipä siis ole Chromestakaan tähän apua.

Sinulla Chrome yrittää käyttää järjestelmään asennettua Flash Player 10.3-versiota ja toteaa sen vanhentuneeksi.

Taro Turtiainen

  • Käyttäjä
  • Viestejä: 579
    • Profiili
    • Taro Turtiainen
Vs: Adobe flash
« Vastaus #36 : 12.03.14 - klo:17.02 »
Asensin tämän pipelight:n koska webcam ei toiminut normi setillä.

Nyt sitten ääni kulkee, mutta kuva ei - kun ei tämä tunnista cameraa.

Milläköhän sen sais vörkkimään?
VASEMMISTOLIITTO - RIKKAUTTA JOLLA ON ARVOA

”Ei ole olemassa todellista vapautta ilman toisinajattelun vapautta.” Rosa Luxemburg 1918

salai

  • Käyttäjä
  • Viestejä: 2126
    • Profiili
Vs: Adobe flash
« Vastaus #37 : 12.03.14 - klo:18.42 »
Kukas lupaa yhteensopivuuden ja toiminnallisuuden 5 vuodeksi?
Luultavasti Adobe. Tuskin tuovat mitään uutta enää 11.2 versioon. Lähinnä tietoturvapäivityksiä.
Eipä taida Adobe taata toiminnallisuutta tai yhteensopivuutta, jos esim. Nelosen Ruutu muuttaa koodiaan siten, ettei tuo vanhempi paikattu versio enää toimi?

Karvameduusa

  • Käyttäjä
  • Viestejä: 1055
    • Profiili
Vs: Adobe flash
« Vastaus #38 : 12.03.14 - klo:19.02 »
Ruutua pystyt katsomaan ilman flashia:a tämän ohjeen mukaan.

http://linux.fi/wiki/Ruutu.fi

Itse kokeilin tuon toimivuutta näyttäisi toimivan. Nelosen ohjelmissa joudut katsomaan sivun lähdekoodia että löydät xml tiedoston, minkä sisällä on video todellinen sijainti.

John Hilly

  • Käyttäjä
  • Viestejä: 313
    • Profiili
Vs: Adobe flash
« Vastaus #39 : 12.03.14 - klo:19.25 »
Tänään tuli päivitys. Enää Firefoxin lisäosat ei herjaa...