Kirjoittaja Aihe: do-release-upgrade ei toimi, antaa virheen  (Luettu 3102 kertaa)

racle

  • Käyttäjä
  • Viestejä: 12
    • Profiili
do-release-upgrade ei toimi, antaa virheen
« : 13.08.13 - klo:09.44 »
Yritän päivittää 11.10 versiota 12.04 LTS versioon, ja tuo antaa seuraavaa virhettä. Yritin asennella pythonia uudelleen ja tutkia internettiä eilen, mutta mikään ei auta ongelmaan... Millä saan asennettua 12.04 LTS version itselleni? (en haluaisi kokonaan palvelinta vetää sileäksi..)

Koodia: [Valitse]
sudo do-release-upgrade
Tarkistetaan onko uutta Ubuntu-julkaisua saatavilla
Ubuntu-versiosi ei ole enää tuettu.
Traceback (most recent call last):
  File "/usr/bin/do-release-upgrade", line 92, in <module>
    "%(url)s\n") % { 'url' : url }
ValueError: unsupported format character '?' (0xa) at index 44


Nykyisen ubuntun versiotiedot
Koodia: [Valitse]
lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 11.10
Release:        11.10
Codename:       oneiric

Edit: Kävi perinteiset, kysy foorumeilla asiasta ja keksi itse muutaman hetken päästä "ratkaistu".. En tiedä toimiiko, mutta kävin kommentoimassa print_f riveiltä 91 ja 92 ja nyt lähti ainakin lataamaan. Ilmoittelen miten kävi
« Viimeksi muokattu: 13.08.13 - klo:09.47 kirjoittanut racle »

racle

  • Käyttäjä
  • Viestejä: 12
    • Profiili
Vs: do-release-upgrade ei toimi, antaa virheen
« Vastaus #1 : 13.08.13 - klo:11.24 »
Nähtävästi tuo asennus meni läpi, /etc/apt/sources.list  löytyy nyt 12.04 (precise)
Mutta tässä on muita jännyyksiä, lsb_release -a näytti alunperin 11.10, muokkasin käsin sen 12.04

Koodia: [Valitse]
lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 12.04
Release:        12.04
Codename:       precise

Mutta /etc/issue näyttää 12.10
Koodia: [Valitse]
cat /etc/issue
Ubuntu 12.10 \n \l

Pitäisikö tästä huolestua vai antaa olla vaan?

juyli

  • Vieras
Vs: do-release-upgrade ei toimi, antaa virheen
« Vastaus #2 : 18.08.13 - klo:20.29 »
Yritän päivittää 11.10 versiota 12.04 LTS versioon, ja tuo antaa seuraavaa virhettä.

Version 11.10 Oneiric tuki päättyi huhtikuussa 2013. Tukemattoman järjestelmän päivitys seuraavaan versioon voi olla aikamoista arpapeliä. Palvelinkäyttöön varmastikin suositellaan LTS-versioita - tai varminta on päivittää jakelu silloin kun se on vielä virallisesti tuettu.
do-release-updaten sijaan on järjestelmä ollut päivitettävissä jo jonkin aikaa update-managerin avulla täysin ongelmitta.

ilkkak

  • Käyttäjä
  • Viestejä: 402
    • Profiili
Vs: do-release-upgrade ei toimi, antaa virheen
« Vastaus #3 : 19.08.13 - klo:09.17 »
Yritän päivittää 11.10 versiota 12.04 LTS versioon, ja tuo antaa seuraavaa virhettä.

Mulle kävi samoin. Kesän (ja viime kevään) aikana palvelimen versio pääsi vanhenemaan ja nyt päivitysongelma.

Itse ratkaisin asian siten, että asensin uudestaan 12.04:n. Datat oli eri levyjaoilla, joten mitään ei hävinnyt.

Ensi kerralla pitää olla tarkempi : :-\