Kirjoittaja Aihe: Wifi ei toimi enää päivityksen jälkeen  (Luettu 9321 kertaa)

kartsa3

  • Käyttäjä
  • Viestejä: 35
    • Profiili
Wifi ei toimi enää päivityksen jälkeen
« : 11.04.13 - klo:21.25 »
asensin 13.04 Raring Ringtailin koneeseeni ja kaikki toimii nyt pienen väännön jälkeen ihan ok wifi-yhteyttä lukuun ottamatta  ???

Käytössä on Ralinkin valmistama usb-sovitin.

lsusb näyttää tältä:

[font=Verdana]Bus 001 Device 002: ID 0411:01a2 BUFFALO INC. (formerly MelCo., Inc.) WLI-UC-GNM Wireless LAN Adapter [Ralink RT8070]
Bus 002 Device 003: ID 0411:0105 BUFFALO INC. (formerly MelCo., Inc.)
Bus 003 Device 002: ID 046d:c05a Logitech, Inc. Optical Mouse M90
Bus 004 Device 002: ID 046d:c31c Logitech, Inc. Keyboard K120 for Business
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub[/font]


Ja nm-tool puolestaan tältä.


NetworkManager Tool

State: connected (global)

- Device: eth0  [Wired connection 1] -------------------------------------------
  Type:              Wired
  Driver:            forcedeth
  State:             connected
  Default:           yes
  HW Address:        00:24:8C:7E:E0:C9

  Capabilities:
    Carrier Detect:  yes
    Speed:           100 Mb/s

  Wired Properties
    Carrier:         on

  IPv4 Settings:
    Address:         192.168.100.100
    Prefix:          24 (255.255.255.0)
    Gateway:         192.168.100.1

    DNS:             192.168.100.1


- Device: wlan0 ----------------------------------------------------------------
  Type:              802.11 WiFi
  Driver:            rt2800usb
  State:             disconnected
  Default:           no
  HW Address:        10:6F:3F:2C:B8:50

  Capabilities:

  Wireless Properties
    WEP Encryption:  yes
    WPA Encryption:  yes
    WPA2 Encryption: yes

  Wireless Access Points
    kotiverkkolol:   Infra, 00:25:12:EE:79:79, Freq 2462 MHz, Rate 54 Mb/s, Strength 39 WPA
    Koti_751C:       Infra, FE:F5:28:16:75:1C, Freq 2472 MHz, Rate 54 Mb/s, Strength 42 WPA WPA2
    Koti20b0:        Infra, 38:46:08:E7:20:B1, Freq 2437 MHz, Rate 54 Mb/s, Strength 39 WPA WPA2



Olen ollut ymärtäväni, että ongelma olisi Ralinkin ajurissa, josta löytyikin uusi versio Ralinkin tuesta, mutta en saanut sitä ahkerasta Googlettamisesta huolimatta asennetuksi.

Tähän tarvitsisin hiukan kokeneempien apua.

juyli

  • Vieras
Vs: Wifi ei toimi enää päivityksen jälkeen
« Vastaus #1 : 11.04.13 - klo:22.14 »
 Wireless Access Points
    kotiverkkolol:   Infra, 00:25:12:EE:79:79, Freq 2462 MHz, Rate 54 Mb/s, Strength 39 WPA
    Koti_751C:       Infra, FE:F5:28:16:75:1C, Freq 2472 MHz, Rate 54 Mb/s, Strength 42 WPA WPA2
    Koti20b0:        Infra, 38:46:08:E7:20:B1, Freq 2437 MHz, Rate 54 Mb/s, Strength 39 WPA WPA2

Kaipa korttisi hyvin toimii, kun se löytää tarjollaolevia langattomia verkkoja. Valitettavasti vain ei ole määritelty sitä verkkoa, johon laitteesi liittyisi automaattisesti (salasanalla vahvistettuna).
Tarjolla on siis sekä WPA että WPA/WPA2 -verkkoja.
Koitapa vielä sieltä network-managerista määritellä oma langaton verkkosi yhdistämään - vähintäänkin automaattisesti.
Onhan jo asennettuna wpasupplicant paketit?
http://packages.ubuntu.com/raring/wpasupplicant

Lisäys: Näyttääpä olevan (lukihäiriökö?):
Wireless Properties
    WEP Encryption:  yes
    WPA Encryption:  yes
    WPA2 Encryption: yes


Esittämässäsi tilanteessa on käytössä piuhayhteys. Irroita piuhayhteys, ja yritä sitten käyttää ainoastaan wlan-yhteyttä.


Vielä kerran muistutettakoon, että Ubuntu 13.04 on testausvaiheessa. (Eikä sitä pidä asentaa, jos ei tiedä, mitä on tekemässä!)
« Viimeksi muokattu: 11.04.13 - klo:22.28 kirjoittanut juyli »

kartsa3

  • Käyttäjä
  • Viestejä: 35
    • Profiili
Vs: Wifi ei toimi enää päivityksen jälkeen
« Vastaus #2 : 11.04.13 - klo:22.36 »
Jep.
Kyllä verkot löytyy, mutta yhteyttä ei muodostu, koska salasanani ei kelpaa, vaikka olen tarkistanut sen oikeellisuuden muilla laitteilla.
Tämä Raring Ringtail tuli asennettua vahingossa, sillä päivitin vanhan koneeni 10.04 -> 12.10 sillä seurauksella, että sain asentaa koko systeemin uudelleen. UNetbootin asetuksista tuli valittua uusin live versio ja se olikin sitten tämä 13.04. Nuo wpasupplicant paketit minulta taitaa puuttua, joten laitetaan asentaen. :-\
Kiitos hyvistä neuvoista.

juyli

  • Vieras
Vs: Wifi ei toimi enää päivityksen jälkeen
« Vastaus #3 : 11.04.13 - klo:22.47 »
Kyllä verkot löytyy, mutta yhteyttä ei muodostu, koska salasanani ei kelpaa, vaikka olen tarkistanut sen oikeellisuuden muilla laitteilla.

Hmmm.... Voisit koittaa määritellä salasanan testiksi hyvin yksinkertaiseksi. Jos näin voit muodostaa yhteyden, voisit tarkentaa salasanasi uudelleen tarpeeksi monipuoliseksi.
« Viimeksi muokattu: 11.04.13 - klo:22.57 kirjoittanut juyli »

vartsu

  • Käyttäjä
  • Viestejä: 507
  • Kyllä, hankin joskus elämän... apt-get a life ...
    • Profiili
Vs: Wifi ei toimi enää päivityksen jälkeen
« Vastaus #4 : 12.04.13 - klo:13.28 »
Tuo että verkot löytyy ja voisi vaikka muuten yhdistää mutta salasana ei kelpaa johtuu ajuri ongelmasta.
Aikoinaan oli realtekin ajureissa samaa vikaa, hakemalla niitten sivuilta ajurin ja asentamalla sen niin toimi.

Mutta voisit kokeilla tiputtaa kokonaan hetkeksi salauksen pois ja kokeilla yhdistää sitten.
Jos toimii silloin niin sitten kannattaa kokeilla tuota ralinkin ajurin asennusta uudelleen.

Kaikenkaikkiaan nuo on aina mielenkiintoisia ongelmina, kaikki muka toimii mutta ei toimi kuitenkaan  ::)
Nyt mennään läppärillä: Hp DV6-6108US
Tulossa jotain muuta...

zordo

  • Käyttäjä
  • Viestejä: 170
    • Profiili
Vs: Wifi ei toimi enää päivityksen jälkeen
« Vastaus #5 : 12.04.13 - klo:22.15 »
Tuo että verkot löytyy ja voisi vaikka muuten yhdistää mutta salasana ei kelpaa johtuu ajuri ongelmasta.
Aikoinaan oli realtekin ajureissa samaa vikaa, hakemalla niitten sivuilta ajurin ja asentamalla sen niin toimi.

Juuri tuon realtekin kanssa tapelleena voisin suositella toimivassa versiossa pysymistä ja jättämään kikkailut väliin. Koita 12.04 versiota.
Core I5 2500K  GTX970 ubuntu 14.10

kartsa3

  • Käyttäjä
  • Viestejä: 35
    • Profiili
Vs: Wifi ei toimi enää päivityksen jälkeen
« Vastaus #6 : 14.04.13 - klo:17.06 »
Kiitoksia kaikille neuvoista.
Tuota ajuria minäkin epäilin, ellei kyseessä ole pelkkä usb:n käyttöoikeus.
Löysin kyllä myös ajurin Realtekin sivuilta, jonka pitäis toimia myös tässä 13.04:ssä (2011_0719_RT3070_RT3370_RT5370_RT5372_Linux_STA_V2.5.0.3_DPO), mutta en löytänyt googlella oikein käypäisiä ohjeita tuon *dpo:n asentamiseen.
Täytyy harkita sitä 12.04:n asentamista, mutta toisaalta muuten tää toimii ihan moitteettomasti pienen Nvidian näytönohjain jumpan jälkeen.