Kirjoittaja Aihe: 12.10 ja outo graafinen häiriö käynnistettäessä  (Luettu 2497 kertaa)

Tim_o

  • Käyttäjä
  • Viestejä: 166
    • Profiili
Hyvää joulunaikaa kaikille ensin toivotan  :)

Mutta sitten on pulma. Kun käynnistin pöytäkoneessani Ubuntu 12.10 niin alun liilan (vai mikä se väri on) ruudun jälkeen näyttö meni oudoksi (sellaisia vaaka-ja pystysuoria raitoja tuli), ja käynnistyminen stoppaa siihen eikä mitään komentoja voi antaa. Ei auttanut kuin virtakytkimestä sammuttaa kone ja sitten yritin pari kertaa uudestaan ja tulos oli sama tilanne ja vain virran sammutus auttoi.

Kokeilin sitten noita muita käynnistysvaihtoehtoja niin nyt sitten pääsin sisään sillä valinnalla, että jatketaan normaalia käynnistymistä sieltä vikasietotilasta (uusin kernel oli asentunut koneeseeni pari päivää aikaisemmin), mutta varoitettiin, että (muistaakseni jotenkin näin) kaikkia grafiikka-ajureita tms ei voi käyttää.

Tässä nyt sitten olen siinä grafiikkatilassa mikä suostui käynnistymään, mutta ei tämä tällä hetkellä näytä kovin erilaiselta kuin normaali grafiikkatila (resoluutio näyttää olevan matalampi).

Mistä tässä oikein on kysymys, ja mikä auttaisi ongelmaan, vai pitääkö jatkossa bootata Ubuntu aina päälle tuon muiden käynnistysvaihtoehtojen vikatilan ja normaalin käynnistymisen jatkamisen kautta?
« Viimeksi muokattu: 23.12.12 - klo:12.02 kirjoittanut Tim_o »

topiv

  • Käyttäjä
  • Viestejä: 71
  • Ubuntu zealot
    • Profiili
Vs: 12.10 ja outo graafinen häiriö käynnistettäessä
« Vastaus #1 : 23.12.12 - klo:12.39 »
Kerrotko vielä koneesi mallin ja mikä näytönohjain siinä on, niin olisi helpompi antaa neuvoja, mitä kokeilla. ???

Tim_o

  • Käyttäjä
  • Viestejä: 166
    • Profiili
Vs: 12.10 ja outo graafinen häiriö käynnistettäessä
« Vastaus #2 : 23.12.12 - klo:13.05 »
Hewlett-Packard pöytäkone (HP Pavilion Elite HPE Series 553s vuodelta 2011), Intelin 4-ydinprosessorilla (icore7-2600 muistakseni). Näytönohjain on ATI Radeon HD 6850, 1 GB muistia.

Auttaako tämä jo eteenpäin?

Tim_o

  • Käyttäjä
  • Viestejä: 166
    • Profiili
Vs: 12.10 ja outo graafinen häiriö käynnistettäessä
« Vastaus #3 : 24.12.12 - klo:13.30 »
Kirjoitan nyt Windowsista käsin. Mahtaako syy tähän, että normaali Ubuntun käynnistyminen kaatuu raidalliseksi menemiseen olla tuossa uudessa kernelissä, joka asentui jokin päivä sitten? Sitä kerneliä ennen Ubuntu toimi tosi hyvin.

Onko minun aina valittava käynnistyksen lisävalinnat ja jokin vanhempi kernel (joita menussa on valittavana), vai mikä auttaisi?

Eesaurus

  • Käyttäjä
  • Viestejä: 3292
    • Profiili
Vs: 12.10 ja outo graafinen häiriö käynnistettäessä
« Vastaus #4 : 24.12.12 - klo:13.51 »
Mahtaako syy tähän, että normaali Ubuntun käynnistyminen kaatuu raidalliseksi menemiseen olla tuossa uudessa kernelissä, joka asentui jokin päivä sitten? Sitä kerneliä ennen Ubuntu toimi tosi hyvin.

Onko minun aina valittava käynnistyksen lisävalinnat ja jokin vanhempi kernel (joita menussa on valittavana), vai mikä auttaisi?

On kai se ihan mahdollista. Itse kun käytän kehitysversioita paljon, niin välillä tulee eteen kernel, jolla kone ei käynnisty normaalisti, vain toipumistilan kautta. Homma korjaantuu itsestään ajan saatossa. En kyllä muista törmänneeni asiaan milloinkaan virallisissa julkaisuissa.

Voit säätää Grub-Customizerilla edellisen kernelin oletukseksi, johon systeemi käynnistyy. Sitten käyt aina välillä kokeilemassa, josko käynnistyisi sillä uusimmallakin.

Koodia: [Valitse]
sudo add-apt-repository ppa:danielrichter2007/grub-customizer
sudo apt-get update && sudo apt-get install grub-customizer

LISÄYS: Jos haluaa pelata varman päälle, niin kannattaa käytellä vain LTS -versioita eli tässä tapauksessa 12.04:ää. Väliversioissa voi olla jotain pikkuhikkoja, joita ei ehkä noissa pitkän tuen versioissa ole.
« Viimeksi muokattu: 24.12.12 - klo:13.55 kirjoittanut Eesaurus »

Tim_o

  • Käyttäjä
  • Viestejä: 166
    • Profiili
Vs: 12.10 ja outo graafinen häiriö käynnistettäessä
« Vastaus #5 : 24.12.12 - klo:14.07 »
Kiitos näistä tiedoista  :)

Olisi varmaan kannattanutkin  se 12.04 ottaa, mutta tällä nyt sitten mennään. Toivotaan, että Canonical julkaisee lähiaikoina jo korjauspäivityksen siihen uuteen kerneliin ("Service Packin"). Onni, että ne vanhemmat kernelit ovat vielä tallella!

Tim_o

  • Käyttäjä
  • Viestejä: 166
    • Profiili
Vs: 12.10 ja outo graafinen häiriö käynnistettäessä
« Vastaus #6 : 25.12.12 - klo:14.45 »
Jep, nyt taas Ubuntun päällä kirjoitan tänne. Tosiaan tuon vähän vanhemman kernelin 3.5.x.19 kun valitsin käynnistyksen lisävalinnoissa niin jo alkoi wörkkiä Ubuntu entiseen tapaan hyvin ja näytön resoluutiokin on alkuperäisen korkea (näkyy Facebook-sivukin paljon paremmin). Onni, että kernel-päivitykset eivät automaattisesti poista vanhempia kerneleitä - ainakin tässä minun tapauksessani!

Tim_o

  • Käyttäjä
  • Viestejä: 166
    • Profiili
Vs: 12.10 ja outo graafinen häiriö käynnistettäessä
« Vastaus #7 : 20.01.13 - klo:20.21 »
Tuli tuossa hetki sitten päiviteltyä kerneliä taas uuteen versioon, 3.5.0.22 taisi olla. Alkuperäisen viestini ongelma se jatkuu silti vaan, onneksi pääsen boottaamaan kernelillä 3.5.0.19. Ehkä seuraava kernel poistaa ärsyttävän ongelman.

shelby

  • Käyttäjä
  • Viestejä: 1865
    • Profiili
Vs: 12.10 ja outo graafinen häiriö käynnistettäessä
« Vastaus #8 : 21.01.13 - klo:06.28 »
Jeps, 12.10 on sekaisin kerneleiltään. Ennen pelasi uusin, nyt ei. 3.0.5-21:llä pelaa. Virheilmoja tehty useita, siis toisetkin, joten jätin tekemättä, kun samasta. 13.04 pelaa parhaiten. :D

e. ei tuon luulisi johtuvan nVidiastakaan, kun Ubu 13.04 ja Kubu 12.10 pelaa?
« Viimeksi muokattu: 21.01.13 - klo:06.30 kirjoittanut shelby »
Ubu Gnome 20.04.3 LTS
Win 8.1 laptop I
Win 10 laptop II
Ubu Mate 20.04.3 LTS
Kubu 20.04.3 LTS

Tim_o

  • Käyttäjä
  • Viestejä: 166
    • Profiili
Vs: 12.10 ja outo graafinen häiriö käynnistettäessä
« Vastaus #9 : 21.01.13 - klo:09.24 »
Ikävää todellakin tämä, että 12.10 on noin sekaisin eikä ongelmat korjaannu vaikka uutta kerneliä pukkaa kuukauden välein. Toivottavasti kernel 3.5.0.19 ainakin säilyy valittavissa olevana kernelinä jatkossakin.

Ja minun olisi näköjään pitänyt alunperinkin asentaa vaan se 12.04 LTS. No opinpa tästäkin jotain jatkoa ajatellen.