Kirjoittaja Aihe: Wubin kanssa ongelma verkkoyhteyksissä  (Luettu 1115 kertaa)

Leko

  • Käyttäjä
  • Viestejä: 224
    • Profiili
Wubin kanssa ongelma verkkoyhteyksissä
« : 31.08.12 - klo:13.56 »
Jatkanpa tähän oman ongelmani kanssa. Hain kaupasta uuden 15 tuuman läppärin. Sinä oli Win 7 home. Asensin wubilla 12.04:n. Verkko toimii Win-puolella, mutta ei Ubuntussa. Kaapeliyhteyttä ei löydy ollenkaan. Langaton käynnistyy, mutta lupsahtaa aina muutaman sekunnin kuluttua pois. Vain mokkulanetti toimii. Kysymykseni kuuluu, onko Win 7 keksinyt jonkun jipon, jolla se pystyy häiritsemään. Vai onko kyse Lenovon ominaisuudesta.

Tuossa on vähän legendaa, jos joku haluaa vilkaista asiaa syvemmältä. Minun konstini loppuivat.

marjatta@ubuntu:~$ ifconfig
lo        Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:639 errors:0 dropped:0 overruns:0 frame:0
          TX packets:639 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:42622 (42.6 KB)  TX bytes:42622 (42.6 KB)

wlan0     Link encap:Ethernet  HWaddr 08:ed:b9:98:73:a3 
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:405 errors:0 dropped:0 overruns:0 frame:0
          TX packets:628 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:75904 (75.9 KB)  TX bytes:112219 (112.2 KB)

marjatta@ubuntu:~$ iwconfig
lo        no wireless extensions.

wlan0     IEEE 802.11bgn  ESSID:"Koti159" 
          Mode:Managed  Frequency:2.437 GHz  Access Point: 00:0C:C3:D9:A8:5F   
          Bit Rate=52 Mb/s   Tx-Power=19 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=54/70  Signal level=-56 dBm 
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:41  Invalid misc:10   Missed beacon:0


marjatta@ubuntu:~$ rfkill list all
0: ideapad_wlan: Wireless LAN
   Soft blocked: no
   Hard blocked: no
1: ideapad_bluetooth: Bluetooth
   Soft blocked: no
   Hard blocked: no
2: phy0: Wireless LAN
   Soft blocked: no
   Hard blocked: no


marjatta@ubuntu:~$ lspci
00:00.0 Host bridge: Intel Corporation 2nd Generation Core Processor Family DRAM Controller (rev 09)
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
00:14.0 USB controller: Intel Corporation Panther Point USB xHCI Host Controller (rev 04)
00:16.0 Communication controller: Intel Corporation Panther Point MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation Panther Point USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation Panther Point High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation Panther Point PCI Express Root Port 1 (rev c4)
00:1c.1 PCI bridge: Intel Corporation Panther Point PCI Express Root Port 2 (rev c4)
00:1d.0 USB controller: Intel Corporation Panther Point USB Enhanced Host Controller #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation Panther Point LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation Panther Point 6 port SATA Controller [AHCI mode] (rev 04)
00:1f.3 SMBus: Intel Corporation Panther Point SMBus Controller (rev 04)
01:00.0 Ethernet controller: Atheros Communications Inc. AR8162 Fast Ethernet (rev 08)
02:00.0 Network controller: Broadcom Corporation BCM4313 802.11b/g/n Wireless LAN Controller (rev 01)

marjatta@ubuntu:~$ lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 003: ID 046d:c016 Logitech, Inc. Optical Wheel Mouse
Bus 001 Device 004: ID 0489:e032 Foxconn / Hon Hai
Bus 002 Device 003: ID 04f2:b2e2 Chicony Electronics Co., Ltd

marjatta@ubuntu:~$ sudo lshw -class network
[sudo] password for marjatta:
  *-network UNCLAIMED     
       description: Ethernet controller
       product: AR8162 Fast Ethernet
       vendor: Atheros Communications Inc.
       physical id: 0
       bus info: pci@0000:01:00.0
       version: 08
       width: 64 bits
       clock: 33MHz
       capabilities: pm pciexpress msi msix bus_master cap_list
       configuration: latency=0
       resources: memory:e0500000-e053ffff ioport:2000(size=128)
  *-network
       description: Wireless interface
       product: BCM4313 802.11b/g/n Wireless LAN Controller
       vendor: Broadcom Corporation
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: wlan0
       version: 01
       serial: 08:ed:b9:98:73:a3
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=brcmsmac driverversion=3.2.0-29-generic firmware=N/A ip=192.168.100.23 latency=0 link=yes multicast=yes wireless=IEEE 802.11bgn
       resources: irq:17 memory:e0400000-e0403fff


marjatta@ubuntu:~$ uname -a
Linux ubuntu 3.2.0-29-generic #46-Ubuntu SMP Fri Jul 27 17:03:23 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux



marjatta@ubuntu:~$ nm-tool

NetworkManager Tool

State: connected (global)

- Device: wlan0  [Koti159] -----------------------------------------------------
  Type:              802.11 WiFi
  Driver:            brcmsmac
  State:             connected
  Default:           yes
  HW Address:        08:ED:B9:98:73:A3

  Capabilities:
    Speed:           57 Mb/s

  Wireless Properties
    WEP Encryption:  yes
    WPA Encryption:  yes
    WPA2 Encryption: yes

  Wireless Access Points (* = current AP)
    *Koti159:        Infra, 00:0C:C3:D9:A8:5F, Freq 2437 MHz, Rate 54 Mb/s, Strength 63 WPA

  IPv4 Settings:
    Address:         192.168.100.23
    Prefix:          24 (255.255.255.0)
    Gateway:         192.168.100.1

    DNS:             192.168.100.1


juyli

  • Vieras
Wubin kanssa ongelma verkkoyhteyksissä
« Vastaus #1 : 31.08.12 - klo:21.17 »
Asensin wubilla 12.04:n. Verkko toimii Win-puolella, mutta ei Ubuntussa.

Wubi-asennus on toki mielenkiintoinen, mutta ei missään tapauksessa oikea tapa asentaa Linux:ia.
Jonkinasteiseen Ubuntu-kokeiluun toki wubi kelvannee (tai sitten ei).
"Oikea tapa" asentaa Ubuntu tai jokin muu käyttöjärjestelmä, on raivata Windows:lta tilaa, ja asentaa sille sitten Linux (tai mikä tahansa käyttöjärjestelmä) ihan oikeasti.

Lisäys: laitteiden toimivuutta voi aina kokeilla Ubuntu-asennus-medialla (CD/USB-tikku tms.). Vaikka laite ei toimisikaan suoraa Live-CD -versiolla, on hyvinkin mahdollista saada laiteet toimimaan asennuksen jälkeen asennettavilla firmware tai laiteajureilla.
« Viimeksi muokattu: 31.08.12 - klo:21.50 kirjoittanut juyli »

Vika/fiba

  • Käyttäjä
  • Viestejä: 569
    • Profiili
Wubin kanssa ongelma verkkoyhteyksissä
« Vastaus #2 : 31.08.12 - klo:23.11 »
@jaakko ahola: +1 rautavian puolesta. Mulla on Lenovo T60 Linux Mint 12 / Cinnamon-työpöytä (=ubuntu 11.10). Toimii hienosti, olis kohta aika päivitttää Mint Mayaan (=Ubuntu 12.04)
Varsinainen ongelma on, ettei kone sammuttamisen jälkeen käynnisty, tai siis käynnistyy, mutta lähde lataamaan mitään. Ruudulle ei siis ilmesty yhtään mitään. Kun käynnistämisen toistaa riittävän monta kertaa, yleensä jossain vaiheessa kone käynnistyy normaalisti, tai välillä niin, että ruutu on täynnä viivoja tai vastaavaa.

Veikkauksia mistä mahtaa johtua, voisiko olla muuta kuin jonkun komponentin kuolinkamppailua?
Voisi tosiaan olla jonkin komponentin kuolinkouristuksia. Muistia vähän epäilen.
Muistitesti asennuslevyltä on mielestäni ensimmäinen tehtävä juttu, mieluummin aja yön yli(siis muistitesti monta kertaa ), jos on iso muistimäärä (>2gb), yksi läpimeno ei välttämättä testaa koko muistia.
Sitten näppärä, yksinkertainen konsti on Ubuntun levytyökalu: kertoo paljon, varsinkin, jos kertoo rikkinäisestä raudasta, ota huomioon.

@Leko
1. en suosittele wubi-asennusta. (tässä olen samaa mieltä Juylin kanssa, ja edustan, ikävä kyllä, tämän foorumin tavallista tilannetta; Wubi-asennuksesta lisää enkkufoorumilla:http://ubuntuforums.org/
2. Jos Win7, todennäköisesti ei mitään Microsoftin tekemää ongelmaa (voi olla, vaikken tiedä mitä;kasissahan niitä lienee)
3. Tuo legend kertoo verkkoasetuksista; Arvoitukseksi jää, mitä on tehtävissä.
Suosittelen:
1. Asenna Ubuntu Windowsin rinnalle
 tai
2.asenna Ubuntu Windowsin virtuaalikoneeseen.(esim. VirtualBox, VMware)
tai
3.asenna Ubuntu koko levylle jaasenna Windowsvirtuaaalikoneeseen (esim.. Virtualboxiin).


Leko

  • Käyttäjä
  • Viestejä: 224
    • Profiili
Wubin kanssa ongelma verkkoyhteyksissä
« Vastaus #3 : 01.09.12 - klo:00.07 »
Kiitos vastauksista!

Wubin tilapäisyydestä olen kanssanne samaa mieltä jo ennestään, aktiivikoneita minulla on useissa eri osoitteissa useita, ja paljailla Ubuntuilla nykyään. Kuitenkin ajattelen, että jos se wubilla toimii, niin kai se myöhemminkin paljaaltaankin.  Unohdin kertoa, että minulla on tikulla joku DSL, kokeilin, eikä verkkoon senkään kautta ollut pääsyä. Taitaa olla parasta unohtaa koko masina ja siirtää katse eteenpäin.

(Off T;
Kovin monta päivää ei enää viitsi tässä iässä (71 v) yhden asian kanssa tuhrata. Tuo muistin määrän kasvu koneissa  vain vähän ihmetyttää. Eka tutustuminen minulla oli vehkeeseen, jossa yksi ja ainoa muisti oli 32 k. Ohjelma ja data ajettiin reikänauhalla sisään, ja tulos räpättäytyi paperille.  Joskus paljon myöhemmin joku maailmalla ihmetteli, kun tsättäsin 386 koneella ja slackwarella. Mutku nykyään meinaa päästä tippua enemmän kuin sinne yrittää lisää ladata.)

Ganymedes

  • Käyttäjä
  • Viestejä: 3515
    • Profiili
Wubin kanssa ongelma verkkoyhteyksissä
« Vastaus #4 : 01.09.12 - klo:11.44 »
Suosittelen näitä:

2. asenna Ubuntu Windowsin virtuaalikoneeseen (esim. VirtualBox, VMware)
tai
3. asenna Ubuntu koko levylle ja asenna Windows virtuaaalikoneeseen (esim. Virtualbox, VMware)

Näistä jälkimmäinen on mielestäni paras, koska Windows on parempi virtuaalisena ja marginaalisena käyttöjärjestelmänä kuin varsinaisena. Tämä vaihtoehto kuitenkin edellyttää, että pystyt käytettävissä olevalla medialla asentamaan virtuaalikoneeseen. Tämän voit kokeilla jo nyt kun järjestelmässä on Windows ja voit itse virtuaalikoneenkin jättää talteen ja käyttää sitten sitä Ubuntussa - siis sikäli kuin windows-lisenssit/aktivoinnit siihen taipuvat). Kokeilu ei maksa mitään, ei vaaranna mitään eikä ole erityisen hidastakaan. Jotta kaikki toimii helposti tee siten, että yksi virtuaalikone = yksi hakemisto (tämän Foorumin VMware-ohjeessa on neuvottu vain tämä tapa).

No, sinulla todennäköisesti ei ole sopivaa mediaa ... jos on media, ja siinä lukee Microsoft, retail tai oem, niin todennäköisesti toimii. Jos siinä lukee vaikkapa "Dell" tai "Asus" ... niin ehkä ei.

... tuohonkin sitä muistia tarvitaan, että ajetaan useita koneita virtuaalisesti samaanaikaan, ilman että järjestelmä hidastuu ...

Postimies

  • Käyttäjä
  • Viestejä: 2445
    • Profiili
Wubin kanssa ongelma verkkoyhteyksissä
« Vastaus #5 : 01.09.12 - klo:13.43 »
Hei!

Minulla on käytössä ubuntun versio 12.04. Kone on Lenovo T60. Ubuntu on toiminut kohtalaisesti, lukuunottamatta välillä tapahtuvaa "jäätymistä", jonka jälkeen koneen joutuu yleensä käynnistämään uudestaan.

dmesg päätteessä voi kertoa mikä mättää. Jäätyminen viittaa rautavikaan. Ottaisin pois graafisen kirjautumisen (gdm). Samoin pois grafiikat grubista (e näppäin ja voi editoida). Kun kone käynnistyy merkkitilassa näkee paremmin mihin käynnistys pysähtyy. Samoin sammutuksessa. startx käynnistää X:n.
Jos näytönohjaimessa ja/tai ajurissa vikaa X:n käynnistyminen voi kestää pitkään. Sotkuinen näyttö viittaa siihen, että udev on arponut väärän ajurin. Xorg.conf tiedostoon voi pistää käytettävän ajurin.

/var/log/Xorg.log tiedostosta löytyy loki X:n startista.
Virheet löytyy helposti  cat /var/log/Xorg.log | grep EE
jos ei jaksa kaikkea lukea.

Storck

  • Vieras
Vs: Wubin kanssa ongelma verkkoyhteyksissä
« Vastaus #6 : 01.09.12 - klo:14.41 »
Tein uuden aiheen koska ongelma ei liity millään tavalla aiheeseen johon tämä oli kirjoitettu.