Kirjoittaja Aihe: ??(invalid encoding)??  (Luettu 4548 kertaa)

lettas

  • Käyttäjä
  • Viestejä: 92
    • Profiili
??(invalid encoding)??
« : 27.05.05 - klo:22.37 »
Suomifoorumia ubuntulle on kaipailtukin, kiitos siitä! Kyseinen lokalisaatio-ongelma siis. Muilla forumeilla oli ehdotettu /etc/fstab :in ntfs- osille optiota iocharset=utf8. Tuo taitaa kuitenkin vain tehota ainoastaan ntfs- osioille. Lääkettä päästä eroon siitä koko tiedostojärjestelmässä, usb-tikku, dvd-polttava ym.. ?

koloppi

  • Käyttäjä
  • Viestejä: 14
    • Profiili
Re: ??(invalid encoding)??
« Vastaus #1 : 06.06.05 - klo:13.25 »
Kuten T_Trainer Skandit ryhmässä jo sanoi:

Aja terminaalissa "sudo dpkg-reconfigure locales" ja valitse oletukseksi fi_FI ISO-8859-1 tai fi_FI@euro ISO-8859-15 niin pitäisi toimia.

Timo Jyrinki

  • Sr. Member
  • ****
  • Viestejä: 1256
    • Profiili
    • kotisivu
Re: ??(invalid encoding)??
« Vastaus #2 : 08.06.05 - klo:10.36 »
Aja terminaalissa "sudo dpkg-reconfigure locales" ja valitse oletukseksi fi_FI ISO-8859-1 tai fi_FI@euro ISO-8859-15 niin pitäisi toimia.

Tuossa on kyllä se huono puoli, että pidemmällä aikavälillä UTF:ään (Unicode) siirrytään joka tapauksessa. Sitten taas jos on vaikkapa ääkkösiä tiedostojen nimissä, näkyvät ne väärin.. parempi olisi siis pysyttäytyä oletuksessa (fi_FI.UTF-8) ja keksiä kiertokeinot ongelmallisia tapauksia (Windowsin tiedostot, ssh-yhteydet vanhoille palvelinkoneille?) varten. Jos ihan Linuxin puolella / hakemistoissa näkyy "invalid encoding", niin se lienee peruja Wartyssä vielä käytetystä 8859-1-merkistöstä, ja tiedoston nimen voi ihan uudelleennimetä oikeaksi.

xet7

  • Käyttäjä
  • Viestejä: 11
    • Profiili
Re: ??(invalid encoding)??
« Vastaus #3 : 23.06.05 - klo:12.20 »
Hei,
minulla on tiedostossa /etc/fstab rivit:

# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
/dev/hda5       /               ext3    defaults,errors=remount-ro 0       1
/dev/hda6       none            swap    sw              0       0
/dev/hdc        /media/cdrom0   udf,iso9660 ro,user,noauto  0       0
/dev/hdd        /media/cdrom1   udf,iso9660 ro,user,noauto  0       0
/dev/fd0        /media/floppy0  auto    rw,user,noauto  0       0
/dev/hda1       /media/windows_c ntfs defaults,ro,nls=utf8,umask=0222 1 0
/dev/hda7       /media/dos vfat defaults,rw,codepage=850,iocharset=utf8,umask=0222 1 0


On toiminut ihan kivasti.

Yucca

  • Käyttäjä
  • Viestejä: 13
    • Profiili
Re: ??(invalid encoding)??
« Vastaus #4 : 23.09.05 - klo:18.02 »
Mulla on Windows XP FAT32 osiolla. Ni mitä codepage ja iocharset ym. asetuksia tarvin, että saan ne skandit pelaamaan? Olen säätänyt tässä jo jonkinaikaa. Samban kautta toimii, mutta ei suoraa IDE väylän kautta.

Open standards rules!