Kirjoittaja Aihe: Natiivi Spotify linuxille  (Luettu 25011 kertaa)

qualtch

  • Käyttäjä
  • Viestejä: 37
    • Profiili
Natiivi Spotify linuxille
« : 12.07.10 - klo:16.52 »
Spotifystä on nyt julkaistu myös natiivi versio Linuxille! Koneellaolevien tiedostojen toisto ei tosin vielä onnistu, mutta muuten ohjelma toimii kyllä moitteetta. :)

Spotify for Linux

SuperOscar

  • Käyttäjä
  • Viestejä: 3489
  • Tänään täällä, huomenna poissa
    • Profiili
    • Legisign.org
Vs: Natiivi Spotify linuxille
« Vastaus #1 : 12.07.10 - klo:17.08 »
Törmäsin tällaiseen ongelmaan:

Koodia: [Valitse]
tn@whitehead [~/Tilap]$ sudo aptitude install spotify-client-qt spotify-client-gnome-support
Luetaan pakettiluetteloita... Valmis
Muodostetaan riippuvuussuhteiden puu       
Luetaan tilatiedot... Valmis       
Luen tilatietoja           
Alustan pakettien tiloja... Valmis
Nämä paketit ovat RIKKI:
  spotify-client-gnome-support
Nämä UUDET paketit asennetaan:
  spotify-client-qt
0 päivitettävää pakettia, 2 uutta asennusta, 0 poistettavaa ja 0 päivittämätöntä.
Tarvitsee noutaa 5 426kB arkistoista. Levytilaa kuluu 11,2MB purkamisen jälkeen.
Näillä paketeilla on tyydyttämättömiä riippuvuuksia:
  spotify-client-gnome-support: Riippuvuudet: gconf2 (>= 2.28.1-2) mutta 2.28.1-0ubuntu1 on asennettu.
Seuraavat toiminnot selvittävät nämä riippuvuudet:

Pidä paketit nykyisessä versiossaan:
spotify-client-gnome-support [Ei asennettu]

Jätä riippuvuudet selvittämättä:
spotify-client-qt suosittelee spotify-client-gnome-support:a
-10079 pistettä

Hyväksytkö tämän ratkaisun? [Kyllä=y/ei=n/lopeta=q/?] q
Lopetetaan yritykset ratkaista näitä riippuvuuksia.
Keskeytys.
openSUSE Leap 15.1 (pöytäkone 1, kannettava 1), openSUSE Tumbleweed (pöytäkone 2), Debian GNU/Linux 10 (kannettava 2), LibreELEC 8.2.5 (RPi 1), Raspbian GNU/Linux 10 (RPi 2)

aku506

  • Käyttäjä
  • Viestejä: 356
    • Profiili
Vs: Natiivi Spotify linuxille
« Vastaus #2 : 12.07.10 - klo:17.21 »
Mainokset eivät vielä toimi, joten....
Lainaus
this version is only available to Spotify Premium subscribers.

muep

  • Käyttäjä
  • Viestejä: 896
    • Profiili
Vs: Natiivi Spotify linuxille
« Vastaus #3 : 12.07.10 - klo:18.51 »
Toivottavasti eivät tämän myötä heikennä Spotifyn toimivuutta Winen kanssa. Tämä nyt julkaistu Spotify kun on lähinnä Ubuntulle.
[http://smolt.fedoraproject.org/show?uuid=pub_ac53b581-021a-4b76-bd14-e7d51f55462f]Pöytäkone[/url]
Läppäri

Karvameduusa

  • Käyttäjä
  • Viestejä: 1055
    • Profiili
Vs: Natiivi Spotify linuxille
« Vastaus #4 : 12.07.10 - klo:18.53 »
Lainaus
Linux-järjestelmille räätälöity esikatseluversio Spotify-palvelusta toimii ainoastaan Premium-tunnuksen hankkineilla käyttäjillä. Musiikkipalvelu perustelee rajausta sillä, ettei se ole toistaiseksi löytänyt riittävän luotettavaa keinoja mainosten esittämiseen Linux-versiossa.

;D

Lähde: http://www.digitoday.fi/vimpaimet/2010/07/12/spotify-saapui-linuxiin/20109661/66

http://linux.fi/wiki/Despotify

qwertyy

  • Käyttäjä
  • Viestejä: 4774
    • Profiili
Vs: Natiivi Spotify linuxille
« Vastaus #5 : 12.07.10 - klo:19.53 »
Toivottavasti suhteellisen moni tuon lataisi koneellensa, että sitten jatkavatkin tuon kehitystä. Loistavaa kyllä, että pukkasivat natiiviversion linuxille.

Teho

  • Käyttäjä
  • Viestejä: 477
    • Profiili
Vs: Natiivi Spotify linuxille
« Vastaus #6 : 12.07.10 - klo:21.25 »
Toivottavasti eivät tämän myötä heikennä Spotifyn toimivuutta Winen kanssa. Tämä nyt julkaistu Spotify kun on lähinnä Ubuntulle.
Se, että sivulla tarjotaan pelkästää Ubuntulle paketteja, ei tarkoita että se ei toimisi muissa distroissa. Luultavasti sitten kuin ensimmäinen vakaa versio tulee niin valmiit paketit tarjottaan ainakin Ubuntulle, Fedoralle, openSUSElle ja Debianille. Mitä luultavammin tulevina päivinä muillekkin distroille ilmenee repoja, joissa on spotify + tarvittavat riippuvuudet - siis muiden kuin spotify tiimin tekemiä.

noname

  • Käyttäjä
  • Viestejä: 828
  • Linuxilla maaliskuusta 2009
    • Profiili
Vs: Natiivi Spotify linuxille
« Vastaus #7 : 12.07.10 - klo:22.01 »
Onko noi nyt sitten suljettuja vai? ???

muep

  • Käyttäjä
  • Viestejä: 896
    • Profiili
Vs: Natiivi Spotify linuxille
« Vastaus #8 : 12.07.10 - klo:22.21 »
Toivottavasti eivät tämän myötä heikennä Spotifyn toimivuutta Winen kanssa. Tämä nyt julkaistu Spotify kun on lähinnä Ubuntulle.
Se, että sivulla tarjotaan pelkästää Ubuntulle paketteja, ei tarkoita että se ei toimisi muissa distroissa. Luultavasti sitten kuin ensimmäinen vakaa versio tulee niin valmiit paketit tarjottaan ainakin Ubuntulle, Fedoralle, openSUSElle ja Debianille. Mitä luultavammin tulevina päivinä muillekkin distroille ilmenee repoja, joissa on spotify + tarvittavat riippuvuudet - siis muiden kuin spotify tiimin tekemiä.

Ei se paketointiformaatti itsessään sitä toki tarkoitakaan, saahan deb-paketinkin purettua helposti ilmankin mitään jakelukohtaisia työkaluja.

Isompi ongelma C++-ohjelmissa on kuitenkin se, että ohjelman ajon aikana käytettävien kirjastojen tulee olla yhteensopivia ohjelman kääntämiseen käytettyjen kirjastojen kanssa. Osassa kirjastoista toki on vakaat binäärirajapinnat, mutta ei niissäkin on omia hankaluuksiaan. Tämänhetkisissä tuon julkaistun binäärin riippuvuuksissa ongelmallinen on ehkä lähinnä tuo libpulse, jota ei kaikista jakeluista löydy lainkaan.

Windowsin Win32-binäärirajapinta sen sijaan on vanha ja tunnettu, ja sen saa asennettua käytännössä mihin tahansa x86-pohjaiseen jakeluun ja jopa kokonaan muillekin ytimille kuin Linuxille. Mikäli Wine-yhteensopivuudesta huolehditaan, sen kautta saa suhteellisen helposti varsin hyvätasoisen tuen lähes käyttöjärjestelmälle kuin käyttöjärjestelmälle.

Fedorasta (32-bit) tuolle alpha-spotifylle näyttäisivät kaikki riippuvuudet löytyvän, mutta ohjelman suoritus päättyy välittömästi Illegal instruction-poikkeukseen. Tämä toki voi olla ihan vain Spotifyn oma bugi, eikä se välttämättä liity ajonaikaisen ympäristön yhteensopivuuteen lainkaan.

Mikäli tuota saadaan jossain vaiheessa jakeluneutraalimmassa paketissa, voisin kuvitella Linux-versiotakin käyttäväni ihan mielelläni.
[http://smolt.fedoraproject.org/show?uuid=pub_ac53b581-021a-4b76-bd14-e7d51f55462f]Pöytäkone[/url]
Läppäri

Karvameduusa

  • Käyttäjä
  • Viestejä: 1055
    • Profiili
Vs: Natiivi Spotify linuxille
« Vastaus #9 : 12.07.10 - klo:23.17 »
Onko noi nyt sitten suljettuja vai? ???

Repojen mukanaan non-free ohjelma. Uusimmat clientit tulee aina www.spotify.com repoista.

12th

  • Käyttäjä
  • Viestejä: 5
    • Profiili
Vs: Natiivi Spotify linuxille
« Vastaus #10 : 14.07.10 - klo:14.51 »
Tällaista herjaa pukkaa kun yrittää asentaa sen spotify-client-gnome-supportin:

Koodia: [Valitse]
spotify-client-gnome-support:
  Riippuvuudet: gconf2 (>=2.28.1-2), mutta versiota 2.28.1-0ubuntu1 ollaan asentamassa

Se spotify-client-qt kyllä toimii muuten hyvin mutta volumesäätö ei pelaa ja ikkunan maksimointi menee yli työpöydän palkeista :)

Tomin

  • Palvelimen ylläpitäjä
  • Käyttäjä / moderaattori+
  • Viestejä: 10893
    • Profiili
    • Tomin kotisivut
Vs: Natiivi Spotify linuxille
« Vastaus #11 : 15.07.10 - klo:13.20 »
Ihan nätisti asentui tänään, mutta Premium-rajoitteesta johtuen en päässyt kokeilemaan. Ihmetyttää kyllä tuo etteivät osaa mainoksia laittaa näkymään. Kuvitellaankohan siellä, että kaikki muokkaavat Qt:tä niin ettei se enää näytä mainoksia? Tai soita niitä? Itse lupaan olla asentamatta moista muokkausta, ellei se sitten tule Ubuntun mukana. ;)
Automaattinen allekirjoitus:
Lisäisitkö [RATKAISTU] ketjun ensimmäisen viestin aiheeseen ongelman ratkettua, kiitos.

Jakke77

  • Käyttäjä
  • Viestejä: 3715
  • Oulu (Oinaansuo)
    • Profiili
Vs: Natiivi Spotify linuxille
« Vastaus #12 : 15.07.10 - klo:13.27 »
Tällaista herjaa pukkaa kun yrittää asentaa sen spotify-client-gnome-supportin:

Koodia: [Valitse]
spotify-client-gnome-support:
  Riippuvuudet: gconf2 (>=2.28.1-2), mutta versiota 2.28.1-0ubuntu1 ollaan asentamassa

Se spotify-client-qt kyllä toimii muuten hyvin mutta volumesäätö ei pelaa ja ikkunan maksimointi menee yli työpöydän palkeista :)

itse latailin tuon gconf2 2.28.1-3:n, asensin ja kokeilin eilen asennella tuota muttei onnistunut, tänään kokeilin uudelleen ja gnome-support asentui vaivatta, ilmeisesti uudelleen käynnistys oli ratkaisu
U_G_H

Aspire E5-575G V1.27 CPU: Intel i3-6100U (4) @ 2.300GHz GPU: Intel® HD Graphics 520 GPU: NVIDIA GeForce 940MX

Tomin

  • Palvelimen ylläpitäjä
  • Käyttäjä / moderaattori+
  • Viestejä: 10893
    • Profiili
    • Tomin kotisivut
Vs: Natiivi Spotify linuxille
« Vastaus #13 : 15.07.10 - klo:13.35 »
Tällaista herjaa pukkaa kun yrittää asentaa sen spotify-client-gnome-supportin:

Koodia: [Valitse]
spotify-client-gnome-support:
  Riippuvuudet: gconf2 (>=2.28.1-2), mutta versiota 2.28.1-0ubuntu1 ollaan asentamassa

Se spotify-client-qt kyllä toimii muuten hyvin mutta volumesäätö ei pelaa ja ikkunan maksimointi menee yli työpöydän palkeista :)

itse latailin tuon gconf2 2.28.1-3:n, asensin ja kokeilin eilen asennella tuota muttei onnistunut, tänään kokeilin uudelleen ja gnome-support asentui vaivatta, ilmeisesti uudelleen käynnistys oli ratkaisu
En usko. Veikkaan, että korjasivat pakettia.
Automaattinen allekirjoitus:
Lisäisitkö [RATKAISTU] ketjun ensimmäisen viestin aiheeseen ongelman ratkettua, kiitos.

Jakke77

  • Käyttäjä
  • Viestejä: 3715
  • Oulu (Oinaansuo)
    • Profiili
Vs: Natiivi Spotify linuxille
« Vastaus #14 : 15.07.10 - klo:13.54 »
no asennus toimi mutta eipä käynnisty mokoma clientti.
tällästä virheilmiitusta jakelee, käynnistipä sen komennolla spotify tai /usr/bin/spotify

Gtk-Message: (for origin information, set GTK_DEBUG): failed to retrieve property `GtkTreeView::odd-row-color' of type `GdkColor' from rc file value "((GString*) 0xa12eea0)" of type `GString'
Virheellinen käsky
U_G_H

Aspire E5-575G V1.27 CPU: Intel i3-6100U (4) @ 2.300GHz GPU: Intel® HD Graphics 520 GPU: NVIDIA GeForce 940MX

noname

  • Käyttäjä
  • Viestejä: 828
  • Linuxilla maaliskuusta 2009
    • Profiili
Vs: Natiivi Spotify linuxille
« Vastaus #15 : 17.07.10 - klo:20.35 »
Toivottavasti joskus tulee Linuxillekin se ilmainen jossa ei tarvitse koodia, ja jossa on 20h/kk rajoitus.

qwertyy

  • Käyttäjä
  • Viestejä: 4774
    • Profiili
Vs: Natiivi Spotify linuxille
« Vastaus #16 : 09.08.10 - klo:14.39 »
Asensin läppärin 10.04 64bit asennukseen Spotifyn ja heti alkoi rokkaamaan. Hienoa :)

eraggo

  • Käyttäjä
  • Viestejä: 63
    • Profiili
Vs: Natiivi Spotify linuxille
« Vastaus #17 : 16.08.10 - klo:21.12 »
Itse odotan Preniumin hankkimisen mahdollisuutta Paypalin kautta... Ennen en harkitse (kai?) linux clientin hankkimista.

Tietenkin asia muuttuu jos hankin Visa Electron -pankkikorttiini myös verkkomaksun.

qwertyy

  • Käyttäjä
  • Viestejä: 4774
    • Profiili
Vs: Natiivi Spotify linuxille
« Vastaus #18 : 16.08.10 - klo:21.17 »
Itse odotan Preniumin hankkimisen mahdollisuutta Paypalin kautta...
Sehän on ollut mahdollista jo kauan.

*edit*
Linux versio ei toimikaan kuin premium tileillä. Mainosperusteiset ei ole tuettuja toistaiseksi.

Tempo

  • Käyttäjä
  • Viestejä: 753
    • Profiili
Vs: Natiivi Spotify linuxille
« Vastaus #19 : 16.08.10 - klo:21.25 »
Että näin :-(

Download Spotify for other platforms

We are sorry, but currently we only support Windows and Mac.

Of course, if you want to go ahead and download the Windows or Mac application for now we’ll keep quiet about it.

If you are using Linux, you might want to run Spotify under Wine or try our Linux for Spotify preview.
Läppäri aikakausi alkaa olla lopuillaan. (lopen kyllästynyt läppäreihin)
Fujitsu siemens E5925 EPA, Intel core 2 duo, 8 G ram, SSD, yms yms......

Ja linkki pääte ohjeisiin-------->http://forum.ubuntu-fi.org/index.php?topic=32091.msg282369#msg2823