Kirjoittaja Aihe: OpenVPN ongelmia  (Luettu 1245 kertaa)

Bent

  • Käyttäjä
  • Viestejä: 77
    • Profiili
OpenVPN ongelmia
« : 30.06.10 - klo:23.05 »
Minulla on useampi Lucid lynx asennus ja käytän openvpn palvelua. Läppärissäni sain gnome network managerilla toimimaan importtaamalla .conf tiedoston ja samantien voisin käydä valitsemassa vpn connections ja connect ja kaikki toimi.

Sama pöytäkoneellani / media serverilläni ei onnistunut vaan tässä valitti että yhteys timeouttaa. Kokeilin tässä 6 tuntia tätä saada tuloksetta. Ongelma lienee että olen säätänyt tässä vpn yhteyksien kanssa jo pidemmän aikaa ja gnome-network-manager ei ole välttämättä ihan default asetuksilla enää. PPTP yhteys toimii jostain syystä.

Kuten myös sudo openvpn --connect vpn.conf kommenolla ajo joka sitten kysyy käyttäjätunnusta ja salasanaa ja yhdistää melkein heti.

Olisiko kellään ideoita ?

Ilokaasu

  • Käyttäjä
  • Viestejä: 1547
    • Profiili
Vs: OpenVPN ongelmia
« Vastaus #1 : 01.07.10 - klo:11.05 »
Ekana tulee mieleen, että olet tehnyt toimivassa koneessa jotain eri tavalla kuin kahdessa muussa, mutta et huomaa sitä vikaa.

Toisena tulisi mieleen koittaa resetoida networkmanagerin asetukset. Se onnistunee varmaan ainakin poistamalla koko manageri, mutta jos joku tietäisi helpomman keinon tyhjentää sen asetukset.

Onko kaikki koneet päivitetty samalle "tasolle", eli uusimmat päivitykset jne. Vai olisiko ykköskoneessa jotain eri tavalla kuin muissa.

Bent

  • Käyttäjä
  • Viestejä: 77
    • Profiili
Vs: OpenVPN ongelmia
« Vastaus #2 : 01.07.10 - klo:11.14 »
Ekana tulee mieleen, että olet tehnyt toimivassa koneessa jotain eri tavalla kuin kahdessa muussa, mutta et huomaa sitä vikaa.

Toisena tulisi mieleen koittaa resetoida networkmanagerin asetukset. Se onnistunee varmaan ainakin poistamalla koko manageri, mutta jos joku tietäisi helpomman keinon tyhjentää sen asetukset.

Onko kaikki koneet päivitetty samalle "tasolle", eli uusimmat päivitykset jne. Vai olisiko ykköskoneessa jotain eri tavalla kuin muissa.

Kokeilin jo eilen network managerin poistamista ja asensin sen takaisin, asetuksia se ei näyttänyt poistavan. Kokeilin myös kvpc (en varmaan kirjoita sitä oikein) mutta joku kde:n clientti se on ja sillä yhdistäminen näytti kaatuvan samaan ongelmaan.

Löysin tänään googletellasani yhden toisen jolla vähän samankaltainen ongelma ja hänellä ongelma oli poistunut poistamalla kaikki conf ja avain tiedostot + hakemalla ne uudelleen vpn palvelutarjoajalta ja tekemällä konffit uudelleen. Kokeilen tuota vielä tänään illalla.

Ilokaasu

  • Käyttäjä
  • Viestejä: 1547
    • Profiili
Vs: OpenVPN ongelmia
« Vastaus #3 : 01.07.10 - klo:11.35 »
Networkmanagerin asetukset ei välttämättä poistu silloin kun sen managerin poistaa. Joku muu/google voinee kertoa missä se oikea asetustiedosto majailee. Muistaakseni se ei ole /etc/network/interfaces jossa nuo asetukset yleensä on.