Kirjoittaja Aihe: razertoolin asennus  (Luettu 2177 kertaa)

tomppa

  • Käyttäjä
  • Viestejä: 165
  • Debian4.0
    • Profiili
razertoolin asennus
« : 02.06.06 - klo:10.58 »
Tuollainen mukava ohjelma löytyi ja asentamisessa tuli hieman ongelmia:
Koodia: [Valitse]
sudo dpkg -i razertool_0.0.6-1_i386.deb
Selecting previously deselected package razertool.
(Reading database ... 140054 files and directories currently installed.)
Unpacking razertool (from razertool_0.0.6-1_i386.deb) ...
dpkg: dependency problems prevent configuration of razertool:
 razertool depends on libc6 (>= 2.3.6-6); however:
  Version of libc6 on system is 2.3.6-0ubuntu20.
 razertool depends on libusb-0.1-4 (>= 2:0.1.12); however:
  Version of libusb-0.1-4 on system is 2:0.1.10a-22ubuntu1.
dpkg: error processing razertool (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 razertool

Mitä tämä tarkoittaa? Libc6 pakettiahan tämä ilmeisesti vaatii, mutta se on jo koneella asennettuna. Samoin tuo libusb on asennettu.  ???

janne

  • Käyttäjä
  • Viestejä: 5150
    • Profiili
Re: razertoolin asennus
« Vastaus #1 : 02.06.06 - klo:11.02 »
Koodia: [Valitse]
razertool depends on libc6 (>= 2.3.6-6); however:
  Version of libc6 on system is 2.3.6-0ubuntu20.
 razertool depends on libusb-0.1-4 (>= 2:0.1.12); however:
  Version of libusb-0.1-4 on system is 2:0.1.10a-22ubuntu1.

Mitä tämä tarkoittaa? Libc6 pakettiahan tämä ilmeisesti vaatii, mutta se on jo koneella asennettuna. Samoin tuo libusb on asennettu.  ???

se tarkoittaa sitä mitä siinä lukeekin, eli se riippuu libc6:n versiosta 2.3.6-6 tai uudemmasta ja sinulla on asennettuna versio 2.3.6-0ubuntu20, sama tilanne tuolla toisellakin paketilla.

[edit]
kokeilin huvikseni kääntää noita dapperille ja kyllä sieltä kaksi pakettia putkahtikin :)
sopii kokeilla omalla vastuulla:
http://omppu.ath.cx/dapper/razertool-gtk_0.0.6-1_i386.deb
http://omppu.ath.cx/dapper/razertool_0.0.6-1_i386.deb
« Viimeksi muokattu: 02.06.06 - klo:11.37 kirjoittanut janne »
Janne

tomppa

  • Käyttäjä
  • Viestejä: 165
  • Debian4.0
    • Profiili
Re: razertoolin asennus
« Vastaus #2 : 02.06.06 - klo:11.27 »
Aivan aivan. Sano vaan tuo apt-get, että on jo uusimmat versiot noista paketeista niin meni hieman sekaisin. :)
Sain toimimaan. Kiitoksia. ;)

janne

  • Käyttäjä
  • Viestejä: 5150
    • Profiili
Re: razertoolin asennus
« Vastaus #3 : 02.06.06 - klo:11.31 »
Aivan aivan. Sano vaan tuo apt-get, että on jo uusimmat versiot noista paketeista niin meni hieman sekaisin. :)

juu, tuo paketti on selvästi luotuo jossain toisessa ympäristössä jossa on eri versiot noista riippuvuuksista ja siksi se ei toiminut sellaisenaan.

monesti kuitenkin, jos ohjelmasta sattuu löytymään debian-paketti, se on aika helppo kääntää ubuntullekin.
Janne