Kirjoittaja Aihe: Ubuntun uuteen versioon päivittäminen ei toiminut  (Luettu 2330 kertaa)

jbullockster

  • Käyttäjä
  • Viestejä: 10
    • Profiili
Päätin päivittää 10.04 versioon: päivittäminen ei onnistunut: kone ilmoitti, että "liikaa virheitä". Päivitysten hallinta sanoo jotakin tähän tapaan: "Järjestelmässä kolme rikkinäistä osiota, suodata pakettitiedostot termillä "rikki". -Tuo "rikki"termi ei kyllä suodata yhtään mitään, kuulostaakin aivan ihmeelliseltä.

Koneellani on asennettuna rinnalle Win-XP.
GRUB-asentui ja toimii.

-Mitäköhän tässä voisi tehdä?

aku506

  • Käyttäjä
  • Viestejä: 356
    • Profiili
Vs: Ubuntun uuteen versioon päivittäminen ei toiminut
« Vastaus #1 : 01.05.10 - klo:12.54 »
Itse en ole asiantuntija, mutta olen lukenut foorumilta paljon kommentteja, joissa sanotaan seuraavaa: ”Kannattaa asentaa uusi versio ennemmin kokonaan vanhan päälle cd:ltä, eikä vain päivittää”

zepotus

  • Käyttäjä
  • Viestejä: 271
    • Profiili
Vs: Ubuntun uuteen versioon päivittäminen ei toiminut
« Vastaus #2 : 01.05.10 - klo:13.04 »
”Kannattaa asentaa uusi versio ennemmin kokonaan vanhan päälle cd:ltä, eikä vain päivittää”

Ehdottomasti!
Ubuntu 12.04 64-bit (i5-750 @ 3.8 Ghz, 4Gt, OCZ Agility 3 60Gt, 150Gt Raptor + 500 Gt + 1000 Gt, GT240 nvidia)

lompolo

  • Käyttäjä
  • Viestejä: 852
    • Profiili
Vs: Ubuntun uuteen versioon päivittäminen ei toiminut
« Vastaus #3 : 01.05.10 - klo:13.25 »
Koodia: [Valitse]
sudo dpkg --configure -a
ja saat paketit kuntoon tai ainakin näet mikä ongelma on.

jbullockster

  • Käyttäjä
  • Viestejä: 10
    • Profiili
Vs: Ubuntun uuteen versioon päivittäminen ei toiminut
« Vastaus #4 : 01.05.10 - klo:15.24 »
kiitti vinkeistä. sudo dpkg --configure -a antoi vastaukseksi:

 dpkg: riippuvuusongelmat estävät paketin xorg-driver-fglrx asetusten asettamisen:
 xorg-driver-fglrx riippuu paketista fglrx; kuitenkin:
  Pakettia fglrx ei ole asennettu.
dpkg: virhe käsiteltäessä xorg-driver-fglrx (--configure):
 riippuvuusongelmia - jätetään asetukset säätämättä
dpkg: riippuvuusongelmat estävät paketin fglrx-kernel-source asetusten asettamisen:
 fglrx-kernel-source riippuu paketista fglrx; kuitenkin:
  Pakettia fglrx ei ole asennettu.
dpkg: virhe käsiteltäessä fglrx-kernel-source (--configure):
 riippuvuusongelmia - jätetään asetukset säätämättä
dpkg: riippuvuusongelmat estävät paketin fglrx-amdcccle asetusten asettamisen:
 fglrx-amdcccle riippuu paketista fglrx; kuitenkin:
  Pakettia fglrx ei ole asennettu.
dpkg: virhe käsiteltäessä fglrx-amdcccle (--configure):
 riippuvuusongelmia - jätetään asetukset säätämättä
Käsittelyssä tapahtui liian monta virhettä:
 xorg-driver-fglrx
 fglrx-kernel-source
 fglrx-amdcccle


Minulla on Ati Catalyst Control Center asennettuna, auttaisiko tuon poisto (mitenköhän se poistetaan?)

Miten puhdasasennus sitten tehdään? -Vanha Ubuntu pitäisi kai saada koneelta jotenkin pois, ja Win XP jättää mielellään koskematta.

lompolo

  • Käyttäjä
  • Viestejä: 852
    • Profiili
Vs: Ubuntun uuteen versioon päivittäminen ei toiminut
« Vastaus #5 : 01.05.10 - klo:16.30 »
Onnistuuko tuon puuttuvan riippuvuuden asennus?
Koodia: [Valitse]
sudo apt-get install fglrx
Jos ei onnistu, nuo riiippuvaiset paketit voi poistaa seuraavalla komennolla
Koodia: [Valitse]
sudo apt-get remove xorg-driver-fglrx fglrx-kernel-source fglrx-amdcccleKannattaa varmistaa, ettei tuo komento poista muita tarpeellisia paketteja. Tuskin poistaa. Nuo paketit voi asentaa myöhemmin uudelleen.

Tämän jälkeen uudestaan.
Koodia: [Valitse]
sudo dpkg --configure -aJos ei tule valituksia, kaikkien pakettien asetukset on tehty. Sitten kannattaa tarkistaa päivitykset normaalisti.


jbullockster

  • Käyttäjä
  • Viestejä: 10
    • Profiili
Vs: Ubuntun uuteen versioon päivittäminen ei toiminut
« Vastaus #6 : 01.05.10 - klo:17.22 »
Sain vastaukseksi:

dpkg: virhe käsiteltäessä /var/cache/apt/archives/fglrx_2%3a8.723.1-0ubuntu3_i386.deb (--unpack):
 aliprosessi uusi pre-installation-komentosarja palautti virhetilakoodin 1
Valitaan aikaisemmin valitsematon paketti fglrx-amdcccle.
Puretaan pakettia fglrx-amdcccle (.../fglrx-amdcccle_2%3a8.723.1-0ubuntu3_i386.deb)...
Käsittelyssä tapahtui liian monta virhettä:
 /var/cache/apt/archives/fglrx_2%3a8.723.1-0ubuntu3_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)