Kirjoittaja Aihe: Wolfenstein: Enemy Territory käynnistysongelma  (Luettu 3152 kertaa)

Kalemitse

  • Käyttäjä
  • Viestejä: 5
  • 404 error - picture not found
    • Profiili
Minulla olisi kyseisen pelin kanssa ongelma.
Kun käynnistän valikosta Sovellukset -> Pelit -> Wolfenstein: Enemy Territory tulee musta ruutu ja ruutu palaa normaaliin tilaan.
Kun käynnistän päätteen kautta niin tulee seuraavaa koodia:
Koodia: [Valitse]
aroy@axubuntu:~$  et
ET 2.60 linux-i386 Mar 10 2005
----- FS_Startup -----
Current search path:
/home/aroy/.etwolf/etmain
/usr/local/games/enemy-territory/etmain/pak2.pk3 (22 files)
/usr/local/games/enemy-territory/etmain/pak1.pk3 (10 files)
/usr/local/games/enemy-territory/etmain/pak0.pk3 (3725 files)
/usr/local/games/enemy-territory/etmain/mp_bin.pk3 (6 files)
/usr/local/games/enemy-territory/etmain

----------------------
3763 files in pk3 files
execing default.cfg
couldn't exec language.cfg
execing profiles/Fiercen00b/etconfig.cfg
couldn't exec autoexec.cfg
Hunk_Clear: reset the hunk ok

------- Input Initialization -------
Joystick is not active.
------------------------------------
Bypassing CD checks
----- Client Initialization -----
----- Initializing Renderer ----
-------------------------------
----- Client Initialization Complete -----
----- R_Init -----
...loading libGL.so.1: Initializing OpenGL display
...setting mode 5: 960 720
Using XFree86-VidModeExtension Version 2.2
XF86DGA Mouse (Version 2.0) initialized
XFree86-VidModeExtension:  Ignored on non-fullscreen/Voodoo
Using 4/4/4 Color bits, 24 depth, 0 stencil display.
GL_RENDERER: GeForce 6200/AGP/SSE/3DNOW!
Initializing OpenGL extensions
...using GL_S3_s3tc
...ignoring GL_EXT_texture_env_add
...using GL_ARB_multitexture
...using GL_EXT_compiled_vertex_array
...ignoring GL_NV_fog_distance
...ignoring GL_EXT_texture_filter_anisotropic
Initializing GLX extensions
...using GLX_SGI_swap_control
...using GLX_SGI_video_sync
XF86 Gamma extension initialized

GL_VENDOR: NVIDIA Corporation
GL_RENDERER: GeForce 6200/AGP/SSE/3DNOW!
GL_VERSION: 2.1.2 NVIDIA 180.44
GL_EXTENSIONS: GL_ARB_color_buffer_float GL_ARB_depth_texture GL_ARB_draw_buffers GL_ARB_fragment_program GL_ARB_fragment_program_shadow GL_ARB_fragment_shader GL_ARB_half_float_pixel GL_ARB_half_float_vertex GL_ARB_framebuffer_object GL_ARB_imaging GL_ARB_map_buffer_range GL_ARB_multisample GL_ARB_multitexture GL_ARB_occlusion_query GL_ARB_pixel_buffer_object GL_ARB_point_parameters GL_ARB_point_sprite GL_ARB_shadow GL_ARB_shader_objects GL_ARB_shading_language_100 GL_ARB_texture_border_clamp GL_ARB_texture_compression GL_ARB_texture_cube_map GL_ARB_texture_env_add GL_ARB_texture_env_combine GL_ARB_texture_env_dot3 GL_ARB_texture_float GL_ARB_texture_mirrored_repeat GL_ARB_texture_non_power_of_two GL_ARB_texture_rectangle GL_ARB_transpose_matrix GL_ARB_vertex_array_object GL_ARB_vertex_buffer_object GL_ARB_vertex_program GL_ARB_vertex_shader GL_ARB_window_pos GL_ATI_draw_buffers GL_ATI_texture_float GL_ATI_texture_mirror_once GL_S3_s3tc GL_EXT_texture_env_add GL_EXT_abgr GL_EXT_bgra GL_EXT_blend_color GL_EXT_blend_equation_separate GL_EXT_blend_func_separate GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_compiled_vertex_array GL_EXT_Cg_shader GL_EXT_depth_bounds_test GL_EXT_direct_state_access GL_EXT_draw_range_elements GL_EXT_fog_coord GL_EXT_framebuffer_blit GL_EXT_framebuffer_multisample GL_EXT_framebuffer_object GL_EXT_gpu_program_parameters GL_EXT_multi_draw_arrays GL_EXT_packed_depth_stencil GL_EXT_packed_pixels GL_EXT_pixel_buffer_object GL_EXT_point_parameters GL_EXT_rescale_normal GL_EXT_secondary_color GL_EXT_separate_specular_color GL_EXT_shadow_funcs GL_EXT_stencil_two_side GL_EXT_stencil_wrap GL_EXT_texture3D GL_EXT_texture_compression_s3tc GL_EXT_texture_cube_map GL_EXT_texture_edge_clamp GL_EXT_texture_env_combine GL_EXT_texture_env_dot3 GL_EXT_texture_filter_anisotropic GL_EXT_texture_lod GL_EXT_texture_lod_bias GL_EXT_texture_mirror_clamp GL_EXT_texture_object GL_EXT_texture_sRGB GL_EXT_texture_swizzle GL_EXT_timer_query GL_EXT_vertex_array GL_EXT_vertex_array_bgra GL_IBM_rasterpos_clip GL_IBM_texture_mirrored_repeat GL_KTX_buffer_region GL_NV_blend_square GL_NV_copy_depth_to_color GL_NV_depth_clamp GL_NV_fence GL_NV_float_buffer GL_NV_fog_distance GL_NV_fragment_program GL_NV_fragment_program_option GL_NV_fragment_program2 GL_NV_framebuffer_multisample_coverage GL_NV_half_float GL_NV_light_max_exponent GL_NV_multisample_filter_hint GL_NV_occlusion_query GL_NV_packed_depth_stencil GL_NV_pixel_data_range GL_NV_point_sprite GL_NV_primitive_restart GL_NV_register_combiners GL_NV_register_combiners2 GL_NV_texgen_reflection GL_NV_texture_compression_vtc GL_NV_texture_env_combine4 GL_NV_texture_expand_normal GL_NV_texture_rectangle GL_NV_texture_shader GL_NV_texture_shader2 GL_NV_texture_shader3 GL_NV_vertex_array_range GL_NV_vertex_array_range2 GL_NV_vertex_program GL_NV_vertex_program1_1 GL_NV_vertex_program2 GL_NV_vertex_program2_option GL_NV_vertex_program3 GL_NVX_conditional_render GL_SGIS_generate_mipmap GL_SGIS_texture_lod GL_SGIX_depth_texture GL_SGIX_shadow GL_SUN_slice_accum
GLX_EXTENSIONS: GLX_EXT_visual_info GLX_EXT_visual_rating GLX_SGIX_fbconfig GLX_SGIX_pbuffer GLX_SGI_video_sync GLX_SGI_swap_control GLX_EXT_texture_from_pixmap GLX_ARB_create_context GLX_ARB_multisample GLX_NV_float_buffer GLX_ARB_fbconfig_float GLX_ARB_get_proc_address
GL_MAX_TEXTURE_SIZE: 4096
GL_MAX_ACTIVE_TEXTURES_ARB: 4

PIXELFORMAT: color(16-bits) Z(24-bit) stencil(0-bits)
MODE: 5, 960 x 720 windowed hz:N/A
GAMMA: hardware w/ 0 overbright bits
CPU:
rendering primitives: single glDrawElements
texturemode: GL_LINEAR_MIPMAP_NEAREST
picmip: 2
texture bits: 16
multitexture: enabled
compiled vertex arrays: enabled
texenv add: disabled
compressed textures: enabled
anisotropy: 1.0
NV distance fog: disabled
Initializing Shaders
----- finished R_Init -----

------- sound initialization -------
------------------------------------
----- Sound Info -----
sound system is muted
    1 stereo
32768 samples
   16 samplebits
    1 submission_chunk
22050 speed
0x0xafce9000 dma buffer
No background file.
----------------------
Sound memory manager started
Sys_LoadDll(/home/aroy/.etwolf/etmain/ui.mp.i386.so)... ok
Sys_LoadDll(ui) found **vmMain** at  0xadd97420 
Sys_LoadDll(ui) succeeded!
^3WARNING: Couldn't find image for shader ui/assets/icon_jaymod.tga
--- Common Initialization Complete ---
Opening IP socket: localhost:27960
Hostname: axubuntu.TeleWell.gateway
Alias: axubuntu
IP: 127.0.1.1
Started tty console (use +set ttycon 0 to disable)
^5PunkBuster Client: PunkBuster Client (v1.152 | A0) Enabled
Received signal 7, exiting...
Shutdown tty console


Sitten kokeilin komennolla et > etlog.txt niin logissa löytyi seuraavaa:
Koodia: [Valitse]
Received signal 7, exiting...
Mietin ensin, että onko näytönohjaimessa vikaa, ja katsoin ajurien kunnon ja ihan normaalilta näytti olevan.
Sitten googletin ongelman ja ei löytynyt yhtään mitään, vaikkakin löytyi jotain ratkaisuja signaaleille 6 ja 11, mutta ei signaalille 7.  ???

Käyttis on Ubuntu 9.04 jaunty ja näyttiksenä toimii NVIDIA 6200 Geforce 128 Mb.

Laitoin tämän ongelman nyt tänne jos löytyisi ratkaisua tähän pulmaan...  :-\

tommis

  • Käyttäjä
  • Viestejä: 418
    • Profiili
Vs: Wolfenstein: Enemy Territory käynnistysongelma
« Vastaus #1 : 09.03.10 - klo:17.46 »
Asenna peli käyttämällä Playdeb ohjelmalähdettä.

Kalemitse

  • Käyttäjä
  • Viestejä: 5
  • 404 error - picture not found
    • Profiili
Vs: Wolfenstein: Enemy Territory käynnistysongelma
« Vastaus #2 : 10.03.10 - klo:15.16 »
Olen asentanut kyseisen pelin sieltä.
Peli pyöri ihan hyvin kunnes tuli tuo ongelma yhtenä aamuna.

Itse olen käyttänyt kaikki omassa tiedossa olevat keinot, senhän takia laitoinkin tämän ongelman tänne jos täällä osattaisiin jotenkin auttaa. Mutta näyttää siltä että täälläkään ei oikein tunneta tätä ongelmaa. :S

tuke81

  • Käyttäjä
  • Viestejä: 1667
    • Profiili
Vs: Wolfenstein: Enemy Territory käynnistysongelma
« Vastaus #3 : 10.03.10 - klo:17.00 »
Joo oudolta kuulostaa, kokeiles käynnistää peli päätteestä etpro:lla:
et +set fs_game etpro

Nyt muista että mitä noi exit signal codet oli, signal 11 on kuiten ajurista johtuva eli nyt ei pitäisi olla siitä johtuva. Signal 7 ei hajuakaan toivottavasti ei muistit.
Miksi tehdä jotain helposti, kun sen voi tehdä vaikeastikin...

Kalemitse

  • Käyttäjä
  • Viestejä: 5
  • 404 error - picture not found
    • Profiili
Vs: Wolfenstein: Enemy Territory käynnistysongelma
« Vastaus #4 : 10.03.10 - klo:20.20 »
Joo oudolta kuulostaa, kokeiles käynnistää peli päätteestä etpro:lla:
et +set fs_game etpro

Nyt muista että mitä noi exit signal codet oli, signal 11 on kuiten ajurista johtuva eli nyt ei pitäisi olla siitä johtuva. Signal 7 ei hajuakaan toivottavasti ei muistit.

Kävi samalla tavalla kuten pelkällä komennolla et.
Lopetti taas tuohon signal 7:ään. :/

tuke81

  • Käyttäjä
  • Viestejä: 1667
    • Profiili
Vs: Wolfenstein: Enemy Territory käynnistysongelma
« Vastaus #5 : 10.03.10 - klo:21.50 »
Uhh kummallinen errori. En ole ohjelmoija niin en oikein noista tiedä:
SIGEMT      7    EMT instruction

Kokeiles poistaa/siirtää ~/.etwolf/jaymod kansio ja avata peli uudestaan. Koska ainoa varoitus mikä tuossa nyt näkyy koskee jaymodia:
^3WARNING: Couldn't find image for shader ui/assets/icon_jaymod.tga
Miksi tehdä jotain helposti, kun sen voi tehdä vaikeastikin...

Kalemitse

  • Käyttäjä
  • Viestejä: 5
  • 404 error - picture not found
    • Profiili
Vs: Wolfenstein: Enemy Territory käynnistysongelma
« Vastaus #6 : 10.03.10 - klo:22.22 »
Kyseinen varoitus katosi kun poistin jaymodin, mutta se edelleen antaa tuon signaalin 7 ja lopettaa ohjelman. :/

tuke81

  • Käyttäjä
  • Viestejä: 1667
    • Profiili
Vs: Wolfenstein: Enemy Territory käynnistysongelma
« Vastaus #7 : 12.03.10 - klo:17.25 »
Kyseinen varoitus katosi kun poistin jaymodin, mutta se edelleen antaa tuon signaalin 7 ja lopettaa ohjelman. :/

Hmm kummallinen ongelma kaiken kaikkiaan, kokeiles lisätä autoexec.cfg:hen:
r_glIgnoreWicked3D 1
r_ignoreGLErrors 1


Tai käynnistä et niiden avulla: et +set r_glIgnoreWicked3D 1 +set r_ignoreGLErrors 1
Miksi tehdä jotain helposti, kun sen voi tehdä vaikeastikin...

Kalemitse

  • Käyttäjä
  • Viestejä: 5
  • 404 error - picture not found
    • Profiili
Vs: Wolfenstein: Enemy Territory käynnistysongelma
« Vastaus #8 : 12.03.10 - klo:17.49 »

Hmm kummallinen ongelma kaiken kaikkiaan, kokeiles lisätä autoexec.cfg:hen:
r_glIgnoreWicked3D 1
r_ignoreGLErrors 1


Tai käynnistä et niiden avulla: et +set r_glIgnoreWicked3D 1 +set r_ignoreGLErrors 1

Kyseistä tiedostoa (autoexec.cfg) ei löydy tältä koneelta, tiedä sitten onko se pakollinen tiedosto...

Kun yritin käynnistää tuota alempaa komentoa käyttäen niin sama ongelma (signal 7) oli siellä. :(

JTap

  • Käyttäjä
  • Viestejä: 276
    • Profiili
Vs: Wolfenstein: Enemy Territory käynnistysongelma
« Vastaus #9 : 18.04.10 - klo:19.41 »
Vähän samantyylistä vikaa tässä 9.10:ssä myös meikäläisellä. Odotetaan seuraavaa versiota ja toivotaan ettei tartte olla winukan varassa kun pelataan et:tä