Kirjoittaja Aihe: (Ratkaistu) wlan + xubuntu  (Luettu 2656 kertaa)

artohuht

  • Käyttäjä
  • Viestejä: 25
    • Profiili
(Ratkaistu) wlan + xubuntu
« : 18.10.09 - klo:21.19 »
Asensin kannettavaani xubuntu 9.04 version. Omistan Proximin pcmcia-langattoman kortin. Malli on 8421-wd. Miten saan sen toimimaan xubuntun kanssa, vai saanko mitenkään? Mistä edes tuo langattoman netin asennus tulisi aloittaa? Kotonani on siis tuo lähetin kyllä, mutta pitäisi saada siis kannettavalle myös tuo yhteys?
« Viimeksi muokattu: 20.10.09 - klo:22.18 kirjoittanut artohuht »

Timo Virtanen

  • Käyttäjä
  • Viestejä: 2080
    • Profiili
Vs: wlan + xubuntu
« Vastaus #1 : 18.10.09 - klo:21.40 »
Tervetuloa mukaan foorumille. Googlailin hieman etsien tietoa Proximista mutta hyvältä ei näytä. Mikä läppäri on kyseessä? Löytyykö koneesta USB-porttia, johon voisi hankkia halvan A-LINKin USB-WLAN tikun? terveisin Timo
"Linux, made in Finland"

T43, T61p, T500 kierrätysläppärit

artohuht

  • Käyttäjä
  • Viestejä: 25
    • Profiili
Vs: wlan + xubuntu
« Vastaus #2 : 18.10.09 - klo:21.46 »
Tuohon tulokseen olin vähän jo itsekkin päätymässä, ettei taida tuo korttini toimia. Kyseessä on Packard Bellin easynote e3 kannettava vuodelta 2003, joten usb portit kyllä löytyy. Varmaan tosiaan helpoimmalla pääsee, jos tuommoisen ehdottamasi aparaatin ostaisi.Kiitoksia vastauksesta

Timo Virtanen

  • Käyttäjä
  • Viestejä: 2080
    • Profiili
Vs: wlan + xubuntu
« Vastaus #3 : 18.10.09 - klo:21.57 »
No problem! Hienoa kun joku herättelee vanhoja, mutta käyttökelpoisia läppäreitä henkiin! Käytössä oli A-Link WL54USB tikku. Toimi IBM T30 läppärin USB 1.1 portissa hyvin ja hinta n 20 Euroa. Löytyy netistä. terveisin Timo,
"Linux, made in Finland"

T43, T61p, T500 kierrätysläppärit

artohuht

  • Käyttäjä
  • Viestejä: 25
    • Profiili
Vs: wlan + xubuntu
« Vastaus #4 : 19.10.09 - klo:12.36 »
Nyt on kyseinen laite käyty hankkimassa (alink wl54usb). Olen sen verran aloittelija tässä linuxissa, niin mitenkähän tuon saan yhdistettyä langattomaan verkkoon. Langallisen saan toimiin tuon "sudo pppoeconf" komennon avulla. Yläpalkissa kyllä näkyy, että langaton verkko olisi saatavilla, mutta miten on sen yhdistämisen kanssa? Ja minne saan syötettyä operaattorin käyttäjätunnukset ja salasanan?

nm

  • Käyttäjä
  • Viestejä: 12910
    • Profiili
Vs: wlan + xubuntu
« Vastaus #5 : 19.10.09 - klo:14.03 »
Yläpalkissa kyllä näkyy, että langaton verkko olisi saatavilla, mutta miten on sen yhdistämisen kanssa? Ja minne saan syötettyä operaattorin käyttäjätunnukset ja salasanan?

Avaa valikko painamalla sitä langattoman verkon ikonia oikeanpuoleisella hiirennapilla. Sieltä pääsee asetuksiin.

Tai vaihtoehtoisesti voit mennä järjestelmävalikon kautta: http://fi.wikibooks.org/wiki/Ubuntu_tutuksi/J%C3%A4rjestelm%C3%A4n_asetukset#Verkko

artohuht

  • Käyttäjä
  • Viestejä: 25
    • Profiili
Vs: wlan + xubuntu
« Vastaus #6 : 20.10.09 - klo:09.51 »
Jep. Tuon kyllä olin löytänytkin, mutta ilmeisesti jotain muuta häikkää. Esim tuohon TWEA510 motukkaan en saa yhteyttä väitetyllä ip-osoitteella, vaikka olen modeemin nollannutkin. Tosin winkun puolella tuo tikku alkoi toimimaan heti, joten tuossa on joku käytännön juttu ilmeisesti väärin.

nm

  • Käyttäjä
  • Viestejä: 12910
    • Profiili
Vs: wlan + xubuntu
« Vastaus #7 : 20.10.09 - klo:10.07 »
Aja nämä päätteessä ja näytä tulosteet:

Koodia: [Valitse]
/sbin/ifconfig
/sbin/iwconfig
/sbin/route

Onko tukiasemassa WPA-salaus käytössä?

artohuht

  • Käyttäjä
  • Viestejä: 25
    • Profiili
Vs: wlan + xubuntu
« Vastaus #8 : 20.10.09 - klo:10.53 »
Aja nämä päätteessä ja näytä tulosteet:

Koodia: [Valitse]
/sbin/ifconfig
/sbin/iwconfig
/sbin/route

Onko tukiasemassa WPA-salaus käytössä?

arto@arto-laptop:/sbin$ ifconfig
eth0      Link encap:Ethernet  HWaddr 00:40:d0:3d:c6:29 
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:10 Base address:0xa100

lo        Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:10 errors:0 dropped:0 overruns:0 frame:0
          TX packets:10 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:660 (660.0 B)  TX bytes:660 (660.0 B)

wlan0     Link encap:Ethernet  HWaddr 00:1a:9f:90:8e:91 
          inet6 addr: fe80::21a:9fff:fe90:8e91/64 Scope:Link
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:5 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:1548 (1.5 KB)

wmaster0  Link encap:UNSPEC  HWaddr 00-1A-9F-90-8E-91-65-39-00-00-00-00-00-00-00-00 
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

arto@arto-laptop:/sbin$ iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

wmaster0  no wireless extensions.

wlan0     IEEE 802.11bg  ESSID:"wlan-ap" 
          Mode:Managed  Frequency:2.412 GHz  Access Point: Not-Associated   
          Tx-Power=20 dBm   
          Retry min limit:7   RTS thr:off   Fragment thr=2352 B   
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

pan0      no wireless extensions.

arto@arto-laptop:/sbin$ route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface

nm

  • Käyttäjä
  • Viestejä: 12910
    • Profiili
Vs: wlan + xubuntu
« Vastaus #9 : 20.10.09 - klo:11.08 »
Eipä löydy tukiasemaa. Onko sen ESSID tuo "wlan-ap" ja onko salausta?

artohuht

  • Käyttäjä
  • Viestejä: 25
    • Profiili
Vs: wlan + xubuntu
« Vastaus #10 : 20.10.09 - klo:11.11 »
Eipä löydy tukiasemaa. Onko sen ESSID tuo "wlan-ap" ja onko salausta?

Jep tuo wlan-ap on essid ja salausta ei pitäisi olla

reboot

  • Käyttäjä
  • Viestejä: 214
    • Profiili
Vs: wlan + xubuntu
« Vastaus #11 : 20.10.09 - klo:11.17 »
- Onko koneen oma wlan kytketty pois päältä? Jos vaikka sotkisivat toinen toisiaan, jos samanaikaisesti ovat päällä.
- Tunnistaako kone tuon ulkoisen usb-wlan-tikun varmasti? Katso, mitä lsusb -komento kertoo ja copy-pastea tuloste tänne.

Edit:
A-Linkin sivuilta (http://www.a-link.com/WL54USB.html) löytyy pdf-muodossa ohje, miten kikkailla ko. wlan-tikku toimimaan Linuxissa: ftp://ftp.a-link.com/wl54usb/Linux_zd1211x_UserGuide.pdf ... sitäkin voisit kokeilla.
« Viimeksi muokattu: 20.10.09 - klo:11.23 kirjoittanut reboot »
Ubuntu käytössä kotona ja töissä!
*** Kun ongelmasi on ratkaisu lisää otsikkoon [Ratkaistu] ***

artohuht

  • Käyttäjä
  • Viestejä: 25
    • Profiili
Vs: wlan + xubuntu
« Vastaus #12 : 20.10.09 - klo:11.24 »
arto@arto-laptop:~$ lsusb
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 0ace:1215 ZyDAS WLA-54L WiFi

Eli ilmeisesti tunnistaa. Koneessa ei omaa wlania olekkaan. Aikaisemmin oli tuo PCMCIA kortti, jos sitä tarkoitit.

Ehkä se ongelma on tuossa, että miksi en nettiselaimella pääse hallinnoimaan tuota mun TWEA510 modeemia? Toisella foorumilla yritinkin jo kysellä siihen ohjeita, mutta ei löytynyt. Tehdasasetukset siis palautettu, mutta siltikkään windowsin eikä linuxin selaimet sitä löydä?

Storck

  • Vieras
Vs: wlan + xubuntu
« Vastaus #13 : 20.10.09 - klo:11.26 »

Ehkä se ongelma on tuossa, että miksi en nettiselaimella pääse hallinnoimaan tuota mun TWEA510 modeemia? Toisella foorumilla yritinkin jo kysellä siihen ohjeita, mutta ei löytynyt. Tehdasasetukset siis palautettu, mutta siltikkään windowsin eikä linuxin selaimet sitä löydä?

Oletko lukenut ohjeet? Joissain modeemeissa/reitittimissä pitää RJ-45 kaapeli olla tietyssä väylässä ennen kuin pääsee asetuksiin käsiksi. Tuosta en tiedä...

reboot

  • Käyttäjä
  • Viestejä: 214
    • Profiili
Vs: wlan + xubuntu
« Vastaus #14 : 20.10.09 - klo:11.39 »
Eli ilmeisesti tunnistaa. Koneessa ei omaa wlania olekkaan. Aikaisemmin oli tuo PCMCIA kortti, jos sitä tarkoitit.

Katsopa vielä, löytyykö lsmod -käskyllä ko. usb-tikun tarvitsema zd1211-kernelmoduuli?

Ja tosiaan kannattaa varmistaa, että tuo itse modeemi on ok. Saatko siihen yhteyden Windowsista ok, ja toimiiko netti yms. ok myös?
Ubuntu käytössä kotona ja töissä!
*** Kun ongelmasi on ratkaisu lisää otsikkoon [Ratkaistu] ***

nm

  • Käyttäjä
  • Viestejä: 12910
    • Profiili
Vs: wlan + xubuntu
« Vastaus #15 : 20.10.09 - klo:11.54 »
Voisi myös katsoa mahdolliset virheilmoitukset kernelin lokista, eli ota tikku irti koneesta, odota hetki, laita takaisin, odota 10 sekuntia ja komenna päätteessä:

Koodia: [Valitse]
dmesg | tail -50
Täällä on vähän samanlaista ongelmaa, jossa tuo tikku toimii toisella koneella mutta toisella ei: http://forum.ubuntu-fi.org/index.php?topic=27218.0

artohuht

  • Käyttäjä
  • Viestejä: 25
    • Profiili
Vs: wlan + xubuntu
« Vastaus #16 : 20.10.09 - klo:13.25 »
NO nyt surfataan langattomasti. Ongelma taisi olla tosiaan tuossa motukassa. Manuaalissa oli vähän kahdenlaista tietoa, kauanko tulee painaa resettiä että nollautuu. No nyt toimii!

Kiitoksia avusta!

Timo Virtanen

  • Käyttäjä
  • Viestejä: 2080
    • Profiili
Vs: wlan + xubuntu
« Vastaus #17 : 20.10.09 - klo:19.16 »
Hieno juttu, että pelittää! Laita Muokkaa-toiminnolla "Ratkaistu"-sana ensimmäisen viestin otsikkoon. Tarkoittaa samaa kuin poliisisarjojen "case is closed"  ;D terveisin Timo
"Linux, made in Finland"

T43, T61p, T500 kierrätysläppärit