Kirjoittaja Aihe: grub2 ei toimi: Miten korjataan tai muokataan?[Ratkaistu]  (Luettu 3948 kertaa)

Jyrki L

  • Käyttäjä
  • Viestejä: 448
    • Profiili
Asensin ubuntun 9.10 puhtaalle pöydälle. tiedostojärjestelmäksi tuli näköjään ext4 ja menu.lst tiedostoa en tosiaan löydä mistään. Ja ongelmiakin on. Nyt pitäisi ehkä päivittää niitä käynnistyslataajan asetuksia mutta kun en tiedä miten. kone ei suostu käynnistymään grafiikka tilaan.
Ensimmäinen vikailmoitus on:
Koodia: [Valitse]
[1.431212] [firmware bug]:powernowk8: no compatible acppi_pss objects found.
Johtuen emolevystä k9n ultra pitäisi kai laittaa edellisten ubuntun versioiden tapaan acpi=off tai no acpi käyttöön. Ja mitähän eroa noilla edes oli?

Koodia: [Valitse]
[1.431213] [firmware bug] powernowk8 try again with latest bios.(tuo ei liene vakavaa)

Koodia: [Valitse]
fsck from util-linux-ng 2.16
dev/sda5:superblock last mount time (wed oct 7 17:18:27 2009,
now = wed oct 7 17:09:21 2009) is in the future
Siis mitä; Edellinen mounttaus tapahtunut tulevaisuudessa vai miten tuo pitäisi ymmärtää?

Koodia: [Valitse]
/dev/sda5:unexpected inconsistency;
run fsck manually. (i.e., without -a or -p options)
mountall: fsck/[713] terminated with status 4
mountall filesystem has errors:/
init monutall: mainprocess (377) terminated with status 2
rm cannot remove /fsck':read-only filesystem
init mountall post-stop process [722] terminated status 1
filesystem check failed
A maintenance schell will now be started.
control-D will terminate this schell and re entry
root@jyrki-desktop~#
Niin että miten tuon saa toimimaan? ubuntun osoita pystyy tutkimaan elolevyllä ja elolevyn vaivaton toiminta olikin positiivinen ylläri, mutta en osaa sisälläkään muokata tätä uutta grubia ja mitä sille edes pitäisi tehdä?
« Viimeksi muokattu: 08.10.09 - klo:09.20 kirjoittanut Jyrki73 »

gdm

  • Sitä saa mitä tilaa...
  • Käyttäjä
  • Viestejä: 4363
    • Profiili
    • Keskustelualueiden säännöt
Vs: grub2 ei toimi: Miten korjataan tai muokataan?
« Vastaus #1 : 07.10.09 - klo:22.46 »
grubin muokkaukset tiedostoon "/etc/default/grub"
ja riville: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" (lainausmerkkien sisään)
ja päivitys: sudo update-grub

Aseta BIOSin avulla kello utc-aikaan.
Pitäisi korjata tuo väärä aika.

Lisää [Ratkaistu] aloitusviestiin jos ongelmasi selviää!
Saamasi tuki on ilmaista, joten älä vaadi tai uhkaile saadaksesi apua!

Jyrki L

  • Käyttäjä
  • Viestejä: 448
    • Profiili
Vs: grub2 ei toimi: Miten korjataan tai muokataan?
« Vastaus #2 : 07.10.09 - klo:22.59 »
Aseta BIOSin avulla kello utc-aikaan.
Pitäisi korjata tuo väärä aika.
Aivan ja taas on windowsin kello väärässä.

Mutta kiitos tuosta toisesta neuvosta pitää kokeilla ja tutkia.

gdm

  • Sitä saa mitä tilaa...
  • Käyttäjä
  • Viestejä: 4363
    • Profiili
    • Keskustelualueiden säännöt
Lisää [Ratkaistu] aloitusviestiin jos ongelmasi selviää!
Saamasi tuki on ilmaista, joten älä vaadi tai uhkaile saadaksesi apua!

Jyrki L

  • Käyttäjä
  • Viestejä: 448
    • Profiili
Vs: grub2 ei toimi: Miten korjataan tai muokataan?
« Vastaus #4 : 07.10.09 - klo:23.04 »
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" (lainausmerkkien sisään)

Mutta mitä tuo tuo sitten tekee?
Jättääkö se käyttöjärjestelmän ilmoitukset piiloon niin että en tiedä senkään vertaa missä vika voisi olla?
edit:
Niin että koko ongelma sitten johtui pelkästään väärästä kellonajasta. :-\
« Viimeksi muokattu: 07.10.09 - klo:23.33 kirjoittanut Jyrki73 »

gdm

  • Sitä saa mitä tilaa...
  • Käyttäjä
  • Viestejä: 4363
    • Profiili
    • Keskustelualueiden säännöt
Vs: grub2 ei toimi: Miten korjataan tai muokataan?
« Vastaus #5 : 08.10.09 - klo:09.12 »
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" (lainausmerkkien sisään)

Mutta mitä tuo tuo sitten tekee?

Se on sama kuin menu.lst tiedoston #defoptions= splash quiet

Eli
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi=off elevator=deadline jne"
Optiot tuolle riville ja grubin päivitys, niin tulee käyttöön.
Lisää [Ratkaistu] aloitusviestiin jos ongelmasi selviää!
Saamasi tuki on ilmaista, joten älä vaadi tai uhkaile saadaksesi apua!

juyli

  • Vieras
Vs: grub2 ei toimi: Miten korjataan tai muokataan?[Ratkaistu]
« Vastaus #6 : 08.10.09 - klo:10.48 »
pitäisi kai laittaa edellisten ubuntun versioiden tapaan acpi=off tai no acpi käyttöön. Ja mitähän eroa noilla edes oli?

En noita erilaisia vipusia, kernelparametreja eli cheatcodeseja oikein muista, mutta tarkistapa pci=noacpi. Muista takuuvarmoja tuon acpi=off lisäksi ovat esim. noapic ja nolapic jne.

Janiporo

  • Käyttäjä
  • Viestejä: 51
    • Profiili
Vs: grub2 ei toimi: Miten korjataan tai muokataan?[Ratkaistu]
« Vastaus #7 : 06.11.09 - klo:15.56 »
Sit yks ihan perusjuttu, jonka kanssa tappelin tuossa hieman (GRUB 2 siis kyseessä, ja nämä "kivat" muutetut konffaustiedostopaikat ja systeemit)
Koskee ainakin 'Fujitsu Siemens S series s6010' läppäriä ja 'Ubuntu netbook remix 9.10' -julkaisua (joille nämä temput tein)
Koitan selittää tän silleen että on heleppo ymmärtää vähä uusimmillekkin "asiakkaille"

Live CD:ltä käynnistettäessä en saanut käynnistettyä käyttistä suoraan testikäyttöön, vaan piti asettaa päälle F4 valikosta "turvallinen graafinen tila (safe graphics mode)" sekä F6-valikosta acpi=off

Käynnistä live-cd joko "testitilaan", jossa testaat käyttistä, ja asenna sieltä, tai asenna suoraan siitä alkuvalikosta. Kenties kannattaa ekana testata tykkääkö tästä käyttiksestä, ja miten pyörii koneella. Live-CD pyörii toki hieman hitaammin kuin asennettu, riippuen laitteistosta ja kuinka hyvin se tunnistetaan.

Oletan että olet tässä vaiheessa oletettavasti asentanut käyttiksen.
Buuttaa kone.

Koneen käynnistyessä:
Paina F3 kun kone alkaa postaamaan (eli siis käynnistymään, esirmekiksi FujitsuSiemens logon jälkeen), esiin tulee näin grub valikko.
Paina 'e' kirjainta, näin avautuu "editointi-konsoli" grup käynnistysasetuksille.
Etsi kohta jossa todennäköisesti lukee jo 'quiet splash' tai nosplash, tms jotakin vastaavaa... Linux /boot/vmlinuz... -rivin lopussa.
Laita käynnistysasetukset vain ja ainoastaan tämän rivin loppuun, muusta kohtaa niitä ei (ilmeisesti) osata lukea oikein.
Itselläni siis rivin lopussa lukee nyt 'ro   quiet splash acpi=off xforcevesa' Näistä siis tuo 'acpi=off' sekä 'xforcevesa on itse laitettuja.

'acpi=off' oli joku virransäästötoimintoihin liittyvä muistaakseni (googleta), ja
'xforcevesa' pistää päälle sen "turvallinen graafinen tila" -asetuksen (näin ainakin ymmärsin)

paina Ctrl + x , niin kone alkaa käynnistymään näillä asetuksilla, ja asetukset "pitäisi" tallentua käynnistysasetuksiin.

Itse vielä kävin koneen käynnistyttyä varmistamassa, että nuo asetukset olivat latautuneet /etc/default/grub -tiedostoon. (kyllä olivat)
Ilmeisesti seuraavaa ei tarvitse tehdä, mutta varmuudeksi vielä tein, eli terminaalissa ajoin käskyn 'sudo update-grub' , jolloin käyttis kirjottaa tuossa edellämainitussa grub-tiedostossa olevat tiedot grub 2 käynnistystiedostoon, joka on siis boot/grub/grub.cfg (vanhemmassa GRUB-versiossa editoitiin siis suoraan 'menu.lst' tiedostoa, mutta ei enään GRUB 2 versiossa. Pitää mennä vähä takaoven kautta.)


Ja juu, varmasti on joku "oikeampikin" tapa tehdä tämä, mutta tällä tavalla ainakin onnistui =)

Edit 9.11: Kyseinen läppäri ja käyttis ei ole hyvä yhtälö, joku näytönohjainajurin bugi estää sen jouhevan toimimisen. Sensijaan suosittelen ubuntu 8.04. Tuossa ohjeet sille ja mokkulalle --> http://forum.ubuntu-fi.org/index.php?topic=30156.0
« Viimeksi muokattu: 09.11.09 - klo:18.49 kirjoittanut Janiporo »

nm

  • Käyttäjä
  • Viestejä: 13655
    • Profiili
Vs: grub2 ei toimi: Miten korjataan tai muokataan?[Ratkaistu]
« Vastaus #8 : 06.11.09 - klo:16.11 »
Ja juu, varmasti on joku "oikeampikin" tapa tehdä tämä, mutta tällä tavalla ainakin onnistui =)

Kuulostaa ihan hyvältä ja oikealta tavalta. :)