Kirjoittaja Aihe: bind ei käynnisty "oikein" [RATKAISTU]  (Luettu 1641 kertaa)

f7391

  • Käyttäjä
  • Viestejä: 20
    • Profiili
bind ei käynnisty "oikein" [RATKAISTU]
« : 01.04.06 - klo:22.52 »
Kotiverkossani on Breezy-palvelin, joka toimittaa mm. palomuurin, NAT-reitittimen ja nimipalvelimen virkaa.  Ongelmana on, että buutin jälkeen bind ei toimi lähiverkon koneille. Palvelimessa bind kuitenkin on käynnistynyt, ja kaikki toimii kuten pitääkin. Tilanteen korjaa bindin uudelleenkäynnistys, jonka jälkeen lähiverkon koneetkin saavat vastaukset nimikyselyihin. Mikähän nyt oikein mättää ja miten korjaan vian?
« Viimeksi muokattu: 02.04.06 - klo:11.09 kirjoittanut f7391 »

f7391

  • Käyttäjä
  • Viestejä: 20
    • Profiili
Re: bind ei käynnisty "oikein"
« Vastaus #1 : 02.04.06 - klo:09.40 »
Kotiverkossani on Breezy-palvelin, joka toimittaa mm. palomuurin, NAT-reitittimen ja nimipalvelimen virkaa.  Ongelmana on, että buutin jälkeen bind ei toimi lähiverkon koneille. Palvelimessa bind kuitenkin on käynnistynyt, ja kaikki toimii kuten pitääkin. Tilanteen korjaa bindin uudelleenkäynnistys, jonka jälkeen lähiverkon koneetkin saavat vastaukset nimikyselyihin. Mikähän nyt oikein mättää ja miten korjaan vian?

Hieman tarkennusta: syslogia tutkimalla selviää, että kun bind käynnistyy bootin yhteydessä, se kuuntelee eth0, eth1, eth2 ja lo -interfaceja. Kun käynnistän bindin uudelleen, se kuuntelee lisäksi tun0 -interfacea, joka on siis OpenVPN:n "virtuaali-interface". Ongelma on siis ilmeisesti se, että bindin käynnistyessä tuota virtuaalista tun0 -interfacea ei ole vielä luotu, joten bind ei osaa pistää sitä kuuntelulle.

Nyt pitäisi siis joko pystyä kertomaan bindille, mitä interfaceja kuunnella tai sitten saada bind käynnistymään viimeisenä OpenVPN:n jälkeen. Sellainenkin keino olisi toimiva, tosin hieman "karu", että viimeisenä operaationa koneen käynnistyessä käynnistettäisiin bind uudelleen. Missä määritellään palveluiden käynnistysjärjestys?

Jos jotakuta kiinnostaa, niin tuota OpenVPN:ää tarvitaan wlanin autentikointiin ja salaukseen, omissa wlan-härpäkkeissä kun on vain tuo 64-bittinen WEP.

f7391

  • Käyttäjä
  • Viestejä: 20
    • Profiili
Re: bind ei käynnisty "oikein"
« Vastaus #2 : 02.04.06 - klo:11.08 »
Kotiverkossani on Breezy-palvelin, joka toimittaa mm. palomuurin, NAT-reitittimen ja nimipalvelimen virkaa.  Ongelmana on, että buutin jälkeen bind ei toimi lähiverkon koneille. Palvelimessa bind kuitenkin on käynnistynyt, ja kaikki toimii kuten pitääkin. Tilanteen korjaa bindin uudelleenkäynnistys, jonka jälkeen lähiverkon koneetkin saavat vastaukset nimikyselyihin. Mikähän nyt oikein mättää ja miten korjaan vian?

Hieman tarkennusta: syslogia tutkimalla selviää, että kun bind käynnistyy bootin yhteydessä, se kuuntelee eth0, eth1, eth2 ja lo -interfaceja. Kun käynnistän bindin uudelleen, se kuuntelee lisäksi tun0 -interfacea, joka on siis OpenVPN:n "virtuaali-interface". Ongelma on siis ilmeisesti se, että bindin käynnistyessä tuota virtuaalista tun0 -interfacea ei ole vielä luotu, joten bind ei osaa pistää sitä kuuntelulle.

Nyt pitäisi siis joko pystyä kertomaan bindille, mitä interfaceja kuunnella tai sitten saada bind käynnistymään viimeisenä OpenVPN:n jälkeen. Sellainenkin keino olisi toimiva, tosin hieman "karu", että viimeisenä operaationa koneen käynnistyessä käynnistettäisiin bind uudelleen. Missä määritellään palveluiden käynnistysjärjestys?

Jos jotakuta kiinnostaa, niin tuota OpenVPN:ää tarvitaan wlanin autentikointiin ja salaukseen, omissa wlan-härpäkkeissä kun on vain tuo 64-bittinen WEP.

No niin, ongelma on ratkaistu. Järkeilin, että /etc/rc5.d/-hakemiston tiedostojen numerointi säätää palvelujen käynnistysjärjestyksen, niin kuin se tekikin. Eli säädin numerointeja siten, että jokaisella runlevelillä OpenVPN-palvelu käynnistetään ennen bindiä, jolloin bind käynnistyessään löytää tun0-interfacen ja kuuntelee myös sitä. Nyt homma toimii niin kuin pitääkin.