Kirjoittaja Aihe: Apt-get dist-upgrade ja virheilmoitus [ratkaistu]  (Luettu 5814 kertaa)

mrl586

  • Käyttäjä
  • Viestejä: 4638
    • Profiili
Tälläinen errori tulee kun yrittää suorittaa apt-get dist-upgrade -komentoa:
Koodia: [Valitse]
E: Couldn't configure pre-depend libc6 for findutils, probably a dependency cycle.
« Viimeksi muokattu: 22.05.09 - klo:00.57 kirjoittanut mrl586 »

Nollapiste

  • Käyttäjä
  • Viestejä: 292
  • Saku Laukkanen
    • Profiili
Vs: Apt-get dist-upgrade ja virheilmoitus
« Vastaus #1 : 14.05.09 - klo:16.11 »
Toimiiko, jos poistat paketin findutils? Minulla se ei ainakaan ole asennettuna, enkä sitä itse ainakaan ole poistanut.

PS. Yhdistin nimimerkkisi korkeaan viestimäärään ja ihmettelinkin, ettei sinulla ollut paljon viestejä viestilaskurissa. Sitten muistin...
Terveisin nollapiste
Jakelupaketti-informaatiota löydät tämän linkin takaa
(pahoittelen, että joku oli käynyt spämmäämässä wikin etusivua)

gdm

  • Sitä saa mitä tilaa...
  • Käyttäjä
  • Viestejä: 4363
    • Profiili
    • Keskustelualueiden säännöt
Vs: Apt-get dist-upgrade ja virheilmoitus
« Vastaus #2 : 14.05.09 - klo:16.13 »
https://bugs.edge.launchpad.net/ubuntu/+source/aptitude/+bug/124895

Rodolfo oli ratkaissut ongelman:
Lainaus
I believe I've solved it.

After cleaning apt-get's cache, I tried one more time without good results; but with that I generated a "clean" cache (ie only with the debs I was needing).

Then did

cd /var/cache/apt/archives

and then

sudo dpkg --force-depends --install libc6_2.8~20080505-0ubuntu7_i386.deb findutils_4.4.0-2ubuntu3_i386.deb

of course the specific package names may differ.
Lisää [Ratkaistu] aloitusviestiin jos ongelmasi selviää!
Saamasi tuki on ilmaista, joten älä vaadi tai uhkaile saadaksesi apua!

mrl586

  • Käyttäjä
  • Viestejä: 4638
    • Profiili
Vs: Apt-get dist-upgrade ja virheilmoitus
« Vastaus #3 : 14.05.09 - klo:16.15 »
Toimiiko, jos poistat paketin findutils? Minulla se ei ainakaan ole asennettuna, enkä sitä itse ainakaan ole poistanut.
Ei toimi, sillä minulla ei ole tuota pakettia asennettuna.

gdm

  • Sitä saa mitä tilaa...
  • Käyttäjä
  • Viestejä: 4363
    • Profiili
    • Keskustelualueiden säännöt
Vs: Apt-get dist-upgrade ja virheilmoitus
« Vastaus #4 : 14.05.09 - klo:16.17 »
Toimiiko, jos poistat paketin findutils? Minulla se ei ainakaan ole asennettuna, enkä sitä itse ainakaan ole poistanut.
Ei toimi, sillä minulla ei ole tuota pakettia asennettuna.

Tuon pitäisi olla oletuksena asennettu, sillä tarjoaa peruskomentoja.
Lisää [Ratkaistu] aloitusviestiin jos ongelmasi selviää!
Saamasi tuki on ilmaista, joten älä vaadi tai uhkaile saadaksesi apua!

mrl586

  • Käyttäjä
  • Viestejä: 4638
    • Profiili
Vs: Apt-get dist-upgrade ja virheilmoitus
« Vastaus #5 : 14.05.09 - klo:16.22 »
Toimiiko, jos poistat paketin findutils? Minulla se ei ainakaan ole asennettuna, enkä sitä itse ainakaan ole poistanut.
Ei toimi, sillä minulla ei ole tuota pakettia asennettuna.
Tuon pitäisi olla oletuksena asennettu, sillä tarjoaa peruskomentoja.
Niin sen pitäisi, mutta täältä sitä ei (jostain syystä) löydy. Yrittäessäni asentaa tuota tulostuu sama virheilmoitus.

mrl586

  • Käyttäjä
  • Viestejä: 4638
    • Profiili
Vs: Apt-get dist-upgrade ja virheilmoitus
« Vastaus #6 : 14.05.09 - klo:21.13 »
https://bugs.edge.launchpad.net/ubuntu/+source/aptitude/+bug/124895

Rodolfo oli ratkaissut ongelman:
Lainaus
I believe I've solved it.

After cleaning apt-get's cache, I tried one more time without good results; but with that I generated a "clean" cache (ie only with the debs I was needing).

Then did

cd /var/cache/apt/archives

and then

sudo dpkg --force-depends --install libc6_2.8~20080505-0ubuntu7_i386.deb findutils_4.4.0-2ubuntu3_i386.deb

of course the specific package names may differ.
Tuo ei taida ratkaista tätä ongelmaa:
Koodia: [Valitse]
root@localhost:/var/cache/apt/archives# dpkg --force-depends --install libc6_2.9-4ubuntu6_i386.deb findutils_4.4.0-2ubuntu3_i386.deb
(Reading database ... 0 files and directories currently installed.)
Unpacking libc6 (from libc6_2.9-4ubuntu6_i386.deb) ...

A non-dpkg owned copy of the libc6-i686 package was found.
It is not safe to upgrade the C library in this situation;
please remove that copy of the C library and try again.
dpkg: error processing libc6_2.9-4ubuntu6_i386.deb (--install):
 subprocess pre-installation script returned error exit status 1
dpkg: error processing findutils_4.4.0-2ubuntu3_i386.deb (--install):
 cannot access archive: No such file or directory
Errors were encountered while processing:
 libc6_2.9-4ubuntu6_i386.deb
 findutils_4.4.0-2ubuntu3_i386.deb
PS. Virheilmoituksessa mainittu libc6-i686 -paketti on asennettu pakettienhallinnan kautta.
« Viimeksi muokattu: 14.05.09 - klo:21.22 kirjoittanut mrl586 »

Nollapiste

  • Käyttäjä
  • Viestejä: 292
  • Saku Laukkanen
    • Profiili
Vs: Apt-get dist-upgrade ja virheilmoitus
« Vastaus #7 : 15.05.09 - klo:14.59 »
Toimiiko, jos poistat paketin findutils? Minulla se ei ainakaan ole asennettuna, enkä sitä itse ainakaan ole poistanut.
Ei toimi, sillä minulla ei ole tuota pakettia asennettuna.

Tuon pitäisi olla oletuksena asennettu, sillä tarjoaa peruskomentoja.
Joku muu paketti tarjoaa ubuntussa komennon "find", koska minulla ei ole findutils asennettuna, mutta "find" toimii...
Terveisin nollapiste
Jakelupaketti-informaatiota löydät tämän linkin takaa
(pahoittelen, että joku oli käynyt spämmäämässä wikin etusivua)

mrl586

  • Käyttäjä
  • Viestejä: 4638
    • Profiili
Vs: Apt-get dist-upgrade ja virheilmoitus
« Vastaus #8 : 17.05.09 - klo:03.49 »
Aloitusviestin ongelma ratkaistu käyttäen tämän aiheen vikassa viestissä olevaa skriptiä. Tuon ongelman ratkaisun jälkeen konsoliin tulostuu lisää virheilmoituksia (ks. liite)

[ylläpito on poistanut liitteen]

mrl586

  • Käyttäjä
  • Viestejä: 4638
    • Profiili
Vs: Apt-get dist-upgrade ja virheilmoitus
« Vastaus #9 : 19.05.09 - klo:23.07 »
Ehdotuksia?

mrl586

  • Käyttäjä
  • Viestejä: 4638
    • Profiili
Vs: Apt-get dist-upgrade ja virheilmoitus
« Vastaus #10 : 21.05.09 - klo:03.00 »
Tuon ongelman ratkaisun jälkeen konsoliin tulostuu lisää virheilmoituksia (ks. liite)
Sain nuo virheilmoitukset pois soveltamalla Googlettamalla löytyneitä ohjeita. Virheilmoitukset johtuivat muutamasta puuttuvasta hakemistosta sekä tiedostoista. Näiden virheilmoituksen piiloon saannin jälkeen ruudulle ilmestyy vielä muutamia virheilmoituksia
Koodia: [Valitse]
root@localhost:~# apt-get upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
10 not fully installed or removed.
After this operation, 0B of additional disk space will be used.
Do you want to continue [Y/n]? y
Setting up libapache2-mod-php5 (5.2.6.dfsg.1-3ubuntu4.1) ...
dpkg: error processing libapache2-mod-php5 (--configure):
 subprocess post-installation script returned error exit status 10
Setting up php5-cli (5.2.6.dfsg.1-3ubuntu4.1) ...
dpkg: error processing php5-cli (--configure):
 subprocess post-installation script returned error exit status 10
dpkg: dependency problems prevent configuration of php-pear:
 php-pear depends on php5-cli | php4-cli; however:
  Package php5-cli is not configured yet.
  Package php4-cli is not installed.
dpkg: error processing php-pear (--configure):
 dependency problems - leaving unconfigured
Setting up php5-cgi (5.2.6.dfsg.1-3ubuntu4.1) ...
No apport report written because the error message indicates its a followup error from a previous failure.
                          dpkg: error processing php5-cgi (--configure):
 subprocess post-installation script returned error exit status 10
dpkg: dependency problems prevent configuration of php5:
 php5 depends on libapache2-mod-php5 (>= 5.2.6.dfsg.1-3ubuntu4.1) | libapache2-mod-php5filter (>= 5.2.6.dfsg.1-3ubuntu4.1) | php5-cgi (>= 5.2.6.dfsg.1-3ubuntu4.1); however:
  Package libapache2-mod-php5 is not configured yet.
  Package libapache2-mod-php5filter is not installed.
  Package php5-cgi is not configured yet.
dpkg: error processing php5 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of php5-gd:
 php5-gd depends on phpapi-20060613+lfs; however:
  Package phpapi-20060613+lfs is not installed.
  Package libapache2-mod-php5 which provides phpapi-20060613+lfs is not configured yet.
  Package php5-cli which provides phpapi-20060613+lfs is not configured yet.
  Package php5-cgi which provides phpapi-20060613+lfs is not configured yet.
dpkg: error processing php5-gNo apport report written because MaxReports is reached already
           No apport report written because MaxReports is reached already
                                                                         No apport report written because MaxReports is reached already
                                                       No apport report written because MaxReports is reached already
                                     No apport report written because MaxReports is reached already
                   No apport report written because MaxReports is reached already
 No apport report written because MaxReports is reached already
                                                               d (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of php5-ldap:
 php5-ldap depends on phpapi-20060613+lfs; however:
  Package phpapi-20060613+lfs is not installed.
  Package libapache2-mod-php5 which provides phpapi-20060613+lfs is not configured yet.
  Package php5-cli which provides phpapi-20060613+lfs is not configured yet.
  Package php5-cgi which provides phpapi-20060613+lfs is not configured yet.
dpkg: error processing php5-ldap (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of php5-mysql:
 php5-mysql depends on phpapi-20060613+lfs; however:
  Package phpapi-20060613+lfs is not installed.
  Package libapache2-mod-php5 which provides phpapi-20060613+lfs is not configured yet.
  Package php5-cli which provides phpapi-20060613+lfs is not configured yet.
  Package php5-cgi which provides phpapi-20060613+lfs is not configured yet.
dpkg: error processing php5-mysql (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of php5-snmp:
 php5-snmp depends on phpapi-20060613+lfs; however:
  Package phpapi-20060613+lfs is not installed.
  Package libapache2-mod-php5 which provides phpapi-20060613+lfs is not configured yet.
  Package php5-cli which provides phpapi-20060613+lfs is not configured yet.
  Package php5-cgi which provides phpapi-20060613+lfs is not configured yet.
dpkg: error processing php5-snmp (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of cacti:
 cacti depends on libapache2-mod-php4 | php4 | libapache2-mod-php5 | php5; however:
  Package libapache2-mod-php4 is not installed.
  Package php4 is not installed.
  Package libapache2-mod-php5 is not configured yet.
  Package php5 is not configured yet.
 cacti depends on php4-mysql (>= 4.3.10-9) | php5-mysql; however:
  Package php4-mysql is not installed.
  Package php5-mysql is not configured yet.
 cacti depends on php4-cli | php5-cli; however:
  Package php4-cli is not installed.
  Package php5-cli is not configured yet.
 cacti depends on php4-snmp | php5-snmp; however:
  Package php4-snmp is not installed.
  Package php5-snmp is not configured yet.
dpkg: error processing cacti (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 libapache2-mod-php5
 php5-cli
 php-pear
 php5-cgi
 php5
 php5-gd
 php5-ldap
 php5-mysql
 php5-snmp
 cacti
E: Sub-process /usr/bin/dpkg returned an error code (1)

mrl586

  • Käyttäjä
  • Viestejä: 4638
    • Profiili
Vs: Apt-get dist-upgrade ja virheilmoitus
« Vastaus #11 : 22.05.09 - klo:00.56 »
Sain korjattua edellisessä viestissä mainitut virheet toimimalla tämän ohjeen mukaan.
« Viimeksi muokattu: 22.05.09 - klo:01.29 kirjoittanut mrl586 »