Kirjoittaja Aihe: flashplugin-nonfree ei asennu [ratkaistu]  (Luettu 5139 kertaa)

tetrafuran

  • Käyttäjä
  • Viestejä: 405
    • Profiili
flashplugin-nonfree ei asennu [ratkaistu]
« : 25.02.10 - klo:00.16 »
Jonkun päivityksen yhteydessä se ilmoitti ettei paria pakettia saatu päivitettyä. Ihan windows logiikalla poistin flashin ja nyt en sitten saakaan enää asennettua sitä takaisin. Koitin asentaa sitä apt-getillä, synapticilla ja vieläpä ihan firefoxinkin kautta. Nyt olen lukenut ja jankannut tämän kanssa jo pari päivää, eikä vastausta tunnu löytyvän.

Koodia: [Valitse]
peti@home:~$ sudo apt-get upgrade
Reading package lists... Done
Building dependency tree      
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
1 not fully installed or removed.
After this operation, 0B of additional disk space will be used.
Do you want to continue [Y/n]? y
Setting up flashplugin-installer (10.0.45.2ubuntu0.9.10.1) ...
Downloading...
--2010-02-24 23:46:35--  http://archive.canonical.com/pool/partner/a/adobe-flashplugin/adobe-flashplugin_10.0.45.2.orig.tar.gz
Resolving archive.canonical.com... 91.189.88.33
Connecting to archive.canonical.com|91.189.88.33|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 4028753 (3.8M) [application/x-gzip]
Saving to: `./adobe-flashplugin_10.0.45.2.orig.tar.gz'

     0K .......... .......... .......... .......... ..........  1%  285K 14s
    50K .......... .......... .......... .......... ..........  2%  599K 10s
   100K .......... .......... .......... .......... ..........  3%  582K 9s
(paljon saman näköisiä rivejä... sensuroitu)
  3800K .......... .......... .......... .......... .......... 97%  596K 0s
  3850K .......... .......... .......... .......... .......... 99%  584K 0s
  3900K .......... .......... .......... ....                 100%  266K=6.8s

2010-02-24 23:46:42 (576 KB/s) - `./adobe-flashplugin_10.0.45.2.orig.tar.gz' saved [4028753/4028753]

Download done.
Starting /usr/local/bin/install script.
download script not found.
configure script not found.
compile script not found.
sudo: ./installasroot: command not found
configure2 script not found.
compile2 script not found.
sudo: ./installasroot2: command not found
test script not found.
Flash Plugin installed.
nspluginwrapper: /usr/lib/flashplugin-installer/libflashplayer.so is not a valid NPAPI plugin
dpkg: error processing flashplugin-installer (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 flashplugin-installer
E: Sub-process /usr/bin/dpkg returned an error code (1)
peti@home:~$

Hakua olen käyttänyt, ja dpkg:tä neuvoivat.

Koodia: [Valitse]
peti@home:~$ sudo dpkg --configure -a
[sudo] password for comet:
Setting up flashplugin-installer (10.0.45.2ubuntu0.9.10.1) ...
Downloading...
--2010-02-24 23:45:06--  http://archive.canonical.com/pool/partner/a/adobe-flashplugin/adobe-flashplugin_10.0.45.2.orig.tar.gz
Resolving archive.canonical.com... 91.189.88.33
Connecting to archive.canonical.com|91.189.88.33|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 4028753 (3.8M) [application/x-gzip]
Saving to: `./adobe-flashplugin_10.0.45.2.orig.tar.gz'

     0K .......... .......... .......... .......... ..........  1%  198K 20s
    50K .......... .......... .......... .......... ..........  2%  546K 13s
   100K .......... .......... .......... .......... ..........  3%  582K 11s
(taas sama... sensuroitu esteettisistä syistä)  
  3700K .......... .......... .......... .......... .......... 95%  581K 0s
  3750K .......... .......... .......... .......... .......... 96%  598K 0s
  3800K .......... .......... .......... .......... .......... 97%  599K 0s
  3850K .......... .......... .......... .......... .......... 99%  351K 0s
  3900K .......... .......... .......... ....                 100%  176M=7.0s

2010-02-24 23:45:13 (560 KB/s) - `./adobe-flashplugin_10.0.45.2.orig.tar.gz' saved [4028753/4028753]

Download done.
Starting /usr/local/bin/install script.
download script not found.
configure script not found.
compile script not found.
sudo: ./installasroot: command not found
configure2 script not found.
compile2 script not found.
sudo: ./installasroot2: command not found
test script not found.
Flash Plugin installed.
nspluginwrapper: /usr/lib/flashplugin-installer/libflashplayer.so is not a valid NPAPI plugin
dpkg: error processing flashplugin-installer (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 flashplugin-installer
peti@home:~$ wtf
Minun huomion kiinnitti, kun tuli vastaan tosi paljon "not found" tyyppisiä mutinoita. Jotenkin tuntuu, että joku on ampunu haulikolla käyttikseen koripallon mentävän reijän kun noin paljon kamaa puuttuu yhtäkkiä.

Huvikseni koitin asentaa cowsay ohojelman ja testata siinä samalla, että eihän mikään tärkeä asentamiseen liittyvä ole kadonnut. Ilmeisesti mitään kriittistä ei puuttunut sillä lehmä asentui ja toimi toimi moitteetta. Huomasin kuitenkin, että asennuksen yhteydessä vilahti teksti
Koodia: [Valitse]
Use 'apt-get autoremove' to remove them.Siispä ajoin tuonkin komennon ja lopputuloksena oli taas nuo samat pisterivit ja errorit. kts. edellinen koodinippu.

Toinen mielenkiintoinen rivi oli
Koodia: [Valitse]
Suggested packages:
  filters
ja senkin asennuksen lopputuloksena oli jälleen samaa, kuin äsken. Eli paljon kamaa puuttui. kts edelliset pitkät koodilitanjat. Samaa se sylkee vähän joka yrittämällä näköjään.
« Viimeksi muokattu: 25.02.10 - klo:19.29 kirjoittanut tetrafuran »
And so at last the beast fell and the unbelievers rejoiced. But all was not lost, for from the ash rose a great bird. The bird gazed down upon the unbelievers and cast fire and thunder upon them. For the beast had been reborn with its strength renewed, and the followers of Mammon cowered in horror.

Jakke77

  • Käyttäjä
  • Viestejä: 3933
  • Oulu (Oinaansuo)
    • Profiili
Vs: flashplugin-nonfree ei asennu
« Vastaus #1 : 25.02.10 - klo:10.18 »
http://get.adobe.com/flashplayer/ oletko kokeillut ladata sitä tuolta ja asentaa sitä
U_G_H

Aspire E5-575G V1.27 CPU: Intel i3-6100U (4) @ 2.300GHz GPU: Intel® HD Graphics 520 GPU: NVIDIA GeForce 940MX Samsung SSD 970 EVO Plus 500GB

tetrafuran

  • Käyttäjä
  • Viestejä: 405
    • Profiili
Vs: flashplugin-nonfree ei asennu
« Vastaus #2 : 25.02.10 - klo:15.14 »
Koodia: [Valitse]
peti@home:~/download$ sudo dpkg -i install_flash_player_10_linux.deb
[sudo] password for peti:
dpkg: error processing install_flash_player_10_linux.deb (--install):
 package architecture (i386) does not match system (amd64)
Errors were encountered while processing:
 install_flash_player_10_linux.deb

Kuusnelonen ossi, ei näköjään tykkää i386 softista. Koitin kattella tuolta adoben siuilta 64 versioo, mutta ei näkynyt.
And so at last the beast fell and the unbelievers rejoiced. But all was not lost, for from the ash rose a great bird. The bird gazed down upon the unbelievers and cast fire and thunder upon them. For the beast had been reborn with its strength renewed, and the followers of Mammon cowered in horror.

Tomin

  • Palvelimen ylläpitäjä
  • Käyttäjä / moderaattori+
  • Viestejä: 11447
    • Profiili
    • Tomin kotisivut
Vs: flashplugin-nonfree ei asennu
« Vastaus #3 : 25.02.10 - klo:15.43 »
Kuusnelonen ossi, ei näköjään tykkää i386 softista. Koitin kattella tuolta adoben siuilta 64 versioo, mutta ei näkynyt.

Joo ei olekkaan paitsi joku Pre-Release Adobe Labsista ja sekin versiota 10 eikä edes 10.1 :(: http://labs.adobe.com/technologies/flashplayer10/64bit.html
Tuo kyllä toimii hyvin ja itsekin käytän sitä. Laittasin siis sen. Ainut miinus on tuossa, että pitää aina välillä päivittää käsin. Kokeilin kyllä jotain PPA:ta, mutta sen ylläpitäjät eivät muistaneet päivittää mokomaa, joten hylkäsin sen PPA:n.

Asennus tapahtuu kopioimalla libflashplayer.so hakemistoon /usr/lib/mozilla/plugins . Muista poistaa vanha ensin.

Tuota 32-bittistäkin voi käyttää ja siten se on Ubuntussa oletuksena paketoitukin. Tarttee myös ainakin nspluginwrapper ja ia32-libs lisänä jos 32-bittisen laittaa.
« Viimeksi muokattu: 25.02.10 - klo:15.45 kirjoittanut Tomppeli »
Automaattinen allekirjoitus:
Lisäisitkö [RATKAISTU] ketjun ensimmäisen viestin aiheeseen ongelman ratkettua, kiitos.

tetrafuran

  • Käyttäjä
  • Viestejä: 405
    • Profiili
Vs: flashplugin-nonfree ei asennu
« Vastaus #4 : 25.02.10 - klo:19.25 »
Jaahas. Palattiin sitten käsin päivittämisen aikakaudelle... Paketinhallinta nimenomaan oli yksi iso juttu, jota opin arvostamaan ubuntuun siirryttyäni. Windows koneita kun kattelee, niin rupeaa heti häiritsemään kun vähän väliä kukin ohjelma ilmoittelee omista päivityksistään tai sitten ovat aivan hiljaa ja vanhenevat vaivihkaa.

Noh. Ainakin flash jutut toimiat nyt, joten kiitos avusta.
And so at last the beast fell and the unbelievers rejoiced. But all was not lost, for from the ash rose a great bird. The bird gazed down upon the unbelievers and cast fire and thunder upon them. For the beast had been reborn with its strength renewed, and the followers of Mammon cowered in horror.

tetrafuran

  • Käyttäjä
  • Viestejä: 405
    • Profiili
Vs: flashplugin-nonfree ei asennu [ratkaistu]
« Vastaus #5 : 27.02.10 - klo:16.24 »
Osoittautui muuten, että tämä ratkaisu oli vähän "quick and dirty". Ongelman ydin, eli flashin asentuminen jäi ratkaisematta. Päivityksien yhteydessä tulevat mussutukset flashista ja muista sekoiluista eivät korjautuneet ollenkaan. Ainoa hyvä juttu tässä oli se, että nettisivujen flash jutut näkyvät oikein. Huonoa siinäkin on se, että nyt flashin päivitys on tehtävä käsin. Joku pidempiaikainen ja tyylikkäämpi ratkaisu siis tarvitaan.
And so at last the beast fell and the unbelievers rejoiced. But all was not lost, for from the ash rose a great bird. The bird gazed down upon the unbelievers and cast fire and thunder upon them. For the beast had been reborn with its strength renewed, and the followers of Mammon cowered in horror.

mek

  • Käyttäjä
  • Viestejä: 138
    • Profiili
Vs: flashplugin-nonfree ei asennu
« Vastaus #6 : 27.02.10 - klo:17.47 »
Kerropa, millä komennolla tuo libflashplayer.so kopioidaan työpöydältä /usr/lib/mozilla/plugins -hakemistoon komentorivillä. Nautiluksella ei onnistu, kun vaatii pääkäyttäjän oikeuksia tuohon kansioon. On tuo komentorivin käyttö niiin harvinaista, että on päässyt unohtumaan...

Kuusnelonen ossi, ei näköjään tykkää i386 softista. Koitin kattella tuolta adoben siuilta 64 versioo, mutta ei näkynyt.

Joo ei olekkaan paitsi joku Pre-Release Adobe Labsista ja sekin versiota 10 eikä edes 10.1 :(: http://labs.adobe.com/technologies/flashplayer10/64bit.html
Tuo kyllä toimii hyvin ja itsekin käytän sitä. Laittasin siis sen. Ainut miinus on tuossa, että pitää aina välillä päivittää käsin. Kokeilin kyllä jotain PPA:ta, mutta sen ylläpitäjät eivät muistaneet päivittää mokomaa, joten hylkäsin sen PPA:n.

Asennus tapahtuu kopioimalla libflashplayer.so hakemistoon /usr/lib/mozilla/plugins . Muista poistaa vanha ensin.

Tuota 32-bittistäkin voi käyttää ja siten se on Ubuntussa oletuksena paketoitukin. Tarttee myös ainakin nspluginwrapper ja ia32-libs lisänä jos 32-bittisen laittaa.

vartsu

  • Käyttäjä
  • Viestejä: 506
  • Kyllä, hankin joskus elämän... apt-get a life ...
    • Profiili
Vs: flashplugin-nonfree ei asennu
« Vastaus #7 : 27.02.10 - klo:18.02 »
Kerropa, millä komennolla tuo libflashplayer.so kopioidaan työpöydältä /usr/lib/mozilla/plugins -hakemistoon komentorivillä. Nautiluksella ei onnistu, kun vaatii pääkäyttäjän oikeuksia tuohon kansioon. On tuo komentorivin käyttö niiin harvinaista, että on päässyt unohtumaan...

Eli työpöydällä: (siis päätteessä  cd /home/käyttäjätunnus/Työpöytä)
Koodia: [Valitse]
sudo cp libflashplayer.so  /usr/lib/mozilla/plugins
Nyt mennään läppärillä: Hp DV6-6108US
Tulossa jotain muuta...

tetrafuran

  • Käyttäjä
  • Viestejä: 405
    • Profiili
Vs: flashplugin-nonfree ei asennu [ratkaistu]
« Vastaus #8 : 27.02.10 - klo:18.36 »
Kannattaa painella tab nappia, jotta rivit täydentyvät itsestään. Tulee vähemmän kirjoitusvirheitä.
/usr/ hakemistot ovat kotihakemiston ulkopuolella, joten niihin kohdistuvat komennot alkavat sudolla.

sudo cp /home/KäyttäjänNimi/Desktop/Se-ja-Se-tiedosto.jotain /usr/lib/mozilla/plugins
And so at last the beast fell and the unbelievers rejoiced. But all was not lost, for from the ash rose a great bird. The bird gazed down upon the unbelievers and cast fire and thunder upon them. For the beast had been reborn with its strength renewed, and the followers of Mammon cowered in horror.

Tomin

  • Palvelimen ylläpitäjä
  • Käyttäjä / moderaattori+
  • Viestejä: 11447
    • Profiili
    • Tomin kotisivut
Vs: flashplugin-nonfree ei asennu [ratkaistu]
« Vastaus #9 : 27.02.10 - klo:18.41 »
Poistithan ne aiemmin asennetut flash-kikkareet? Jos et niin poista ja tarkista sen jälkeen ettei niiden poisto hävittänyt tuota uutta flash-pluginia.

Tuossa se aiemmin mainitsemani PPA Adobe Shockwave (miksi tuo sana piti sotkea tähän!!!) Flash Player 64-bittistä varten:
https://launchpad.net/~sevenmachines/+archive/flash
Tällä hetkellä tuolta saa uusimman version (paketin nimi on flashplugin64-nonfree).
Automaattinen allekirjoitus:
Lisäisitkö [RATKAISTU] ketjun ensimmäisen viestin aiheeseen ongelman ratkettua, kiitos.

mek

  • Käyttäjä
  • Viestejä: 138
    • Profiili
Vs: flashplugin-nonfree ei asennu
« Vastaus #10 : 04.03.10 - klo:20.36 »
Joo ei olekkaan paitsi joku Pre-Release Adobe Labsista ja sekin versiota 10 eikä edes 10.1 :(: http://labs.adobe.com/technologies/flashplayer10/64bit.html
Tuo kyllä toimii hyvin ja itsekin käytän sitä. Laittasin siis sen. Ainut miinus on tuossa, että pitää aina välillä päivittää käsin. Kokeilin kyllä jotain PPA:ta, mutta sen ylläpitäjät eivät muistaneet päivittää mokomaa, joten hylkäsin sen PPA:n.

Asennus tapahtuu kopioimalla libflashplayer.so hakemistoon /usr/lib/mozilla/plugins . Muista poistaa vanha ensin.

Tuota 32-bittistäkin voi käyttää ja siten se on Ubuntussa oletuksena paketoitukin. Tarttee myös ainakin nspluginwrapper ja ia32-libs lisänä jos 32-bittisen laittaa.

Kun ei toimi. Poistin kaikki Flash -kikkareet pakettienhallinnan kautta. Samoin poistin päätteessä tuon libflashplayer.so -tiedoston hakemistosta  /usr/lib/mozilla/plugins ja katsoin vielä että se myös lähti pois. Sen jälkeen noudin tuosta yllä olevasta linkistä tuon 64 bittisen Flashplayerin, purin paketin työpöydälle ja kopioin sen em. hakemistoon. Katsoin vielä, että se myös meni sinne.

Ei vaan toimi. Esim. google streetview ja saab.fi -sivut vaan herjaavat, että hanki uusin Flashplayer Adoben sivuilta, eivätkä suostu näyttämään mitään, edes sitä mustaa ruutua, joka näkyi ubuntu-restricter extras tms. paketin mukana tulleella macromedian flash playerillä.
(This site requires flash and javascript for an ultimate user experience!
Enable javascript in your browser and get the flashplayer from Adobe here:
Get Flash Here)

(Tarvitset Street Viewin käyttöön Adobe Flash Playerin 9-version tai uudemman.
Hae uusin Flash Player.)

Kokeilin vielä asentaa noita linkeissä mainittuja versioitakin:
Koodia: [Valitse]
markku@ppower:~$ sudo rm /usr/lib/mozilla/plugins/libflashplayer.so
markku@ppower:~$ dir /usr/lib/mozilla/plugins/
flashplugin-alternative.so  libgcjwebplugin.so

markku@ppower:~/Työpöytä$ sudo cp libflashplayer.so /usr/lib/mozilla/plugins
markku@ppower:~/Työpöytä$

markku@ppower:~/Työpöytä$ dir /usr/lib/mozilla/plugins/
flashplugin-alternative.so  libflashplayer.so  libgcjwebplugin.so

Eli sinne meni, mutta ei toimi sekään. Samat herjat tulee.
« Viimeksi muokattu: 04.03.10 - klo:20.45 kirjoittanut mek »

Tomin

  • Palvelimen ylläpitäjä
  • Käyttäjä / moderaattori+
  • Viestejä: 11447
    • Profiili
    • Tomin kotisivut
Vs: flashplugin-nonfree ei asennu [ratkaistu]
« Vastaus #11 : 05.03.10 - klo:19.35 »
Sitä dir:iä kutsutaan ls:ksi (list). ;) No joo ei kovin tärkeä tieto tässä yhteydessä.

Olethan käynnistänyt nettiselaimen (kokonaan) uudelleen? Kuulemma FF:stä voisi jäädä joku prosessi päälle kun sen sulkee (enpä ole huomannut moista, mutta käytäkin normaalisti Operaa).
Automaattinen allekirjoitus:
Lisäisitkö [RATKAISTU] ketjun ensimmäisen viestin aiheeseen ongelman ratkettua, kiitos.

mek

  • Käyttäjä
  • Viestejä: 138
    • Profiili
Vs: flashplugin-nonfree ei asennu [ratkaistu]
« Vastaus #12 : 06.03.10 - klo:13.27 »
Nyt ei näy enää mitkään flashit, nekään jotka ovat ennen näkyneet... kele. Enää ei näy edes Youtube, joka sentään ennen näkyi. Poistin ja asensin uudelleen ubuntu-restricted-extras -paketin, mutta ei apua... Eikä muuten toimi Javakaan, esim. www.fotoyks.fi sivujen vakio -kuvien tilausliittymä ei avaudu, aplettia ei löydy...

Ubuntu tutuksi -ohjeiden mukaan pitäisi riittää, että tuo ubuntu-restricted-extras on asennettuna, mutta ei näköjään riitä. Ubuntu on siis 8.04 LTS 64bit AMD ja Mozilla Firefox 3.0.18

Täytynee odottaa 10.04 LTS versiota?
« Viimeksi muokattu: 06.03.10 - klo:14.03 kirjoittanut mek »

mek

  • Käyttäjä
  • Viestejä: 138
    • Profiili
Vs: flashplugin-nonfree ei asennu [ratkaistu]
« Vastaus #13 : 19.03.10 - klo:20.06 »
Nyt ei näy enää mitkään flashit, nekään jotka ovat ennen näkyneet... kele. Enää ei näy edes Youtube, joka sentään ennen näkyi. Poistin ja asensin uudelleen ubuntu-restricted-extras -paketin, mutta ei apua... Eikä muuten toimi Javakaan, esim. www.fotoyks.fi sivujen vakio -kuvien tilausliittymä ei avaudu, aplettia ei löydy...

Ubuntu tutuksi -ohjeiden mukaan pitäisi riittää, että tuo ubuntu-restricted-extras on asennettuna, mutta ei näköjään riitä. Ubuntu on siis 8.04 LTS 64bit AMD ja Mozilla Firefox 3.0.18

Täytynee odottaa 10.04 LTS versiota?
Nyt toimii minullakin, apu löytyi tuosta

Jakke77

  • Käyttäjä
  • Viestejä: 3933
  • Oulu (Oinaansuo)
    • Profiili
Vs: flashplugin-nonfree ei asennu
« Vastaus #14 : 19.03.10 - klo:20.28 »
Kerropa, millä komennolla tuo libflashplayer.so kopioidaan työpöydältä /usr/lib/mozilla/plugins -hakemistoon komentorivillä. Nautiluksella ei onnistu, kun vaatii pääkäyttäjän oikeuksia tuohon kansioon. On tuo komentorivin käyttö niiin harvinaista, että on päässyt unohtumaan...

Eli työpöydällä: (siis päätteessä  cd /home/käyttäjätunnus/Työpöytä)
Koodia: [Valitse]
sudo cp libflashplayer.so  /usr/lib/mozilla/plugins


toinen tapa on avata nautilus sudolla

sudo nautilus

ja tiedostojen kopiominen onnistuu
U_G_H

Aspire E5-575G V1.27 CPU: Intel i3-6100U (4) @ 2.300GHz GPU: Intel® HD Graphics 520 GPU: NVIDIA GeForce 940MX Samsung SSD 970 EVO Plus 500GB

ajaaskel

  • Palvelimen ylläpitäjä
  • Käyttäjä
  • Viestejä: 3401
    • Profiili
Vs: flashplugin-nonfree ei asennu [ratkaistu]
« Vastaus #15 : 19.03.10 - klo:20.57 »
Arvaus:  Taisi olla homman juju tässä tapauksessa vanhempi Firefox, ei jostain syystä ladannut tuolta tavanomaisesta nykyisestä paikasta mutta lataus sillä toimi kotihakemiston alta.
Autamme ilolla ja ilmaiseksi omalla ajallamme.  Ethän vaadi, uhoa tai isottele näin saamasi palvelun johdosta.

ajaaskel

  • Palvelimen ylläpitäjä
  • Käyttäjä
  • Viestejä: 3401
    • Profiili
Vs: flashplugin-nonfree ei asennu [ratkaistu]
« Vastaus #16 : 19.03.10 - klo:21.33 »
Tämä vahvistaa arvaustani lisää.  Lisäksi siinä on jokunen mielenkiintoinen yksityiskohta, esimerkiksi latauspolun säätäminen ympäristömuuttujan MOZ_PLUGIN_PATH avulla.

http://forums.mozillazine.org/viewtopic.php?f=7&t=1659935
« Viimeksi muokattu: 19.03.10 - klo:21.35 kirjoittanut ajaaskel »
Autamme ilolla ja ilmaiseksi omalla ajallamme.  Ethän vaadi, uhoa tai isottele näin saamasi palvelun johdosta.

salai

  • Käyttäjä
  • Viestejä: 2126
    • Profiili
Vs: flashplugin-nonfree ei asennu [ratkaistu]
« Vastaus #17 : 20.03.10 - klo:03.26 »
Tämä vahvistaa arvaustani lisää.  Lisäksi siinä on jokunen mielenkiintoinen yksityiskohta, esimerkiksi latauspolun säätäminen ympäristömuuttujan MOZ_PLUGIN_PATH avulla.

http://forums.mozillazine.org/viewtopic.php?f=7&t=1659935

Tuota latauspolkujen säätämisen mielenkiintoisuutta on selitetty tälläkin foorumilla jo ainakin vuonna 2008: Flash playerin asentaminen ei onnistu. [Ratkaisu]. Windowsin puolella ainakin jo 2005 on asia esitetty melko seikkaperäisesti  mm. tuolla: Meteorin syöksy maahan livenä - Keskustelut - Tiede.fi

Alkuperäinen lähde oli Henrik Gemalin hieno sivusto: Plug-ins with Mozilla