Kirjoittaja Aihe: VirtualBox - Ei löydy äänikorttia [Ratkaistu]  (Luettu 2775 kertaa)

Cocktus

  • Käyttäjä
  • Viestejä: 73
    • Profiili
Äänet olisi mukava saada kuulumaan myös Windowsin puolelta. Ongelmana on se, että VirtualBox ei löydä äänikorttia. Se löysi kyllä emolevyn integroidun kortin, mutta en saanut silläkään toimimaan ääniä. SB Audigya se ei löydä ollenkaan jostain syystä. VirtualBoxin ääniasetuksista olen koittanut kaikki mahdolliset vaihtoehdot läpi, mutta XP:n puolella ei ole havaintoa Audigysta.

Ubuntu Intrepid Ibex
VirtualBox 2.0.6

VB:ssa pyörii Windows XP, joka on riisuttu versio täydestä asennuksesta (näillä Hiilloksen ohjeilla).
« Viimeksi muokattu: 27.11.08 - klo:11.26 kirjoittanut Cocktus »

Cocktus

  • Käyttäjä
  • Viestejä: 73
    • Profiili
Vs: VirtualBox - Ei löydy äänikorttia
« Vastaus #1 : 26.11.08 - klo:10.12 »
Äänet olisi mukava saada kuulumaan myös Windowsin puolelta. Ongelmana on se, että VirtualBox ei löydä äänikorttia. Se löysi kyllä emolevyn integroidun kortin, mutta en saanut silläkään toimimaan ääniä. SB Audigya se ei löydä ollenkaan jostain syystä. VirtualBoxin ääniasetuksista olen koittanut kaikki mahdolliset vaihtoehdot läpi, mutta XP:n puolella ei ole havaintoa Audigysta.

Ubuntu Intrepid Ibex
VirtualBox 2.0.6

VB:ssa pyörii Windows XP, joka on riisuttu versio täydestä asennuksesta (näillä Hiilloksen ohjeilla).

Ei sen XP:n pitäisikään löytää audigyä, sehän pyörii virtuaalikoneessa missä clienteille näkyvät laitteet ovat puhtaasti ohjelmallisesti tehtyjä. Säädä ääniasetukset kuntoon Settings->Audio. Sinne laitat Pulseaudion ja ICH AC97. Pitäisi pelittää. Jossei toimi niin tarkista että winkun laitehallinta löytää äänipiirin.

No niinpä tietysti. Eipä se silti lähtenyt pelittämään kun kokeilin. Videotiedostosta näkyy kuva, mutta ääntä ei kuulu. Mediaplayer ei valita mitään, mutta Subtitle Workshop valittaa kodekkien puuttumista. Olen koittanut asentaa FFDShown, mutta asialla ei ole ollut vaikutusta.

Asmo Koskinen

  • Käyttäjä
  • Viestejä: 4443
    • Profiili
Vs: VirtualBox - Ei löydy äänikorttia
« Vastaus #2 : 26.11.08 - klo:10.41 »
Eipä se silti lähtenyt pelittämään kun kokeilin.

Oma nettiradio kuuluu aivan hyvin Virtualbox/XP/VLC-yhdistelmällä.



http://www.arkki.info/howto/Icecast2/Sound_02.png

Ystävällisin terveisin Asmo Koskinen.

Cocktus

  • Käyttäjä
  • Viestejä: 73
    • Profiili
Vs: VirtualBox - Ei löydy äänikorttia
« Vastaus #3 : 26.11.08 - klo:18.56 »
No niinpä tietysti. Eipä se silti lähtenyt pelittämään kun kokeilin. Videotiedostosta näkyy kuva, mutta ääntä ei kuulu. Mediaplayer ei valita mitään, mutta Subtitle Workshop valittaa kodekkien puuttumista. Olen koittanut asentaa FFDShown, mutta asialla ei ole ollut vaikutusta.

No joko katsoit onko xp:n laitehallinnassa "Intel lippalappa AC97 audio controller" tai niitä keltaisia huutomerkkejä.

Kyllä se siellä näkyy - ihan normaalisti vielä ilman huutomerkkejä.

"Laitteen tila: Laite toimii oikein."

Tälle laitteelle ei ole asennettu ohjaimia. Jos laitteen käyttämisessä on ongelmia, käynnistä vianmääritys valitsemalla Vianmääritys."

Koitin VLC Playerillä myös, mutta ei sekään tuonut minulle ääntä :(


jori52

  • Käyttäjä
  • Viestejä: 2047
    • Profiili
Vs: VirtualBox - Ei löydy äänikorttia
« Vastaus #4 : 26.11.08 - klo:19.32 »
Onko virtuaaliboxin asetuksista laitettu ääni käyttöön.

Terveisin jori52
Linux counter #348392
 Asus G750JW ja ubuntu 13.10

jori52

  • Käyttäjä
  • Viestejä: 2047
    • Profiili
Vs: VirtualBox - Ei löydy äänikorttia
« Vastaus #5 : 26.11.08 - klo:21.12 »
Onko virtuaaliboxin asetuksista laitettu ääni käyttöön.

Eiköhän jos windows löytää virtuaali-äänikortin.

Olisi vissiin pitänyt lukea koko säie läpi. :D

Terveisin jori52
Linux counter #348392
 Asus G750JW ja ubuntu 13.10

Cocktus

  • Käyttäjä
  • Viestejä: 73
    • Profiili
Vs: VirtualBox - Ei löydy äänikorttia [RATKAISTU]
« Vastaus #6 : 26.11.08 - klo:21.49 »
Meneepäs mielenkiintoiseksi. Asenna pavucontrol(ellei ole jo) ja käynnistä se siksi aikaa kun buuttaat virtuaali-winkun. Sinne pitäisi ilmaantua VBox-niminen äänistriimi olettaen että olet laittanut pulsen käyttöön virtualboxin asetuksista. Ei sulla satu olemaan jotain äänilaitetta käyttävää ohjelmaa päällä, joka voisi varata äänikorttisi?

Pavucontrollissa näkyy VBox ja sen stream meni itse asiassa väärään paikkaan, mutta ei se siirtämisen jälkeenkään toiminut. Ainakaan pavucontrolin mukaan ei ole mitään muuta äänikorttia varaavaa ohjelmaa päällä. Pitää kohta varmaan asentaa täyden asennuksen XP ja koittaa onko ongelma nykyisessä asennuksessa.

EDIT: Täydellä asennuksella toimii eli vika oli XP:n päässä. Täytyy koittaa bongata probleema rajoitetulta versiolta.
« Viimeksi muokattu: 27.11.08 - klo:00.10 kirjoittanut Cocktus »