Kirjoittaja Aihe: Näin saat toimimaan: YLE Areena ja Elävä arkisto  (Luettu 318751 kertaa)

nm

  • Käyttäjä
  • Viestejä: 13029
    • Profiili
Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
« Vastaus #280 : 19.10.15 - klo:21.16 »
yle-dl http://areena.yle.fi/1-2761106
yle-dl 2.7.0: Download media files from Yle Areena and Elävä Arkisto
Copyright (C) 2009-2015 Antti Ajanki <antti.ajanki@iki.fi>, license: GPLv2
Can't read http://areena.yle.fi/api/programs/v1/items.json?series=1-2761106&type=program&availability=ondemand&order=ondemand.publication.starttime%253Adesc&app_id=cb021459&app_key=fa6c26b3b3e617b7033c83c108417200&limit=25&offset=0&olang=fi: HTTP Error 500: Internal Server Error


  KSV Adobe HDS Downloader

Processing manifest info....                                                   
Quality Selection:                                                             
 Available: 1114 775 446 181
 Selected : 1114                                                               
Fragments Total: 151, First: 1, Start: 1, Parallel: 8                         
Downloading 151/151 fragments                                                 
Found 151 fragments                                                           
Finished

Hyvin näkyy latautuneen. Nyt kotihakemistossasi on tiedosto Yle Uutiset-2015-10-18T20:30:00+03:00.flv

aapee

  • Käyttäjä
  • Viestejä: 16
    • Profiili
Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
« Vastaus #281 : 19.10.15 - klo:21.42 »
Vielä...


Joudun vielä kiusaamaan sinua... Jouduin asentamaan uudestaan käyttöjärjestelmän koneeseeni. Linux Mint 17.2
Tuli eteen sama ongelma..

Youtube-dl on koneella, mutten saa yle-dl asennettua..Voitko ohjeistaa...

Kaikki taas kunnossa...
« Viimeksi muokattu: 19.11.15 - klo:21.57 kirjoittanut aapee »

raimo

  • Käyttäjä
  • Viestejä: 3381
    • Profiili
Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
« Vastaus #282 : 25.10.15 - klo:13.58 »
Yle-dl + AdobeHDS:
Koodia: [Valitse]
KSV Adobe HDS Downloader
You have to install and enable the following extension(s) to continue: 'mcrypt'
Joo, no asennetaan vaikka yle-dl README.fi ohjeessa ei niin ohjeisteta.
Koodia: [Valitse]
sudo apt-get install mcrypt php5-mcrypt
Seuraus silti tympeä:
Koodia: [Valitse]
KSV Adobe HDS Downloader
You have to install and enable the following extension(s) to continue: 'mcrypt'

Mikä neuvoksi? youtube-dl kanssa toimii kyllä, mutta itkee kuitenkin tuota jokaisessa latauksessa.
yle-dl on versio 2.8.1 ja AdobeHDS on kai siellä missä pitääkin:
Koodia: [Valitse]
raimo@kone:~$ ls -l /usr/local/share/yle-dl/AdobeHDS.php
-rw-r--r-- 1 root root 93138 loka  25 13:31 /usr/local/share/yle-dl/AdobeHDS.php

edit: näemmä äsken tuli päivitys, versio on nyt 2.8.2 ja homma sama.
« Viimeksi muokattu: 25.10.15 - klo:18.01 kirjoittanut raimo »
So long and thanks for all the fish!

nm

  • Käyttäjä
  • Viestejä: 13029
    • Profiili
Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
« Vastaus #283 : 25.10.15 - klo:17.58 »
Yle-dl + AdobeHDS:
Koodia: [Valitse]
KSV Adobe HDS Downloader
You have to install and enable the following extension(s) to continue: 'mcrypt'
Joo, no asennetaan vaikka yle-dl README.fi ohjeessa ei niin ohjeisteta.

mcrypt on Adobe HDS:n uusi vaatimus. Hetki sitten sitä ei tuettu eikä tarvittu, ja yle-dl:n dokumentaatiota ei ole päivitetty, koska muutosta ei ole huomattu / raportoitu.


Koodia: [Valitse]
sudo apt-get install mcrypt php5-mcrypt
Seuraus silti tympeä:
Koodia: [Valitse]
KSV Adobe HDS Downloader
You have to install and enable the following extension(s) to continue: 'mcrypt'

Laajennos pitää kytkeä erikseen käyttöön:

Koodia: [Valitse]
sudo php5enmod mcrypt
Tai vaihtoehtoisesti voit tehdä tarvittavan linkin manuaalisesti:

Koodia: [Valitse]
sudo ln -s /etc/php5/mods-available/mcrypt.ini /etc/php5/cli/conf.d/20-mcrypt.ini

Kannattaa raportoida asiasta Antille, niin dokumentaatio saadaan ajantasalle.
« Viimeksi muokattu: 25.10.15 - klo:18.01 kirjoittanut nm »

raimo

  • Käyttäjä
  • Viestejä: 3381
    • Profiili
Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
« Vastaus #284 : 25.10.15 - klo:18.07 »
Yle-dl + AdobeHDS:
Koodia: [Valitse]
KSV Adobe HDS Downloader
You have to install and enable the following extension(s) to continue: 'mcrypt'
Joo, no asennetaan vaikka yle-dl README.fi ohjeessa ei niin ohjeisteta.

mcrypt on Adobe HDS:n uusi vaatimus. Hetki sitten sitä ei tuettu eikä tarvittu, ja yle-dl:n dokumentaatiota ei ole päivitetty, koska muutosta ei ole huomattu / raportoitu.


Koodia: [Valitse]
sudo apt-get install mcrypt php5-mcrypt
Seuraus silti tympeä:
Koodia: [Valitse]
KSV Adobe HDS Downloader
You have to install and enable the following extension(s) to continue: 'mcrypt'

Laajennos pitää kytkeä erikseen käyttöön:

Koodia: [Valitse]
sudo php5enmod mcrypt
Tai vaihtoehtoisesti voit tehdä tarvittavan linkin manuaalisesti:

Koodia: [Valitse]
sudo ln -s /etc/php5/mods-available/mcrypt.ini /etc/php5/cli/conf.d/20-mcrypt.ini

Kannattaa raportoida asiasta Antille, niin dokumentaatio saadaan ajantasalle.

Kiitos, nyt toimii. Rakennan Antille jonkinlaisen raportin, vaikken ymmärrä mistään mitään. :)
So long and thanks for all the fish!

ajaaskel

  • Palvelimen ylläpitäjä
  • Käyttäjä
  • Viestejä: 3384
    • Profiili
Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
« Vastaus #285 : 19.12.15 - klo:14.46 »
Kasasin yle-dl v2.9.0 deb-paketin:

http://www.homelinuxpc.com/download/yle-dl_2.9.0-1_all.deb

Siinä on mukana myös tuo uusi mcrypt-riippuvuus ja aktivointi.
Autamme ilolla ja ilmaiseksi omalla ajallamme.  Ethän vaadi, uhoa tai isottele näin saamasi palvelun johdosta.

Kurskin torpedo

  • Käyttäjä
  • Viestejä: 351
    • Profiili
Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
« Vastaus #286 : 01.03.16 - klo:19.41 »
Asensin uudelleen ajaaskelin ohjeilla kun LAunchy ei ole toiminut pitkään aikaan.
http://www.homelinuxpc.com/download/Areenan_nauhoituksen_asennus.html
yle-dl:n ja launchyn vanhalle läppärilleni - ubuntu 14.04 ja Compaq Presario CQ71.

Areena minulla toimii suoraan selaimissa Firefox ja Chromium, Launchy ei kuitenkaan käynnistä ohjelmia VLC:ssä. VLC aukeaa mutta ei käynnistä ohjelmaa. Areenan linkki kyllä kopioituu VLC:n osoiteriville.
Päätteestä areenan ohjelmat tallentuvat yle-dl:n avulla moitteettomasti.

Katsomon osalta ei aukea VLC:n eikä myöskään tallennu ollenkaan. Eli lähinnä ongelmana on tuo Katsomo (vaikkei tämä Katsomo-ketju olekaan - voin kopioida tämän sinnekin).  Pitäisikö poistaa jotain vanhoja asennuksia ensin vaiko ... ?  Saanko Katsomon tallennuksen toimimaan päätteestä - sekin riittäisi hyvin.

ajaaskel

  • Palvelimen ylläpitäjä
  • Käyttäjä
  • Viestejä: 3384
    • Profiili
Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
« Vastaus #287 : 06.03.16 - klo:19.12 »
Tilanne on sikäli huono että se mikä ei toimi Katsomossa Launchy-menun kautta ei toimi johtuen muutoksista mitä ohjelman lähettäjä on tehnyt. 
Jos joku haluaa/ehtii/jaksaa sitä viritellä uuteen uskoon niin hyvä.  Skriptiä tulee nopeasti jos tekninen tausta selvitetty.

Toinen kiusa mikä on Areenan muuttumisen mukana (tahallisesti?) tullut on puuttuvat RSS-linkit. 
Puuttuvat RSS-napit tekevät automaattinauhurin AutoDL käyttökelvottomaksi joka tulkkasi näitä ja toimi ok jonkun vuoden jo. 
Siinäkin sama, "kiitokset" ohjelman lähettäjälle YLE: lle  RSS-linkkien puuttumisesta.
Samoin tämä, en voi nyt ottaa aikaa tämän kikkailuun jotain toista tietä.

 
Autamme ilolla ja ilmaiseksi omalla ajallamme.  Ethän vaadi, uhoa tai isottele näin saamasi palvelun johdosta.

vellu@vmach

  • Käyttäjä
  • Viestejä: 347
  • Kiroitusvirheitä jo vuodesta feisty
    • Profiili
Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
« Vastaus #288 : 27.04.16 - klo:20.46 »
Onko tätä saatu toimimaan vielä 16.04:llä? Itsellä tulee vain valituksia php5:n puuttumisesta, jota ei pakettivarastosta löydy.

raimo

  • Käyttäjä
  • Viestejä: 3381
    • Profiili
Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
« Vastaus #289 : 27.04.16 - klo:21.41 »
Onko tätä saatu toimimaan vielä 16.04:llä? Itsellä tulee vain valituksia php5:n puuttumisesta, jota ei pakettivarastosta löydy.

Tuntuisi toimivan php7:n kanssa, tämmöiset paketit asensin ja yle-dl 2.10.1 toimii OK.
Koodia: [Valitse]
sudo apt-get install php7.0-cli php7.0-curl php7.0-mcrypt php7.0-bcmath php7.0-xml
So long and thanks for all the fish!

vellu@vmach

  • Käyttäjä
  • Viestejä: 347
  • Kiroitusvirheitä jo vuodesta feisty
    • Profiili
Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
« Vastaus #290 : 27.04.16 - klo:21.56 »
Onko tätä saatu toimimaan vielä 16.04:llä? Itsellä tulee vain valituksia php5:n puuttumisesta, jota ei pakettivarastosta löydy.

Tuntuisi toimivan php7:n kanssa, tämmöiset paketit asensin ja yle-dl 2.10.1 toimii OK.
Koodia: [Valitse]
sudo apt-get install php7.0-cli php7.0-curl php7.0-mcrypt php7.0-bcmath php7.0-xml

Ei toiminut.
Koodia: [Valitse]
~/Downloads$ gdebi yle-dl_2.10.0-1_all.deb
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Reading state information... Done
This package is uninstallable
Dependency is not satisfiable: php5-cli

raimo

  • Käyttäjä
  • Viestejä: 3381
    • Profiili
Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
« Vastaus #291 : 27.04.16 - klo:22.06 »
Jep, vaatii tuon deb-paketin tekijältä toimenpiteitä riippuvuuksien korjaamiseksi.

Minä asensin suoraan valmistajan sivuilta manuaalisesti. https://aajanki.github.io/yle-dl/

Se on helppo homma purat tar.gz paketin johonkin, menet syntyneeseen hakemistoon ja komennat:
Koodia: [Valitse]
sudo make install
Noiden php7 pakettien lisäksi tarvitaan nämä, asenna ne siis ennen kuin ajat tuon sudo make install komennon.
Koodia: [Valitse]
sudo apt-get install rtmpdump python python-crypto
Paketissa oleva README.fi kertoo lisää.
So long and thanks for all the fish!

vellu@vmach

  • Käyttäjä
  • Viestejä: 347
  • Kiroitusvirheitä jo vuodesta feisty
    • Profiili
Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
« Vastaus #292 : 27.04.16 - klo:23.04 »
Jep, vaatii tuon deb-paketin tekijältä toimenpiteitä riippuvuuksien korjaamiseksi.

Minä asensin suoraan valmistajan sivuilta manuaalisesti. https://aajanki.github.io/yle-dl/

Se on helppo homma purat tar.gz paketin johonkin, menet syntyneeseen hakemistoon ja komennat:
Koodia: [Valitse]
sudo make install
Noiden php7 pakettien lisäksi tarvitaan nämä, asenna ne siis ennen kuin ajat tuon sudo make install komennon.
Koodia: [Valitse]
sudo apt-get install rtmpdump python python-crypto
Paketissa oleva README.fi kertoo lisää.

Yep, yep. Tämä toimii. Toimiva .deb-paketti olisi kyllä käytännöllinen.

mrl586

  • Käyttäjä
  • Viestejä: 4517
    • Profiili
Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
« Vastaus #293 : 28.04.16 - klo:03.03 »
youtube-dl ei vaadi php:tä toimiakseen.

Olotila

  • Käyttäjä
  • Viestejä: 7
    • Profiili
Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
« Vastaus #294 : 02.05.16 - klo:20.39 »
Minulle tulee
Failed to execute php /usr/local/share/yle-dl/AdobeHDS.php --manifest
Mitä tehdä?

raimo

  • Käyttäjä
  • Viestejä: 3381
    • Profiili
Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
« Vastaus #295 : 02.05.16 - klo:21.04 »
Minulle tulee
Failed to execute php /usr/local/share/yle-dl/AdobeHDS.php --manifest
Mitä tehdä?

Mitä sanoo
Koodia: [Valitse]
ls -l /usr/local/share/yle-dl/AdobeHDS.php
pitäisi tulla tämmöinen vastaus:
Lainaus
-rw-r--r-- 1 root root 93612 huhti 27 21:34 /usr/local/share/yle-dl/AdobeHDS.php
päiväys on tietenkin eri, mutta muuten.

Lisäksi tarkista että oikeat php7 paketit on asennettu
Koodia: [Valitse]
dpkg -l | grep php
Näkymät pitäisi olla tämänlaiset:
Koodia: [Valitse]
ii  php-common                                      1:35ubuntu6                                all          Common files for PHP packages
ii  php7.0-bcmath                                   7.0.4-7ubuntu2                             amd64        Bcmath module for PHP
ii  php7.0-cli                                      7.0.4-7ubuntu2                             amd64        command-line interpreter for the PHP scripting language
ii  php7.0-common                                   7.0.4-7ubuntu2                             amd64        documentation, examples and common module for PHP
ii  php7.0-curl                                     7.0.4-7ubuntu2                             amd64        CURL module for PHP
ii  php7.0-json                                     7.0.4-7ubuntu2                             amd64        JSON module for PHP
ii  php7.0-mcrypt                                   7.0.4-7ubuntu2                             amd64        libmcrypt module for PHP
ii  php7.0-opcache                                  7.0.4-7ubuntu2                             amd64        Zend OpCache module for PHP
ii  php7.0-readline                                 7.0.4-7ubuntu2                             amd64        readline module for PHP
ii  php7.0-xml                                      7.0.4-7ubuntu2                             amd64        DOM, SimpleXML, WDDX, XML, and XSL module for PHP
So long and thanks for all the fish!

Olotila

  • Käyttäjä
  • Viestejä: 7
    • Profiili
Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
« Vastaus #296 : 02.05.16 - klo:21.19 »
Puuttui php, mutta nyt sanoo
You have to install and enable the following extension(s) to continue: 'bcmath', 'curl', 'mcrypt', 'SimpleXML'


raimo

  • Käyttäjä
  • Viestejä: 3381
    • Profiili
Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
« Vastaus #297 : 02.05.16 - klo:22.00 »
Puuttui php, mutta nyt sanoo
You have to install and enable the following extension(s) to continue: 'bcmath', 'curl', 'mcrypt', 'SimpleXML'

Jos nuo PHP-moduli-paketit on asennettu niin sitten ne pitänee vielä ottaa käyttöön, minulla kyllä 16.04:ssä se tapahtui itsestään.
Mutta näin se menee manuaalisesti:
Koodia: [Valitse]
sudo phpenmod bcmath curl mcrypt simplexml
So long and thanks for all the fish!

Olotila

  • Käyttäjä
  • Viestejä: 7
    • Profiili
Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
« Vastaus #298 : 02.05.16 - klo:22.24 »
Joo nyt rullaa, kiitos!

vellu@vmach

  • Käyttäjä
  • Viestejä: 347
  • Kiroitusvirheitä jo vuodesta feisty
    • Profiili
Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
« Vastaus #299 : 28.04.17 - klo:04.15 »
Puuttui php, mutta nyt sanoo
You have to install and enable the following extension(s) to continue: 'bcmath', 'curl', 'mcrypt', 'SimpleXML'

Jos nuo PHP-moduli-paketit on asennettu niin sitten ne pitänee vielä ottaa käyttöön, minulla kyllä 16.04:ssä se tapahtui itsestään.
Mutta näin se menee manuaalisesti:
Koodia: [Valitse]
sudo phpenmod bcmath curl mcrypt simplexml

Ubuntu-Gnome 17.04 sanoo että:
Koodia: [Valitse]
$ sudo phpenmod bcmath curl mcrypt simplexml
WARNING: Module bcmath ini file doesn't exist under /etc/php/7.0/mods-available
WARNING: Module bcmath ini file doesn't exist under /etc/php/7.0/mods-available
WARNING: Module curl ini file doesn't exist under /etc/php/7.0/mods-available
WARNING: Module curl ini file doesn't exist under /etc/php/7.0/mods-available
WARNING: Module mcrypt ini file doesn't exist under /etc/php/7.0/mods-available
WARNING: Module mcrypt ini file doesn't exist under /etc/php/7.0/mods-available
WARNING: Module simplexml ini file doesn't exist under /etc/php/7.0/mods-available
WARNING: Module simplexml ini file doesn't exist under /etc/php/7.0/mods-available