Kirjoittaja Aihe: Amarok ongelma  (Luettu 5412 kertaa)

haamu

  • Käyttäjä
  • Viestejä: 36
    • Profiili
Amarok ongelma
« : 12.01.06 - klo:19.16 »
Ongelmana on, ettei Amarok suostu näyttämään kokoelmaa albumeittain. Kaikki muut ryhmittelyperusteet toimivat ok, mutta jos jokin peruste on albumi, niin ensimmäistäkään biisiä ei näy missään. Kaikkien biisien tageissa on albumin nimi asetettuna. Mistähän mättää?

teprrr

  • Käyttäjä
  • Viestejä: 304
    • Profiili
Re: Amarok ongelma
« Vastaus #1 : 17.01.06 - klo:22.30 »
Tarkoitat albumin mukaan järjesteltynä? Ainakin täällä toimii ihan niin kuin pitääkin...

jamaatta

  • Käyttäjä
  • Viestejä: 37
    • Profiili
Re: Amarok ongelma
« Vastaus #2 : 18.01.06 - klo:12.26 »
Ongelmana on, ettei Amarok suostu näyttämään kokoelmaa albumeittain. Kaikki muut ryhmittelyperusteet toimivat ok, mutta jos jokin peruste on albumi, niin ensimmäistäkään biisiä ei näy missään. Kaikkien biisien tageissa on albumin nimi asetettuna. Mistähän mättää?

Itselläni Amarok toimii ok. En oikein osaa auttaa, mutta ehkä joku muu osaisi paremmin, jos pistäisit Amarokkisi versionumeron. Google voi auttaa, jos kyseessä on vaikka ns. tunnettu ongelma.

t. Jari Määttä

haamu

  • Käyttäjä
  • Viestejä: 36
    • Profiili
Re: Amarok ongelma
« Vastaus #3 : 18.01.06 - klo:17.27 »
Vaihdoin tänään databasen MySQL pohjaiseksi, ja kaikki toimii nyt mainiosti. Alunperin oli tuo SQLite valittuna. Pienestä se on joskus kiinni.

munakuutio-

  • Käyttäjä
  • Viestejä: 115
    • Profiili
Re: Amarok ongelma
« Vastaus #4 : 14.02.06 - klo:23.24 »
Kun topickina kerran on että "Amarok ongelma" niin kai tässä voisi kysyä että:

Miksi en saa mp3:sia toimimaan amarokissa (enkä oikeastaan missään muussakaan soittimessa)? Paketteja on asennettu ja xine-engineä käytän, mutta muitakin on kokeiltu. Soitin käy vaan playlistin sekunnissa läpi eikä mitään kuulu mistään.

Voisiko joku kertoa mitä muita paketteja tarvitsisi asentaa kuin xinet, gstreamer, w32codecs (siitä tässä tuskin hyötyä) jne. ?

Kiitos.  :)

tuke81

  • Käyttäjä
  • Viestejä: 1667
    • Profiili
Miksi tehdä jotain helposti, kun sen voi tehdä vaikeastikin...

munakuutio-

  • Käyttäjä
  • Viestejä: 115
    • Profiili
Re: Amarok ongelma
« Vastaus #6 : 15.02.06 - klo:00.05 »
No kyllähän tuolla nyt on vierailtu mutta eipä siellä ole kun amarokin asennus ohjeet eikä mitään muuta siitä. Kyllähän siihen nyt luulisi saavan myös mpeg formaatit toimimaan (mp3)?

HammerPower

  • Käyttäjä
  • Viestejä: 122
    • Profiili
Re: Amarok ongelma
« Vastaus #7 : 15.02.06 - klo:00.23 »
tuke81 tuossa jo vastasikin

http://easylinux.info/wiki/Ubuntu#How_to_install_Multimedia_Codecs

Kannattaa ihan oikeasti asentaa tuon linkin takaa löytyvien ohjeiden mukaisesti ne codekit.

munakuutio-

  • Käyttäjä
  • Viestejä: 115
    • Profiili
Re: Amarok ongelma
« Vastaus #8 : 15.02.06 - klo:16.01 »
No nythän on niin ett' ainut komento mistä mitään tapahtui oli apt. .

JPK1990

  • Vieras
Re: Amarok ongelma
« Vastaus #9 : 15.02.06 - klo:17.02 »
pitäisiköhän ensin tehdä ne muutokset sources.list:iin

tuke81

  • Käyttäjä
  • Viestejä: 1667
    • Profiili
Re: Amarok ongelma
« Vastaus #10 : 15.02.06 - klo:17.32 »
No jos lukutaito ei ole tarpeeksi hyvä voit koettaa tuota easyubuntua. Itellä ole hajuakaan miten se toimii, mutta voit luultavasti silti joutua muokkaamaan sources.listiä kuten jpk tuossa sanoi:

sudo cp /etc/apt/sources.list /etc/apt/sources.list_backup (varmuuskopioidaan entinen)
sudo nano /etc/apt/sources.list
etsit sieltä rivejä, jotka ovat kommentoituja #-merkillä. Poista tämä kommentointi merkki kyseisistä kohdista. Ei siis kohdista, joissa lukee puutaheinää vaan kohdista jotka alkavat deb osoite blaa blaa
tämän jälkeen sudo apt-get update ja sitten asentelemaan.

Toinen automaatti asentaja olisi automatix, josta on täälläkin how-to, mutta sitä ei yleensä suositella, koska se asentaa paketit pakottamalla ja on mahdollista että järjestelmä särkyy.
Miksi tehdä jotain helposti, kun sen voi tehdä vaikeastikin...

munakuutio-

  • Käyttäjä
  • Viestejä: 115
    • Profiili
Re: Amarok ongelma
« Vastaus #11 : 15.02.06 - klo:22.54 »
Kyllä maar oli repositoriot asennuttu ja xine tuli ihan kivasti, mutta mutta nämä ei tehnyt mitään muutosta:

Koodia: [Valitse]
gconftool-2 --type string --set /desktop/gnome/volume_manager/autoplay_dvd_command "xine dvd://"
sudo rm -f /usr/share/applnk/Multimedia/xine.desktop
sudo ln -fs /usr/share/xine/desktop/xine.desktop /usr/share/applications/
sudo cp /usr/share/applications/defaults.list /usr/share/applications/defaults.list_backup
sudo sed -e 's/totem.desktop/xine.desktop/g' /usr/share/applications/defaults.list_backup > /tmp/defaults.list
sudo mv /tmp/defaults.list /usr/share/applications/defaults.list

tuke81

  • Käyttäjä
  • Viestejä: 1667
    • Profiili
Re: Amarok ongelma
« Vastaus #12 : 15.02.06 - klo:23.19 »
Siis oletkos nyt varmasti asentanut oikeat codekit, jotta järjestelmäsi tunnistaisi mp3:set:

sudo apt-get install gstreamer0.8-plugins
sudo apt-get install gstreamer0.8-lame
sudo apt-get install gstreamer0.8-ffmpeg
sudo apt-get install lame
sudo apt-get install sox
sudo apt-get install ffmpeg
sudo apt-get install mjpegtools
sudo apt-get install vorbis-tools
sudo apt-get install w32codecs
gst-register-0.8

Ei noita kaikkia tarvitsisi asennella mutta en nyt muista mikä sisälsi mp3-codekin w32codecs se ei ainakaan ollut. Lisäksi voit ajaa terminaalissa xine-check komennon, se näyttää mitä puuttuu.
« Viimeksi muokattu: 15.02.06 - klo:23.21 kirjoittanut tuke81 »
Miksi tehdä jotain helposti, kun sen voi tehdä vaikeastikin...

Melmacian

  • Käyttäjä
  • Viestejä: 868
  • Ubuntu Hardy
    • Profiili
Re: Amarok ongelma
« Vastaus #13 : 15.02.06 - klo:23.58 »
Ei noita kaikkia tarvitsisi asennella mutta en nyt muista mikä sisälsi mp3-codekin w32codecs se ei ainakaan ollut.
Nuo Lame paketit.

JPK1990

  • Vieras
Re: Amarok ongelma
« Vastaus #14 : 16.02.06 - klo:16.27 »
Jos asentaa paketin mpg321 niin voi esikatsella mp-3 tiedostoja nautiluksessa.

munakuutio-

  • Käyttäjä
  • Viestejä: 115
    • Profiili
Re: Amarok ongelma
« Vastaus #15 : 16.02.06 - klo:17.13 »
No nyt on ainakin aivan kaikki mainitut codecit asennettu mutta xine-checkin kun ajan niin:

Lainaus
[OUCH!!] There are no input plugins.
         xine needs at least one input plugin, but none is installed.
         You should probably reinstall xine-lib...
         press <enter> to continue...

[OUCH!!] There are no demux plugins.
         xine needs at least one demux plugin, but none is installed.
         You should probably reinstall xine-lib...
         press <enter> to continue...

[OUCH!!] There are no decoder plugins.
         xine needs at least one decoder plugin, but none is installed.
         You should probably reinstall xine-lib...
         press <enter> to continue...

[OUCH!!] There are no video_out plugins.
         xine needs at least one video_out plugin, but none is installed.
         You should probably reinstall xine-lib...
         press <enter> to continue...

[OUCH!!] There are no audio_out plugins.
         xine needs at least one audio_out plugin, but none is installed.
         You should probably reinstall xine-lib...
         press <enter> to continue...


Kaikki muut on [good] paitsi nuo. Mitäs nyt sitten asentamamaan?

Ja nämä eivän vaikuta mitenkään ilmeisesti:

Koodia: [Valitse]
gconftool-2 --type string --set /desktop/gnome/volume_manager/autoplay_dvd_command "xine dvd://"
sudo rm -f /usr/share/applnk/Multimedia/xine.desktop
sudo ln -fs /usr/share/xine/desktop/xine.desktop /usr/share/applications/
sudo cp /usr/share/applications/defaults.list /usr/share/applications/defaults.list_backup
sudo sed -e 's/totem.desktop/xine.desktop/g' /usr/share/applications/defaults.list_backup > /tmp/defaults.list
sudo mv /tmp/defaults.list /usr/share/applications/defaults.list

 :-\


tuke81

  • Käyttäjä
  • Viestejä: 1667
    • Profiili
Re: Amarok ongelma
« Vastaus #16 : 16.02.06 - klo:20.09 »
No tee niinukuin siinä neuvotaan asenna xine uudestaan.
Miksi tehdä jotain helposti, kun sen voi tehdä vaikeastikin...

munakuutio-

  • Käyttäjä
  • Viestejä: 115
    • Profiili
Re: Amarok ongelma
« Vastaus #17 : 22.02.06 - klo:16.54 »
No xine on uudelleen asennettu mutta eipäs mitään tapahdu. Ei vieläkään mikään playeri toista mp3 tiedostoja vaikka kuinka väännän.  :-[

Vapaan koodin kananmuna

  • Käyttäjä
  • Viestejä: 1536
    • Profiili
Re: Amarok ongelma
« Vastaus #18 : 22.02.06 - klo:18.14 »
Koodia: [Valitse]
sudo apt-get --reinstall install xine-lib
En Vastaa Vaikeisiin Kysymyksiin.