Kirjoittaja Aihe: Uusi syntaksi filu GEditille ei pelitä jostain syystä.  (Luettu 1435 kertaa)

E.K.Virtanen

  • Käyttäjä
  • Viestejä: 736
    • Profiili
    • Sähköaivoilua
Eli luomalla alla olevasta koodista fb.lang tiedosto ja tallentamalla se  /usr/share/gtksourceview-1.0/language-specs/freebasic.lang pitäisi käyttöön tulla uusi syntaksi geditiin.

Jaa, en voikaan koodia suoraan tähän laittaa kun tulee ilmoitus
Lainaus
Viestissä on liikaa (%d merkkejä).
No, .txt filu löytyy http://www.geocities.com/roope00/gedit.txt

Sain tuon jo kerran toimimaan hienosti, vaihtelin vielä muutamien funktioden paikkaa ja nyt se lakkasi toimimasta kokonaan. Mielestäni hakat yms. ovat kaikki suljettuna kuten pitää mutta ei vaan toimi.  :-\

raimo

  • Käyttäjä
  • Viestejä: 3480
    • Profiili
Re: Uusi syntaksi filu GEditille ei pelitä jostain syystä.
« Vastaus #1 : 26.11.06 - klo:14.29 »
Mielestäni hakat yms. ovat kaikki suljettuna kuten pitää mutta ei vaan toimi.  :-\

Tämmöiset pistää silmään, tosin en tiedä vaikuttaako miten?
mimetypes="text/x-fb;text/x-fb"

pitäsi varmaan olla (?):
Koodia: [Valitse]
mimetypes="text/x-fb"
En tiedä vaikuttaako mihinkään kun on kahdesti noin, tai sitten tuon toisen pitäisi olla jopa
jokin eri kuin tuo ensimäinen, nythän molemmat tyypit ovat samat, siis text/x-fb

Toinen joka hämmentää on tässä (myös muutamassa muussa kohdssa ilmenee)
Koodia: [Valitse]
        <pattern-item Name = "Literals-Octal" style = "Base-N Integer">
                <regex>\B&amp;[oO][0-7]+([uU]([lL]|[lL][lL])?)?\b</regex>
        </pattern-item>
Tarkoitan tuota &amp; entiteettiä, luulisi että pitää olla ihan & -merkki (\&)?

Kolmas joka pistää silmään on sinun tiedostossa olevien nimettyjen "tagien" nimi-attribuutti (name).
Kun se oletustiedostoissa on kaikissa näin:
Koodia: [Valitse]
<eläin _name="kissa">mijau</eläin>
Niin tuossa fb-tiedostossa ne on kaikki näin:
Koodia: [Valitse]
<eläin Name="kissa">mijau</eläin>
Eli alkuperäisissä on _name ja sinulla on Name, emt. vaikuttaako tämäkään mihinkään?

Eli ihan arvailua nämä, tosin tuo &amp; lienee hassu?

Olisi ihan kiva jos "NE" tekisivät nuo tiedostot "validina" XML:nä (kun kuitenkin "muka" ovat XML:ää).
Voisi sitten XML-validaattorilla tarkistaa edes well-formed asian, mutta nyt nuo eivät sitä ole.
Joten ei voi tarkistaa, tai voi mutta sylkee turhaa virhettä hirveästi,
mahdollisen oikea vikapaikka jäädessä huomaamatta.

Mutta ota alkuperäinen, siis muokkaamaton, tiedosto uudelleen käyttöön, eikös se ratkaise koko jutun?
« Viimeksi muokattu: 26.11.06 - klo:14.34 kirjoittanut raimo »
So long and thanks for all the fish!

E.K.Virtanen

  • Käyttäjä
  • Viestejä: 736
    • Profiili
    • Sähköaivoilua
Re: Uusi syntaksi filu GEditille ei pelitä jostain syystä.
« Vastaus #2 : 27.11.06 - klo:11.41 »
Katselin muita .lang tiedostoja ja tosiaan parissa kohtaa olit oikeassa.
_name tosiaan näyttää muissakin olevan ja &amp entiitti menee myös kuten sanoit.
Sen sijaan kaikissa .lang filuissa on tyyliin mimetypes="text/x-ada;text/x-adasrc"> ja tämän oman tekeleeni kanssa aikani leikittyänä ja vaihdeltuani noita postaamassani filessä olleita uudelleen nimeämällä totesin ettei se vieläkään toimi.

Ensimmäisellä kerralla rakensin koko homman vb.lang filun päälle ja niin taidan tälläkin kertaa tehdä (siis uudelleen) kun se alkuperäinen joka jotenkin toimi on tietysti jo päässyt hukkumaan.
Kiitoksia vinkeistä. Ehkä tästä vielä joskus jotain tulee  ;)