Näytä kirjoitukset

Tässä osiossa voit tarkastella kaikkia tämän jäsenen viestejä. Huomaa, että näet viestit vain niiltä alueilta, joihin sinulla on pääsy.


Viestit - Kurskin torpedo

Sivuja: [1] 2 3 ... 20
1
Boottausjärjestyksellä ei sinänsä ole väliä koska hakee kuitenkin kovalevyltä mutta ei löydä.

Boot-repairilla voi myös yrittää korjata käynnistystä. Vika liittynee johonkin yhteensopivuusongelmaan HP:n vanhoissa UEFI-firmiksissä. Asentaminen legacy-tilassa on myös yksi vaihtoehto, jos ongelma ilmenee nimenomaan UEFI-tilassa.

https://help.ubuntu.com/community/Boot-Repair#Getting_Boot-Repair

Jätin tuon askartelun kun olisi minulta vienyt melkoisesti aikaa näin "sunnuntaiasentajana". Koneita on vain muutama niin helpotin työtäni ja asensin 20.04:n ja siitä päivitys kuitenkin sujuu ihan hyvin versioon 22.04.

Kiitos ohjeista ja vihjeistä.

2
Olen tehnyt Ubuntu 20.04 koneella asennustikun "käynnistyslevyn luonti"-ohjelmalla. Tein puhtaan asennuksen, 22.04 asentuu koneelle lopuun asti. Pyytää pouistamaan asennustikun ja käynnistämään koneen uudelleen. Kone ilmoittaa ettei löydä kovalevyltä käyttöjärjestelmää.
Kone on HP Probook vuosimallia 2014.

Minulla on työpaikalla useampi tällainen (käytöstä poistettu) kone. Muutamiin olen aiemmin asentanut Ubuntu 20.04. Päivitys onnistuu versioon 22.04, mutta puhtaassa asennuksessa yllä oleva ongelma. Kokeilin useammalla tikulla ja useammalla koneella. Aina sama: kone ei löydä käyttöjärjestelmää.

3
Multimedia ja grafiikka / Vs: Yle-dl asentaminen
« : 07.11.21 - klo:13.37 »
sudo pois tuosta edestä, muuten se asentuu rootin hakemistoon.

Tosiaan. Nyt onnistui. Kiitos!

4
Multimedia ja grafiikka / Vs: Yle-dl asentaminen
« : 03.11.21 - klo:20.35 »
Mutta toisessa koneessa ei toiminutkaan. Myös uudelleenkäynnistyksen jälkeen väittää että yle-dl ei löydy.

Päätteessä:
:~$ sudo apt install wget ffmpeg python3-dev python3-setuptools \
>     python3-pip python3-requests python3-lxml
[sudo] xxxx-käyttäjän salasana:
Luetaan pakettiluetteloita... Valmis
Muodostetaan riippuvuussuhteiden puu       
Luetaan tilatiedot... Valmis       
python3-dev on jo uusimmassa versiossa (3.8.2-0ubuntu2).
python3-requests on jo uusimmassa versiossa (2.22.0-2ubuntu1).
python3-setuptools on jo uusimmassa versiossa (45.2.0-1).
wget on jo uusimmassa versiossa (1.20.3-1ubuntu1).
python3-lxml on jo uusimmassa versiossa (4.5.0-1ubuntu0.3).
ffmpeg on jo uusimmassa versiossa (7:4.2.4-1ubuntu0.1).
python3-pip on jo uusimmassa versiossa (20.0.2-5ubuntu1.6).
0 päivitetty, 0 uutta asennusta, 0 poistettavaa ja 0 päivittämätöntä.

:~$ sudo pip3 install --user --upgrade yle-dl
Requirement already up-to-date: yle-dl in /root/.local/lib/python3.8/site-packages (20210917)
Requirement already satisfied, skipping upgrade: ConfigArgParse>=0.13.0 in /root/.local/lib/python3.8/site-packages (from yle-dl) (1.5.3)
Requirement already satisfied, skipping upgrade: lxml in /root/.local/lib/python3.8/site-packages (from yle-dl) (4.6.3)
Requirement already satisfied, skipping upgrade: attrs>=18.1.0 in /root/.local/lib/python3.8/site-packages (from yle-dl) (21.2.0)
Requirement already satisfied, skipping upgrade: requests in /usr/lib/python3/dist-packages (from yle-dl) (2.22.0)

:~$ yle-dl https://areena.yle.fi/1-4298947
yle-dl: komentoa ei löytynyt

5
Multimedia ja grafiikka / Vs: Yle-dl asentaminen
« : 03.11.21 - klo:20.02 »
Kiitos paljon. Vaati tosiaan uudelleenkäynnistyksen.

Tällainen varoitus kuitenkin tuli vaikkei se haitannut toimintaa. Lieneekö sitä ottaa huomioon millään lailla.
"Installing collected packages: lxml, attrs, ConfigArgParse, yle-dl
  WARNING: The script yle-dl is installed in '/home/risto/.local/bin' which is not on PATH.
  Consider adding this directory to PATH or, if you prefer to suppress this warning, use --no-warn-script-location.
Successfully installed ConfigArgParse-1.5.3 attrs-21.2.0 lxml-4.6.4 yle-dl-20210917"

6
Multimedia ja grafiikka / Yle-dl asentaminen (RATKAISTU)
« : 31.10.21 - klo:22.14 »
Pitäisi asentaa yle-dl uudelle koneelle Unbuntun asentamisen jälkeen. Taitaa olla muille niin selvää juttua ettei ohjeita löydy kuin vuosien takaa eikä niistä ole hyötyä meikäläislle, kun komentojen muokkaamista olen niin harvoin tehnyt, ettei näillä taidoilla uskalla omaa logiikkaa käyttää!  ;D

Siis: voisiko joku kirjoitata tai linkata aivan selväḱieliset komennot joilla saan yle-dl: koneelle. Ubuntu 20.04.

7
Erinomaista. Tuo EpsonScan asentui ja toimii itsenäisenä. Siinä on vain varsin vähän muotoiluasetuksia. (Sopii hyvin yksinkertaisten pdf:ien skannaamiseen.)

XSanen osaisi sitä käyttää ja nyt löytää skannerin. Mutta XSane ei oikein tuntunut hyväksyvän asetuksiani ja luki vain mustavalkoisena kuvaa. En ole sen käytössä mikään tekijä mutta aiemmin sen olen saanut toimimaan. XSane myös kaatui ladattaessa kuvaa ...  Asensin XSanen myös uudestaan mutta vika ei korjautunut.

Voiko tuon vanhemman iscan-ajurin ladata EpsonScanin rinnalle ja kokeilla XSanea sillä? Vai olisiko jokin parempi scannausohjelma löydettävissä kuin XSane.

8
Toimii täysin Epsonin suljetulla ajurilla: http://support.epson.net/linux/en/iscan.php?model=perfection-v550&version=1.0.1

Löytyyköhän Epson PerfectionV550 Photo scannerille ajureita mistään. Tuossa osoitteissa ei niitä enää ole.

Järjestelmä: Ubuntu 20.04

9
Ennen kuin sain kokeiltua miten saan grubin näkyviin kone käynnistyi taas 640 resoluutiossa ja pyysi päivityksiä. Jotain nvidian juttuja näytti lataavan. Päivitysten jälkeen uudelleenkäynnistys ja resoluutiot taas kohdallaan. (Grubin sain myös sitten kokeilemalla näkyviin shiftillä.) Notta silleen.  :D

10
Toimiiko edellisellä kernelin versiolla, jos valitset sen Grub-valikon kautta koneen käynnistyessä?

Miten saan Grub-valikon pakotettua näkyviin? Biosin saan kyllä käynnistettäessä mutta Grubia ei.

11
Näytöstä hävisi taas kaikki muuta resoluutiovaihtoehdot kuin 640x480.
Tein yllämainitun ohjeen mukaan eli poistin nvidian ajurit

Koodia: [Valitse]
sudo apt purge nvidia*
ja sitten asensin pyydetyn ajurin.

Koodia: [Valitse]
sudo apt install nvidia-driver-390[/quote]

Käynnistin uudellen mutta homma ei korjaantunut. Tein tuon parikin kertaa.

12
En osaa sanoa, miksi mesa-paketit jätetään odottamaan, mutta toisaalta et niitä varsinaisesti tarvitsekaan Nvidian suljetun ajurin kanssa.

OK. Kiitos tiedosta.

13
Koodia: [Valitse]
sudo apt install nvidia-driver-390

Nyt asentui ajuri ja näytössä on kaikki reloluutiovaihtoehdot! Kiitos taas!  ;D

Edelleen päivityksessä ilmoittaa seuraavaa:
Koodia: [Valitse]
Nämä paketit on jätetty odottamaan:
  libegl-mesa0 libgbm1 libgl1-mesa-dri libgl1-mesa-dri:i386 libglapi-mesa libglapi-mesa:i386 libglx-mesa0 libglx-mesa0:i386 libxatracker2
  mesa-va-drivers mesa-vdpau-drivers mesa-vulkan-drivers mesa-vulkan-drivers:i386
0 päivitetty, 0 uutta asennusta, 0 poistettavaa ja 13 päivittämätöntä.

Mikähän on nyt sitten tuo ongelma?

14
Kokeilin ehdotettuja komentoja ja sain seuraavaa.

Koodia: [Valitse]
sudo apt purge nvidia*

E: Pakettia nvidia* ei löydy

Koodia: [Valitse]
sudo ubuntu-drivers autoinstall

Luetaan pakettiluetteloita... Valmis
Muodostetaan riippuvuussuhteiden puu       
Luetaan tilatiedot... Valmis       
0 päivitetty, 0 uutta asennusta, 0 poistettavaa ja 34 päivittämätöntä.

Koodia: [Valitse]
ubuntu-drivers devices | grep recommended
driver   : nvidia-driver-390 - distro non-free recommended

Koodia: [Valitse]
apt-cache search "NVIDIA.*binary"

nvidia-settings - NVIDIA-grafiikka-ajurien hallintatyökalu
nvidia-340-dev - NVIDIA:n suljetun ajurin kehitystiedostot
libnvidia-cfg1-390 - NVIDIA binary OpenGL/GLX configuration library
nvidia-340 - NVIDIA binary driver - version 340.108
nvidia-driver-390 - NVIDIA driver metapackage
xserver-xorg-video-nvidia-390 - NVIDIA binary Xorg driver
mir-platform-graphics-eglstream-kms16 - Display server for Ubuntu - platform library for NVIDIA
libnvvm3 - NVIDIA NVVM Library
libnvidia-cfg1-450 - NVIDIA binary OpenGL/GLX configuration library
libnvidia-cfg1-450-server - NVIDIA binary OpenGL/GLX configuration library
libnvidia-cfg1-460 - NVIDIA binary OpenGL/GLX configuration library
nvidia-driver-450 - NVIDIA driver metapackage
nvidia-driver-450-server - NVIDIA Server Driver metapackage
nvidia-driver-460 - NVIDIA driver metapackage
xserver-xorg-video-nvidia-435 - Transitional package for xserver-xorg-video-nvidia-455
xserver-xorg-video-nvidia-440 - Transitional package for xserver-xorg-video-nvidia-450
xserver-xorg-video-nvidia-450 - NVIDIA binary Xorg driver
xserver-xorg-video-nvidia-450-server - NVIDIA binary Xorg driver
xserver-xorg-video-nvidia-460 - NVIDIA binary Xorg driver
libnvidia-cfg1-418-server - NVIDIA binary OpenGL/GLX configuration library
libnvidia-cfg1-440-server - NVIDIA binary OpenGL/GLX configuration library
nvidia-driver-418-server - NVIDIA Server Driver metapackage
nvidia-driver-440-server - NVIDIA Server Driver metapackage
xserver-xorg-video-nvidia-418-server - NVIDIA binary Xorg driver
xserver-xorg-video-nvidia-440-server - NVIDIA binary Xorg driver
 

Lisäksi tein updaten ja upgraden, jolloin tuli tällaista
Koodia: [Valitse]
sudo apt-get upgrade
Luetaan pakettiluetteloita... Valmis
Muodostetaan riippuvuussuhteiden puu       
Luetaan tilatiedot... Valmis       
Käsitellään päivitystä... Valmis
Nämä paketit on jätetty odottamaan:
  libegl-mesa0 libgbm1 libgl1-mesa-dri libgl1-mesa-dri:i386
  libglapi-mesa libglapi-mesa:i386 libglx-mesa0
  libglx-mesa0:i386 libnvidia-cfg1-390 libnvidia-compute-390
  libnvidia-compute-390:i386 libnvidia-decode-390
  libnvidia-decode-390:i386 libnvidia-encode-390
  libnvidia-encode-390:i386 libnvidia-fbc1-390
  libnvidia-fbc1-390:i386 libnvidia-gl-390
  libnvidia-gl-390:i386 libnvidia-ifr1-390
  libnvidia-ifr1-390:i386 libxatracker2
  linux-modules-nvidia-390-generic-hwe-20.04 mesa-va-drivers
  mesa-vdpau-drivers mesa-vulkan-drivers
  mesa-vulkan-drivers:i386 nvidia-compute-utils-390
  nvidia-dkms-390 nvidia-driver-390 nvidia-kernel-common-390
  nvidia-kernel-source-390 nvidia-utils-390
  xserver-xorg-video-nvidia-390
0 päivitetty, 0 uutta asennusta, 0 poistettavaa ja 34 päivittämätöntä.

Mitäs nämä kertovat ?

15
Poista Nvidian suljettu ajuri ja asenna se uudelleen Lisäajurien kautta.

Tuohon tarvitsisin selvät komentorivit. Ei muuten onnistu minun taidoillani.  :(

16
Tuli reilut parikymmentä riviä tavaraa mutta näkyykö tässä oleelliset.
Koodia: [Valitse]
01:00.0 VGA compatible controller: NVIDIA Corporation GF108 [GeForce GT 440] (rev a1)
01:00.1 Audio device: NVIDIA Corporation GF108 High Definition Audio Controller (rev a1)
03:00.0 USB controller: NEC Corporation uPD720200 USB 3.0 Host Controller (rev 03)

17
Pöytäkone, johon olen joskus vaihtanut näytönohjaimen (en muista mallia). Näytöstä hävisivät resoluution vaihtoehdot. Antaa valita ainoastaan 640x480. Olen käyttänyt näyttöä HDMI-kaapelilla sekä DisplayPort-muuntokaapelilla (lähinnä kun olen halunnut työläppäriin ison näytön).

Nyt ei anna kummallakaan kaapelilla kuin ainoastaan em. resoluution. Läppärillä näyttö toimii moitteettomasti.

Olisiko kyse näytönohjaimen vikaantumisesta vai ajureista?

18
Oliko sinulla joitakin ppa repositoreita käytössä ja olet poistanut tämän sitten  ?

https://askubuntu.com/questions/1185227/cannot-upgrade-19-04-to-19-10-because-of-held-back-packages-libsnmp30

Tein tuon sivun ekan vastauksen mukaiset komennot ja ajoin päivitykset eikä enää herjannut yhdestä asentamattomasta, Srn jälkeen uuden version asennus käynnistyi komennolla; sudo do-release-upgrade

Kiitos nopeasti annetuista ohjeista kaikille!  ;D

19
Tein päätteet ohjeiden mukaan:
Koodia: [Valitse]
apt list --upgradable -a
Listataan... Valmis
libsnmp30/eoan 5.7.3+dfsg-5ubuntu5 amd64 [päivitettävissä versiosta: 5.7.3+dfsg-1.8ubuntu3.3]
libsnmp30/now 5.7.3+dfsg-1.8ubuntu3.3 amd64 [asennettu,päivitettävissä versioon: 5.7.3+dfsg-5ubuntu5]

Entä nyt?

20
En ole ollenkaan varma mitä kaikkia tuon sivun  komennoista pitää/uskaltaa ajaa. Komennolla sudo do-release-upgrade tulee saeraavaa:
Koodia: [Valitse]
sudo do-release-upgrade
Etsitään uutta Ubuntu-julkaisua
Asenna kaikki saatavilla olevat päivitykset, ennen kuin suoritat jakelupäivityksen.

Suorita siis ensin normaalit järjestelmäpäivitykset:
Koodia: [Valitse]
sudo apt update && sudo apt full-upgrade
ja sitten vasta:
Koodia: [Valitse]
sudo do-release-upgrade

Tulee sama ilmoitus kuin yllä: "Asenna kaikki saatavilla olevat päivitykset, ennen kuin suoritat jakelupäivityksen."

Sivuja: [1] 2 3 ... 20