Näytä kirjoitukset

Tässä osiossa voit tarkastella kaikkia tämän jäsenen viestejä. Huomaa, että näet viestit vain niiltä alueilta, joihin sinulla on pääsy.


Viestit - USakari

Sivuja: [1] 2 3 ... 8
1
Ubuntu tietokoneissa / Vs: cupsd ahmii resursseja
« : 29.09.19 - klo:22.50 »
Jossain on bugi ja voisi auttaa, jos sen raportoisi, mutta se vaatii englannin taitoa.
Minä kyllä käytin kielitaitoani jo heinäkuussa ja raportoin Launchpadiin, mutta jotenkin homma meni eri tavalla kuin odotin. Minulta pyydettiin joitain vähäisiä lisätietoja, ja siihen yhteydenpito loppui. Muutaman viikon kuluttua virhe sitten näytti korjautuvan jonkun päivityksen yhteydessä, mutta ei minulle siitä mitään ilmoitettu, eikä Launchpadiinkaan ilmestynyt mitään kommenttia. Erikoiselta näytti, että virhettä ei osoitettu kenellekään ("assigned to" pysyi tyhjänä).

Jäin odottamaan jotain tietoa tietoa virheen käsittelystä. Mutta eipä sellaista ole tullut, ja nyt kai koko aihe häviää Launchpadista, kun sitä ei kukaan ole kommentoinut pitkään aikaan.

Kaipa ongelma sitten on RATKAISTU.

2
Ubuntu tietokoneissa / Vs: cupsd ahmii resursseja
« : 08.07.19 - klo:21.55 »
Mites jos tulostat jotain, onko vaikutusta. Ja sama kun käynnistät cupsd:n uudelleen?
Uudelleenkäynnistys ei vaikuta, mutta tosiaan: heti yhdenkin tulostuksen jälkeen cupsd:n resurssitarve asettuu vaatimattomalle alle 1%:n tasolle.

Rersurssiongelman voisi siis kiertää tulostamalla joka bootin jälkeen jotakin. Mutta ei se tunnu oikein ratkaisulta...

3
Ubuntu tietokoneissa / Vs: cupsd ahmii resursseja
« : 05.07.19 - klo:20.51 »
Onko tulostusjonossa jotain hämyä?
Koodia: [Valitse]
sudo ls /var/spool/cups/tmp/

tmp-hakemisto on tyhjä, mutta... Toisaalta cups-hakemistossa on noin 500 jotenkin tarpeettoman näköistä tiedostoa, tässä listauksen loppua:
Lainaus
.........................................................
-rw------- 1 root lp 1307 touko 13 13:36 c01647
-rw------- 1 root lp 1086 touko 14 15:26 c01648
-rw------- 1 root lp 1174 touko 16 16:38 c01649
-rw------- 1 root lp 1143 touko 16 23:39 c01650
-rw------- 1 root lp 1143 touko 16 23:40 c01651
-rw------- 1 root lp 1101 touko 17 12:12 c01652
-rw------- 1 root lp 1168 touko 21 20:49 c01653
-rw------- 1 root lp 1152 touko 23 23:09 c01654
-rw------- 1 root lp 1162 touko 23 23:10 c01655
-rw------- 1 root lp 1152 touko 23 23:11 c01656
-rw------- 1 root lp 1066 touko 25 09:54 c01657
-rw------- 1 root lp 1066 touko 25 10:10 c01658
-rw------- 1 root lp 1065 touko 25 11:51 c01659
-rw------- 1 root lp 1144 touko 25 15:49 c01660
-rw------- 1 root lp 1148 touko 26 12:13 c01661
-rw------- 1 root lp 1064 touko 30 13:19 c01662
-rw------- 1 root lp 1341 kesä   3 08:27 c01663
-rw------- 1 root lp 1341 kesä   3 08:28 c01664
-rw------- 1 root lp 1070 kesä  18 16:30 c01665
-rw------- 1 root lp 1082 kesä  18 19:47 c01666
-rw------- 1 root lp 1065 kesä  27 10:27 c01667
-rw------- 1 root lp 1067 heinä  3 09:00 c01668
-rw------- 1 root lp 1165 heinä  4 13:14 c01669
drwxrwx--T 2 root lp 4096 huhti 20  2016 tmp


4
Ubuntu tietokoneissa / cupsd ahmii resursseja [RATKAISTU]
« : 03.07.19 - klo:18.22 »
Olen muutaman viikon ihmetellyt, kun tietokone tahmaa ja kovalevy raksuttaa. Löytyipä top:lla syyllinen. Tulostusta cupsd:n käynnistyksen jälkeen:
Lainaus
30900 root      20   0  305452 287396   5768 S   5,3  9,3   0:41.34 cupsd     
Sitten puolitoista tuntia myöhemmin (välillä ei ole tulostettu mitään):
Lainaus
30900 root      20   0 2565692 2,125g   2240 R  79,0 71,9  93:01.45 cupsd       

%CPU on siis kasvanut 5,3 -> 79,0 ja %MEM 9,3 -> 71,9. Onko tässä mitään järkeä?

Käyttöjärjestelmä on 16.04.6 LTS (32-bit). Joo, se on vanha, mutta ei kai tämmöistä resurssien käyttöä silti saisi olla.

5
Multimedia ja grafiikka / Vs: Digikuvan kallistus?
« : 09.12.18 - klo:18.15 »
Gimp tosiaan hankala yksinkertaisiin asioihin. KolourPaint olen käyttänyt pieniin korjauksiin. Lähinnä pienennys & rajaus. Kallistus onnistuu myös. varsinaiset editorit hankalia. Yksi hyvä on DarkTable.
Kiitos! KolourPaint taitaa riittää minulle!

6
Katselin muutamaa digikuvaa sillä silmällä, että tulostaisin niitä paperille. Sitten rupesi harmittamaan, kun monessa kuvassa ei ole horisontti ihan suorassa. Sitä siis tekisi mieli kallistaa pikkuisen. Mutta kokeilemissani kuvankäsittelyohjelmissa näyttää olevan vain isoja kallistuksia, 90 asteen askelin. Tai sitten en vain löydä tätä pieni-kallistus-ominaisuutta – näissä ohjelmissa kun tuppaa olemaan enemmän fiitsöreitä kuin pystyn hahmottamaan. gimp esimerkiksi saa pääni aivan pyörälle.

Kiitos kaikista vihjeistä!

7
Voi hyvin olla joku 18.10:n uusi bugi. Suosittelisin tuotantokäyttöön 18.04.1:tä.

Jos kuitenkin haluat selvitellä ongelmaa, kannattaa lähteä liikkeelle siitä, miten järjestelmä tunnistaa nettitikun:
Entä onko modemmanager ja usb-modeswitch asennettuna?

Kyllä järjestelmä 18.10 tunnisti nettitikun ihan oikein, ja modemmanager ja usb-modeswitch oli molemmat asennettu. Mutta ei yhdistelmä sitten vain kelvannut network-managerille. Kone myös kaatuili ihan kummasti ("non-maskable interrupt" ja "soft lockup" jne.) 18.10 oli todella keskeneräisen tuntuinen.

Asensin sitten suosittelemasi 18.04.1:n ja sehän  olikin soiva peli alusta alkaen. Jo itse asennusohjelma tarjosi nettitikkua käyttöön. Kaikki tarkistamani jutut toimivat OK. Toisaalta, kun nyt ei ollut kyseessä päivitys (do-release-upgrade), niin "oman" version kasaamiseen on mennyt paljon aikaa.

8
Kun 16.04:n tarina näytti olevan lopussa, asensin 18.10:n. Mutta nettitikku hävisi. Uusi systeemi näyttää osaavan käyttää vain Ethernettiä ja WiFi:tä, mutta ei Mobile Broadbandia. Mikähän tässä nyt mättää? Miten uusi network-manager ei osaa sitä, mitä vanha?

Kiitos kaikista vihjeistä!

9
Onko jo kokeiltu käpistellä ikkunan ulkoasun asetuksia? Minusta tämän keskustelun aihe muistuttaa melko paljon terminaali-ikkunan asetuksia: siellä on asetuksissa ulkoasu, josta voi halutessaan täpätä päälle läpinäkyvyyden ja säätää liukusäätimellä arvo väliltä 0 - 100 prosenttia.

Uskoakseni koko hankaluus johtui päivityksestä (do-release-upgrade) uuden asennuksen sijasta. Päivitetyssä versiossa esiintyi muutakin häikkää. Esimerkiksi jos firefoxin ikkunaan avasi useampi välilehtiä, niin niistä päivittyi vain yksi. Muilla välilehdillä saattoi osoitekenttään kirjoittaa jotain ja se kenttä muuttui ihan niinkuin pitikin, mutta välilehti sinänsä pysyi tyhjänä (valkoisena).

Tässä kyllä menee luotto näihin päivitysversioihin. Toisessa ketjusssa jo valitin WiFi-ongelmaa, joka osoittautui johtuvan siitä, että päivityksestä oli jäänyt joku juttu pois.

No, nyt sitten tein uuden asennuksen – tosin 18.04.1:n sijasta käyttöön tuli 18.10, kun se oli nyt ilmestynyt. gedit näyttää olevan kunnossa. Asennus oli kyllä todella hankalaa, mutta se kuuluu kai eri topikkiin.

10
saisko sitä teemaa muokkaamalla kuntoon, tuolta löytyy eri keinoja https://askubuntu.com/questions/576001/how-to-add-custom-color-scheme-to-gedit-3-14-0

En usko, koska kuten mainitsin, sama läpinäkyvyys vaivaa myös im-configia, eli ongelma ei koske pelkästään geditiä.

11
Entä jos poistat .xinputrc:n ja vaihdat sitten ibusin ja ximin välillä työpöydän näppäimistöasetuksissa? Eli ibus -> xim -> ibus, kirjautuen jokaisen vaihdon jälkeen ulos ja takaisin sisään.
Jos vaihtaminen edestakaisin ei auta, kokeile luoda järjestelmään uusi käyttäjätunnus. Ilmeneekö sama ongelma sillä?

Ei auta kumpikaan. Myös silloin, kun Input Method on XIM, geditin ja im-configin ikkunat näkyvät läpi.

Ikkunaongelma häviää vain, jos Input Method on NONE eli .xinputrc ei ole olemassakaan.

Toisella käyttäjälĺä en saa IBUSia toimimaan ollenkaan.

Taidan lopettaa mökki-pähkäilyn tämän päivitetyn Lubuntun kanssa ja tehdä "puhtaan" asennuksen sitten, kun on käytettävissä lankaliittymä, eli muutaman päivän päästä.

12
Tässä näyttää olevan joku monimutkainen Input Method-juttu. Läpinäkyvyys ei muuten vaivaa pelkästään geditiä, vaan myös Input Methodin säätämiseen tarkoitettua ohjelmaa im-config. Käskyllä "env |grep IM" saa näkyviin asetukset
Lainaus
CLUTTER_IM_MODULE=xim
QT4_IM_MODULE=xim
QT_IM_MODULE=ibus
GTK_IM_MODULE=xim

Osaisiko joku sanoa, mistä nämä asetukset tulevat? Jotenkin ne näyttävät sekavilta.


13
https://bugs.launchpad.net/ubuntu/+source/gtk+3.0/+bug/1760818

Tuollainen bugi on ollut. Koita deletoida ~/.xinputrc

Kiitos linkistä; se ei ainakaan vielä ole minua kyllä auttanut, mutta enpähän ole yksin ongelman kanssa.

.xinputrc:n poistaminen kyllä "ratkaisee" läpinäkyvyysongelman, mutta siitä seuraa, etten voi käyttää ibusia, joka taas on minulle tosi tärkeä. Eli tuloksena on toinen ongelma.

14
Kokeile asentaa se uudelleen siten että poistat purgella asetustiedostot.

Kiitos, mutta uudelleenasennuksen jälkeen tilanne on ihan sama.

15
Lubuntu 18.04.1-päivityksen jälkeen geditiä ei enää voi käyttää, koska sen ikkuna näkyy läpi. Ikkunaan ei siis tule halutunväristä taustaa, vaan se, mitä työpöydällä sattuu sen (ikkunan) kohdalla olemaan.

Olen käyttäänyt geditiä vuosikausia, ja mielelläni käyttäisin jatkossakin. Mutta nyt pitäisi jotain keksiä. Olisiko kellään neuvoa?

Nimen gedit g-kirjain kai tarkoittaa Gnomea, ja minulla ei sitä ole. Mutta ei ole ennenkään ollut, ja gedit on silti toiminut...

16
Ubuntu tietokoneissa / Vs: Nettitikulla hotspot (17.10)
« : 18.10.18 - klo:19.11 »
Oliko kyseessä 16.04:stä päivitetty Lubuntu 18.04? Puhtaassa asennuksessa pitäisi olla valmiina dnsmasq-base.

Kyllä – do-release-upgrade.

17
Viimein taisi löytyä. Noudatin ohjetta https://askubuntu.com/questions/1045324/any-gui-apps-easy-method-for-creating-wifi-hotspot-in-lubuntu eli pelkästään asensin paketin dnsmasq-base, käynnistin uudestaan  ja se oli siinä.

(Pakettia network-manager ei tarvinnut asentaa, koska se oli Lubuntu 18.04.1:ssä jo olemassa.)

18
Ubuntu tietokoneissa / Vs: Nettitikulla hotspot (17.10)
« : 18.10.18 - klo:08.35 »
Palaan taas aiheeseen, kun ollaan taas mökillä ja haluaisin taas saada läppärillä pienen WLANin aikaiseksi. Nyt on Lubuntun versio jo 18.04.1 LTS, mutta ei vaan onnistu.

Hotspot on luotu, mutta aina vain Adroid-puhelin ensin ilmoittaa "Haetaan IP-osoitetta..."  minuuttikaupalla – ja sitten luovuttaa.

Ainoa virheilmoitus, mitä olen toistaiseksi löytänyt. on dmesgin
Lainaus
netlink: 'wpa_supplicant': attribute type 213 has an invalid length.

Tästä en ymmärrä mitään. Hotspot on nimenomaan määritelty avoimeksi, eikä siinä siis pitäisi mitään WPA:ta olla mukana.

(Harmittaa, kun Windows 10:llä syntyy toimiva hotspot suunnilleen yhdellä klikkauksella. Mitään säätöä ei tarvita.)

19
Nyt siis 18.04.1 LTS näyttäisi olevan pystyssä. Paitsi että... Kaiuttimista ei kuulu pihahdustakaan. SIitä pitänee tehdä uusi topikki.
Ei kun siis  tämä oli se juttu, että jos käyttää Windows 10:ä ja sitten siirtyy Linuxiin sammuttamatta konetta välillä, niin ääniä ei saa kuulumaan. Kone pitää sammuttaa.

20
Kannattanee poistaa Nvidian suljettu ajuri, kunnes saat graafisen työpöydän toimimaan:

Koodia: [Valitse]
sudo apt purge "nvidia*"
Poista vielä vanha /etc/X11/xorg.conf, jos se on olemassa:

Koodia: [Valitse]
sudo rm /etc/X11/xorg.conf
Kiitos; nämä taisivat riittää (Gnomea en käytä). Asensin sitten uudestaan nvidian, ja se lähti nyt toimimaan. Tosin tarvittiin joku ylimääräinen UEFI-salasana.  Jota en oikein ymmärtänyt, koska ei sitä käynnistyksen yhteydessä sitten kysyttykään.

Nyt siis 18.04.1 LTS näyttäisi olevan pystyssä. Paitsi että... Kaiuttimista ei kuulu pihahdustakaan. SIitä pitänee tehdä uusi topikki.

Sivuja: [1] 2 3 ... 8