Ubuntu Suomen keskustelualueet

Ubuntun käyttö => Multimedia ja grafiikka => Aiheen aloitti: mikkohuo - 12.08.08 - klo:23.53

Otsikko: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: mikkohuo - 12.08.08 - klo:23.53
[edit 25.4.2009]

Yle on avannut käyttöön Areenasta uuden beta-versio (http://areena-beta.yle.fi), jonka käyttäminen on suositeltavaa.

 Lue lisää: http://blog.ubuntu-fi.org/2009/yle-tukee-ubuntua/

Nämä ohjeet toimii edelleen, jos haluat käyttää Elävää arkistoa tai Areenan vanhempaa versiota.

[/edit]
---

YLE:n hienot palvelut Areena ja Elävä Arkisto toimivat Ubuntulla hyvin asentamalla paketin ubuntu-restricted-extras. Palvelujen käyttämiseksi ei tarvitse tehdä mitään muuta.

Monet ovat kuitenkin tuskailleet palvelujen kanssa ja kokeilleet sisällön näyttämiseen mm. mplayeria ja vlc:tä. Palvelun saattaa saada toimimaan niidenkin kanssa, mutta mitään erityistä tarvetta siihen ei ole. Restricted-extras on ns. metapaketti, joka asentaa tarvittavat kodeekit.

Oletuksena Ubuntussa Firefox käyttää multimedian näyttämiseen Totemia, joten jos tuohon asetukseen on mennyt koskemaan, niin kannattaa varmistua, että paketti totem-mozilla on asennettuna. Oletuksen Totem käyttää taustamoottorinaan gstreameria, joten jos sitäkin on tullut vaihdettua, niin on syytä ottaa käyttöön alkuperäinen paketti totem-gstreamer.

Näiden pakettien kanssa ongelmia voivat tuottaa mm. seuraavat paketit mozilla-mplayer ja totem-xine. Mikäli ne on asennettuna, kannattaa paketit poistaa.

Firefoxin liitännäisellä mediaplayer-connectivity voi säätää tarkkaan mikä ohjelma avaa minkäkinlaisen videon, mutta peruskäytössä siihen ei ole tarvetta. Liitännäisen voi siis poistaa, jos sellaisen on mennyt asentamaan.

Nämä ohjeet on testattu ja todettu toimiviksi useissa Ubuntu 8.04 asennuksissa.


edit/rhkfin. Kubuntussa ilmeisesti riittää asentaa paketti kubuntu-restricted-extras niin konqueror ja kaffeine osaavat näyttää videot nätisti.

edit/gdm. Poistettu huomautus.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: juhani46 - 13.08.08 - klo:22.17
Suuri kiitos ohjeesta, nyt toimii ilman kikkailuja..
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Antifilatelisti - 13.08.08 - klo:22.56
Lainaus
Kubuntusta ei ole tarkempaa tietoa.
Minulla ainakin toimii Kubuntu-restricted-extras paketilla+konqueror+kaffeine niin kuin pitääkin.
Mozillan puolella kubuntussa ei elävä arkisto(Ea) toiminut suoraan. Liekö kaffeinesta mozillan päälle versiotakaan. Nyt rupesi toimimaan mozillallakin mutta vlc pluginin avulla. Mikään muu mediaplayer tiedostoja toistava ohjelma liitännäinen ei saanut olla päällä. mplayer pluginia mozilla joskus tarjosi itsestään soittamaan Ea: ta ja areenaa. Asensin sen silloin, mutta se toimi vain näennäisen satunnasisesti.


Ubuntu+ubuntu-restricted-extras paketilla en näe mitään syytä, miksi ei toimisi. Paitsi jos on liilkaa liitännäisiä käytössä.
Ne pois päältä ja uusi yritys jos ei toimi.




Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Senior - 17.08.08 - klo:07.51
Toimin moderaattorin ohjeiden mukaisesti ja tulos pysyi ennallaan - Ylen Areena ja Elävä arkisto joko näkyi - tai sitten ei. Ja sama video joka toisti äsken hyvin saattoi toisella soittokerralla jättää kuvan pois ja soittaa pelkkää ääntä. Välimuistin tyhjennyt ja/tai reload saattoi taas näyttää videon suhteellisen hyvin.

Joten Totem soittaa suurinpiirtein kaikki videot joten kuten, mutta joskus joudut lataamaan videon uudelleen ja uudelleen ennenkuin se näyttää sen kunnolla. Päätin palauttaa ne asetukset jotka minulla oli aiemmin.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Jallu59 - 19.08.08 - klo:14.52
Ei toiminut noilla ohjeilla ainakaan kaverin HP Vectra VL420, jossa kyllä toimii esimerkkifileet ja Youtubelkin sekä nettiradiot.
Jää EElavassa arkistossa seisomaan kohtaan "ladataan kohteesta yle. ...." maailman tappiin , ellei ikkunaa sulje.

Eli ladattu on Ubuntu-restricted-extras, totem-mozilla ja totem-gstreamer ovat kotona eikä noita kiusaajia ollut asentunut.(puhdas ensiasennus)..

Lisävinkkejä kaivataan

T:Jallu59
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Aspen - 19.08.08 - klo:20.09
Ei toiminut noilla ohjeilla ainakaan kaverin HP Vectra VL420, jossa kyllä toimii esimerkkifileet ja Youtubelkin sekä nettiradiot.
Jää EElavassa arkistossa seisomaan kohtaan "ladataan kohteesta yle. ...." maailman tappiin , ellei ikkunaa sulje.

Eli ladattu on Ubuntu-restricted-extras, totem-mozilla ja totem-gstreamer ovat kotona eikä noita kiusaajia ollut asentunut.(puhdas ensiasennus)..

Lisävinkkejä kaivataan

T:Jallu59

Asensin tuon mediaplayer-connectivity -liitännäiseen Firefoxiin ja laitoin kaikki käynnistymään VLC:llä, niin nyt toimii Ylen areena sekä Elävä arkisto.
https://addons.mozilla.org/fi/firefox/addon/446
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: vaeltava-aave - 23.08.08 - klo:19.52
Ylen Areena ja Elävä arkisto joko näkyi - tai sitten ei. Ja sama video joka toisti äsken hyvin saattoi toisella soittokerralla jättää kuvan pois ja soittaa pelkkää ääntä.

Tuttu juttu minullekin, joskus näkyy ja joskus ei. Sama homma mtv3 uutisvideoiden kohdalla, vaikka en tiedäkään pitäisikö niiden näkyä noilla asetuksilla.

Lainaus
Päätin palauttaa ne asetukset jotka minulla oli aiemmin.

Millähän asetuksilla katselit aiemmin?
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: oltsee - 27.08.08 - klo:21.26
toimii ihan kafeinellakin jos ei ole firefox plugin mplayereita. vai miten se pitäisi muotoilla :D
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: kestosippi - 12.09.08 - klo:10.33
Hieno palvelu tuo Ylen arkisto ja toimii Toteemilla. Mutta milläs saisin Saunavision (http://www.saunavisio.fi/nettivisio/player.html#) toimimaan?
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Jtkone - 13.09.08 - klo:09.06
Ylen Areena ja Elävä arkisto joko näkyi - tai sitten ei. Ja sama video joka toisti äsken hyvin saattoi toisella soittokerralla jättää kuvan pois ja soittaa pelkkää ääntä.

Tuttu juttu minullekin, joskus näkyy ja joskus ei. Sama homma mtv3 uutisvideoiden kohdalla, vaikka en tiedäkään pitäisikö niiden näkyä noilla asetuksilla.

Lainaus
Päätin palauttaa ne asetukset jotka minulla oli aiemmin.

Millähän asetuksilla katselit aiemmin?

Kumma juttu, mutta sain toimimaan sekä YLEn että MTV3n asentamalla ihan Lisää/poista... kohdasta sekä Totem (gstreamer) että Totem (xine). Oletuksena käytti gstreameria, jolloin MTV3 tökki. (Jäi lataamaan tai näytti vain mainospätkän). Poistin Totem gsteamerin eli käyttää xinea. Niinpä vain läksi YLEt ja MTV3 toimimaan moitteetta :)
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: salai - 13.09.08 - klo:10.51
Näiden pakettien kanssa ongelmia voivat tuottaa mm. seuraavat paketit mozilla-mplayer ja totem-xine. Mikäli ne on asennettuna, kannattaa paketit poistaa.

Ainoa, millä minä saan Fintoton suorat ravilähetykset toimimaan on nimenomaan totem-xine, joten pidän tuota neuvoa kyllä harhaanjohtavana. Samaten Ylen Areenan uutislähetysten ääni pätkii totem-gstreamerilla usein. Jollakin näytönohjaimella totem-xinen värit olivat kyllä pahasti pielessä, mutta muuten toimii paljon paremmin kuin gstreamer.

Totem-gstreamer ja totem-xine voivat olla samaan aikaan asennettuna ja niitä voi vaihdella keskenään konsolissa komennolla:
Koodia: [Valitse]
kokeilija@hardy-32:~$ sudo update-alternatives --config totem

There are 2 alternatives which provide `totem'.

  Selection    Alternative
-----------------------------------------------
 +        1    /usr/bin/totem-gstreamer
*         2    /usr/bin/totem-xine

Press enter to keep the default[*], or type selection number:
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: hiltuer - 04.11.08 - klo:20.35
Moi,
Tässä toimi kaikki kuin buikki ihan heittämällä. Areenan ja elävän arkiston videot näkyvät. Yle nettiradio kuuluu rytmiboxilla. Asennettuna on ubuntu estricted ja totem gstreamer ja totem mozilla plugin. Ibexi on tässä wubin avulla, mutta eipä taida vaikuttaa.
Sen sijaan työpaikan koneella ei saa kuulumaan mitään nettiradioita Rytmiboxilla. Johtuneeko siitä, että siinäa on proxy välissä. Sain Radio Helsingin kuulumaan VLC:llä kun kerroin välityspalvelimen osoitteen. Miten lie Rytmiboxissa? Osaako se etsiä oikean reitin?  Ylen radioita en ole saanut kuulumaan. Pitääpä tarkistaa, että säädöt ovat samat.
Ihan henkimaailman hommaa.
Erkki   
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Senior - 22.11.08 - klo:16.00
Käytän Totemia ja toimii aika hyvin. Mplayer on sensijaan täysin mysteeri. Se ei pelitä pätkääkään enkä ole sitä enää viikkokausiin edes yrittänyt.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: jake - 26.12.08 - klo:23.09
Vanhaan aiheeseen - jos ei nyt ongelmana, vaan upeen ohjelman esiinottona...
Ylen teemalta tuli torstaina huippuhieno kolmen papin konsertti, joka on nähtävissä ylen areenasta nyt ja ainakin minä näin sen ihka hyvin linuxilla, monista moitteista huolimatta... java/areena/dispatcher/1742083.asx?bitrate=1

Sieltä tuli ja tulee - siis Teemassa - näin loppuvuonna monia hienoja esityksiä esim oopperan ystäville :)
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Kitten - 26.12.08 - klo:23.20
E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.

Moi, yritin asentaa tuota mutta hyppäsi tällainen ruutuun... mikä lie? Olen huono koneiden kanssa.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Minna S - 26.12.08 - klo:23.37
Kirjoita päätteeseen tuo rimpsu
Koodia: [Valitse]
sudo dpkg --configure -a
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Kitten - 26.12.08 - klo:23.39
Kiitos kovasti, nyt toimii  ;)
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: jake - 27.12.08 - klo:00.19
ja tässä linkki sen pappien konsertin valmisteluohjelmaan.
On muuten melkonen homma - ei uskois ikinä

http://areena.yle.fi/toista?id=1742052
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: mikko_h - 02.01.09 - klo:23.30
Meikäläisen havainnon mukaan Areena ja Elävän arkiston katselemisessa videoiden toisto-ohjelmat (mplayer, totem) kyllä toimivat, mutta Ylen palvelinten lähettämä videovirta katkeilee varsin usein ainakin ns. parhaisiin katseluaikoihin. Sunnuntaina päivällä yleensä toimii. Itse päädyin käyttämään mimmsiä videoiden lataamiseen, koska sillä katkenneen latauksen voi helposti käynnistää uudelleen. Katsomaan en ryhdy, ennen kuin koko pätkä on omassa koneessa.  En usko, että katkeilu johtuisi siitä, että asiakkaana on Linux. Itse en muuta käytä, mutta Windowsin varassa elelevät tutut ovat kyllä havainneet katkeilua sekä Ylellä että Maikkarilla.

En tiedä, mikä tähän auttaisi. Ehkä Ylen pitäisi varata videoilleen enemmän kaistanleveyttä tai vaihtaa palvelintensa ohjelmistoja.

Nyt ois itellä hommana saada joululomalla digiboksista Linux-koneeseen imuroidut Ylen ohjelmat dvd:lle tekstityksineen, mihin kyllä löytyi toimivat konstit pienen hakemisen jälkeen. Tekstitysformaatit ovat luvalla sanoen sinänsä yhtä monihyväinen sekametelisoppa kuin digivideo.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Senior - 16.01.09 - klo:11.34
Meikäläisen havainnon mukaan Areena ja Elävän arkiston katselemisessa videoiden toisto-ohjelmat (mplayer, totem) kyllä toimivat, mutta Ylen palvelinten lähettämä videovirta katkeilee varsin usein ainakin ns. parhaisiin katseluaikoihin.

Et ole ainoastaan oikeassa vaan olet suuremmoisen oikeassa. Samat videot jotka pätkivät pahemman kerran iltaisin näkyvät ja kuuluvat vallan mainiosti esim. aamupäivällä. Luultavasti monilla meistä ongelmien taustalla on hidas ja tukkoinen verkko.

Yhdestä asiasta täytyy tässä yhteydessä mainita. Kun Totem näyttää näitä nettivideoita niin usein käy kun sitten avaa työpöydältäsi/kansiostasi jonkin videon, eteenkin pitkän, niin silloin käy melkein aina ettei tuo video lähde toimimaan ollenkaan. Monesti saattaa riittää se että suljet nettivideosivuston ja tyhjennät sivuhistorian. Mutta joskus joudut sulkemaan kertakaikkisen kokonaan koko Firefoxin sivuhistoriatyhjennyksen yhteydessä. Näin kävi mm. eilen kun yritin katsella bittorrentilla Atomic Cafee-videota.

Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Pekkam - 27.01.09 - klo:18.54
Kerrompa minäkin miten olen saanut toimimaan. Olen pyrkinyt ensinnäkin siihen, että sekä Yle Areena että Mtv3:n Nettitv toimii. Nettitv:n lyhyet pätkät (kuten tulosruutu) sain toimimaan asentamalla Firefoxin laajennuksen Mediaplayer-Connectivity.
Lisäksi tietysti asetin paketin ubuntu-restricted-extras.
Tiedotoon .mplayer/cofing lisäsin seuraavan rivin:
Koodia: [Valitse]
prefer-ipv4 = yes
Tuolla sain siitä virheilmoitukset pois. Suuremmissa tiedostoissa on vielä ilmeisesti jokin salauksen luku-ongelma.

Ps. Sain nyt myö Mtv3:n nettitv:n (metafile.asx) katselun toimimaan. Onnistui siten, että muutin Firefoxin mediaplayerconnectivity asetuksista vlc-soittimen oletukseksi.
Sen saa muutettua Firefoxin valikosta Työkalut->Lisäosat->mediaplayerconnectivity->Asetukset
Vlc asetus on muotoa:
Koodia: [Valitse]
/usr/bin/X11/vlc

Areenakin toimii, tosin viivellä.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Reiser - 28.01.09 - klo:19.18
Kerrompa minäkin miten olen saanut toimimaan. Olen pyrkinyt ensinnäkin siihen, että sekä Yle Areena että Mtv3:n Nettitv toimii.

Käytössä Hardy. Samat tavoitteet, eri menetelmä.

Eka pois totem-mozilla ja mozilla-mplayer, jos asennettuna. Myöskään Mediaplayer-Connectivity laajennusta ei tarvita.

Lisätään ohjelmalähteisiin:
deb http://ppa.launchpad.net/c-korn/ubuntu hardy main

Asennetaan VLC uudempi versio 0.9.8a:
sudo aptitude install vlc mozilla-plugin-vlc

Ohje Lontooksi täällä (http://tinyurl.com/5vcnaw).


Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Remontti - 31.01.09 - klo:22.44
Mullon tässä 8.10 ja koitin soveltaa noita ohjeita mutta en mä saa noita ylen ohjelmia toimimaan vaikka kuika vaihtelisin noita soittimia. Ei vaan lataa. VLC:llä tuli vaan pitkä liuta virheilmoituksia. Muut artikikelissa mainitut meee jumiin.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Reiser - 31.01.09 - klo:22.54
Mullon tässä 8.10 ja koitin soveltaa noita ohjeita
Kokeilitko muuttaa lähdettä?
deb http://ppa.launchpad.net/c-korn/ubuntu intrepid main
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: salai - 03.02.09 - klo:17.07
Lopullinen? ratkaisu videoitten toistoon Intrepidissä (toimii ainakin tällä hetkellä kaikissa testaamissani koneissa):

1. Poista totem-gstreamer (miksi se yleensä on oletuksena?)
2. Asenna totem-xine (ja totem-mozilla, jos se puuttuu)

Noilla saa toistettua kaikki Ylen videot ja FinToto:n ravit, mutta ei MTV3:n nettiTV:tä, siispä

3. Poistetaan kaikki vlc:n vanhat asennetut osat
4. Lisätään pakettivarasto PPA for Mefisto (https://launchpad.net/~dariovezzosi/+archive/ppa)
Koodia: [Valitse]
deb http://ppa.launchpad.net/dariovezzosi/ppa/ubuntu intrepid main
ja asennetaan sieltä
4. mozilla-plugin-vlc, joka vetää mukanaan muut tarpeelliset paketit

Nyt on siis asennettuna kaksi pluginia videoitten toistoon vlc ja totem.

Firefox 3.* näyttää käyttävän (ainakin minun asennuksissani) vlc:tä, jos se on sallittuna. Tuo 0.9.8a-ppa6-versio tuntuu toimivan oikein hyvin MTV3:n kanssa. Vlc:ssä on edelleenkin aivan uskomattoman surkea käyttöliittymä pluginissa, eikä se toimi ollenkaan Ylen Elävässä arkistossa, minkä vuoksi poistan sen käytöstä muulloin kuin tarvittaessa. Käytöstä poistaminenhan tapahtuu Työkalut > Lisäosat > Liitännäiset -kohdasta, sivun lataaminen vaihtaa pluginia lennosta.

Sama systeemi toimi myös Hardyssa käytettäessäni aikaisemmin mainittua http://ppa.launchpad.net/c-korn/ubuntu -repon versiota. Se tuntui kuitenkin hyvin kaatumisherkältä, mm. c:n painaminen jämäytti näytön ja Ylen Areenan kaatoon riitti Ylen linkin klikkaaminen kesken toiston.

Kokemukset voivat tietysti vaihdella eri asennuksissa.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: |PuLi| - 03.02.09 - klo:17.33
http://linux.fi/wiki/YLE_Areena_ja_El%C3%A4v%C3%A4_arkisto (http://linux.fi/wiki/YLE_Areena_ja_El%C3%A4v%C3%A4_arkisto)  tuoltahan olis saannu nopeesti
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: salai - 03.02.09 - klo:22.30
http://linux.fi/wiki/YLE_Areena_ja_El%C3%A4v%C3%A4_arkisto (http://linux.fi/wiki/YLE_Areena_ja_El%C3%A4v%C3%A4_arkisto)  tuoltahan olis saannu nopeesti

Minkä tiedon sinun neuvoillasi olisi "saannu nopeesti"?

Käsittääkseni esitin helpon ratkaisun, joka toimii ainakin minulla joka ikinen kerta.

Taitaa vaan olla teikäläisille googlaajille liian vaikeaa vaihtaa tarvittaessa pluginia lennosta?
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Jtkone - 03.02.09 - klo:23.37
Aiheeseen on niin monta ohjetta kuin on kirjoittajaakin (ja konetta), joten en enää edes yritä väittää että seuraava toimisi muilla kuin minulla.

Minulla siis toimii Areena, Elävä arkisto ja MTV 3  Totem xinellä ja Mediaplayer-Connectivity firefox palikalla. Ei tarvitse mitään kikkailua vaan kaikki aukeavat nätisti Totemiin.
VLC:tä en ole koskaan käyttänyt.

Ja Salain kanssa olen samaa mieltä tuosta totem-gstreamerista. Sillä en ole koskaan onnistunut.

U8.04
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Tekno - 04.02.09 - klo:09.54
Lopullinen? ratkaisu videoitten toistoon Intrepidissä (toimii ainakin tällä hetkellä kaikissa testaamissani koneissa):

1. Poista totem-gstreamer (miksi se yleensä on oletuksena?)
2. Asenna totem-xine (ja totem-mozilla, jos se puuttuu)

Noilla saa toistettua kaikki Ylen videot ja FinToto:n ravit, mutta ei MTV3:n nettiTV:tä, siispä

3. Poistetaan kaikki vlc:n vanhat asennetut osat
4. Lisätään pakettivarasto PPA for Mefisto (https://launchpad.net/~dariovezzosi/+archive/ppa)
Koodia: [Valitse]
deb http://ppa.launchpad.net/dariovezzosi/ppa/ubuntu intrepid main
ja asennetaan sieltä
4. mozilla-plugin-vlc, joka vetää mukanaan muut tarpeelliset paketit

Nyt on siis asennettuna kaksi pluginia videoitten toistoon vlc ja totem.

Firefox 3.* näyttää käyttävän (ainakin minun asennuksissani) vlc:tä, jos se on sallittuna. Tuo 0.9.8a-ppa6-versio tuntuu toimivan oikein hyvin MTV3:n kanssa. Vlc:ssä on edelleenkin aivan uskomattoman surkea käyttöliittymä pluginissa, eikä se toimi ollenkaan Ylen Elävässä arkistossa, minkä vuoksi poistan sen käytöstä muulloin kuin tarvittaessa. Käytöstä poistaminenhan tapahtuu Työkalut > Lisäosat > Liitännäiset -kohdasta, sivun lataaminen vaihtaa pluginia lennosta.

Sama systeemi toimi myös Hardyssa käytettäessäni aikaisemmin mainittua http://ppa.launchpad.net/c-korn/ubuntu -repon versiota. Se tuntui kuitenkin hyvin kaatumisherkältä, mm. c:n painaminen jämäytti näytön ja Ylen Areenan kaatoon riitti Ylen linkin klikkaaminen kesken toiston.

Kokemukset voivat tietysti vaihdella eri asennuksissa.

Näillä ohjeilla Yle Areena kaataa firefoxin alta aikayksikön. Ilman VLC -pluginia pyytää avaamaan asx -tiedoston, jonka avaamalla mikään soitin ei käynnisty.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: salai - 04.02.09 - klo:13.51
Näillä ohjeilla Yle Areena kaataa firefoxin alta aikayksikön. Ilman VLC -pluginia pyytää avaamaan asx -tiedoston, jonka avaamalla mikään soitin ei käynnisty.

Siis mikä plugini kaataa, missä distrossa, millä lisukkeilla varustetun Firefoxin?

Kyllä minulla ainakin Areenan asx-tiedostot aukeavat halutessani ilman mitään ongelmia oletussoittimella eli Totem Movie Playerillä tai sitten pyörivät selaimen ikkunassa. Tilanne voi tietysti olla toinen, jos Firefoxin perusasetuksia on muutettu tai siihen on esim. asennettu monen suosittelema MediaPlayerConnectivity-tekele. Sen sotkemien kymmenien asetusten poistokin kesti viimeksi puoli tuntia käsipelillä, eli uuden profiilin teko on helpompi homma.

Ei pelkkä totem-mozilla + totem-xine ole "ikinä" kaatanut yhtään Firefoxia missään kymmenistä asennuksistani. Tuota ohjettakin kokeilin toissa yönä kahdessa eri koneessa kolmella täysin puhtaalla asennuksella ilman ongelmia. Toki Totem-gstreamer toimii useimmiten melkein yhtä hyvin; ainoastaan Areenan uutisissa ääni muuttuu usein sammakon kurnutukseksi ja suorat  (maksulliset) ravilähetykset pysähtyvät ensimmäiseen kuvaan. Eikä muistaakseni Hardyssä gtreamerillä näy Ylen TV-lähetyksissä tai tallenteissa tekstitykset.

Vlc:tä  käytin siis pelkästään MTV3:n ilmaisten nettivideoitten testaamiseen, koska sen selain-plugini on ollut vuosia keskeneräinen kaatumatautinen kyhäelmä (myös Windows-puolella) ilman alkeellisimpiakaan kontrolleja. Sehän eilenkin testatessanikin kaatoi Areenan pelkkää Ylen linkkiä kesken uutisten katselun klikatessani ja toisella kertaa koko näytön c:tä painaessani. Siis aivan tuoreessa, puhtaassa asennuksessa Firefoxin perusasetuksilla. Hardyn puhtaassa asennuksessa katosivat lisäksi vlc:stä (0.8.6) äänet Myytinmurtajista parin minuutin katselun jälkeen. Nuo ongelmat tuntuivat katoavan käyttäessäni mainitsemaani PPA for Mefisto (https://launchpad.net/~dariovezzosi/+archive/ppa)-repoa Intrepidin vlc:lle.

Mutta kokemukset voivat tietysti vaihdella ohjelmaversioista ja koneista (varsinkin näytönohjaimet ja niitten ajurit) riippuen. Puhtaan asennuksen testaaminen usb-tikulta käynnistettynä ei kyllä montaa minuuttia kestä. Firefoxiin uuden puhtaan profiilin teko puolestaan vie aikaa muutaman sekunnin.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Tekno - 05.02.09 - klo:15.53
noh nyt on asennettu:
ubuntu-restricted-extras
totem-xine
totem-mozilla

tulos:
http://img4.imageshack.us/img4/788/areenaof9.png

mediaplayer connectivityn, vlc:n ja vlc-pluginin poistin

Ubuntu 8.10
GMA900 (Intel ajurilla)
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Reiser - 05.02.09 - klo:17.35
tulos:
http://img4.imageshack.us/img4/788/areenaof9.png
Kirjoita firefoxin osoiteriville about:plugins
Päivitä sivu kertaalleen. Muuttuiko näkymä mitenkään?

Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Tekno - 05.02.09 - klo:17.59
tulos:
http://img4.imageshack.us/img4/788/areenaof9.png
Kirjoita firefoxin osoiteriville about:plugins
Päivitä sivu kertaalleen. Muuttuiko näkymä mitenkään?



ei

tuota palkkia klikkaamalla tulee tämmönen dialogi:
http://img88.imageshack.us/img88/5372/liitnnisetvs0.png

...mutta valittuani seuraava, tulee että "Liitännäinen jo asennettu" tms.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: salai - 05.02.09 - klo:18.17
Minä kyllä kokeilisin Firefoxia puhtaalla profiilin, jos ei asennetut pluginit näy (ja muissakin vastaavissa ongelmissa).
Profiilimanageri käynnistetään yksinkertaisesti "firefox -P" komennolla konsolista tai lisäämällä -P käynnistimen perään.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Tekno - 05.02.09 - klo:18.27
Minä kyllä kokeilisin Firefoxia puhtaalla profiilin, jos ei asennetut pluginit näy (ja muissakin vastaavissa ongelmissa).
Profiilimanageri käynnistetään yksinkertaisesti "firefox -P" komennolla konsolista tai lisäämällä -P käynnistimen perään.

ei auttanut tämäkään. about:plugins listalle ei tule mitään totemiin viittaavaa.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: gdm - 05.02.09 - klo:18.57
noh nyt on asennettu:
ubuntu-restricted-extras
totem-xine
totem-mozilla

tulos:
http://img4.imageshack.us/img4/788/areenaof9.png

mediaplayer connectivityn, vlc:n ja vlc-pluginin poistin

Ubuntu 8.10
GMA900 (Intel ajurilla)

Areena toimii ihan gstreamer raja-pinnalla, joka myös on oletuksena GNOMEssa.
Tarkista synapticin avulla, että kaikki poistettujen pakettien konfiguraatio tiedostot on myös poistettu.
Status välilehdellä löytyy vaihtoehdot.

Mahdollisesti Xine ei täysin toimi totemin kanssa, kokeile vaihtaa takaisin gstreameriin.
Myös totemin asetuskansion poisto voi auttaa
Koodia: [Valitse]
rm -r ~/.config/totem/

Jos ei FF toimi, niin uuden profiilin luonti pitäisi auttaa, kuten muutama on sanonut.
Selain kiinni ja komentoriviltä uuden luonti.
Koodia: [Valitse]
firefox -ProfileManager
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: salai - 05.02.09 - klo:19.30
Mahdollisesti Xine ei täysin toimi totemin kanssa, kokeile vaihtaa takaisin gstreameriin.
Kymmenien testien jälkeen eri koneilla ja distroilla olen kyllä todennut, että totem-xine toimii aivan varmasti paremmin kuin totem-gstreamer. Esimerkiksi Areenan uutisissa ääni hyvin usein muuttuu kurnutukseksi, eikä suorat ravilähetykset toimi lainkaan.

En todellakaan ymmärrä, miksi sitä väkisten tyrkytetään Ubuntussa käyttäjille. Asensin äsken Mint Felician toiselle koneelle, eikä siinä ole gstreameria asennettuna ollenkaan.

Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Tekno - 05.02.09 - klo:19.34
Kokeilin toisella profiililla, kuten aiemmin jo sanoin: ei toimi.

paras tulos tähän mennessä on mplayer -pluginilla, sillä kuuluu ääni mutta kuva ei näy.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: mikko_h - 05.02.09 - klo:20.40
Tämähän on keskitason tragikomedia koko sekoilu. Joku voisi vihjata Yleläisille, että on olemassa semmoinen keksintö kuin Juutuubi ja sitten semmoinen kuin Vimeo, ja niissä näkyy peräti toimivia nettivideoita. (Jos ketä suljetun koodin Flash-liitännäinen ahistaa, niin siihenkin on nykyään videoiden osalta vapaita vaihtoehtoja.)
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Reiser - 06.02.09 - klo:17.28
Minä kyllä kokeilisin Firefoxia puhtaalla profiilin, jos ei asennetut pluginit näy (ja muissakin vastaavissa ongelmissa).
Profiilimanageri käynnistetään yksinkertaisesti "firefox -P" komennolla konsolista tai lisäämällä -P käynnistimen perään.

ei auttanut tämäkään. about:plugins listalle ei tule mitään totemiin viittaavaa.
Kokeiles vielä asentaa totem paketit uudelleen.
Laita päätteeseen:
sudo aptitude reinstall totem-xine totem-mozilla totem-plugins
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Tekno - 06.02.09 - klo:17.49
ei auttanut. ::)
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: salai - 06.02.09 - klo:22.11
Tuo aikaisemmin antamani ohje toimii ainakin minulla edelleen kuin junan vessa kaikissa testaamissani 8.10-pohjaisissa distroissa, tässä on nyt kokeiltavana uusin Crunchbang.

Eli asensin tähänkin totem-xinen, poistin totem-gstreamerin ja asensin tuoreimman mozilla-plugin-vlc (tällä kertaa Matti Lidellin repoista https://launchpad.net/~mlind/+archive/ppa), joka veti mukanaan muut palikat.

Voihan tuo (siis mahdollisuus vaihtaa Firefoxin käyttämää plugia lennosta pelkästään vlc:hen vaikuttamalla) olla vahingossa tullut ominaisuus (eli bugi), joka poistuu myöhemmin. Tai sitten kyseessä on kuun asennosta johtuva ilmiö, joka sidottuna IP-osoitteeseen toimii vain minun kaikissa koneissani ja asennuksissani.  :D


Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Tekno - 11.02.09 - klo:18.30
Probleema näyttäs olevan että FF ei lataa totem-mozilla pluginia jostain syystä.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: salai - 12.02.09 - klo:02.02
Probleema näyttäs olevan että FF ei lataa totem-mozilla pluginia jostain syystä.
Lienevät symboliset linkit sitten jotenkin sekaisin.
 
Ainakin minulla totem-xinen toimivat pluginit ovat asentuneet /usr/lib/totem/xine -kansioon.
Firefox lataa ensimmäisenä ne pluginit, jotka ovat ~/.mozilla/plugins -kansiossa.

Eli yksi vaihtoehto olisi kopioida edellisen kansion sisältö jälkimmäiseen tai tehdä symbolinen linkitys. Siis, jos halua noita suosittelemiani ja minulla jokaisessa asennuksessa toimivia käyttää.

Tuo ehkä auttaa selvittämään tilannetta: Firefoxin lataamien pluginien paikan saa selville seuraavasti:
Kun laittaa about:config:ssa "plugin.expose_full_path" arvoksi "true" näkee komennolla about:plugins kaikkien pluginien täyden polun.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Tekno - 12.02.09 - klo:23.38
Tuo ehkä auttaa selvittämään tilannetta: Firefoxin lataamien pluginien paikan saa selville seuraavasti:
Kun laittaa about:config:ssa "plugin.expose_full_path" arvoksi "true" näkee komennolla about:plugins kaikkien pluginien täyden polun.

Mitään totemiin viittaavaa ei tuonne about:plugins sivulle tule. Joten ei näy polkujakaan.

ja  ~/.mozilla -hakemiston alla on "extensions" ja "firefox" -hakemistot.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: salai - 13.02.09 - klo:00.51
Tässä vielä hieman tarkemmin selostettuna:

Minulta löytyy seuraavat (xine) pluginit:
 
/usr/lib/totem/xine/totem-plugin-viewer
/usr/lib/totem/xine/libtotem-basic-plugin.so
/usr/lib/totem/xine/libtotem-cone-plugin.so
/usr/lib/totem/xine/libtotem-gmp-plugin.so
/usr/lib/totem/xine/libtotem-mully-plugin.so
/usr/lib/totem/xine/libtotem-narrowspace-plugin.so

Jollei sinulla ole niitä, et liene paketteja totem-xine ja totem-mozilla asentanutkaan.

Ilmaukseni "Firefox lataa ensimmäisenä ne pluginit, jotka ovat ~/.mozilla/plugins -kansiossa. "
tarkoitti puolestaan sitä, että tuohon kansioon sijoitetut pluginit ladataan ensimmäisinä Gecko-pohjaisissa selaimissa. Kansiota ei ole olemassa oletusarvioisesti, vaan se on tehtävä itse.

Esimerkiksi ei-asennettua (paketti vain purettu jonnekin) Firefoxin testiversiota varten tuonne pitää sijoittaa nuo xinen (tai gstreamerin, jos sitä suosii) pluginit ja samaten flashplayerin ja vlc:n.

Kaikkien koneelle asennettujen tiedostojen polut taas löytyvät Synapticilla katsomalla paketin ominaisuuksista (Properties > Installed files, enkkuversiossa).
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Tekno - 13.02.09 - klo:01.57
(http://img6.imageshack.us/img6/8016/totemgu9.th.png) (http://img6.imageshack.us/my.php?image=totemgu9.png)

noh, asensin sitten totem-gstreamerin ja tulos:
(http://ruohoranta.fi/galleries/sekalaiset/EeePC/_thumbs/700x500-totem2.png) (http://ruohoranta.fi/galleries/sekalaiset/EeePC/totem2.png)

eli TOIMII!

tosin kuva nykii pahasti. Mutta sekin on parempi kuin ei mitään.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: rale - 19.02.09 - klo:21.52
Sekä Areena että Elävä arkisto ovat tähän asti pelanneet ihan hyvin mutta nyt alkoivat oikuttelemaan. Välillä näkyy ja välillä ei lataudu ollenkaan. Jos näkyy niin äänessä kuuluu välillä kuin sian röhkimistä. ???
Asetuksiin ja ohjelmiin en ole koskenut.
Koskahan se YLE:n formaattimuutos pitäisi tulla?

Ja vielä:
Miten mediaplayer-connectivityllä asetetaan se tietty ohjelma. Selaa-painikkeen kautta tietty ja sieltä löytyy ohjelmien kansiot mutta mikä polku tarkalleen?
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: motalb - 20.02.09 - klo:09.36
Ja vielä:
Miten mediaplayer-connectivityllä asetetaan se tietty ohjelma. Selaa-painikkeen kautta tietty ja sieltä löytyy ohjelmien kansiot mutta mikä polku tarkalleen?

Polku on /usr/bin/X11/
Sieltä sitten etsit haluamasi ohjelman. Näin siis jos olet valinnut "Selaa...".

Jos ohjelman tarkka nimi on tiedossa niin voit myös kirjoittaa tai liittää osoitteen suoraan siihen kenttään.
Esimerkiksi Elokuvasoittimen (Totem) tarkka osoite on /usr/bin/X11/totem
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: rale - 20.02.09 - klo:11.54
Asensin tuon lisukkeen mutta nyt siinä mediaslistassa on vain Real Media. Aiemmin kun kokeilin tuota lisäosaa listassa oli paljon muutakin. Kokeilin velhoa mutta se jämähtää vähän aikaa etsittyään.

Edit:
Vaihdoin Firefoxiin uuden profiilin ja nyt sai valittua vlc:n soittimeksi. Sillä näyttäisi pelittävän sekä Areena että Arkisto!

Kiittää motalb ia!
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Senior - 21.02.09 - klo:17.52
Merkillinen juttu sinänsä, että Totem upotettuna Firefoxiin näyttää vierityspalkin. Sen sijaan VLC-playerillä mitään vastaavaa ei ole - ei edes hiiren kakkospainikkeella kuten Mplayerilla. Koska kaikenkaikkiaan useammat Areenan videot näkyvät Totemilla kuin Mplayerillä, niin en ole ottanut sen paremmin Mplayeriä kuin VLC-playeria Firefoxin oletus soittimeksi. Sen verran asiat ovat kuitenkin jo parantuneet syksystä lähtien, että tavalliset tallennetut videot näkyvät nykyisin aika hyvin sekä VLC:llä että Mplayerillä. Joten otetaanpa vähän takaisin aikaisempaa kritiikkiäni Mplayeriä ja VLC:tä kohtaan. Tilanne on siis tässä suhteessa parantunut.

Ehkä kiusallisin juttu nettivideoissa (Ylen Areena erityisesti) on se, että usein joudun tyhjentämään sivuhistorian ja käynnistämään videosivun uudestaan jotta Firefox näyttää videon. Usein nimittäin video ei heti lähde toimimaan tai se toimii ilman ääntä... Lisäki Ylen Arkiston puolella on tapauksia joissa video näyttää pelkkää mustaa, mutta ääni kuuluu. Täysin kunnossa tämä Ylen Areena toiminta ei ole vieläkään. Youtuben puolella ei ole ollut ongelmia sitten ensiviikkojen jälkeen.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: jussike - 26.02.09 - klo:01.20
Tuli asennettua Xubuntu 8.04 yhteen koneeseen ja oletin, että Areena toimii samaan tyyliin kuin Ubuntussakin. Eipäs toiminutkaan. Piti hikoilla hieman.

Xubuntu-restricted-extras sisältää näköjään vähemmän kodekkeja kuin ubuntu-restricted-extras. Jälkimmäisen asentamisella ei vielä toiminut, mutta ratkesi kun vaihdoin totem-gstreamerin totem-xineen.

Elikäs...
 
Poista:
totem-gstreamer

Asenna:
totem-mozilla
totem-xine
ubuntu-restricted-extras
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: TurpoNieminen - 07.03.09 - klo:23.03
Lainaan nyt tätä threadia senverran kun liippasee aikas läheltä nimittäin...

Täällä kanssa yksi alotteleva Ubuntun käyttäjä ja senverran pitkällä ollaan, että olen saanut kyllä nuo videot näkymään.
Ongelmana on kumminkin noiden videoiden kelaaminen (siis se slideri siinä videon alapuolella) ei toimi.
Asensin myös totem-xinen ja käytin ekalla sivulla olevia ohjeita, joilla vaihdoin tuon xinen käyttöön (en siis poistanut vielä gstreameria)
Etsintä videossa ei toimi kummallakaan (xinellä slideri ei yksinkertaisesti edes liiku, gtreamerilla se liikkuu mutta toisto lakkaa)
Oikeestaan ainoa minkä haluaisin saada toimimaan on nuo maxinetin videot eli wmv streamit http://tototv.maxinetti.fi/arkisto/index.php?vod_id=14037 (http://tototv.maxinetti.fi/arkisto/index.php?vod_id=14037)
Osaisiko joku sanoa voiko kelauksen niissä saada toimimaan tällä ubuntu 8.10 versiolla?
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: anttimr - 07.03.09 - klo:23.57
Lainaan nyt tätä threadia senverran kun liippasee aikas läheltä nimittäin...

Täällä kanssa yksi alotteleva Ubuntun käyttäjä ja senverran pitkällä ollaan, että olen saanut kyllä nuo videot näkymään.
Ongelmana on kumminkin noiden videoiden kelaaminen (siis se slideri siinä videon alapuolella) ei toimi.
Asensin myös totem-xinen ja käytin ekalla sivulla olevia ohjeita, joilla vaihdoin tuon xinen käyttöön (en siis poistanut vielä gstreameria)
Etsintä videossa ei toimi kummallakaan (xinellä slideri ei yksinkertaisesti edes liiku, gtreamerilla se liikkuu mutta toisto lakkaa)
Oikeestaan ainoa minkä haluaisin saada toimimaan on nuo maxinetin videot eli wmv streamit http://tototv.maxinetti.fi/arkisto/index.php?vod_id=14037 (http://tototv.maxinetti.fi/arkisto/index.php?vod_id=14037)
Osaisiko joku sanoa voiko kelauksen niissä saada toimimaan tällä ubuntu 8.10 versiolla?

Mulla on tässä 8.04, mutta eiköhän tilanne ole sama. Ainoa soitin, jolla wmv-virtojen kelaaminen edes jotenkuten onnistuu, on vlc. Asennapa sekin kokeeksi pakettivarastosta. Selaimeen upotetun soittimen oikeassa alanurkassa on painike, jonka takaa löytyy Kopioi (videon osoite). Avaa se osoite sitten vlc:ssä. Kelaus toimii, vaikkakin tökkien. Vlc-selainliitännäistä ei tarvitse asentaa - eikä ehkä kannatakaan.

Eräs vaihtoehto on ladata koko video ensin kiintolevylle ja katsoa vasta sitten. Silloin kelaus toimii kaikilla ohjelmilla. Ohjeita wmv-virran tallentamiseksi löytyy foorumilla näistä YLE-Areena ja muistakin ketjuista.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: TurpoNieminen - 08.03.09 - klo:00.54

Mulla on tässä 8.04, mutta eiköhän tilanne ole sama. Ainoa soitin, jolla wmv-virtojen kelaaminen edes jotenkuten onnistuu, on vlc. Asennapa sekin kokeeksi pakettivarastosta. Selaimeen upotetun soittimen oikeassa alanurkassa on painike, jonka takaa löytyy Kopioi (videon osoite). Avaa se osoite sitten vlc:ssä. Kelaus toimii, vaikkakin tökkien. Vlc-selainliitännäistä ei tarvitse asentaa - eikä ehkä kannatakaan.

Eräs vaihtoehto on ladata koko video ensin kiintolevylle ja katsoa vasta sitten. Silloin kelaus toimii kaikilla ohjelmilla. Ohjeita wmv-virran tallentamiseksi löytyy foorumilla näistä YLE-Areena ja muistakin ketjuista.

Kiits, siellä on myös tuo: Open with "Elokuvasoitin"
Jos saisin sen tuota kautta avautumaan VLChen, Totemin sijasta, ja kelaus toimisi, niin asia olisi oikein bueno.
Mitenhän tuo "Elokuvasoitin" vaihdetaan VLChen?

Tai vielä parempaa:
Mitenhän pitäisi confata tuota mozpluggerrc tiedostoa, että se avaisikin aina wmv streamit vlc:llä täysikkunassa eikä missään mozillan sisällä?

Itsellenihän kävisi tuo kopiointiratkaisukin, mutta säädän tätä konetta 65 vuotiaalle isälleni, jonka ainoa funktio tietokoneella on katsella noita videoita :)
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Antifilatelisti - 12.03.09 - klo:11.07

Tai vielä parempaa:
Mitenhän pitäisi confata tuota mozpluggerrc tiedostoa, että se avaisikin aina wmv streamit vlc:llä täysikkunassa eikä missään mozillan sisällä?

En tiedä sopiiko seuraava ratkaisu sinulle, mutta ainakin voit kokeilla,
1. Avaa mozillan asetuksetuksista välilehti ohjelmat (firefox->muokkaa-> asetukset->ohjelmat )
2.Etsit kohta windows media wideo ja muuta totem liitännäinen VLC:hen (katso kohta 3)
3. Saat lisättyä VLC:n kansiosta usr/bin/

Kelaus toimii !!onnistui, kun asensin mozilla vlc player pluginin. Edes tuota edelläolevaa säätöä ei tarvita.
Kelaus tapahtuu näppäin yhdistelmällä  shift+vasennuolinäppäin / oikeanuolinäppäin. Välilyönti on stop/play nappi
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: TurpoNieminen - 20.03.09 - klo:18.08
Sain itsekin toimimaan, siis avautumaan koko ruudussa VLCllä
Tarvitsi vain poistaa mozilla mplayer plugini ja tuo totem plugini. Disablointi firefoxin asetuksista ei riittänyt, eikä sekään että laittoi windows media video tiedostot avautumaan mozpluggerilla.
Vasta noiden muiden pluginien poiston jälkeen mozplugger heräsi henkiin ja nyt aukeaa ja kelautuu videot VLCssä.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Jouko-Pouko - 06.04.09 - klo:21.59
Ilouutisia Yle Areenan kanssa ongelmissa oleville ihmisille: http://www.digitoday.fi/viihde/2009/04/06/yle-areenan-uusi-versio-nyt-kaikkien-testattavissa/20099034/66?rss=6 (http://www.digitoday.fi/viihde/2009/04/06/yle-areenan-uusi-versio-nyt-kaikkien-testattavissa/20099034/66?rss=6) :)

Lainaus
Yle on julkaissut Areena-videopalvelun uuden version julkiseen testikäyttöön. Suurin muutos on se, että palvelu käyttää flash-videota entisen Windows Median sijaan. Sen ansiosta Areenan videot näkyvät nyt helposti myös muilla kuin Windows-koneilla.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Minna S - 06.04.09 - klo:22.08
^ Tuntuu toimivan hyvin :)
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Gooner - 06.04.09 - klo:22.38
Paras apu löytyy, kun kirjoittaa urliksi:

http://areena-beta.yle.fi

Twiikkausta jäljellä, välillä tökkii, mutta tuohan on beta. Hyvä Yle!
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: UbunTux - 06.04.09 - klo:23.18
Paras apu löytyy, kun kirjoittaa urliksi:

http://areena-beta.yle.fi

Twiikkausta jäljellä, välillä tökkii, mutta tuohan on beta. Hyvä Yle!
Wau. Kuvan taso on aivan eri planeetalta. H.264(?) on todellakin aivan eri planeetalta kuin wmv3. Mihinköhän päin kovalevyä  tuo video dumpataan?

Palikkashow on huomattavasti vähäisempi.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: motalb - 07.04.09 - klo:20.03
Paras apu löytyy, kun kirjoittaa urliksi:

http://areena-beta.yle.fi

Twiikkausta jäljellä, välillä tökkii, mutta tuohan on beta. Hyvä Yle!
Jippii, tätä on odotettu :D
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: ~unknown - 07.04.09 - klo:21.33
Jep, tuosta Subin ja MTV3n pitäisi ottaa mallia omissa netti-tv ihmevirityksissään, jotka ovat ainakin minulla toimineet huonosti, välillä eivät ole toimineet ollenkaan.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: jake - 07.04.09 - klo:22.17
joo, kuva on isompi 16:9 -mittasuhteeltaan, paljon terävämpi ja ääni selkeästi parempi
Seuraavaks sitt myös Yle arkisto samanlaiseksi
...ja molemmat tietty betasta -> valmiiksi - toivottavasti pian
...että ie 8-käyttäjätkin näkee uutiset ja vanhukset... ;) ?
Otsikko: Vs: yle areena uudistuu
Kirjoitti: Tomin - 07.04.09 - klo:22.37
http://www.tietokone.fi/uutta/uutinen.asp?news_id=37466&tyyppi=1

oli jo aikakin  8)

Montakohan kertaa näitä pitää yhdistellä, kun yhden jo poistin (aloittajan pyynnöstä siinä lyhyessä (lähinnä ilmoitettiin vastaavia ketjuja jo olevan) ketjussa). Ei sillä, että se nyt mitenkään "kauheeaa" on, mutta aika hauskaa, kun aina jonkun hyvän uutisen ilmestyessä saa yhdistellä aiheita... Tosin tästä Yle Areenasta löysin äsken ainakin pari ketjua, joten tiedä nyt sitten mihin tämä olisi ollut paras yhdistää... ::)

Hieman hämmentävää joskus. :)
Otsikko: Vs: yle areena uudistuu
Kirjoitti: mikko_h - 08.04.09 - klo:03.25
http://www.tietokone.fi/uutta/uutinen.asp?news_id=37466&tyyppi=1

oli jo aikakin  8)

Halleluja! Nähtävästi Youtube & kumppanit ovat tehneet tehtävänsä siinä mielessä, että kovin paljon huonommin ja harvemmissa laitteissa toimivaa systeemiä ei siedetä.

Tulin kokeilleeksi Firefox 3.1:n beta-versiota, ja siinä Ogg Theora -videot toimivat suoraan selaimessa ilman mitään lisäkkeitä ja ja kodek on HTML 5 -standardin mukainen ja lisenssi vapaa. Olisko siinä seuraava tavoite Ylelle...
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: aho - 08.04.09 - klo:08.23
Kertoilkaa kun saatte tietää miten nuo videot saa näpsäkästi tallennettua.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Tha-Fox - 08.04.09 - klo:12.42
Eikös tuohon flashin tallentamiseen noita härpättimiä löydy? Itse olen aina hoitanut homman Firefoxin lisäosilla.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: mikko_h - 08.04.09 - klo:16.51
Kertoilkaa kun saatte tietää miten nuo videot saa näpsäkästi tallennettua.

Linuxin Flash-plugin tallentaa Youtuben ja useimpien muiden nettivideosysteemien videot /tmp -hakemistoon. Tiedoston nimi on joku kryptinen kirjainsarja, ja tiedostot katoaa kun selain/sivu suljetaan. Sivun ollessa vielä auki videot saa sieltä talteen kopioimalla, jos ei fantsumpia systeemejä satu olemaan käsillä.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Tomin - 08.04.09 - klo:16.54
Juu alunperin itsekin kopioin ne tuolta /tmp:stä, mutta nyt tulee käytettyä DownloadHelperiä. :)
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: jake - 13.04.09 - klo:11.47
Ei pääsiäinen oo kaikille pelkästään susrun juhla (muistopäivä)
kts vaikka:
Pingu hääjuhlissa:
http://areena-beta.yle.fi/player/index.php?clip=50334&language=fi

...sopii mun ikäisille ja kaikille mua nuoremmille...
tai voi olla, ett puberteetti-ikäiset saattaa hiukka vierastaakin...
joten testaa itsesi ;)
Otsikko: Vs: Yle areena siirtyy flashiin
Kirjoitti: Tomin - 13.04.09 - klo:16.39
http://areena-beta.yle.fi/

http://areena-beta.yle.fi/info/7

Jes. Vielä yksi viesti yhdistettäväksi... ::) :D

Mikäs ketju se olikaan "virallinen" Yle areena -ketju.
Otsikko: Vs: Yle areena siirtyy flashiin
Kirjoitti: gdm - 13.04.09 - klo:17.03
http://areena-beta.yle.fi/

http://areena-beta.yle.fi/info/7

Jes. Vielä yksi viesti yhdistettäväksi... ::) :D

Mikäs ketju se olikaan "virallinen" Yle areena -ketju.

Tämähän se taitaa olla.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Kurskin torpedo - 18.04.09 - klo:23.47
Vanhassa Areenassa löytyi oikea ohjelman urli komennolla "kopio linkin osoite" ja se toimi mm. VLC:ssä, jolloin pystyi vlc:llä tallentamaan ohjelman. Nyt "kopioi linkin osoite" tai maalaamalla ja kopioimalla ruudun yläreunasta osoitteen kumpikaan ei toimi VLC:ssä.  Mistäs sen ohjelman oikean osoitteen löytää ?
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Tomin - 19.04.09 - klo:11.32
Se on nyt flashiä joten ei taida onnistua niin. Nuo videot muuten latautuvat /tmp-hakemistoon Flash* nimillä, joten katsoppas sieltä mikäli niitä haluat ottaa talteen tai asenna DownloadHelper-lisäosa Firefoxiin.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: gdm - 19.04.09 - klo:11.36
Se on nyt flashiä joten ei taida onnistua niin. Nuo videot muuten latautuvat /tmp-hakemistoon Flash* nimillä, joten katsoppas sieltä mikäli niitä haluat ottaa talteen tai asenna DownloadHelper-lisäosa Firefoxiin.

Ei lataudu enää...

Täytyy keksiä uudet kikat...
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: jake - 19.04.09 - klo:11.54
...tvkaista.fi... ;)
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: UbunTux - 19.04.09 - klo:12.11
Täytyy keksiä uudet kikat...
Kuten käyttää wanhaa   ;D

...tvkaista.fi... ;)
...tai normaali DVB... ;)
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Tomin - 19.04.09 - klo:12.26
Se on nyt flashiä joten ei taida onnistua niin. Nuo videot muuten latautuvat /tmp-hakemistoon Flash* nimillä, joten katsoppas sieltä mikäli niitä haluat ottaa talteen tai asenna DownloadHelper-lisäosa Firefoxiin.

Ei lataudu enää...
Harmi. Mitenkäs TVNetissä?
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Risto H. Kurppa - 20.04.09 - klo:00.22
joo olisi aika mielenkiintoista tietää saako noita jotenkin a) upotetua muille sivuille (tietty olisi kivin jos Yle suoraan tarjoiais moisen) tai b) latailtua jemmaan omalle koneelle päiväksi, pariksi, kun huomaa noita '1 päivä jäljellä' -juttuja liian myöhään eikä kerkeä heti katselemaan..

r
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: hss-kobolt - 26.04.09 - klo:11.05
Areenan osoite näyttäs olevan muotoa http://areena-beta.yle.fi/

eli ei pisteellä vaan viivalla.

google haku:

http://www.google.fi/search?hl=fi&q=yle+areena+beta&btnG=Hae&meta=lr%3Dlang_fi
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Tomin - 26.04.09 - klo:11.14
Areenan osoite näyttäs olevan muotoa http://areena-beta.yle.fi/

Juu näin on. :) Miten niin? ???
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: JocceKoo - 07.05.09 - klo:10.33
Moi,

onko ketään saanut http://yle.fi/elavaarkisto/?s=s&g=1&ag=86&t=321&a=2291 videota toimimaan ubuntussa noilla aloituspostissa olevilla ohjeilla?
Kaikki muut videot tuolla elävässä arkistossa toimii, paitsi tuo kyseinen video.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: salai - 07.05.09 - klo:10.52
Moi,

onko ketään saanut http://yle.fi/elavaarkisto/?s=s&g=1&ag=86&t=321&a=2291 videota toimimaan ubuntussa noilla aloituspostissa olevilla ohjeilla?
Kaikki muut videot tuolla elävässä arkistossa toimii, paitsi tuo kyseinen video.

Voisiko joku viimeinkin selittää, miksi tuota gstreameriä tyrkytetään joka paikassa käyttäjille?

Sillähän ei voi katsella edes suoria ravilähetyksiä, eikä se muuallakaan toimi kunnolla - ei näytä esim. Ylen tekstityksiä dvb:llä (siis digikortin kanssa)

Ensimmäinen asia mitä teen kaikissa distroissa on sen poisto ja totem-xinen asennus.
Tässä on nyt vaihteeksi alla Mandriva Linux One 2009 Spring (gnome), eikä mitään ongelmia tuonkaan videon kanssa.
Ja täälläkin oli gstreamer oletuksena.

Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: JocceKoo - 07.05.09 - klo:10.56

Voisiko joku viimeinkin selittää, miksi tuota gstreameriä tyrkytetään joka paikassa käyttäjille?

Sillähän ei voi katsella edes suoria ravilähetyksiä, eikä se muuallakaan toimi kunnolla - ei näytä esim. Ylen tekstityksiä dvb:llä (siis digikortin kanssa)

Ensimmäinen asia mitä teen kaikissa distroissa on sen poisto ja totem-xinen asennus.
Tässä on nyt vaihteeksi alla Mandriva Linux One 2009 Spring (gnome), eikä mitään ongelmia tuonkaan videon kanssa.
Ja täälläkin oli gstreamer oletuksena.


Eli korjaukseen riittää kun poistaa paketin gstreamer ja asentaa totem-xinen?
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: gdm - 07.05.09 - klo:11.00
Moi,

onko ketään saanut http://yle.fi/elavaarkisto/?s=s&g=1&ag=86&t=321&a=2291 videota toimimaan ubuntussa noilla aloituspostissa olevilla ohjeilla?
Kaikki muut videot tuolla elävässä arkistossa toimii, paitsi tuo kyseinen video.

Voisiko joku viimeinkin selittää, miksi tuota gstreameriä tyrkytetään joka paikassa käyttäjille?

Jossain vaiheessa xine moottori käytti suljettuja windowsin kodekkeja median toistoon, joten sen jakelu suoraan saattaa rikkoa kaikenlaisia lakeja.

gstreamer taas on vapaa, joten ymmärrettävää sen käyttö.

Tuo linkki toimi ihan oikein täällä, Firefox-3.5 ja totem-gstreamer yhdistelmä.
ubuntu-restricted-extras asennettu.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: JocceKoo - 07.05.09 - klo:13.10
Jees. No en tiedä kyllä sitten missä kiikastaa, firefox:sta on versio 3.0 jotain käytössä. Ja aloituspostin mukaan olen tehnyt. Sinäänsä hassua, että kaikki muut Elävän Arkiston pätkistä toimivat loistavasti, mutta tuo yksi ei.

Videosta tulee siis "ensimmäinen frame" näkyviin, mutta siihen se jääkin. Ääntä ei siis kuulu missään vaiheessa, ja tulee todellakin vain yksi still-kuva videon sijasta. Ei auta vaikka kuinka koittaisi F5:sta painella tai muuta.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Tekno - 09.05.09 - klo:23.05
Miten tuon MTV3 katsomon nyt saa toimimaan  ???
Ubuntu restricted extras asennettu. Ylen areena ja nelosen nettitv kyllä toimivat.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: ajaaskel - 09.05.09 - klo:23.31
VLC Multimedia Plug-in
Version 0.9.9a Grishenko
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: jussike - 10.05.09 - klo:01.18
VLC Multimedia Plug-in
Version 0.9.9a Grishenko


Minusta tuo VLC:n plugini on tällä hetkellä paras kompromissi. Ei nyvi areenan videot (niinkuin totem-gstreamer ja myös totem-xine). Ja tosiaan kun tuo maikkari näkyy myös. Ja olikohan niin että juurikin tuolla VLC:llä pystyi myös kelaamaan Areenan pätkiä.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: salai - 12.05.09 - klo:08.18
Minusta tuo VLC:n plugini on tällä hetkellä paras kompromissi. Ei nyvi areenan videot (niinkuin totem-gstreamer ja myös totem-xine). Ja tosiaan kun tuo maikkari näkyy myös. Ja olikohan niin että juurikin tuolla VLC:llä pystyi myös kelaamaan Areenan pätkiä.

Mozilla-plugin-vlc ei todellakaan ole mikään yleispätevä ratkaisu.

1. Se ei lähes koskaan - ainakaan minulla - suostu näyttämään Elävän arkiston videoita. Paitsi, jos kopioin videon osoitteen totem-xinestä, joka siis toimii aina, eikä nyi.

2. Se on käyttöliittymältään pahnanpohjimmaisin kaikista plugineista: Ei mitään näkyviä kontrolleja, eikä edes mahdollisuutta avata videota erilliseen soittimeen - kuten totem-xinessä.


Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: ajaaskel - 12.05.09 - klo:11.08
Yllä "Tekno" kysyi miten saa mtv3: n näkymään ja vastasin siihen.  Olen tietoinen rajoituksesta että Elävä arkisto ei aukea kun mainitsemani mozilla-plugin-vlc on päällä. Onneksi näitä on helppo sammuttaa ja laittaa takaisin päälle napista. Kun sammutan sen Firefoxin pluginien hallinnasta niin Elävä arkisto näkyy kun avaa sen hiiren oikealla elokuvasoittimeen.    Yleispätevää pluginia ei vielä ole --- sorry.  Sopivalla kokoelmalla plugineja näkyy paljon, kun vain tietää sammuttaa tarpeettoman hetkeksi tieltä pois... ;)


Pieni lisäys vielä:  Kun avaat elokuvasoittimen hiiren oikealla niin kuin sanoin yllä ja jos saat viestin "oikeutesi eivät ehkä rittäneet" niin käy katsomassa Synapticin (Järjestelmä/Ylläpito/Synaptic-pakettienhallinta) avulla että sinulla ei ole "totem-plugins-extra" asennettuna. Jostain syystä tuo näytti aihettavan kyseisen ongelman itselläni ja ongelma häipyi kun poistin kyseisen osan.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: jussike - 12.05.09 - klo:11.41
Minusta tuo VLC:n plugini on tällä hetkellä paras kompromissi. Ei nyvi areenan videot (niinkuin totem-gstreamer ja myös totem-xine). Ja tosiaan kun tuo maikkari näkyy myös. Ja olikohan niin että juurikin tuolla VLC:llä pystyi myös kelaamaan Areenan pätkiä.
Mozilla-plugin-vlc ei todellakaan ole mikään yleispätevä ratkaisu.

Jeps, pitää ottaa vähän kehuja takaisin. Eilen tappelin yhden maikkaripätkän kanssa, näkyi vlc:llä aina vain 4 minuuttia alusta eikä yhtään enempää. Onneksi mplayer osasi dumpata senkin streamin.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Tomin - 12.05.09 - klo:15.40
Minusta tuo VLC:n plugini on tällä hetkellä paras kompromissi. Ei nyvi areenan videot (niinkuin totem-gstreamer ja myös totem-xine). Ja tosiaan kun tuo maikkari näkyy myös. Ja olikohan niin että juurikin tuolla VLC:llä pystyi myös kelaamaan Areenan pätkiä.
Mozilla-plugin-vlc ei todellakaan ole mikään yleispätevä ratkaisu.

Jeps, pitää ottaa vähän kehuja takaisin. Eilen tappelin yhden maikkaripätkän kanssa, näkyi vlc:llä aina vain 4 minuuttia alusta eikä yhtään enempää. Onneksi mplayer osasi dumpata senkin streamin.

Minulla on ollut sama ongelma kun olen katso...yrittänyt katsoa Myytinmurtajia netistä (ja joskus duudsoneja). :( Enpä ole kokeillut dumpata mplayerillä...
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: jimbo - 17.05.09 - klo:15.53
lähinnä katselee uutisia areenasta ja tv3, ennen 8.10:
+areena toimi ok (ennen flash muutosta)
- urheiluruutua piti katsella vlc:llä
- tv3 vain wintoosassa  :-\

nyt 9.04 testilevyllä käytössä, tuli kokeiltua miten näkyy clipit, asennus puhtaalle levylle ok ja Ubuntu restricted
extras (ei ollut 8.10) eikä muita virityksiä

areena, vanhan mallinen:
+ uutiset toimii ja jopa palkista vetäminen eteenpäin melkein aina :-)
(ei toiminut 8.10)

- kuva (paras) asetuksella on huonompilaatuinen kuin 8.10  :-\
ja pientä nykimistä joka ei paljoa haittaa (näytönohjaimesta on uusin ajuri)

- urheiluruutua pitää edelleen katsella vlc:llä (0.9.9a Grishenko)

- tv 3 ei toimi  :-\ -> wintoosassa katselu jatkuu...
(katsomossa ei löydä fileä)

kovasti ei jaksaisi viritellä, plussaa olisi, jos kaiken näkisi ubuntussa ja
kuvanlaatu olisi kuten ennen, taitaa tapoja/virityksiä olla yhtä monta,
kuin on käyttäjiäkin  ;)

Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: mora - 21.05.09 - klo:22.46

- tv 3 ei toimi  :-\ -> wintoosassa katselu jatkuu...
(katsomossa ei löydä fileä)

kovasti ei jaksaisi viritellä, plussaa olisi, jos kaiken näkisi ubuntussa ja
kuvanlaatu olisi kuten ennen, taitaa tapoja/virityksiä olla yhtä monta,
kuin on käyttäjiäkin  ;)



Olen myös etsinyt oikeaa lisäosakokoonpanoa Firefoxille jonkin aikaa että näkyisi yleareena, maikkarin katsomo ja juutuubi. Alla 64-bit 9.04. Tämän hetken tilanne on että yleareena ja juutuubi toimii osittain, mutta kun klikkaa ylellä korkealaadun päälle tai youtubessa hq:n niin siihen stoppaa. Maikkarin katsomo ei avaudu. Tilanne ihan sama Epiphanyssa. Asennettuna adoben flashplayer-plugin mozilla/plugin-kansioon, laajennuksia ei päällä, lisäosissa lähes kaikki mahdollinen mediapluginin on päällä. Mikähän olisi se plugin/laajennuskokoonpano että kaikki nämä kolme videotarjoajaa toimii ja myös se korkealaatuvalinta niin ettei välillä tarvi käydä "säätämässä" lisäosia?
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Antifilatelisti - 09.06.09 - klo:12.22
Minulla on aina toiminut ylen,youtuben ym. videot suoraan asennettuani ubuntu-restricted exstras paketin. MTV 3:n kanssa lähinnä ollut ongelmia.  Xine härpäkkeillä taas myös MTV 3 on toiminut suoraan, mutta lähdekoodistakin voi videon tarvittaessa napata.   
Otsikko: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Vaarala - 22.06.09 - klo:02.04
Mitenkäs tuosta uudesta Areenasta saa videon kokoruutuun? Kun koittaa klikata sitä kokoruutunappia niin mitään ei tapahdu. Ubuntun versio on 8.04, Firefox 3.0.11
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: pttk - 22.06.09 - klo:02.15

Ihan samat emmeet ja toimii tuo kokoruututila, ainoa haitta jos haitaksi voi sanoa on alareunaan näkyviin jäävä aikapalkki.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: PenguinNerd - 26.06.09 - klo:08.37
Meikäläisen havainnon mukaan Areena ja Elävän arkiston katselemisessa videoiden toisto-ohjelmat (mplayer, totem) kyllä toimivat, mutta Ylen palvelinten lähettämä videovirta katkeilee varsin usein ainakin ns. parhaisiin katseluaikoihin. Sunnuntaina päivällä yleensä toimii. ... jne
Minulla ainakin koko YLE  areena ei ole toiminut ollenkaan parhaisiin katseluaikoihin. Sivu ei ole edes latautunut, mutta johtuneeko se "pikkuisen" kaistaa vievästä pikkuveljeni käyttäjätilillä pyörivästä tiedostojenjako-ohjelmasta ::). (Pahuksen tiedostojenjako-ohjelmat  >:( )
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: redu - 26.06.09 - klo:18.08
Esimerkiksi:   http://areena-beta.yle.fi/video/281265

Ainoa Flash, joka minun koneissani (pöytäkone ja läppäri) pelittää Areenassa on
adobe-flashplugin 10.0.
Mikään muu Flashi ei avnnut kuvaa! Sitäpaitsi: Kaikki muut Flash-pluggarit piti poistaa koneista, ennenkuin tuo ainoa toimiva = "Adobe" muuttui toimivaksi!

On kummallista, että adobe-flashplugin 10 löytyi pöytäkoneen synapticistasta valmiina, mutta ei läppärin synapticista? Vaikka kummassakin on täsmälleen sama Jaunty-versio.
Löysin vastaavan "adoben" kannettavaan jostakin sourceforcesta (.deb). Kun asensin sen, niin asennusikkuna väitti, että sama löytyy uudempana reposta. Vaan kun ei löydy! Eikä löydy edes täältä:
http://packages.ubuntu.com/jaunty/allpackages
Ilman leikkiä kahdella koneella en kai olisi koskaan saanut Areenaa pelittämään Jauntyssa?

No,
nyt pelittää hyvin 1M:n mobiililaajakaistallani. Kuvan laatu on tosiaan hyvä. Areenaa on ruvettava katselemaan enemmänkin.

redu
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: jis - 26.06.09 - klo:20.38
On kummallista, että adobe-flashplugin 10 löytyi pöytäkoneen synapticistasta valmiina, mutta ei läppärin synapticista? Vaikka kummassakin on täsmälleen sama Jaunty-versio.

adobe-flashplugin on kolmannen osapuolen partner-repositoriossa, jonka voi sallia ohjelmalähteiden hallinnasta.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Tomin - 28.06.09 - klo:20.55
Meikäläisen havainnon mukaan Areena ja Elävän arkiston katselemisessa videoiden toisto-ohjelmat (mplayer, totem) kyllä toimivat, mutta Ylen palvelinten lähettämä videovirta katkeilee varsin usein ainakin ns. parhaisiin katseluaikoihin. Sunnuntaina päivällä yleensä toimii. ... jne
Minulla ainakin koko YLE  areena ei ole toiminut ollenkaan parhaisiin katseluaikoihin. Sivu ei ole edes latautunut, mutta johtuneeko se "pikkuisen" kaistaa vievästä pikkuveljeni käyttäjätilillä pyörivästä tiedostojenjako-ohjelmasta ::). (Pahuksen tiedostojenjako-ohjelmat  >:( )

Kenellä on rootin oikeudet? ;)
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: PenguinNerd - 28.06.09 - klo:21.02
Meikäläisen havainnon mukaan Areena ja Elävän arkiston katselemisessa videoiden toisto-ohjelmat (mplayer, totem) kyllä toimivat, mutta Ylen palvelinten lähettämä videovirta katkeilee varsin usein ainakin ns. parhaisiin katseluaikoihin. Sunnuntaina päivällä yleensä toimii. ... jne
Minulla ainakin koko YLE  areena ei ole toiminut ollenkaan parhaisiin katseluaikoihin. Sivu ei ole edes latautunut, mutta johtuneeko se "pikkuisen" kaistaa vievästä pikkuveljeni käyttäjätilillä pyörivästä tiedostojenjako-ohjelmasta ::). (Pahuksen tiedostojenjako-ohjelmat  >:( )

Kenellä on rootin oikeudet? ;)
Minulla. Ja olen kyllä potkinutkin veljen tilin pihalle, kun hermot menee.  ;D Mutta riitahan siitä syntyy..   :P
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: peran - 28.06.09 - klo:21.48
Minulla. Ja olen kyllä potkinutkin veljen tilin pihalle, kun hermot menee.  ;D Mutta riitahan siitä syntyy..   :P

Rajoita veljesi tiedostojenjako-ohjelmien kaistaa. Luultavasti sen saa määriteltyä jakoohjelmista. Siitä ei varmaan hirveetä riitaa tule, vaikka ehkä vähän sanomista.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: nm - 30.06.09 - klo:17.31
On kummallista, että adobe-flashplugin 10 löytyi pöytäkoneen synapticistasta valmiina, mutta ei läppärin synapticista? Vaikka kummassakin on täsmälleen sama Jaunty-versio.
Löysin vastaavan "adoben" kannettavaan jostakin sourceforcesta (.deb). Kun asensin sen, niin asennusikkuna väitti, että sama löytyy uudempana reposta. Vaan kun ei löydy! Eikä löydy edes täältä:
http://packages.ubuntu.com/jaunty/allpackages

Siellä on paketti "flashplugin-installer (10.0.22.87ubuntu2) [multiverse]".
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: redu - 01.07.09 - klo:20.03
On kummallista, että adobe-flashplugin 10 löytyi pöytäkoneen synapticistasta valmiina, mutta ei läppärin synapticista? Vaikka kummassakin on täsmälleen sama Jaunty-versio.
Löysin vastaavan "adoben" kannettavaan jostakin sourceforcesta (.deb). Kun asensin sen, niin asennusikkuna väitti, että sama löytyy uudempana reposta. Vaan kun ei löydy! Eikä löydy edes täältä:
http://packages.ubuntu.com/jaunty/allpackages

Siellä on paketti "flashplugin-installer (10.0.22.87ubuntu2) [multiverse]".

Repoon ilmestyi adobe-flashplugin 10.0.22.87-2jaunty, kun ruksasin "software sources":issa "partner (Source Codes)". Hö! Miksei pelkällä partner-ruksauksella? Miksi Sources? No hyvä kuitenkin, tämä on juuri se  ainoa flash-plugin minun koneissani, joka pelittää Areenassa. Edellyttäen, että  kaikki muut flash-pluggarit on poistettu!

redu
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: vastis - 06.07.09 - klo:15.45
Moi,
onko muilla sitä ongelmaa, että Areenan videot käynnistyvät kiusallisen hitaasti? Tämän foorumin ja linux.fi -sivuston ohjeilla videot saa näkymään, mutta vasta 10-15 min odottelun jälkeen. Tämä ns. ominaisuus on sekä videoissa että audioissa (mm ylen nettiradiot). Muutoin Areena toimii kuten pitääkin. Youtuben flashit toimivat oikein. Käytössä on Ubuntu 9.04, Flash Player 10, Firefox 3.0 ja ainakin paketit:

totem-plugins, totem-common, totem-mozilla, totem-gstreamer, mozilla-plugin-vlc ja ubuntu-restricted extras.

Paketit totem-xine ja mplayer-mozilla on poistettu. Kokemuksia, neuvoja?
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Nake - 06.07.09 - klo:17.14
Tosiaan tämä Yle Areena vie toimimattomuudellaan hermot.  Ihanat ruusut sen sijaan voi antaa esim. SVT:lle http://svt.se/ ja Rtve:lle http://www.rtve.es/, joita paremman puutteessa käytän päivittäin uutisseurantaan, heräävät nopeasti  ja toimivat  hyvin (Kubuntu 9.10, Firefox 3.5 ja Adobe Flash 10).  Mikähän Ylellä mättää?
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Matu - 06.07.09 - klo:17.54
Itsellä Yle areenan videot toimivat ihan hyvin. Ei tarvitse odotella mitään sen enempään. Video lähtee pyörimään, kun sen laittaa päälle. Firefox ja Flashin versio 10,0,22,87 käytössä.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Tha-Fox - 07.07.09 - klo:08.13
Täällä toimi myös, kun oli asentanut vain Ubuntun ja restricted-extras -paketin.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Stuge - 07.07.09 - klo:21.32
Omituista kyllä, itsellänikin toimii tuo Elävä arkisto pienellä ruudulla. Jos haluaa koko ruudulle, kuva alkaa tahmaamaan. Käytössä on Ubuntu 9.04. Kokeilin asentaa uudestaan juuri tuon flashin 10.xx. Kävin sen oikein Adoben sivulta lataamassa. Mitähän tässä kannattaisi roplata, vai nostanko kädet pystyyn.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: jis - 07.07.09 - klo:21.50
Omituista kyllä, itsellänikin toimii tuo Elävä arkisto pienellä ruudulla. Jos haluaa koko ruudulle, kuva alkaa tahmaamaan.

Hakusana: yle-dl
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Stuge - 07.07.09 - klo:23.32
Omituista kyllä, itsellänikin toimii tuo Elävä arkisto pienellä ruudulla. Jos haluaa koko ruudulle, kuva alkaa tahmaamaan.

Hakusana: yle-dl

Haettu. Ilmeisesti olen liian tyhmä/aloittelija. Ei aukene. Areena ja Elävä arkisto näkyvät edelleen pienenä hyvin, mutta koko näytöllä tahmaa.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: jis - 08.07.09 - klo:06.28
Haettu. Ilmeisesti olen liian tyhmä/aloittelija. Ei aukene. Areena ja Elävä arkisto näkyvät edelleen pienenä hyvin, mutta koko näytöllä tahmaa.

Siis Googlella tai tämän foorumin haulla löytyy http://linux.fi/wiki/Yle-dl (http://linux.fi/wiki/Yle-dl). Flash-pluginilla tahmaa kokoruututilassa, jollei kone ole huippunopea, mutta jos lataa videon yle-dl:llä ja katsoo erillisellä soittimella (esim. VLC) niin tahmaa vähemmän. Videon katsomisen voi aloittaa jo ennen kuin video on kokonaan ladattu.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: PenguinNerd - 08.07.09 - klo:07.22
Haettu. Ilmeisesti olen liian tyhmä/aloittelija. Ei aukene. Areena ja Elävä arkisto näkyvät edelleen pienenä hyvin, mutta koko näytöllä tahmaa.

Siis Googlella tai tämän foorumin haulla löytyy http://linux.fi/wiki/Yle-dl (http://linux.fi/wiki/Yle-dl). Flash-pluginilla tahmaa kokoruututilassa, jollei kone ole huippunopea, mutta jos lataa videon yle-dl:llä ja katsoo erillisellä soittimella (esim. VLC) niin tahmaa vähemmän. Videon katsomisen voi aloittaa jo ennen kuin video on kokonaan ladattu.

Minä taas olen pienentänyt näytön resuluutiota vastaavissa ongelmissa ja heti on tahmaaminen loppunut. (Taitaa Flash olla huonoa koodia  :P, kun on kerran niin tavattoman raskas.) Entisellä ja tosi wanhalla koneellani en Flashia saanut toimimaan itkemälläkään!
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: jassoo - 08.07.09 - klo:09.51
Olenkohan jostain jäänyt paitsi,? sillä tuo yleareena ohjelman katselu onnistuu hetimiten ilman minkään hakemisia erikseen???
Siis jos puuttuu flash,niin sehän ilmoitetaan suoraan siinä videossa jos puuttuu,,ja itse varmaan olen jossain vaiheessa sen ladannu-
automaattisesti ja toimii normaalisti kaikki videon katselut tällä hetkellä.... 8)
Näytönohjain on ati express mobile 1100..
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: anttimr - 08.07.09 - klo:14.29
Haettu. Ilmeisesti olen liian tyhmä/aloittelija. Ei aukene. Areena ja Elävä arkisto näkyvät edelleen pienenä hyvin, mutta koko näytöllä tahmaa.

Siis Googlella tai tämän foorumin haulla löytyy http://linux.fi/wiki/Yle-dl (http://linux.fi/wiki/Yle-dl). Flash-pluginilla tahmaa kokoruututilassa, jollei kone ole huippunopea, mutta jos lataa videon yle-dl:llä ja katsoo erillisellä soittimella (esim. VLC) niin tahmaa vähemmän. Videon katsomisen voi aloittaa jo ennen kuin video on kokonaan ladattu.

Olen kiertänyt kokoruudun Flashin raskaan toiminnan käyttämällä Compizin zoomia. Se onkin oletuksena työpöytätehosteissa käytettävissä vasenta win-näppäintä painamalla ja hiiren rullaa pyörittämällä. Skaalaus isommaksi tapahtuu grafiikkapiirin ominaisuuksien avulla, mitä ei prosessorikuormasta päätellen koko ruudun flash-esityksessä tapahdu (Intelin näytönohjaimella).

Jos komposoitu ikkunointi ei jostain syystä ole vaihtoehto, silloin tämä vinkki ei tietenkään auta.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Tomin - 08.07.09 - klo:16.21
Olen kiertänyt kokoruudun Flashin raskaan toiminnan käyttämällä Compizin zoomia. Se onkin oletuksena työpöytätehosteissa käytettävissä vasenta win-näppäintä painamalla ja hiiren rullaa pyörittämällä. Skaalaus isommaksi tapahtuu grafiikkapiirin ominaisuuksien avulla, mitä ei prosessorikuormasta päätellen koko ruudun flash-esityksessä tapahdu (Intelin näytönohjaimella).
Ei ilmeisesti NVidioillakaan, koska minullakin tuo vaikuttaa eli ei luultavasti yhtään millään näyttiksellä... :(
Mutta joka tapauksessa ihan hyvä ratkaisu, kiitos siitä. :)
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: svea - 14.07.09 - klo:10.15
Asensin 9.04 koneelle 8.04:n tilalle. Ja vanhasta muistista asensin ubuntu-restricted-extras -paketin. Sen jälkeen vasta muistin, että areena toimii nykyään flashilla. Paitsi ettei toimi minun koneellani. Esimerkiksi youtuben videot näkyvät, mutta Yle Areena ei toimi, videon sijaan näkyvillä on ainoastaan musta ruutu.

Mistäköhän ongelma voi johtua, koska Flashista pitäisi koneellani olla 10-versio? Eikä toimi Elävä Arkistokaan, vaikka tuo ubuntu-restricted-extras on asennettu...

Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: nm - 14.07.09 - klo:13.27
Tarkista, mitä Flash-versiota Firefox käyttää: avaa about:plugins -sivu selaimeen ja etsi sieltä Shockwave Flash. Version pitäisi olla 10.0 r22.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: vastis - 14.07.09 - klo:13.30
...
Paitsi ettei toimi minun koneellani. Esimerkiksi youtuben videot näkyvät, mutta Yle Areena ei toimi, videon sijaan näkyvillä on ainoastaan musta ruutu.
...

Voisiko olla sama ongelma kuin jonka kuvasin viestissä #109? Kokeile, svea, avata video selaimella tavalliseen tapaan ja jää odottamaan n. varttitunniksi. Itellä toimii pienen (=kiusallisen pitkän) odottelun jälkeen. Onko sama ongelma myös esim Ylexin nettiradiossa?
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: svea - 14.07.09 - klo:19.16

Jeps, on versio 9.0 r999, vaikka koneelle on ladattu tuo 10. Miten mä saan sen vaihdettua?
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: nm - 14.07.09 - klo:19.40
Aseta Firefox näyttämään pluginin sijainti (http://news.cnet.com/8301-13554_3-9917431-33.html) levyllä, jotta voit poistaa sen.

Ongelma ja ratkaisu taitaa tosin olla sama kuin täällä: http://forum.ubuntu-fi.org/index.php?topic=27743.msg212463#msg212463
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: tetrao - 15.07.09 - klo:17.55
Lainaus
Aseta Firefox näyttämään pluginin sijainti levyllä, jotta voit poistaa sen.

Kiitos, noilla ohjeilla sain toimimaan. Itellä oli kanssa tuo pluggari ongelma.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: vastis - 05.08.09 - klo:18.14
Moi,
onko muilla sitä ongelmaa, että Areenan videot käynnistyvät kiusallisen hitaasti?
...

Ongelma ilmeneekin näköjään vain ulkomailla. Suomeen paluun jälkeen toimii taas hyvin.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: redu - 06.09.09 - klo:07.57
Kuvasuhdeongelma!
Olen tässä katsellut suoria lentopallon EM-pelejä areenassa. TV-kanavilla ne ovat vain lyhenneltyinä ja keskellä yötä. Mobiililaajakaista 1M näyttää riittävän. Hyvä.

Mutta kuvasuhde näyttää menevän väkisin PC:n näytön raamien mukaiseksi. Kun minulla on kaikissa PC:issä litteä näyttö, niin kaikki lyhenee pituussuunnassa. Kiusallista. Saako näytön kuvasuhdetta säädettyä jollakin Compiz-tempulla Ubuntussa?

redu
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: UbunTux - 06.09.09 - klo:11.37

Mutta kuvasuhde näyttää menevän väkisin PC:n näytön raamien mukaiseksi. Kun minulla on kaikissa PC:issä litteä näyttö, niin kaikki lyhenee pituussuunnassa. Kiusallista. Saako näytön kuvasuhdetta säädettyä jollakin Compiz-tempulla Ubuntussa?

redu
yle-dl + jokin kunnollinen soitin  ;)
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: redu - 07.09.09 - klo:08.07

Mutta kuvasuhde näyttää menevän väkisin PC:n näytön raamien mukaiseksi. Kun minulla on kaikissa PC:issä litteä näyttö, niin kaikki lyhenee pituussuunnassa. Kiusallista. Saako näytön kuvasuhdetta säädettyä jollakin Compiz-tempulla Ubuntussa?

redu
yle-dl + jokin kunnollinen soitin  ;)

Kiitos UbunTux,
muttakun tarkoituksena on katsella suoraa lähetystä suorana? Kokeilin joskus yle.dl:ää, kun tallensin flash-filun areenasta. Mutta en muista, että sillä voisi katsella suorana?

redu
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: nm - 07.09.09 - klo:10.13

Mutta kuvasuhde näyttää menevän väkisin PC:n näytön raamien mukaiseksi. Kun minulla on kaikissa PC:issä litteä näyttö, niin kaikki lyhenee pituussuunnassa. Kiusallista. Saako näytön kuvasuhdetta säädettyä jollakin Compiz-tempulla Ubuntussa?

En ole katsonut livelähetyksiä, mutta minulla tätä ei tapahdu ainakaan Areenan muissa videoissa 16:10-näytöllä. Koskeeko ongelma siis vain livekuvaa?

Lainaus
muttakun tarkoituksena on katsella suoraa lähetystä suorana? Kokeilin joskus yle.dl:ää, kun tallensin flash-filun areenasta. Mutta en muista, että sillä voisi katsella suorana?

Voit toistaa tiedostoa samalla kun sitä ladataan.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: redu - 08.09.09 - klo:07.50

Mutta kuvasuhde näyttää menevän väkisin PC:n näytön raamien mukaiseksi. Kun minulla on kaikissa PC:issä litteä näyttö, niin kaikki lyhenee pituussuunnassa. Kiusallista. Saako näytön kuvasuhdetta säädettyä jollakin Compiz-tempulla Ubuntussa?

En ole katsonut livelähetyksiä, mutta minulla tätä ei tapahdu ainakaan Areenan muissa videoissa 16:10-näytöllä. Koskeeko ongelma siis vain livekuvaa?

Lainaus
muttakun tarkoituksena on katsella suoraa lähetystä suorana? Kokeilin joskus yle.dl:ää, kun tallensin flash-filun areenasta. Mutta en muista, että sillä voisi katsella suorana?

Voit toistaa tiedostoa samalla kun sitä ladataan.

Hö,
suora naisten jalkapallo tuli eilen oikealla kuvasuhteella (leveä kuva). Liekö tuossa Turkista tulevassa lentislähetyksessä jokin kuvasuhde-flag väärä? Lentistä tulee taas tänään suorana klo 20.00 areenasta, ja ukot lienevät taas matalia?

Yle-dl;
Nonni, nyt ei yle-dl enää pelitäkään koneissani. Pari kuukautta sitten pelitti. Onko jotakin muuttunut? Minulla on rpmpdump versio 1.6, ja uusin näkyy olevan 1.7. Tulee virheilmoitus:

Esimerkki:
~$ yle-dl http://areena.yle.fi/video/405894
Trying to extract ID from URL
clip ID is 405894
RTMPDump-YLE 1.0.2 (based on RTMPDump v1.6)
(c) 2009 Andrej Stepanchuk, Antti Ajanki
License: GPL

DEBUG: Parsing...
DEBUG: Parsed protocol: 0
DEBUG: Parsed host    : flashk.yle.fi
DEBUG: Parsed app     : AreenaServer
DEBUG: Setting buffer time to: 36000000ms
Connecting ...
DEBUG: clip ID  : 405894
DEBUG: Protocol : RTMP
DEBUG: Hostname : flashk.yle.fi
DEBUG: Port     : 1935
DEBUG: Playpath : (null)
DEBUG: tcUrl    : rtmp://flashk.yle.fi:1935/AreenaServer
DEBUG: pageUrl  : http://areena.yle.fi/video/405894
DEBUG: app      : AreenaServer
DEBUG: flashVer : LNX 9,0,124,0
DEBUG: live     : no
DEBUG: timeout  : 300 sec
DEBUG: Connect, ... connected, handshaking
DEBUG: HandShake: Client type: 03

DEBUG: HandShake: Client digest offset: 533
DEBUG: HandShake: Initial client digest:
1B E9 90 FC 18 09 F1 3F 07 F2 CB 73 9A 58 09 AE 4E D2 D6 77 6F 74 FD D3 D2 1A 67 04 44 B0 1E 2E
DEBUG: HandShake: Type Answer   : 03
DEBUG: HandShake: Server Uptime : 75563636
DEBUG: HandShake: FMS Version   : 3.0.4.1
WARNING: Trying different position for server digest!

DEBUG: HandShake: Server DH public key offset: 1117
DEBUG: HandShake: Client signature digest position: 533
DEBUG: HandShake: Digest key:
2C D8 75 07 D2 4B 9B 65 23 BE 3C E0 EB 3C 95 26 65 54 29 D4 43 8D 96 BD 88 15 EB 1F 81 D9 CF CA
DEBUG: HandShake: Signature calculated:
50 2B 8D E4 54 B0 F8 D4 7E 96 FA 53 E0 8A 46 38 6C 03 F1 B4 11 9B D2 15 74 33 68 FA 4D B1 18 EB
DEBUG: HandShake: Server sent signature:
50 2B 8D E4 54 B0 F8 D4 7E 96 FA 53 E0 8A 46 38 6C 03 F1 B4 11 9B D2 15 74 33 68 FA 4D B1 18 EB
DEBUG: HandShake: Genuine Adobe Flash Media Server
DEBUG: HandShake: Calculated digest key from secure key and server digest:
DB 04 7B 71 07 B7 30 A9 47 C1 97 93 06 0B EC F7 66 CB 12 26 F4 02 30 67 DA 0D 0F CE BB AC 42 35
DEBUG: HandShake: Client signature calculated:
1B AD 89 7B 9B F6 ED A4 7F 5B 5B 52 54 64 6F 84 63 CA 46 81 12 D3 86 02 F6 6C A8 4D 21 D7 D0 CA
DEBUG: HandShake: Handshaking finished....
DEBUG: Connect, handshaked
Connected...

Starting download at 0.000 KB
DEBUG: HandlePacket, received: server BW
DEBUG: HandlePacket, received: client BW
DEBUG: HandlePacket, received: server BW
DEBUG: HandlePacket, received: client BW
DEBUG: HandlePing, received ping. type: 0, len: 6
DEBUG: HandlePacket, received: invoke 126 bytes
DEBUG: Property: <Name:                  no-name., STRING:   _error>
DEBUG: Property: <Name:                  no-name., NUMBER:   1.00>
DEBUG: Property: NULL
DEBUG: Property: <Name:                  no-name., OBJECT>
DEBUG: Property: <Name:                     level, STRING:   error>
DEBUG: Property: <Name:                      code, STRING:   NetConnection.Connect.Rejected>
DEBUG: Property: <Name:               description, STRING:   Connection failed.>
DEBUG: Property: <Name:               application, BOOLEAN:   FALSE>
DEBUG: ExecuteInvokedMethod, server invoking <_error>
DEBUG: ExecuteInvokedMethod, server invoking <_error>
ERROR: rtmp server sent error
DEBUG: HandlePacket, received: invoke 18 bytes
DEBUG: Property: <Name:                  no-name., STRING:   close>
DEBUG: Property: <Name:                  no-name., NUMBER:   0.00>
DEBUG: ExecuteInvokedMethod, server invoking <close>
DEBUG: ExecuteInvokedMethod, server invoking <close>
ERROR: rtmp server requested close
Failed to play stream

Closing connection... done!
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: redu - 08.09.09 - klo:11.10

Mutta kuvasuhde näyttää menevän väkisin PC:n näytön raamien mukaiseksi. Kun minulla on kaikissa PC:issä litteä näyttö, niin kaikki lyhenee pituussuunnassa. Kiusallista. Saako näytön kuvasuhdetta säädettyä jollakin Compiz-tempulla Ubuntussa?

En ole katsonut livelähetyksiä, mutta minulla tätä ei tapahdu ainakaan Areenan muissa videoissa 16:10-näytöllä. Koskeeko ongelma siis vain livekuvaa?

Lainaus
muttakun tarkoituksena on katsella suoraa lähetystä suorana? Kokeilin joskus yle.dl:ää, kun tallensin flash-filun areenasta. Mutta en muista, että sillä voisi katsella suorana?

Voit toistaa tiedostoa samalla kun sitä ladataan.

Hö,
suora naisten jalkapallo tuli eilen oikealla kuvasuhteella (leveä kuva). Liekö tuossa Turkista tulevassa lentislähetyksessä jokin kuvasuhde-flag väärä? Lentistä tulee taas tänään suorana klo 20.00 areenasta, ja ukot lienevät taas matalia?

Yle-dl;
Nonni, nyt ei yle-dl enää pelitäkään koneissani. Pari kuukautta sitten pelitti. Onko jotakin muuttunut? Minulla on rpmpdump versio 1.6, ja uusin näkyy olevan 1.7. Tulee virheilmoitus:

Joo,
uusimmalla yle-dl:llä lähti pelittämään. Mutta tämä yle-dl on näämmäs hidas! Simultaanikatselu playerillä toimii, mutta tulee katkoja! Hyötysuhde n. 50% tällä core2duo2500M koneella. Se siitä suorasta katselusta yle-dl:llä!

redu
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: nm - 08.09.09 - klo:12.34
Joo,
uusimmalla yle-dl:llä lähti pelittämään. Mutta tämä yle-dl on näämmäs hidas!

Ei ole täällä hidas. Lataa niin nopeasti kuin nettiliittymä mahdollistaa eikä kuormita prosessoria juuri lainkaan.

Lainaus
Simultaanikatselu playerillä toimii, mutta tulee katkoja! Hyötysuhde n. 50% tällä core2duo2500M koneella. Se siitä suorasta katselusta yle-dl:llä!

Mitä tarkoitat hyötysuhteella? Jos videosoittimesi kuormittaa Core2:ta (tai edes sen yhtä ydintä) 50 %, siinä on kyllä jotain vikaa. Minulla MPlayerin aiheuttama kuorma noissa Areenan videoissa on 10 % yhdestä 2 GHz:n ytimestä, eikä tule katkoja.

Mitä soitinta käytät (versio)?
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: redu - 08.09.09 - klo:21.33
Joo,
uusimmalla yle-dl:llä lähti pelittämään. Mutta tämä yle-dl on näämmäs hidas!

Ei ole täällä hidas. Lataa niin nopeasti kuin nettiliittymä mahdollistaa eikä kuormita prosessoria juuri lainkaan.

Lainaus
Simultaanikatselu playerillä toimii, mutta tulee katkoja! Hyötysuhde n. 50% tällä core2duo2500M koneella. Se siitä suorasta katselusta yle-dl:llä!

Mitä tarkoitat hyötysuhteella? Jos videosoittimesi kuormittaa Core2:ta (tai edes sen yhtä ydintä) 50 %, siinä on kyllä jotain vikaa. Minulla MPlayerin aiheuttama kuorma noissa Areenan videoissa on 10 % yhdestä 2 GHz:n ytimestä, eikä tule katkoja.

Mitä soitinta käytät (versio)?


Jaaha,
no saattoihan tuo hitailu yle-dl-testissäni johtua mobiililaajakaistastanikin? Sen nopeus kyllä saattaa vaihdella, vaikka onkin ollut kiitettävästi 0.9...1.4M. Oliko sitten sattumaa, että katkoja ei juuri tule suorana katsellessa, mutta yle-dl:n kautta katkeili niin, että kuva pysähteli koko ajan. Arvioitu "kuva seis" aika oli 50% ja kuva päällä aika 50%. Pitää kai testailla lisää...

Olen kokeillut sekä Kaffeinella (xine) että Totem playerillä. Tuossa yle-dl-testissä oli käytössä Kaffeine 0.8.8.

reedu
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: nm - 08.09.09 - klo:23.22
no saattoihan tuo hitailu yle-dl-testissäni johtua mobiililaajakaistastanikin? Sen nopeus kyllä saattaa vaihdella, vaikka onkin ollut kiitettävästi 0.9...1.4M. Oliko sitten sattumaa, että katkoja ei juuri tule suorana katsellessa, mutta yle-dl:n kautta katkeili niin, että kuva pysähteli koko ajan. Arvioitu "kuva seis" aika oli 50% ja kuva päällä aika 50%. Pitää kai testailla lisää...

Ok, siinä tapauksessa syynä voisi olla sekin että tallennetta ei ollut vielä tarpeeksi levyllä kun aloitit toiston ja mediasoitin saa tiedoston lopun kiinni puskuroidessaan sitä. Kannattaa kokeilla niin että odotat ainakin 20 sekuntia ennen kuin aloitat katselun yle-dl:n käynnistämisen jälkeen. Itse en tosin ole havainnut tällaista ongelmaa millään soittimella 2 Mbps yhteydellä. Tuo ~1Mbps on ehkä niillä rajoilla, että toimivatko Areenan videot sujuvasti vai eivät.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: redu - 10.09.09 - klo:08.14
Kiitos auttaneille.
Eilen onnistuin katselemaan suoraa lentopalloa klo 20.00 oikealla kuvasuhteella käyttäen yle-dl:ää, eikä pätkinyt yhtään 1M:n mobiililaajakaistalla. Yle-dl:n perässä ei saanut olla --live lisuketta, vaikka katselin livenä. Tiedä sitten, miksi viimeksi katkoi pahasti. Uutta oli koneessa  vain Mozilla Mediaplayer Connectivity Utility.

Kaikki yle:n arkistot wmv, elävä, areena pelittävät.

redu
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: ~unknown - 11.09.09 - klo:19.47
Areena pelittää, mutta Elävä arkisto ei, käytössä MPC ja VLC.
Lainaus
Syötettä ei voi avata:
VLC ei kyennyt avaamaan MRL-sijaintia "http://10.1.6.5:80/player/1/81/18159_1.wmv?MSWMExt=.asf". Katso lokista lisätietoja.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: topi - 02.10.09 - klo:18.49
[edit 25.4.2009]

Yle on avannut käyttöön Areenasta uuden beta-versio (http://areena-beta.yle.fi), jonka käyttäminen on suositeltavaa.

 Lue lisää: http://blog.ubuntu-fi.org/2009/yle-tukee-ubuntua/

Nämä ohjeet toimii edelleen, jos haluat käyttää Elävää arkistoa tai Areenan vanhempaa versiota.

Siis mitkä ohjeet/missä ? Asennettuna on Totem ja ubuntu-restricted-extras mutta mitään ei tapahdu kun yrittää katsoa yle-areenaa. Yle arkisto, youtube mm. kyllä toimivat. Asensin myös Adobe Flash -playerin, mutta ohjelmat eivät näy.


[/edit]
---

YLE:n hienot palvelut Areena ja Elävä Arkisto toimivat Ubuntulla hyvin asentamalla paketin ubuntu-restricted-extras. Palvelujen käyttämiseksi ei tarvitse tehdä mitään muuta.

Monet ovat kuitenkin tuskailleet palvelujen kanssa ja kokeilleet sisällön näyttämiseen mm. mplayeria ja vlc:tä. Palvelun saattaa saada toimimaan niidenkin kanssa, mutta mitään erityistä tarvetta siihen ei ole. Restricted-extras on ns. metapaketti, joka asentaa tarvittavat kodeekit.

Oletuksena Ubuntussa Firefox käyttää multimedian näyttämiseen Totemia, joten jos tuohon asetukseen on mennyt koskemaan, niin kannattaa varmistua, että paketti totem-mozilla on asennettuna. Oletuksen Totem käyttää taustamoottorinaan gstreameria, joten jos sitäkin on tullut vaihdettua, niin on syytä ottaa käyttöön alkuperäinen paketti totem-gstreamer.

Näiden pakettien kanssa ongelmia voivat tuottaa mm. seuraavat paketit mozilla-mplayer ja totem-xine. Mikäli ne on asennettuna, kannattaa paketit poistaa.

Firefoxin liitännäisellä mediaplayer-connectivity voi säätää tarkkaan mikä ohjelma avaa minkäkinlaisen videon, mutta peruskäytössä siihen ei ole tarvetta. Liitännäisen voi siis poistaa, jos sellaisen on mennyt asentamaan.

Nämä ohjeet on testattu ja todettu toimiviksi useissa Ubuntu 8.04 asennuksissa.


edit/rhkfin. Kubuntussa ilmeisesti riittää asentaa paketti kubuntu-restricted-extras niin konqueror ja kaffeine osaavat näyttää videot nätisti.

edit/gdm. Poistettu huomautus.

Otsikko: YLE Areena ei toimi
Kirjoitti: topi - 02.10.09 - klo:20.25
vaikka seuraavat asiat on hoidettu kuntoon (esim. yle arkisto, youtube toimivat):

ubuntu-restricted-extras is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 24 not upgraded.

totem-mozilla is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 24 not upgraded.

totem-gstreamer is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 24 not upgraded.

Package mozilla-mplayer is not installed, so not removed
0 upgraded, 0 newly installed, 0 to remove and 24 not upgraded.

E: Couldn't find package mozilla-xine

Onko mitään tehtävissä ?




[edit 25.4.2009]

Yle on avannut käyttöön Areenasta uuden beta-versio (http://areena-beta.yle.fi), jonka käyttäminen on suositeltavaa.

 Lue lisää: http://blog.ubuntu-fi.org/2009/yle-tukee-ubuntua/

Nämä ohjeet toimii edelleen, jos haluat käyttää Elävää arkistoa tai Areenan vanhempaa versiota.

[/edit]
---

YLE:n hienot palvelut Areena ja Elävä Arkisto toimivat Ubuntulla hyvin asentamalla paketin ubuntu-restricted-extras. Palvelujen käyttämiseksi ei tarvitse tehdä mitään muuta.

Monet ovat kuitenkin tuskailleet palvelujen kanssa ja kokeilleet sisällön näyttämiseen mm. mplayeria ja vlc:tä. Palvelun saattaa saada toimimaan niidenkin kanssa, mutta mitään erityistä tarvetta siihen ei ole. Restricted-extras on ns. metapaketti, joka asentaa tarvittavat kodeekit.

Oletuksena Ubuntussa Firefox käyttää multimedian näyttämiseen Totemia, joten jos tuohon asetukseen on mennyt koskemaan, niin kannattaa varmistua, että paketti totem-mozilla on asennettuna. Oletuksen Totem käyttää taustamoottorinaan gstreameria, joten jos sitäkin on tullut vaihdettua, niin on syytä ottaa käyttöön alkuperäinen paketti totem-gstreamer.

Näiden pakettien kanssa ongelmia voivat tuottaa mm. seuraavat paketit mozilla-mplayer ja totem-xine. Mikäli ne on asennettuna, kannattaa paketit poistaa.

Firefoxin liitännäisellä mediaplayer-connectivity voi säätää tarkkaan mikä ohjelma avaa minkäkinlaisen videon, mutta peruskäytössä siihen ei ole tarvetta. Liitännäisen voi siis poistaa, jos sellaisen on mennyt asentamaan.

Nämä ohjeet on testattu ja todettu toimiviksi useissa Ubuntu 8.04 asennuksissa.


edit/rhkfin. Kubuntussa ilmeisesti riittää asentaa paketti kubuntu-restricted-extras niin konqueror ja kaffeine osaavat näyttää videot nätisti.

edit/gdm. Poistettu huomautus.

Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Skoge - 03.10.09 - klo:13.36
Totem ei minullakaan toistanut Areenaa. Minulla toimii kun asensin paketinhallinnan kautta xine-plugin paketin. 

Koeta jos auttaa.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: nm - 03.10.09 - klo:14.42
Areena toimii nykyisin vain Adobe Flash Playerillä (ja lataukset onnistuvat rtmpdump-ylellä), eli tee seuraavat toimenpiteet:

Koodia: [Valitse]
sudo apt-get remove swfdec-mozilla
sudo apt-get install flashplugin-installer

...ja käynnistä selain uudelleen.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: topi - 03.10.09 - klo:15.10
Areena toimii nykyisin vain Adobe Flash Playerillä (ja lataukset onnistuvat rtmpdump-ylellä), eli tee seuraavat toimenpiteet:

Koodia: [Valitse]
sudo apt-get remove swfdec-mozilla
sudo apt-get install flashplugin-installer

 ;D

TOIMII !

Kiitos paljon, tämä foorumi oli taas välttämätön apu.




...ja käynnistä selain uudelleen.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: samAnen - 26.11.09 - klo:14.43
Ite oon asentanut aikoinaan jotku paketit mitä täällä foorumeilla kerrottiin, ja sain sen vanhan areenan toimimaan. Nykyäänhän areena toimii käyttiksellä kuin käyttiksellä kunhan on flash asennettuna. Elävää arkistoa en oo saanut toimimaan, mikä harmittaa. Myöskään mtv3 katsomoa en saa toimimaan, anytime toimi vielä silloin kun se oli mtv3:llä käytössä nettitvnä. Ohjeita kaivataan :) toi ubuntu-restricted-extras vai mikä lie olikaan on asennettu. Setuppina ubuntu 9.10 ja KDE 4.3, eli pitäiskö asentaa kubuntu-restricted-extras? Mutta ei kyllä Gnomellakaan toimi tolla ubuntun paketilla, että en usko että hyödyttäis.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: nm - 26.11.09 - klo:15.03
Ite oon asentanut aikoinaan jotku paketit mitä täällä foorumeilla kerrottiin, ja sain sen vanhan areenan toimimaan. Nykyäänhän areena toimii käyttiksellä kuin käyttiksellä kunhan on flash asennettuna. Elävää arkistoa en oo saanut toimimaan, mikä harmittaa. Myöskään mtv3 katsomoa en saa toimimaan, anytime toimi vielä silloin kun se oli mtv3:llä käytössä nettitvnä. Ohjeita kaivataan :)

Ratkaisuja ja niiden ongelmia on käsitelty mm. tässä keskustelussa: http://forum.ubuntu-fi.org/index.php?topic=29300.0
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: samAnen - 26.11.09 - klo:19.26
Ite oon asentanut aikoinaan jotku paketit mitä täällä foorumeilla kerrottiin, ja sain sen vanhan areenan toimimaan. Nykyäänhän areena toimii käyttiksellä kuin käyttiksellä kunhan on flash asennettuna. Elävää arkistoa en oo saanut toimimaan, mikä harmittaa. Myöskään mtv3 katsomoa en saa toimimaan, anytime toimi vielä silloin kun se oli mtv3:llä käytössä nettitvnä. Ohjeita kaivataan :)

Ratkaisuja ja niiden ongelmia on käsitelty mm. tässä keskustelussa: http://forum.ubuntu-fi.org/index.php?topic=29300.0

Kiitokset linkistä, replysin tohon aiheeseen, joten jos sulla riittää halua auttaa niin käy tsekkaamassa mun vastaus sieltä ;) (saa toki muutkin, ja pitääkin :D )
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Outolintu - 26.01.10 - klo:13.19
Tänään päivittyi Firefox versioon 3.6 Lucidlynx-kehitysversiossa, yllättäen yle areena ja elävä arkisto sekä mtv katsomo alkoivat toimimaan !

3.5- versiolla mikään ei auttanut. Kokeilkaas päivittää sitä virevoksia...
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Jallu59 - 26.01.10 - klo:20.06
Tänään päivittyi Firefox versioon 3.6 Lucidlynx-kehitysversiossa, yllättäen yle areena ja elävä arkisto sekä mtv katsomo alkoivat toimimaan !

3.5- versiolla mikään ei auttanut. Kokeilkaas päivittää sitä virevoksia...

Millä plugin & liitännäiset &MPC-asetuset kombinaatiolla moinen tapahtuu. Toimiiko myös Elävän arkiston audiopätkät ?

T:Jallu59
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Outolintu - 26.01.10 - klo:20.45
Ylen audiopätkätkin toimivat.

Tässä screenshot plugareista:



[ylläpito on poistanut liitteen]
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: nm - 27.01.10 - klo:01.22
Tuossa on asennettuna Flashin lisäksi gecko-mediaplayer, totem-mozilla ja mozilla-plugin-vlc (joka on kytketty pois päältä). Ehkä Katsomo ei toiminut aiemmin, koska Totem meni gecko-mediaplayerin edelle, ja nyt taas päinvastoin.

Kokeilitko tosiaan Elävän arkiston audiota, etkä esimerkiksi Areenaa, joka toimii Flash-tekniikalla?
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Outolintu - 27.01.10 - klo:09.47
Kokeilin tosiaan kaikkea tässä ketjussa olleita kikkoja (paitsi MPC) jonka jälkeen luovutin ja jätin koko homman.

Sitten yhtäkkiä FF3.6 korjasi asian ilman että koskin mihinkään.

Ja tosiaan ylen ELÄVÄN ARKISTON ääniclipit toimivat.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Daneli - 29.01.10 - klo:21.34
Kuinka saada buffering aikaa isommaksi ? välistä kun nopeus on hidas olisi kivempi saada puskuroitua enemmän kerralla.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: nm - 30.01.10 - klo:02.05
Kuinka saada buffering aikaa isommaksi ? välistä kun nopeus on hidas olisi kivempi saada puskuroitua enemmän kerralla.

Areenassa ei ehkä onnistu muuten kuin lataamalla tiedoston koneelle rtmpdump-ylellä. Elävässä arkistossa riippuu soittimesta/liitännäisestä. VLC:ssä ja MPlayerissä voi ainakin säätää puskureita.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Daneli - 30.01.10 - klo:10.30

Areenassa ei ehkä onnistu muuten kuin lataamalla tiedoston koneelle rtmpdump-ylellä.

Kuinkas se tapahtuu ? (howto)
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: mrl586 - 30.01.10 - klo:10.38
Lataat erään softan lähdekoodin (http://users.tkk.fi/~aajanki/rtmpdump-yle/index.html). Käännät sen. Ja sen jälkeen komennat yle-dl ohjelman_osoite_areenassa
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Daneli - 30.01.10 - klo:11.07
Kiitos! Latasin juuri Chromen tähän ja yllätyksekseni areena toimi sillä paljon paremmin.
Tuo yle-dl asennus onnistui ja toimi hyvin, kivan simppeli ja jos tuon dl kommenon lataus nopeutta katsoo ei voi käsittää miten se tökkii noin paljon suoraan sivulta katsoessa.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: fveitsi - 14.02.10 - klo:20.43
edit: ongelma ratkaistu.  ;D
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Matti Tuomas - 22.03.10 - klo:13.16
Näin saat toimimaan kaiken: asenna Linux Mint.

haha lol vitsi vitsi. kyl ne restricted extratki auttaa ja firefoxiin asensi jonkun media controllin tai jotain tai poistaa totem pluginnin ni mtv3 katsomoki toimii.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: poiuyt - 13.05.10 - klo:05.13
Edit: paremmin sopivaan ketjuun...




Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: tetrao - 16.05.10 - klo:20.46
"Yhteysvirhe: Areenan palvelimet ovat hetkellisesti alhaalla tai verkkoyhteydessä on ongelmia"

Sanoo, kun yrittää katsella esim. tätä: http://areena.yle.fi/video/983127

Muilla vastaavia ongelmia? Sama juttu, kun yritin katsella yksi ilta suoraa lätkä lähetystä (Taisi olla Suomi - Saksa)

Ongelmaa esiintyy vain joillakin tallenteilla, esim. kakkosen kevätsää näkyy hyvin.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: K-Veikko - 16.05.10 - klo:22.43
"Yhteysvirhe: Areenan palvelimet ovat hetkellisesti alhaalla tai verkkoyhteydessä on ongelmia"

Sanoo, kun yrittää katsella esim. tätä: http://areena.yle.fi/video/983127

Mulla toimi - nyt. Olisiko mahdollista että jääkiekon takia palvelimella on oikeasti ruuhkaa.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Capitane - 26.05.10 - klo:03.49
Mä olen Suomessa ja Lahdessa, mutta Yle-areena ilmottaa seuraavaa:
"Tallenteen katseluoikeus on rajattu
Kyseisen tallenteen voi avata vain Suomessa"
 ??? PERFECT!

Mä olen kokeillu asennella erilaisia paketteja ja selainliitännäisiä täällä olleiden ohjeiden mukaisesti. Tuntuu siltä, että tässä on jostain muusta kysymys, aikaisemmin nimittäin on toiminu ihan hyvin, jopa ilman MediaPlayerConnectivityä. Onko kellään kokemuksia tästä edellä mainitusta ilmoituksesta?
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Nake - 26.05.10 - klo:04.51
Mä olen Suomessa ja Lahdessa, mutta Yle-areena ilmottaa seuraavaa:
"Tallenteen katseluoikeus on rajattu
Kyseisen tallenteen voi avata vain Suomessa"
 ??? PERFECT!

Mä olen kokeillu asennella erilaisia paketteja ja selainliitännäisiä täällä olleiden ohjeiden mukaisesti. Tuntuu siltä, että tässä on jostain muusta kysymys, aikaisemmin nimittäin on toiminu ihan hyvin, jopa ilman MediaPlayerConnectivityä. Onko kellään kokemuksia tästä edellä mainitusta ilmoituksesta?

Minulla oli sama ongelma, mutta oikeni, kun kun aukaisin routerini palomuuriin portin 1835, joka laskee läpi Yle Areenan käyttämän RTMP-formaatin liikenteen. Tästä taitaa olla ohje Areenan sivun alalaidassakin.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Illu - 26.05.10 - klo:11.39
Murheenkryyni Fujitsu-Siemens L1310G lähti pelittämään suoraan U10.04 asennuksella ja ubuntu-restricted-extras paketilla. Areena ja Ylen Elävä arkisto toimivat. Ei mitään ylimääräisiä säätöjä tai javan muutoksia.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: topi - 26.05.10 - klo:22.09
Kaikki neuvotut loitsut on yritetty eikä toimi 10.04 :ssä. Aikaisemmin kyllä toimi (9.04 ja 9.10). Onkohan nyt jotain uusia kikkoja? 

Viime versiossa häipyi digikortin toiminta lopullisesti ja nyt tämä eli koko ajan mun kannalta huonompaan suuntaan. Osaisiko joku kertoa, miten voisi päivittää koneen 9.04. :ään tai vastaavaan järjestelmään, jossa on perustoiminnat jo toimineet?
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: nm - 26.05.10 - klo:23.15
Viime versiossa häipyi digikortin toiminta lopullisesti ja nyt tämä eli koko ajan mun kannalta huonompaan suuntaan. Osaisiko joku kertoa, miten voisi päivittää koneen 9.04. :ään tai vastaavaan järjestelmään, jossa on perustoiminnat jo toimineet?

Tee varmuuskopio kotihakemistosta toiselle koneelle tai ulkoiselle levylle ja asenna haluamasi Ubuntun versio uudelleen. Puhdas 10.04:n asennus voisi myös auttaa joihinkin ongelmiin, mutta ei ehkä Kaffeineen eikä tähän Ylen maatarkistukseen / portin 1935 estoon, joka tuntuu vaivaavan muitakin nimenomaan Lucidissa. Vai onko sinulla jokin muu ongelma Areenan kanssa?

Huomasitko Kaffeineen liittyen tämän: http://forum.ubuntu-fi.org/index.php?topic=33855.0
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: topi - 27.05.10 - klo:09.55
Viime versiossa häipyi digikortin toiminta lopullisesti ja nyt tämä eli koko ajan mun kannalta huonompaan suuntaan. Osaisiko joku kertoa, miten voisi päivittää koneen 9.04. :ään tai vastaavaan järjestelmään, jossa on perustoiminnat jo toimineet?

Tee varmuuskopio kotihakemistosta toiselle koneelle tai ulkoiselle levylle ja asenna haluamasi Ubuntun versio uudelleen. Puhdas 10.04:n asennus voisi myös auttaa joihinkin ongelmiin, mutta ei ehkä Kaffeineen eikä tähän Ylen maatarkistukseen / portin 1935 estoon, joka tuntuu vaivaavan muitakin nimenomaan Lucidissa. Vai onko sinulla jokin muu ongelma Areenan kanssa?

Kyllä, olisi pitänyt mainita, eli:

Videon toisto vaatii uusimman Flash-player laajennuksen. Ole hyvä ja lataa se tästä.

Aikaisemmin on ollut sama ilmoitus, joka on korjaantunut tämän viestiketjun ohjeilla. Tuo Flash-plaeyer lataaminenkaan ei onnistunut.

Lainaus
Huomasitko Kaffeineen liittyen tämän: http://forum.ubuntu-fi.org/index.php?topic=33855.0

Kyllä, jos saan tuon Areenan toimimaan, niin koetan tuota.

Latasin jo 9.04. :jän. Löysin tuon version. Odotan kuitenkin jos tuohon Areenan ongelmaan löytyisi ratkaisu. 9.04. :ssä saattaa olla ongelmia Huawei E230-mokkulan kanssa (sitä ei ollut vielä tuota versiota käyttäessäni).
  
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Tempo - 27.05.10 - klo:11.31
Mulla on iki vanha läppis (katso ala tekstiä) ja XUBUNTU.    Kaikki yle jutut toimii, ei tarvinnut mitään asennella eikä säätää :-)
Oli pakko käydä kokeilemassa kun tästä niin paljon puhutaan täällä.

Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: nm - 27.05.10 - klo:11.53
Videon toisto vaatii uusimman Flash-player laajennuksen. Ole hyvä ja lataa se tästä.

Aikaisemmin on ollut sama ilmoitus, joka on korjaantunut tämän viestiketjun ohjeilla. Tuo Flash-plaeyer lataaminenkaan ei onnistunut.

Ok, tämä on kyllä ratkaistavissa, eikä puuttuva/väärä Flash-liitännäinen ole erityisesti Lucidia koskeva vika.

Avaa selaimeen osoite about:plugins ja katso sieltä kohta Shockwave Flash. Mitä sen alla lukee? Pitäisi olla suunnilleen tällaista:

Koodia: [Valitse]
Tiedosto: libflashplayer.so
Versio: Shockwave Flash 10.0 r45

Jos versio on 9.0 r999, sinulla on asennettuna joko mozilla-plugin-gnash tai swfdec-mozilla, jotka yleensä menevät Adobe Flash Playerin edelle. Poista ne ja asenna flashplugin-installer uudelleen:

Koodia: [Valitse]
sudo apt-get purge mozilla-plugin-gnash swfdec-mozilla flashplugin-installer flashplugin-nonfree
sudo apt-get install flashplugin-installer

Kirjaudu sitten ulos työpöydältä ja takaisin sisään tai käynnistä kone uudelleen, jotta selain sulkeutuu varmasti.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: topi - 27.05.10 - klo:14.41
Videon toisto vaatii uusimman Flash-player laajennuksen. Ole hyvä ja lataa se tästä.

Aikaisemmin on ollut sama ilmoitus, joka on korjaantunut tämän viestiketjun ohjeilla. Tuo Flash-plaeyer lataaminenkaan ei onnistunut.

Ok, tämä on kyllä ratkaistavissa, eikä puuttuva/väärä Flash-liitännäinen ole erityisesti Lucidia koskeva vika.

Avaa selaimeen osoite about:plugins ja katso sieltä kohta Shockwave Flash. Mitä sen alla lukee? Pitäisi olla suunnilleen tällaista:

Koodia: [Valitse]
Tiedosto: libflashplayer.so
Versio: Shockwave Flash 10.0 r45

Jos versio on 9.0 r999, sinulla on asennettuna joko mozilla-plugin-gnash tai swfdec-mozilla, jotka yleensä menevät Adobe Flash Playerin edelle. Poista ne ja asenna flashplugin-installer uudelleen:

Koodia: [Valitse]
sudo apt-get purge mozilla-plugin-gnash swfdec-mozilla flashplugin-installer flashplugin-nonfree
sudo apt-get install flashplugin-installer

Kirjaudu sitten ulos työpöydältä ja takaisin sisään tai käynnistä kone uudelleen, jotta selain sulkeutuu varmasti.

Nyt toimii, tosin kuva takertelee. Tällainen ongelma on kyllä ollut välillä aikaisemminkin, mutta ei mielestäni näin pahana. Mutta vaikea sanoa, onko se varmasti huonompilaatuinen. Ääni tulee hyvin eikä virheilmoituksia tule, joten ongelma on varmaan ylellä. Nyt kyllä huomaan että kuva tulee paljon hitaammin, eli se on jäänyt jälkeen äänestä. Tällaista ongelmaa ei ole ollut aikaisemmin. Itseasiassa myös tekstin tulo ruutuun takertelee, se tulee tuskallisen hitaasti, samaten nuolinäppäimellä kursorin siirto.



MUOKKAUS: Tarkista quote-tagien käyttö lainauksissa, jotta viestistä näkee, mikä teksti on lainattua ja mikä omaasi! Korjasin lainaukset tähän ja edelliseen viestiisi. T. nm
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: nm - 27.05.10 - klo:14.51
Nyt toimii, tosin kuva takertelee. Tällainen ongelma on kyllä ollut välillä aikaisemminkin, mutta ei mielestäni näin pahana. Mutta vaikea sanoa, onko se varmasti huonompilaatuinen. Ääni tulee hyvin eikä virheilmoituksia tule, joten ongelma on varmaan ylellä. Nyt kyllä huomaan että kuva tulee paljon hitaammin, eli se on jäänyt jälkeen äänestä. Tällaista ongelmaa ei ole ollut aikaisemmin. Itseasiassa myös tekstin tulo ruutuun takertelee, se tulee tuskallisen hitaasti, samaten nuolinäppäimellä kursorin siirto.

Teksti on poltettu kuvaan, joten ne tulevat samassa tahdissa. Takerteleeko kuva siis sekä ikkunassa että kokoruudussa? Jos vain kokoruudussa, ongelmana on videon skaalaus, joka on raskas operaatio ilman näytönohjaimen apua. Sitä varten pitäisi saada käyttöön Flashin OpenGL-kiihdytys. Atin ja Intelin ajureilla se on pakotettava päälle (http://forum.ubuntu-fi.org/index.php?topic=31969.msg248655#msg248655).

Mikä näytönohjain koneessa on ja mikä ajuri on käytössä? Oletko kokeillut myös ilman työpöytätehosteita?

Onko selaimessa auki vain Areena, etteivät muut Flash-sovellukset (esim. mainokset) kuormita prosessoria?
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: topi - 28.05.10 - klo:10.01
Nyt toimii, tosin kuva takertelee. Tällainen ongelma on kyllä ollut välillä aikaisemminkin, mutta ei mielestäni näin pahana. Mutta vaikea sanoa, onko se varmasti huonompilaatuinen. Ääni tulee hyvin eikä virheilmoituksia tule, joten ongelma on varmaan ylellä. Nyt kyllä huomaan että kuva tulee paljon hitaammin, eli se on jäänyt jälkeen äänestä. Tällaista ongelmaa ei ole ollut aikaisemmin. Itseasiassa myös tekstin tulo ruutuun takertelee, se tulee tuskallisen hitaasti, samaten nuolinäppäimellä kursorin siirto.

Teksti on poltettu kuvaan, joten ne tulevat samassa tahdissa. Takerteleeko kuva siis sekä ikkunassa että kokoruudussa?

KYLLÄ

Lainaus
Jos vain kokoruudussa, ongelmana on videon skaalaus, joka on raskas operaatio ilman näytönohjaimen apua. Sitä varten pitäisi saada käyttöön Flashin OpenGL-kiihdytys. Atin ja Intelin ajureilla se on pakotettava päälle (http://forum.ubuntu-fi.org/index.php?topic=31969.msg248655#msg248655).

Mikä näytönohjain koneessa on ja mikä ajuri on käytössä?

MISTÄ TIETO?

Lainaus
Oletko kokeillut myös ilman työpöytätehosteita?

MITÄ NE ON?

Lainaus
Onko selaimessa auki vain Areena, etteivät muut Flash-sovellukset (esim. mainokset) kuormita prosessoria?

OLI MUUTAKIN AUKI, MUTTA kun suljin muita ikkunoita, niin alkoi toimia. Tosin seuraavalla kerralla avatessa oli sama ongelma, mutta kuva alkoi pikkuhiljaa toimia. En ole varma, mikä sen aiheutti, ehkä facebook sivu tms. Täytyy yrittää tutkia tarkemmin syytä, mutta siis ainakin kuva toimii kun firefox on ollut jonkin aikaa päällä ja/tai ikkunoita/tiettyjä ikkunoita ei ole liikaa auki.

Kiitos avusta, ongelma on ratkaistu!
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Ganymedes - 03.07.10 - klo:16.01
Miten tämä Elävä Arkisto oikein tällä hetkellä toimii?

Tein näillä toukokuisilla ohjeilla:

sudo apt-get purge mozilla-plugin-gnash swfdec-mozilla flashplugin-installer flashplugin-nonfree
sudo apt-get install flashplugin-installer

Minulla on aivan uusi 10.04 64-bit Ubuntu kone ja edellisessä, 1. rivi ei poista mitään kun ei ole mitään poistettavaa, seuraava kyllä asentaa mutta lopputulos on sama:

Valittaa että ei toimi muualla kuin Suomessa tai hetkellinen häiriö.

Tälle koneelle ei juurikaan ole ladattu mitään muuta kuin perusjuttuja: VLC, MediaConnectivity, ubuntu-restricted-extras ja pikkuohjelmia jotka eivät ehkä tähän liity.

Adobe Plugin näyttää löytyvän sovellusohjelmien lataamisen kautta, mutta ei sitä voi asentaa kuin tämä on 64-bit kone.

Joten mitenköhän?
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: nm - 03.07.10 - klo:23.09
Miten tämä Elävä Arkisto oikein tällä hetkellä toimii?

Tein näillä toukokuisilla ohjeilla:

sudo apt-get purge mozilla-plugin-gnash swfdec-mozilla flashplugin-installer flashplugin-nonfree
sudo apt-get install flashplugin-installer

Minulla on aivan uusi 10.04 64-bit Ubuntu kone ja edellisessä, 1. rivi ei poista mitään kun ei ole mitään poistettavaa, seuraava kyllä asentaa mutta lopputulos on sama:

Valittaa että ei toimi muualla kuin Suomessa tai hetkellinen häiriö.

Pitäisi kyllä toimia tuolla flashplugin-installerilla. Jos myös Areena antaa tuon virheen 10.04:ssä, mutta esim. Youtube ja muut Flash-sivustot toimivat, sinulla voi olla tämä mystinen ongelma: http://forum.ubuntu-fi.org/index.php?topic=33438.0
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: nm - 06.07.10 - klo:11.06
Siirsin keskustelun katselurajoitusongelmasta sopivamman aiheen alle: http://forum.ubuntu-fi.org/index.php?topic=33438.msg268743#msg268743
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: zarmo - 14.07.10 - klo:11.48
Asentelin uuteen läppäriin 64 bittisen Ubuntu 10.04:n. Ylen Areenassa on varsin erikoinen ongelma:

Areena toimii muuten, mutta ylin laatikko ei. Eli tuo, missä on rinnakkain kolmen ohjelman kuvake ja sivuilla selausnuolet ja päällä Suosittelemme | Perheen pienimmille | Dokumenttiohjelmia. Noista minkään klikkaaminen hiirellä, ei tuota mitää tulosta. Linkki kyllä vaihtaa väriä, kun osoittimen vie sen päälle.

Muut ohjelmat toimivat normaalisti esimerkiksi tuolta alemmasta osastosta klikattuina.

-Jarkko
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: nm - 14.07.10 - klo:12.17
Asentelin uuteen läppäriin 64 bittisen Ubuntu 10.04:n. Ylen Areenassa on varsin erikoinen ongelma:

Areena toimii muuten, mutta ylin laatikko ei. Eli tuo, missä on rinnakkain kolmen ohjelman kuvake ja sivuilla selausnuolet ja päällä Suosittelemme | Perheen pienimmille | Dokumenttiohjelmia. Noista minkään klikkaaminen hiirellä, ei tuota mitää tulosta. Linkki kyllä vaihtaa väriä, kun osoittimen vie sen päälle.

Saattaisi olla Compizin ja Flash Playerin yhteensopivuusongelma, joka esiintyy helposti varsinkin 64-bittisessä järjestelmässä: https://bugs.launchpad.net/ubuntu/+source/flashplugin-nonfree/+bug/410407

Lainaus
WORKAROUND 1: Disable compiz
WORKAROUND 2: Remove flashplugin-nonfree / flashplugin-installer and install from adobe
WORKAROUND 3: Open a terminal and enter:

gksudo gedit /usr/lib/nspluginwrapper/i386/linux/npviewer

Then add: export GDK_NATIVE_WINDOWS=1 before the last line of text

Note: Chrome & Chromium are now working fine without workaround

These workaround's have been verified to work for some users. We don't need verification of whether or not they work for you.

Workaround 1 tarkoittaa siis visuaalisten tehosteiden kytkemistä pois päältä: Järjestelmä->Asetukset->Ulkoasu, Visuaaliset tehosteet -välilehti, valitse "Ei mitään".
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: zarmo - 18.07.10 - klo:19.38
Asentelin uuteen läppäriin 64 bittisen Ubuntu 10.04:n. Ylen Areenassa on varsin erikoinen ongelma:

Areena toimii muuten, mutta ylin laatikko ei. Eli tuo, missä on rinnakkain kolmen ohjelman kuvake ja sivuilla selausnuolet ja päällä Suosittelemme | Perheen pienimmille | Dokumenttiohjelmia. Noista minkään klikkaaminen hiirellä, ei tuota mitää tulosta. Linkki kyllä vaihtaa väriä, kun osoittimen vie sen päälle.

Muut ohjelmat toimivat normaalisti esimerkiksi tuolta alemmasta osastosta klikattuina.

-Jarkko

Operalla muuten toimii.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: hirvi - 10.09.10 - klo:16.50
Päivitetty ohje: http://ubuntuone.com/p/FaE/

Näkyykö?
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Ganymedes - 10.09.10 - klo:23.17
Päivitetty ohje: http://ubuntuone.com/p/FaE/

Näkyykö?

No ei. Juuri aiheen mukaisessa kohdassa kuvat ja tekstit on päällekkäin Ubuntu 9.04:n oletuskatselimella.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Turbineair - 11.12.10 - klo:23.21
Ilmeisen helppo ratkaistava asian osaavalle?
Miten saan käynnistettyä Päätteen läppärin napista suoraan "yle-dl " tekstillä varustettuna siten, että voisi suoraan liittää Areenan sivuilta kopsatun osoitteen sen perään. Toinen, vielä parempi vaihtoehto, olisi Käynnistin joka tekee saman asian, jolloin ei tarvitsisi koskea näppikseen lainkaan.

Vastaava käynnistin olisi jopa kiva lisä itse "ohjelman" asennuspakettiin(ko&köh,köh)  ::)
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: JarTak - 12.12.10 - klo:02.06
Toinen, vielä parempi vaihtoehto, olisi Käynnistin joka tekee saman asian, jolloin ei tarvitsisi koskea näppikseen lainkaan.

Vastaava käynnistin olisi jopa kiva lisä itse "ohjelman" asennuspakettiin(ko&köh,köh)  ::)

Vähän vastaavan kaltainen löytyy jo täältä: http://forum.ubuntu-fi.org/index.php?topic=14127.360

Siellä nimimerkki Salai kertoi tuosta lisäohjelmasta.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Illu - 12.12.10 - klo:18.42
Toinen, vielä parempi vaihtoehto, olisi Käynnistin joka tekee saman asian, jolloin ei tarvitsisi koskea näppikseen lainkaan.

Jos sinulla on jokin vakio-ohjelma jonka haluat tallentaa, hieman näppäilyä helpottava konsti on, jos teet työpöydälle käynnistimen ja annat sen komennoksi esim.:

yle-dl --latestepisode http://areena.yle.fi/haku//uusimmat/hakusana/knalli+ja+sateenv

Tuolla rapsahtaa (vielä hetken) jokaviikkoinen Knalli ja sateenvarjon viimeinen jakso. Mitään ikkunaa ei avaudu, josta näkisit latautumisen mutta kotikansioon ilmestyy hakemasi jakso.

Yllämainittu Launchy (linkki keskusteluun) on kyllä melko kätevä, suosittelen tutustumaan.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Ganymedes - 11.01.11 - klo:21.20
... ahaa .... kysymys on näköjään kadonnut. No jätetään vastaus silti tähän ...  ;D

Tuo katseluongelma on ratkaistu jo kesällä ja alla olevassa paikassa on siihen esitetty ratkaisu - tai itseasiassa kaksi vaihtoehtoa. Ymmärrettävästi silloin uusin versio oli 10.04, mutta pikaisesti katsottuna 10.10:ssa on sama tilanne. Eri asia on sitten onko ratkaisu tarpeeksi yksityiskohtainen, koska ratkaisu edellyttää joko a) väärin toimivan DNS-palvelimen uudelleen konfigurointia (sinun ADSL-purkkisi), b) tai Ubuntun verkkoasetusten muuttamista ohittamaan oman DNS-palvelimesi. Tästä johtuen ohje olisi pitkähkö vaikka itse asian tekeminen vie noin minuutin.

http://forum.ubuntu-fi.org/index.php?topic=33438.msg273444#msg273444

Loppujen lopuksi asia voi myös korjaantua Adobe Flashin korjatulla versiolla sitten joskus, vaikkapa 64-bittisella alfa/betaversiolla.

Kumpaa oikeasti kysyt, katselua vain tallennusta ? - tämä ei ole tallennus säie. Jälkimmäisen ongelmista en tiedä.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: japfin - 16.05.11 - klo:19.46
11.04

Eilen toimi, tänään ei. Mites muilla?

Vai onko kulta imenyt kaistat tyhjiks?

EDIT: Minuutin kun kyttäs mustaa ruutua niin alko toimiin. Taitaa olla kaista aikas tukossa.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: avanti - 17.05.11 - klo:00.42
11.04

Eilen toimi, tänään ei. Mites muilla?

Vai onko kulta imenyt kaistat tyhjiks?

EDIT: Minuutin kun kyttäs mustaa ruutua niin alko toimiin. Taitaa olla kaista aikas tukossa.

Sen jääkiekkokullan jälkeen tuntui todellakin tukkoiselta kaistalla! Ja vieläpä yöllä matsin jälkeen. En ole koskaan ennen kokenut moista! (Vaikka onhan tuo mestaruus todellakin harvinaista herkkua, et silleen.)

ML
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: USakari - 21.07.11 - klo:10.50
Mac mini:ssä (Ubuntu 10.10, Firefox) yritettiin parin kuukauden tauon jälkeen käyttää YLE Areenaa, mutta sepä ei enää toiminutkaan. AIkaisemmin keväällä kyllä toimi.

Yritin päivittää Flash-pluginin Adoben sivuilta, mutta törmäsin omituiseen ongelmaan. Päivitys 10.3:een onnistuu vain näennäisesti. Firefox, muka päivitettyään pluginin, ilmoittaa kuitenkin edelleen käyttävänsä versiota 10.1, joka on gnash, vaan ei flash. Ja tätä gnashia en saa millään pois käytöstä.

Jos panee Firefoxin tutkimaan pluginejaan, niin se ilmoittaa gnash-pluginin olevan vanhentunut, mutta jos sitä yrittää päivittää, plugin ei kuitenkaan vaihdu.

Mikähän tässä mättää?
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Ganymedes - 21.07.11 - klo:11.01
Mitens tuo "ubuntu-restricted-extras" toimii nyt?

Viime kesänä, kun tätä analysoitiin oikein urakalla ja selvitettiin juurta jaksaen miksi Elävä Arkisto / Areena tietyissä tapauksissa ei toimi, tuo komento hoiti tuoreimman Adobe Plug-in asennuksen (tosin ei ratkaissut silloin ongelmaa). Miten on nyt? (en voi tarkistaa tällä hetkellä).

Tarkoitan siis komentoa:

sudo apt-get install ubuntu-restricted-extras
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Storck - 21.07.11 - klo:11.03
Mitens tuo "ubuntu-restricted-extras" toimii nyt?

Viime kesänä, kun tätä analysoitiin oikein urakalla ja selvitettiin juurta jaksaen miksi Elävä Arkisto / Areena tietyissä tapauksissa ei toimi, tuo komento hoiti tuoreimman Adobe Plug-in asennuksen (tosin ei ratkaissut silloin ongelmaa). Miten on nyt? (en voi tarkistaa tällä hetkellä).

Tarkoitan siis komentoa:

sudo apt-get install ubuntu-restricted-extras

Kahdella koneellani normaali Ubuntu ja areenat sekä arkistot toimii. Vain ubuntu-restricted-extras asennettuina ilman muita lisukkeita. (siis ei muita video/elokuvalisukkeita)
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: nm - 21.07.11 - klo:13.14
Yritin päivittää Flash-pluginin Adoben sivuilta, mutta törmäsin omituiseen ongelmaan. Päivitys 10.3:een onnistuu vain näennäisesti. Firefox, muka päivitettyään pluginin, ilmoittaa kuitenkin edelleen käyttävänsä versiota 10.1, joka on gnash, vaan ei flash. Ja tätä gnashia en saa millään pois käytöstä.

Poista paketti mozilla-plugin-gnash. Päätteessä: sudo apt-get remove mozilla-plugin-gnash
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: USakari - 21.07.11 - klo:19.56
Poista paketti mozilla-plugin-gnash. Päätteessä: sudo apt-get remove mozilla-plugin-gnash

Kun tätä yritän, apt-get vastaa:
    Luetaan pakettiluetteloita... Valmis
    Muodostetaan riippuvuussuhteiden puu       
    Luetaan tilatiedot... Valmis       
    Pakettia mozilla-plugin-gnash ei ole asennettu, niinpä sitä ei poisteta
    0 päivitetty, 0 uutta asennusta, 0 poistettavaa ja 0 päivittämätöntä.

Kuitenkin Firefox ilmoittaa edelleen käyttävänsä gnashia.

(Huom: YouTube toimii tällä gnashillakin, mutta YLE Areena siis ei.)

Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: USakari - 21.07.11 - klo:20.37
sudo apt-get install ubuntu-restricted-extras

Tässäpä taisi olla ratkaisu tällä kertaa - kiitos. Täydensin sitä vielä etsimällä ja poistamalla (graafisella) paketinhallinnalla kaikki gnashit.

Nyt, kun YLE Areena siis taas näkyy,  Firefox ilmoittaa käyttävänsä Flash-videoihin liitännäistä "VLC Multimedia Plugin". Hiukan yllättävää, kun nettisivuilla yleensä kuitenkin suositellaan Flash-pluginin hakemista Adobelta itseltään, ja Adobelta Linux-versio löytyy.

VLC-plugin muuten kaatui heti ensimmäiseen YouTube-videoon (ei toki kaikkiin). Ja sekä YouTube että YLE Areenakin pikselöityvät silloin tällöin tosi oudosti. Ei oikein herätä luottamusta. Vai olenko liian kriittinen?

Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: nm - 21.07.11 - klo:22.19
Nyt, kun YLE Areena siis taas näkyy,  Firefox ilmoittaa käyttävänsä Flash-videoihin liitännäistä "VLC Multimedia Plugin". Hiukan yllättävää, kun nettisivuilla yleensä kuitenkin suositellaan Flash-pluginin hakemista Adobelta itseltään, ja Adobelta Linux-versio löytyy.

VLC-liitännäinen toistaa FLV-videot, joka on eri asia kuin Flash (.swf). Sinulla on kyllä myös Adoben Flash Player asennettuna ja sitä käytetään Flash-sisällön esittämiseen, kun kerran Yle Areena toimii. Syytä siis Flash Playeriä pikselöitymisistä ja kaatuilusta.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: USakari - 21.07.11 - klo:23.22
Poista paketti mozilla-plugin-gnash. Päätteessä: sudo apt-get remove mozilla-plugin-gnash

En ole ihan varma, mutta tämän pitäisi olla ehkä sudo apt-get remove browser-plugin-gnash. (Sain gnash-pluginin poistettua graafisen paketinhallinnan avulla, ja sen viesteissä vilahti browser- jne.)
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: nm - 22.07.11 - klo:00.51
En ole ihan varma, mutta tämän pitäisi olla ehkä sudo apt-get remove browser-plugin-gnash. (Sain gnash-pluginin poistettua graafisen paketinhallinnan avulla, ja sen viesteissä vilahti browser- jne.)

Jep, mozilla-plugin-gnash on näemmä uudelleennimetty browser-plugin-gnashiksi Ubuntu 10.10:stä lähtien.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: topi - 24.11.11 - klo:13.19
Ubuntu 10.04 läppärissä, yle areena on toiminut usean  vuoden, mutta nyt lakkasi toimimasta ilmeisesti jonkikn päivityksen jälkeen. Koneeseen ei ole asennettu mitään muuta kuin päivityksiä. Olen kokeillut kaikkia tässä keskustelussa annettuja ohjeita, mutta mikään ei auta. Yle-dl kyllä toimii.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: nm - 24.11.11 - klo:13.37
Ubuntu 10.04 läppärissä, yle areena on toiminut usean  vuoden, mutta nyt lakkasi toimimasta ilmeisesti jonkikn päivityksen jälkeen. Koneeseen ei ole asennettu mitään muuta kuin päivityksiä. Olen kokeillut kaikkia tässä keskustelussa annettuja ohjeita, mutta mikään ei auta. Yle-dl kyllä toimii.

Ilmeisesti uusin flashplugin-installer on buginen. Muutkin ovat törmänneet samaan ongelmaan (http://forum.ubuntu-fi.org/index.php?topic=40929.0) ainakin 11.10:ssä. Vika varmaankin korjaantuu jossain vaiheessa päivitysten myötä.

Jos on kiire, asenna Firefoxiin Flash-aid -lisäosa (https://addons.mozilla.org/en-US/firefox/addon/flash-aid/) ja asenna sen avulla Flash Player uudelleen.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: 2-mieli-FI-poliisi - 11.04.12 - klo:19.35
Vanhaa ja uutta kauraa

Asensin Liferea RSS lukijan koneelle ja hokasin, että Areenan audio podcastit saa ohjelmittain tilaatua "koneelle muistiin". Lisäksi liitetiedoston (audio/mpeg) avaamiseen sai määritettyä oletusohjelmaksi VLC:n. Ja mikä parasta audiostreamin voi kuunnella livenäkin jopa 1,5 kertaisella nopeudella. Kaikki tämä "vain liitetiedostoa tuplaklikkaamalla".
- Vinkkinä vaan niille harvoille, joita asia kiinnostaa.

Mutta, varsinainen asia tai pikemminkin pyyntö, koskee yle-dl:n kanssa peiton alla häärineitä. Onkohan edes teoriassa mahdollista saada Liferea ja yle-dl toimimaan samalla periaatteella?

Ylekin olisi fiksuna julkisen palvelun mediaosaajana varmaankin valmis vähentämään "sivustolla hengailijoiden" määrää tällaisella yleishyödyllisellä kansalaistarpeita tyydyttävällä ratkaisumallilla.
 ;D  ;D  ;D
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: ajaaskel - 11.04.12 - klo:22.35
Lainaus
Onkohan edes teoriassa mahdollista saada Liferea ja yle-dl toimimaan samalla periaatteella?
En ole tutustunut Lifereaan mutta täällä on kuukauden päivät pyörinyt testissä proto ohjelmasta joka on eräänlainen "automaattinen yle-dl", voit nimetä ohjelmat joita haluat seurata ja ne nauhoittuvat automaattisesti ilmestyttyään.  Ohjelma toimii RSS periaatteella, tottelee feedin ttl-ohjausta ja osaa jo tunnistaa huoltokatkojakin kahta eri tietä.  Käyttöliittymään en ole ehtinyt koskemaan vielä vaan aika on huvennut taustaohjelman parissa.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: 2-mieli-FI-poliisi - 12.04.12 - klo:01.42
Loistavaa!
Jos olet jo asian ytimeen pääsyt käsiksi, niin Liferean voit sivuuttaa mennen tullen, se on melkoinen kuraläppä omassa genressäänkin. (toisaalta ei niukasta tarjonnasta kolmejakaista hevosta parempaakaan löydy)

Nykyisen yle-dl+launchy:n hevijuuserina ehdottaisin samanaikaisten latausten maksimimääräksi 3:a. Palvelinhan rajaa nykyisin ruuhkahuippujen latausnopeudet 1-2 Megan yhteystasolle per tiedosto. Latausjono tiedostojen haistelutiheydenkin voisi rajata esim. 17-59 minuutin aikavälille. Reaaliaikaisuus ei välttämättä ole tässä kohtaa se paras valttikortti.

Mutta, kuten ilmeistä, niin teet ensin oman toimivan versiosi parhaaksi katsomallasi tavalla ja muuntelet sitä vasta tarpeen tullen varsinaisten käyttäjäpalautteiden pohjalta.

Kiitos kuitenkin jo näin etukäteen.
Odotan mielenkiinnolla mitä tuleman pitää.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: ajaaskel - 12.04.12 - klo:13.17
Lainaus
Latausjono tiedostojen haistelutiheydenkin voisi rajata esim. 17-59 minuutin aikavälille.
Ohjelma seuraa feedin lähettäjän ohjeita eli tarkistaa uuden feedin YLE: n lähettämän ohjauksen mukaisesti. Tällä hetkellä se on ollut 15 minuuttia. Yle voi helposti laittaa esimerkiksi huoltokatkon lähestyessä viimeistään 15 minuuttia ennen huoltokatkoa ttl-ajaksi vaikka 120 minuuttia jolloin liikennne hiljenee itsestään huoltokatkon ajaksi.  Tuota ohjausta ei ole havaintoni mukaan toistaiseksi käytetty.  Ohjelma tunnistaa myös sanat "huolto" ja  "katko", laitoin ne tunnistumaan html-koodista kuten ne viimeksi olivat ja ohjelma menee ttl-ajan mukaiseen odotukseen.  Virheet ja huollot loggautuvat tiedostoon. Tältä näyttävät tapahtumat päätteessä kun se on laitettu seuraamaan ohjelmia Humps, Pikku Kakkonen ja Touhulan arvoituksia:
Time for new feed...                    
Feed received.
RSS feed contents validation passed.
Filtering file... done.
Using received RSS cycle 15 minutes.
Category= Lapset
Converting to tsv... done.
Getting feed titles... done.
Matching title: Humps: 09.04.2012 07.33
This was already done: Humps, id: 405033
Matching title: Pikku Kakkonen: 11.04.2012 17.00
This was already done: Pikku Kakkonen, id: 1475894
Matching title: Richard Scarry: Touhulan arvoituksia: 07.04.2012 07.47
This was already done: Richard Scarry: Touhulan arvoituksia, id: 3329
Idle...900 s
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: K-Veikko - 15.04.12 - klo:18.46
Feature request.

Voisiko yle-dl ohjelmassa olla päivitysoptio. Samaan tapaan kuin youtube-dl ohjelmassa on komento
Koodia: [Valitse]
sudo youtube-dl -U
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: nm - 15.04.12 - klo:18.50
Voisiko yle-dl ohjelmassa olla päivitysoptio. Samaan tapaan kuin youtube-dl ohjelmassa on komento
Koodia: [Valitse]
sudo youtube-dl -U

Tuo rikkoo paketoinnin. Olisi fiksumpaa tehdä ohjelmalle PPA, josta päivitykset valuvat käyttäjille automaattisesti.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: ubunyyppä - 19.07.12 - klo:09.23
Pystyykö YLE Areenaa katsomaan jollain muulla kuin Adoben flashilla, se kun ei kerta kaikkiaan suostu toimimaan meikäläisen Ubuntu 10.04:ssä. Olen kokeillut sekä ubuntu-restricted-extras-pakettia että Flashin lataamista Firefoxin Flash-aid -lisäosalla. Youtubea kyllä voi katsoa Firefoxilla pitämällä Shockwave Flashin poissa päältä ja käyttämällä jotain Totem-yhteensopivaa pluginia (nyt on käytössä VLC Multimedia Plugin).

Aiemmin käytin Areenan katsomiseen Google Chromea, jossa Flash kyllä toimi, mutta viimeisin päivitys versiosta 19 versioon 20 rikkoi senkin, enkä ole keksinyt miten saisin sen downgradattua takaisin versioon 19...

Edit: Tarkennetaan vielä sen verran että Chrome kyllä muuten toimii Flashia lukuunottamatta.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: welmar - 19.07.12 - klo:11.15
Chromessa flash pitää laittaa päälle että se toimii http://support.google.com/chrome/bin/answer.py?hl=fi&answer=108086
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: ubunyyppä - 19.07.12 - klo:14.39
Flash on kyllä päällä, mutta Areenan tai Youtuben videoita katsellessa tulee ilmoitus "Laajennuksen lataaminen epäonnistui".

chrome://plugins antaa tällaiset tiedot:

Flash - Versio: 11.2 r202
Shockwave Flash 11.2 r202
Nimi:   Shockwave Flash
Versio:   11.2 r202
Sijainti:   /usr/lib/mozilla/plugins/libflashplayer.so
Tyyppi:   NPAPI
     Poista käytöstä
MIME-tyypit:   
MIME-tyyppi   Kuvaus   Tiedostotunnisteet
application/x-shockwave-flash   Shockwave Flash   .swf
application/futuresplash   FutureSplash Player   .spl

Chromehan on ymmärtääkseni siirtymässä käyttämään Pepper APIa (PPAPI), mutta sitä ei ole listattu pluginseissa, joten en voi sitä kokeilla.


EDIT: Ratkaisu löytyi! Ilmeisesti meikäläisellä on käytössä niin vanhaa rautaa (Athlon-prosessori) että uusin Flash ei yksinkertaisesti sillä toimi koska se hyödyntää SSE2-käskykantaa. Niinpä ainut mahdollisuus oli löytää vanhempi versio Flashista. Ketjusta http://forum.ubuntu-fi.org/index.php?topic=42989.0 löytyi linkki Chromen versioon 19, joka vielä toimi. Latasin .deb-paketin, purin siitä tiedoston libgcflashplayer.so ja kopioin sen Chromen hakemistoon. Nyt toimii taas Areena, ainakin seuraavaan Chromen päivitykseen asti...
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: avanti - 28.08.12 - klo:01.56
Nyt kun olen asentanut ja ottanut yle-dl:n taas käyttööni, niin mitähän tämä on kun ei onnistukaan. Päätteeseen tulee tämä teksti:

"matti@matti-DD376A-ABX-6660-FI110:~$ cd Videot
matti@matti-DD376A-ABX-6660-FI110:~/Videot$ yle-dl http://areena.yle.fi/tv/1649310
Can't find AreenaPlayerParams from the page.
Is http://areena.yle.fi/tv/1649310 really a YLE Areena video page?
matti@matti-DD376A-ABX-6660-FI110:~/Videot$"

Kyllä otin tuon URL:n areenan videosivulta, samalta sivulta kuin missä video on. Näkisin edes alueuutiset tallennettuna. Ja vaikka jotain muutakin.

Onpa muuten hassu yksityiskohta tuo heksadesimaaliosa aina päätteessä.

ML
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: ajaaskel - 28.08.12 - klo:08.36
Kokeilin, toimii täällä
yle-dl http://areena.yle.fi/tv/1649310
.
51789.954 kB / 599.21 sec (99.9%)
Download complete
Stream saved to Yle Uutiset Uusimaa-2012-08-27T19:10:00.flv

Ettei olisi vanha versio jostain syystä, näyttääkö se "v2.0" ?

yle-dl 2.0.0: Download media files from Yle Areena and Elävä Arkisto
Copyright (C) 2009-2012 Antti Ajanki <antti.ajanki@iki.fi>, license: GPLv2

Kummalla menetelmällä asensit sen, asennusohjelma (skripti) vai pelkkä .deb -paketti ? Asennusohjelman tiputtaminen ja ajaminen korjaisi varmaan tuon.

http://www.homelinuxpc.com/download/Areenan_nauhoituksen_asennus.html (http://www.homelinuxpc.com/download/Areenan_nauhoituksen_asennus.html)
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: avanti - 28.08.12 - klo:23.42
Ahaa, minulla vanha versio, v. 1.4.3 ja asensin sen täältä: http://rtmpdump-yle.xn--tlt-qlaac.fi/. Deb-paketti se oli. Täytyy asentaa uusiksi. Jostain syystä tuotti ongelmia löytää jokin sivu, josta saada ja asentaa. Tuon sivun löysin ja näytti olevan ohjeetkin.

Itseasiassa antamaasi linkkiä etsinkin, olin sen jo kerran löytänyt, mutta kadotin silloin kun piti alkaa tapahtumaankin.

ML
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: OJK - 24.10.12 - klo:15.48
Ajattelin laittaa ihmettelyni tähän ketjuun, näyttää osuvan nappiin minunkin ongelmani kanssa.
Ongelma: En saa enää tallennettua Yle-dl:llä ohjelmia Areenasta.
Tässä kuvausta ongelmasta ja JO TEHDYISTÄ toimenpiteistä:
1. Olen tallentanut aiemmin paljon radio-ohjelmia Yle Areenasta. Kaikki on toiminut hyvin. Nyt yritin tallentaa ensimmäistä TV-ohjelmaa.
2. Kun yritin tallentaa TV-ohjelmaa, sain seuraavan herjan:
Koodia: [Valitse]
Connecting ...
WARNING: HandShake: client signature does not match!
INFO: Connected...
ERROR: rtmp server sent error
ERROR: rtmp server requested close
Eli samasta on tässä ketjussa aiemminkin kirjoitettu.
3. Yritin korjata tilanteen varmistamalla, että minulla on oikea versio Yle-dl:stä. Asensin ohjelman uudelleen täältä: http://www.homelinuxpc.com/download/Areenan_nauhoituksen_asennus.html (http://www.homelinuxpc.com/download/Areenan_nauhoituksen_asennus.html)
Sama tulos, ei tallenna.
4. Onnistun kuitenkin katsomaan ohjelman itse Areenan sivuilta, eli mikään flash-plugin -ongelma ei ole kyseessä.
5. En saa ohjelmaa myöskään näkyviin VLC:ssä, en osaa :-( Enkä myöskään osaa edes kokeilla ohjelman tallennusta VLC:ssä - aika tumpula olen...

Olisin kiitollinen pikaisista vastauksista, sillä ohjelma on enää kuusi päivää Areenassa.

EDIT: Niin, unohtui äsken mainita. Ubuntuni versio on 10.04 LTS, jos sillä sattuisi olemaan vaikutusta.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: nm - 24.10.12 - klo:17.58
2. Kun yritin tallentaa TV-ohjelmaa, sain seuraavan herjan:
Koodia: [Valitse]
Connecting ...
WARNING: HandShake: client signature does not match!
INFO: Connected...
ERROR: rtmp server sent error
ERROR: rtmp server requested close
Eli samasta on tässä ketjussa aiemminkin kirjoitettu.
3. Yritin korjata tilanteen varmistamalla, että minulla on oikea versio Yle-dl:stä. Asensin ohjelman uudelleen täältä: http://www.homelinuxpc.com/download/Areenan_nauhoituksen_asennus.html (http://www.homelinuxpc.com/download/Areenan_nauhoituksen_asennus.html)
Sama tulos, ei tallenna.

Poista ensin kaikki järjestelmään asennetut vanhat yle-dl-versiot ja asenna sitten tuo nykyinen versio. Eli varmista ennen asennusta, ettei ohjelmaa löydy ajamalla komento yle-dl päätteessä. Jos se löytyy ja näyttää ohjelistauksen, tutki missä hakemistossa ja paketissa ohjelma sijaitsee. Aja nämä päätteessä ja kopioi tuloste tänne:

Koodia: [Valitse]
which yle-dl
dpkg -S yle-dl
dpkg -l *yle*
dpkg -l *rtmp*


4. Onnistun kuitenkin katsomaan ohjelman itse Areenan sivuilta, eli mikään flash-plugin -ongelma ei ole kyseessä.

Juu, eikä yle-dl/rtmpdump edes tarvitse Flash Playeriä tai muita Adoben palikoita. Verkkopuoli kuitenkin on ilmeisesti kunnossa, joten sen puolesta yle-dl:n pitäisi toimia.

Lainaus
5. En saa ohjelmaa myöskään näkyviin VLC:ssä, en osaa :-( Enkä myöskään osaa edes kokeilla ohjelman tallennusta VLC:ssä - aika tumpula olen...

Areena toimii VLC:llä vain rtmpdump-putkituksen kautta, ja vaatii siten päätekomentoja tai tarkoitusta varten tehdyn skriptin. Rtmpdumpin pitäisi myös ensin toimia yle-dl:n kautta, ennen kuin suoratoistosta VLC:llä tai muilla mediasoittimilla voi edes haaveilla.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: OJK - 24.10.12 - klo:19.46
Poista ensin kaikki järjestelmään asennetut vanhat yle-dl-versiot ja asenna sitten tuo nykyinen versio. Eli varmista ennen asennusta, ettei ohjelmaa löydy ajamalla komento yle-dl päätteessä.

Kiitos opastuksesta. Nyt toimii tallennus mainiosti. Mutta ilmeni uusi ongelma: Tallenteen ääni kuuluu, mutta kuva ei näy. Ilmeisesti jotkin codecit puuttuvat, nyt kun vain muistaisin, mikä kirjasto pitää olla asennettuna...Jos siihen vielä joku viitsii vastauksen nakata. Selvittelen kyllä itsekin.
Kiitos!

EDIT: Olen nyt varmistanut, että minulla on asennettuna Ubuntu-restricted-extras. Se on ja varmuudeksi vielä uudelleen asennettuna. Lisäksi Flash on erikseen päivitetty.
Mutta kuva ei vain näy. Ubuntun oma elokuvasoitin näyttää metatiedoissa kuvan koodekkin kohdalla tyhjää. Äänen kohdalla näkyy koodekkina Mpeg-4 AAC audio.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: nm - 24.10.12 - klo:20.28
Varmista, että paketti libavcodec-extra-52 on asennettuna ja kokeile sitten tiedoston toistoa VLC:llä.

Jos video näkyy nyt VLC:llä, mutta Elokuvasoitin (Totem) ei toimi vieläkään, tarkista myös, että ubuntu-restricted-extras-paketin myötä asentuvat gstreamer-paketit (http://packages.ubuntu.com/lucid/ubuntu-restricted-extras) ovat varmasti asennettuna.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Ganymedes - 24.10.12 - klo:20.59
...
EDIT: Olen nyt varmistanut, että minulla on asennettuna Ubuntu-restricted-extras. Se on ja varmuudeksi vielä uudelleen asennettuna. Lisäksi Flash on erikseen päivitetty.
Mutta kuva ei vain näy. Ubuntun oma elokuvasoitin näyttää metatiedoissa kuvan koodekkin kohdalla tyhjää. Äänen kohdalla näkyy koodekkina Mpeg-4 AAC audio.

Joskus tosiaan tuota ilmenee FLV:n toistossa, en tiedä miksi, ehkä nm:n ohjeella selviää? Toisaalta, tuossa tilanteessa kuva kuitenkin tulee heti näkyviin kun ikkunan kokoa muuttaa - toimiiko tuo?

VLC kuitenkin yleensä toistaa tässäkin tilanteessa ilman että ikkunan kokoa tarvitsee muutella. Tämä siis 10.x versioissa, uudet tuntuvat toimivan paremmin.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: OJK - 25.10.12 - klo:16.09
Varmista, että paketti libavcodec-extra-52 on asennettuna ja kokeile sitten tiedoston toistoa VLC:llä.

Jos video näkyy nyt VLC:llä, mutta Elokuvasoitin (Totem) ei toimi vieläkään, tarkista myös, että ubuntu-restricted-extras-paketin myötä asentuvat gstreamer-paketit (http://packages.ubuntu.com/lucid/ubuntu-restricted-extras) ovat varmasti asennettuna.

Olen nyt tarkastanut molemmat. Eli minulla ovat sekä libavcodec-extra-52 että gstreamer-paketit asennettuna.
Mutta kuva ei näy vieläkään, ei VLC:ssä eikä Totemissa. Edelleen Totem näyttää metatiedoissa kuvakoodekkin kohdalla pelkkää tyhjää. Ääni kuuluu kyllä mainiosti. Poistin jopa eilen lataamani ohjelman ja latasin sen uudelleen. Ei auttanut. Nyt loppui minun osaamiseni :-(
Kokeilen vielä jollain toisella ohjelmalla, mutta kun niitä kerran samasta palvelusta yritän ladata, niin eipä varmaan muutosta tuloksessa ole. Mutta jos nyt kuitenkin sattuisi olemaan tuossa yhdessä tiedostossa jokin ongelma...Saapa nähdä.

EDIT: Kävin lataamassa Ylen uutiset. Sama juttu: Ääni kuuluu, mutta kuva ei näy - ei VLC:ssä eikä Totemissa.
Se ero edelliseen ohjelmaan on, että nyt Totemin metatiedoissa näkyy kuvakoodekkina H.264/AVC Video.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Ganymedes - 25.10.12 - klo:16.16
...
Mutta kuva ei näy vieläkään, ei VLC:ssä eikä Totemissa.
...

Kokeilitko muuttaa ikkunan kokoa?
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: ajaaskel - 28.10.12 - klo:20.51
Lainaus
OJK:
Kokeilin muuttaa, eikä auttanut. Mutta Hola! Löysin ongelman syyn ja sain asian ratkaistua! :-)
Ongelman aiheuttaja oli kakkosnäyttö. Minulla on VGA-porttiin liitetty toinen näyttö, johon olen laajentanut työpöytää. Tämä kytkentä aiheutti ongelman.
Hoksasin sen sitä kautta, että huomasin, etteivät VLC:n eikä Totemin visualisoinnit toimineet musiikkia kuunnellessa. En ollut aiemmin kiinnittänyt tuohon huomiota, vaikka minulla onkin ollut Totemin visualisointi päällä.
Napsaisin kakkosnäytön irti koneesta ja jo näkyivät Yle uutiset sekä haluamani ohjelma.

Kiitos Ganymedes ja nm hyvistä neuvoista. Ilman neuvojanne en olisi osannut lähteä sulkeistamaan mahdollisia virheitä pois, vaikka syyn suurin piirtein olisin osannutkin aavistella. Lopullinen virhe olisi jäänyt kuitenkin huomaamatta, jos en olisi tehnyt neuvojenne mukaista sulkeistamista.

Olisiko kenelläkään neuvoa, miten saisin pidettyä kakkosnäytön kiinni ja silti tallenteet näkyisivät? Olisi mukavampi katsella niitä tuosta 19" näytöltä kuin 11-tuumaiselta :-) Vaikka pääasia kuitenkin on, että näkyyvät edes jollain tavalla.


Merkkien muuttumisongelma jatkuu täällä:

http://forum.ubuntu-fi.org/index.php?topic=43813.0 (http://forum.ubuntu-fi.org/index.php?topic=43813.0)

Kakkosnäytön ongelma jatkuu täällä:

http://forum.ubuntu-fi.org/index.php?topic=44710.msg343716#msg343716 (http://forum.ubuntu-fi.org/index.php?topic=44710.msg343716#msg343716)
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: ajaaskel - 06.03.13 - klo:09.17
Lainaus
Pystyykö YLE Areenaa katsomaan jollain muulla kuin Adoben flashilla...

Kiertotie aika monesti on nauhoittaa ohjelma ensin ja katsella sitten. Hieman hitaammalla koneella tuo voi olla ainut hyvin toimiva vaihtoehto sillä hitaammissa koneissa ei tehot riitä ja kuva nykii jos katselee Flash: in avulla.  Itse nauhoituksen asennus on pika-asennusohjelman (skripti) avulla Ubuntu/Mint/vast. käyttäjille nopea.  Täydellisempiä ohjesivuja on täällä:

Käsin nauhoitus:
http://www.homelinuxpc.com/download/Areenan_nauhoituksen_asennus.html (http://www.homelinuxpc.com/download/Areenan_nauhoituksen_asennus.html)

Tuo nauhoittelee sen ohjelman minkä valitset Firefox: ssa.   Jos sen sijaan haluat automaatin missä valitset kerran ohjelman ja se nauhoittaa itsekseen siitä eteenpäin kaikki ohjelmasarjan tulevatkin jaksot sitä mukaa kun ne ilmestyvät niin tarvitset "Auto DL" ohjelman joka on automaattinen nauhuri:

Automaattinauhoitus:
http://forum.ubuntu-fi.org/index.php?topic=43484.msg343730#msg343730 (http://forum.ubuntu-fi.org/index.php?topic=43484.msg343730#msg343730)


Yhteensopivuus:  Kaikki tekemäni ohjelmat/asennusohjelmat/paketit on kirjoitettu/ testattu Ubuntussa ja Linux Mint: ssä.  Asennus näihin on ongelmaton.  Asentaminen muihin vaatii näiden Linuxien tarkempaa teknistä asiantuntemusta asentajalta. Kannattaa huomata että Ubuntulle tyypillinen "sudoilu" pitää toimia ja rakenteissa on jossain määrin Debian -perusteisia asioita.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: ajaaskel - 04.04.13 - klo:11.22
Katsomon nauhoitusongelman selvittely täällä:

http://forum.ubuntu-fi.org/index.php?topic=44885.msg344654#msg344654 (http://forum.ubuntu-fi.org/index.php?topic=44885.msg344654#msg344654)
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Jiku - 22.04.13 - klo:18.35
Areenassa on nyt sitten kanavat suoranakin saatavilla. Ainakin nämä mobiili-streamit toimivat suoraan VLC:llä

YLE Fem_sv http://yletv-lh.akamaihd.net/i/ylefemsehls_1@103186/index_1_av-b.m3u8
YLE Fem_fi http://yletv-lh.akamaihd.net/i/ylefemfihls_1@103185/index_1_av-b.m3u8
YLE TV1 http://yletv-lh.akamaihd.net/i/yletv1hls_1@103188/index_1_av-b.m3u8
YLE TV2 http://yletv-lh.akamaihd.net/i/yletv2hls_1@103189/index_1_av-b.m3u8
YLE Teema http://yletv-lh.akamaihd.net/i/yleteemahls_1@103187/index_1_av-b.m3u8

Edit: korjattu linkit

Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: salai - 22.04.13 - klo:19.08
Tv1 ja 2 pitäisi kirjoittaa kai kuin muutkin, eli näin toimivat minulla:
YLE TV1 http://yletv-lh.akamaihd.net/i/yletv1hls_1@103188/index_1_av-b.m3u8
YLE TV2 http://yletv-lh.akamaihd.net/i/yletv2hls_1@103189/index_1_av-b.m3u8

Jaa, eipä toimi ainakaan tällä hetkellä Yle1 kuin hetken aikaa ennen katkeamista.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Jiku - 22.04.13 - klo:19.13
Olet aivan oikeassa, salai!
Toisaalta nuo master-linkit sisältää kaikki valittavissa olevat laadut, joten voisi nekin listata.
Lisään ne kohta. Ne voi ladata vaikka wgetillä ja avata tekstieditorilla, niin saa suoraan haluamansa laadun.

Edit:
YLE Fem_sv http://yletv-lh.akamaihd.net/i/ylefemsehls_1@103186/master.m3u8
YLE Fem_fi http://yletv-lh.akamaihd.net/i/ylefemfihls_1@103185/master.m3u8
YLE TV1 http://yletv-lh.akamaihd.net/i/yletv1hls_1@103188/master.m3u8
YLE TV2 http://yletv-lh.akamaihd.net/i/yletv2hls_1@103189/master.m3u8
YLE Teema http://yletv-lh.akamaihd.net/i/yleteemahls_1@103187/master.m3u8
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Jiku - 22.04.13 - klo:19.25
Jaa, eipä toimi ainakaan tällä hetkellä Yle1 kuin hetken aikaa ennen katkeamista.

Näköjään kun avaan tuon master-streamin, niin VLC vaihtaa jossain vaiheessa vähäksi aikaa huonompaan laatuun. Aivan kuin kaista ei riittäisi parempaan. Ei kyllä luulisi, että Akamain päästä ainakaan kaista olisi ongelma. Mistähän tätä nyt lähtisi ratkomaan?
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: salai - 22.04.13 - klo:19.42
Jos laittaa koko sen stringin, niin näyttäisi toimivan.
Esim. Yle1:
http://yletv-lh.akamaihd.net/i/yletv1hls_1@103188/index_1_av-b.m3u8?sd=10&rebase=on

Katkeaa aina välillä hetkeksi, mutta jatkuu välittömästi.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Cultor - 23.04.13 - klo:09.26
Nuo ovat nähdäkseni i-laitteille tarkoitettuja ja soittolistoja. Video tulee vajaan kymmenen sekunnin pätkissä. Mistä nuo muuten löytyvät mobiili-areenasta?

rtsp://stream3.yle.mobi/ngareena/b3/b3846159da934bbd83723c4939614856_high.mp4

Tämäkin näkyy VLC:llä, kun sen antaa suoraan. FlashGot'in kautta ei toiminut. K Movie Player'lla toimii paremmin, myös FlashGot'illa avattuna.

 K Movie Player v0.7.2  based on FFplay, is made to play various media files on OS/2
and eComStation.
© KO Myung-Hun
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Jiku - 23.04.13 - klo:10.04
Nuo ovat nähdäkseni i-laitteille tarkoitettuja ja soittolistoja. Video tulee vajaan kymmenen sekunnin pätkissä. Mistä nuo muuten löytyvät mobiili-areenasta?

Nuo on Areenan Android-sovelluksesta poimittu. Laitoin tällaisen (http://pastebin.com/YTSrbEbN) python-proxyn pyörimään tietokoneelle ja sitten Androidiin ProxyDroid (https://play.google.com/store/apps/details?id=org.proxydroid) kierrättämään liikenteen tietokoneen kautta. Nyt tietokoneen näytölle tulee kaikki pyynnöt selväkielisenä eli sitä ei ole mitenkään salattu, toisin kuin www-versiossa.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Cultor - 23.04.13 - klo:10.36
Siis Mobiili-Areenassa (http://yle.mobi/w/areena/tv) eilisen puoli yhdeksän uutisten linkki default user agentilla on:
rtsp://stream3.yle.mobi/ngareena/b3/b3846159da934bbd83723c4939614856_high.mp4  VLC:n record-napilla tallennetusta hyvälaatuisesta pätkästä MPlayer kertoo "VIDEO:  [H264]  640x360  24bpp  25.083 fps  720.1 kbps (87.9 kbyte/s)".

iPhone user agent antaa:
http://lataa3.yle.mobi/tstreamng/b3/b3846159da934bbd83723c4939614856_high.m3u8
joka on soittolista. VLC:llä pätkii streamin vaihtuessa kymmenen sekunnin välein, K Movie Playerilla vähemmän.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Sprottivakti - 24.04.13 - klo:02.10
Nuo on Areenan Android-sovelluksesta poimittu. Laitoin tällaisen (http://pastebin.com/YTSrbEbN) python-proxyn pyörimään tietokoneelle ja sitten Androidiin ProxyDroid (https://play.google.com/store/apps/details?id=org.proxydroid) kierrättämään liikenteen tietokoneen kautta. Nyt tietokoneen näytölle tulee kaikki pyynnöt selväkielisenä eli sitä ei ole mitenkään salattu, toisin kuin www-versiossa.

Jaa, että Androidille tarjotaan parempaa maksimilaatua kuin tavallisen Areenan käyttäjille. ???

Tuolla kun maksimilaatu on 704x396, Areenassa "vain" 640x360. ;D
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Jiku - 28.04.13 - klo:14.32
Raspberryn omxplayer näköjään toistaa streamit ongelmitta ja nykimättä.
esim:
Koodia: [Valitse]
omxplayer -o hdmi "http://yletv-lh.akamaihd.net/i/yletv1hls_1@103188/index_1_av-b.m3u8?sd=10&rebase=on"
Saisikohan tuota omxplayeriä mitenkään käännettyä Ubuntulle? Vaikuttaa muutenkin olevan nimittäin soitin, jonka kanssa on vähiten ongelmia..
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: PeeAaa - 02.05.13 - klo:14.48
Koodia: [Valitse]
ffplay http://yletv-lh.akamaihd.net/i/yletv1hls_1@103188/index_1_av-b.m3u8?sd=10&rebase=onHyvin pyörii.

Koodia: [Valitse]
ffplay rtsp://stream3.yle.mobi/ngareena/b3/b3846159da934bbd83723c4939614856_high.mp4Pyörii pätkimättä ,mutta kuvassa värihäiriöitä.

Koodia: [Valitse]
gst-launch-0.10 playbin uri=rtsp://stream3.yle.mobi/ngareena/b3/b3846159da934bbd83723c4939614856_high.mp4 -vvv
Kuva ok ,mutta ääni pätkii satunnaisesti . Jos tuon -vvv:n poistaa niin tulee pelkkä ääni joka ei pätki.Komento lainattu jostain keskustelupalstalta.
Lisäksi joka kerran kun käynnistää uudestaan niin toisinaan pyörii täydellisesti ja toisinaan
lyö poikki. Tämä virhe tulee kuitenkin joka kerta.
Koodia: [Valitse]
There may be a timestamping problem, or this computer is too slow.Ehkä parametreja pitäis lisätä kun vain osais.

T:PeeAaa

Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Jiku - 02.05.13 - klo:17.24
Millä ffplay:n versiolla, PeeAaa, saat tuon toimimaan?
Minä saan tuolla vain sekunnin murto-osan näkyviin tai sitten ilmoituksen muistialueen ylityksestä.

Koodia: [Valitse]
avplay version 0.8.6-6:0.8.6-0ubuntu0.12.10.1
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: PeeAaa - 02.05.13 - klo:17.51
Koodia: [Valitse]
avplay version 0.8.6-4:0.8.6-0ubuntu0.12.04.1
T:PeeAaa
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: mek - 21.05.13 - klo:21.44
Lainaus
Pystyykö YLE Areenaa katsomaan jollain muulla kuin Adoben flashilla...

Kiertotie aika monesti on nauhoittaa ohjelma ensin ja katsella sitten. Hieman hitaammalla koneella tuo voi olla ainut hyvin toimiva vaihtoehto sillä hitaammissa koneissa ei tehot riitä ja kuva nykii jos katselee Flash: in avulla.  Itse nauhoituksen asennus on pika-asennusohjelman (skripti) avulla Ubuntu/Mint/vast. käyttäjille nopea.  Täydellisempiä ohjesivuja on täällä:

Käsin nauhoitus:
http://www.homelinuxpc.com/download/Areenan_nauhoituksen_asennus.html (http://www.homelinuxpc.com/download/Areenan_nauhoituksen_asennus.html)

Tuo nauhoittelee sen ohjelman minkä valitset Firefox: ssa.   Jos sen sijaan haluat automaatin missä valitset kerran ohjelman ja se nauhoittaa itsekseen siitä eteenpäin kaikki ohjelmasarjan tulevatkin jaksot sitä mukaa kun ne ilmestyvät niin tarvitset "Auto DL" ohjelman joka on automaattinen nauhuri:

Automaattinauhoitus:
http://forum.ubuntu-fi.org/index.php?topic=43484.msg343730#msg343730 (http://forum.ubuntu-fi.org/index.php?topic=43484.msg343730#msg343730)


Yhteensopivuus:  Kaikki tekemäni ohjelmat/asennusohjelmat/paketit on kirjoitettu/ testattu Ubuntussa ja Linux Mint: ssä.  Asennus näihin on ongelmaton.  Asentaminen muihin vaatii näiden Linuxien tarkempaa teknistä asiantuntemusta asentajalta. Kannattaa huomata että Ubuntulle tyypillinen "sudoilu" pitää toimia ja rakenteissa on jossain määrin Debian -perusteisia asioita.

Osaako joku sanoa, miksi esim. tuon http://areena.yle.fi/tv/1900846 (http://areena.yle.fi/tv/1900846) ohjelman tallennus ei onnistu, vaikka asensin Launchyn pika-asennuksena yllä olevan ohjeen mukaan. Launchyn menut tulivat ok Firefoxiin, mutta Launchy ei löydä tuolta sivulta mitään tallennettavaa ohjelmaa.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: oobetimer - 21.05.13 - klo:22.39
Osaako joku sanoa, miksi esim. tuon http://areena.yle.fi/tv/1900846 (http://areena.yle.fi/tv/1900846) ohjelman tallennus ei onnistu, vaikka asensin Launchyn pika-asennuksena yllä olevan ohjeen mukaan. Launchyn menut tulivat ok Firefoxiin, mutta Launchy ei löydä tuolta sivulta mitään tallennettavaa ohjelmaa.

Yle-dl toimii myös ilman Launchya, ja komentoriviltä näkee myös mahdollisen virheen aiheuttajan. Tuo esimerkkinä mainittu video latautui ilman ongelmia koneelle.

(http://i11.aijaa.com/t/00267/12245830.t.jpg) (http://aijaa.com/HPjRlN)
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: mek - 22.05.13 - klo:07.52

Yle-dl toimii myös ilman Launchya, ja komentoriviltä näkee myös mahdollisen virheen aiheuttajan. Tuo esimerkkinä mainittu video latautui ilman ongelmia koneelle.

(http://i11.aijaa.com/t/00267/12245830.t.jpg) (http://aijaa.com/HPjRlN)
Miten? Kysyy tyhmä... :o
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: mrl586 - 22.05.13 - klo:08.36

Yle-dl toimii myös ilman Launchya, ja komentoriviltä näkee myös mahdollisen virheen aiheuttajan. Tuo esimerkkinä mainittu video latautui ilman ongelmia koneelle.

(http://i11.aijaa.com/t/00267/12245830.t.jpg) (http://aijaa.com/HPjRlN)
Miten? Kysyy tyhmä... :o
Vastauksen näet kuvasta, paitsi jos olet näkörajoitteinen. Yle-dl toimii komentoriviltä käsin niin, että ohjelman nimen perään laitetaan ohjelman osoite ja tämän jälkeen painetaan enteriä (tai joissain koneissa returnia).
Koodia: [Valitse]
yle-dl http://areena.yle.fi/tv/numerosarja
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: ajaaskel - 22.05.13 - klo:16.11
Lainaus
Launchy ei löydä tuolta sivulta mitään tallennettavaa ohjelmaa.

Arvaan että osoitat hiirellä sellaisen kohtaan missä ei ole linkkiä takana jos Launchy ei anna mitään valittavaa.  Pyörittele kuvaa sen verran alaspäin että saat näkyviin "Jaksot", siellä näkyy kolme jaksoa ja kokeile sieltä joko ohjelman nimen tai kuvan päältä.


(Alla kuva, klikkaa kerran niin suurenee)
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: mek - 22.05.13 - klo:21.18
Kiitos.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: mrl586 - 20.09.13 - klo:22.01
yle-dl ei osaa tallentaa ruotsinkielisen areenan (http://arenan.yle.fi) sisältöä, vaan tuloksena on Unsupported URL -virheilmoitus.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: raimo - 20.09.13 - klo:23.25
yle-dl ei osaa tallentaa ruotsinkielisen areenan (http://arenan.yle.fi) sisältöä, vaan tuloksena on Unsupported URL -virheilmoitus.
Hyvin toimii täällä, en nyt tosin kokeillut kuin yhtä videota: http://arenan.yle.fi/tv/1996840
yle-dl versio 2.0.2-1
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: mrl586 - 21.09.13 - klo:22.00
Ilmeisesti tuorein yle-dl ei tunnista ruotsinkielisen YLE Arenan osoitteita. Tästä kohtaa koodia lienee jokin puute.
Koodia: [Valitse]
def downloader_factory(url):
    if url.startswith('http://www.yle.fi/elavaarkisto/') or \
            url.startswith('http://yle.fi/elavaarkisto/'):
        return ElavaArkistoDownloader()
    elif url.startswith('http://ylex.yle.fi/'):
        return YleXDownloader()
    elif url.startswith('http://areena.yle.fi/tv/suora/'):
        return AreenaLiveDownloader()
    elif url.startswith('http://areena.yle.fi/') or \
            url.startswith('http://yle.fi/'):
        return AreenaNGDownloader()
    else:
        return None
Eli jos urlin alku on jotain muuta kuin tuolla listalla, palautetaan None. Tämä johtaa URL ei tuettu -virheilmoitukseen.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Kullervo - 29.10.13 - klo:20.10
Koodia: [Valitse]
:~$ yle-dl http://areena.yle.fi/tv/2061644
Traceback (most recent call last):
  File "/usr/local/bin/yle-dl", line 1095, in <module>
    main()
  File "/usr/local/bin/yle-dl", line 1091, in main
    sys.exit(dl.download_episodes(url, rtmpdumpargs, latest_episode, sublang, destdir))
  File "/usr/local/bin/yle-dl", line 426, in download_episodes
    return self.process_episodes(url, parameters, latest_episode, sublang, destdir, False)
  File "/usr/local/bin/yle-dl", line 451, in process_episodes
    sublang, destdir, print_url)
  File "/usr/local/bin/yle-dl", line 460, in process_single_episode
    rtmpparams = self.get_rtmp_parameters(clip, pageurl)
  File "/usr/local/bin/yle-dl", line 529, in get_rtmp_parameters
    return self.get_tv_rtmp_parameters(clip, pageurl)
  File "/usr/local/bin/yle-dl", line 548, in get_tv_rtmp_parameters
    papiurl = 'http://papi.yle.fi/ng/mod/rtmp/' + media['id']
TypeError: cannot concatenate 'str' and 'NoneType' objects
Missä vika? Ja miksi vain tuo ohjelma näyttäisi bugaavan?
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Cultor - 31.10.13 - klo:11.30
Koodia: [Valitse]
:~$ yle-dl http://areena.yle.fi/tv/2061644 Missä vika? Ja miksi vain tuo ohjelma näyttäisi bugaavan?

Downton Abbey on toteutettu eri tavalla, uudella Areena player 1.3.3.0, muissa on käytössä Areena player 1.2.2.0.1. Ajamalla yle-dl --verbose vivulla päätteellä, seasta löytyy http://areena-pdl-finland.edgesuite.net/drm/downton_01_fi_20131023.flv. Linkki selaimeen, niin latautuu kyllä, mutta en ole saanut sitä millään katsottua. Lienee drm käytössä. Areenan suorasta sen saa tai paremminkin sai talteen.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: nm - 31.10.13 - klo:15.30
Downton Abbey on toteutettu eri tavalla, uudella Areena player 1.3.3.0, muissa on käytössä Areena player 1.2.2.0.1. Ajamalla yle-dl --verbose vivulla päätteellä, seasta löytyy http://areena-pdl-finland.edgesuite.net/drm/downton_01_fi_20131023.flv. Linkki selaimeen, niin latautuu kyllä, mutta en ole saanut sitä millään katsottua. Lienee drm käytössä. Areenan suorasta sen saa tai paremminkin sai talteen.

Jep, tiedosto on DRM-suojattu, joten yle-dl:stä ei olisi hyötyä sen kanssa. Ellei sitten jostain linkistä saisi Androidille tai iOS:lle tarkoitettua versiota ilman DRM:ää...
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Cultor - 31.10.13 - klo:16.52
Downton Abbey on toteutettu eri tavalla, uudella Areena player 1.3.3.0, muissa on käytössä Areena player 1.2.2.0.1. Ajamalla yle-dl --verbose vivulla päätteellä, seasta löytyy http://areena-pdl-finland.edgesuite.net/drm/downton_01_fi_20131023.flv. Linkki selaimeen, niin latautuu kyllä, mutta en ole saanut sitä millään katsottua. Lienee drm käytössä. Areenan suorasta sen saa tai paremminkin sai talteen.

Jep, tiedosto on DRM-suojattu, joten yle-dl:stä ei olisi hyötyä sen kanssa. Ellei sitten jostain linkistä saisi Androidille tai iOS:lle tarkoitettua versiota ilman DRM:ää...

Lainaus
Downton Abbey -sarja on katseltavissa tietokoneen www-selaimella, valitettavasti ei mobiililaitteilla (puhelimet, tabletit).

Mobiililaiteille ei ilmeisesti ole saatavissa drm-suojattuna, joten olkoot ilman ;- ) Tämä kaikki rikkoo yleisradiolain 7. pykälää, kuten kaikki tähänastiset Areenan ja Elävän Arkiston toteutukset, mutta se ei ole ennenkään yleläisiä haitannut. Vaikenevat sujuvasti, jos asiasta huomauttaa.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: HifiTollo - 27.04.14 - klo:22.13
14.04 LTS Finnish Remix -asennuksen jälkeen totesin, että YLE Areena futaa Mozillalla, muttei Chromium-selaimella.

Chromium selittää, että pitää ladata uudempi Flash, jopa tarjoaa linkkiä, mutta uutta ei sieltä saa downloadattua.

Mutta Mozillalla tosiaan: hyvä kuva, ääni ja tekstitys pelaavat.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Postimies - 07.05.14 - klo:20.34
Itse olen Firefoxilla katsonut Areenasta muutaman ohjelman eikä ole valittamista lubuntu 14.04. Mitenkäs XBMC:n yle areena plugin? Itse en saanut toimimaan. Muistakin areena plugareista saa vinkata.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Illu - 01.07.14 - klo:22.06
Varsin ärsyttävää on tuo Areenan toiminta, jossa videon (ja äänenkin) laatua pudotetaan yhteyden mukaan kesken suoratoiston.

Lainaus Ylen sivulta: "Kuvanlaatu riippuu käyttäjän verkkoyhteyden tasosta. Mikäli käyttäjän verkkoyhteyden taso ei riitä (tämä päätellään automaattisesti playerin puskurin koosta ja playerin mahdollisesta pudottamista freimeistä), laskee kuvanlaatu alemmalle tasolle, kunnes toisto on ongelmatonta."

Minulla käytössä olevat yhteydet ovat kyllä riittäneet hyväänkin videon laatuun. Silti laatu vaihtelee katselun aikana. Milläs noita playerin puskureita voisi säätää, mikäli se nyt sitten on syyllinen? Käytössä on 10 megainen lanka, U12.04, L14.04 ja Peppermint 4 (enimmäkseen nuo).
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: HifiTollo - 09.08.14 - klo:22.16
Minulla on 20M yhteys, tai ainakin sellaisesta Elisa laskuttaa, eihän siihen nopeuteen kyllä ole koskaan speedtestin mukaan päästy, mutta yli kypään kuitenkin.

Mutta ei riitä  sekään, etteikö YLE.n tv-kuva menisi vähän väliä sumeaksi mössöksi.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: mazottaja - 13.09.14 - klo:20.50
Mitenkä tälläinen tavan tallaaja saa tuon yle arennan ohjelmat ladattua
ja katsottua. Eikö ole mitään valmista ohjelmaa jonka vain asentaa.
Koodi ei osaa viritellä ja laitella.
Yle arenan tuo pitäs järjestää, muuhunkin kuin windows versioon  ::)
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: avanti - 14.09.14 - klo:00.14
Mitenkä tälläinen tavan tallaaja saa tuon yle arennan ohjelmat ladattua
ja katsottua. Eikö ole mitään valmista ohjelmaa jonka vain asentaa.
Koodi ei osaa viritellä ja laitella.
Yle arenan tuo pitäs järjestää, muuhunkin kuin windows versioon  ::)


Esimerkiksi Launchy nimisellä Firefoxin lisäosalla. Asennusohjeet tuolta: http://www.homelinuxpc.com/download/Areenan_nauhoituksen_asennus.html

Varsinainen moottori Launchyllä on nauhoitukselle yle-dl, jolla myös voi helposti ladata Areenasta komentorivillä.

ML
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: mazottaja - 14.09.14 - klo:18.27
Tämän sen antaa asentaa ja siihen kai se osoite minkä haluaa
ladata kopiodaan. Miten toi sitten käyntiin lähtee, jonkun haki vahingossa
tai osan, mutta pyyteli lisäosien asennusta että voisi edes näyttää kuva.
Joku asetus kai vaan tökkii.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: avanti - 15.09.14 - klo:00.34
Tämän sen antaa asentaa ja siihen kai se osoite minkä haluaa
ladata kopiodaan. Miten toi sitten käyntiin lähtee, jonkun haki vahingossa
tai osan, mutta pyyteli lisäosien asennusta että voisi edes näyttää kuva.
Joku asetus kai vaan tökkii.

Kopioidaan? Siis jos käyttää päätteessä yle-dl -komentoa (Videot -kansiossa), niin sen perään kopioidaan ohjelman URL.

Launchyssä mennään Areenan sivulle, hiirellä toistettavan ohjelman päälle ja painetaan hiiren oikeanpuoleista nappulaa. Tulee esille valikko, jossa valitaan Launchy-kohta, joka johtaan uuteen valikkoon josta valitaan joko Download with Areena lataus, normaali tai -säästölaatu - tai Katsomonkin videon. Sitten Launchy luo Videot-kansion sisälle Areena-kansion ja lataa ohjelman sinne.

Mutta jokin tökkii silti, kun valittaa.

ML
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: avanti - 15.09.14 - klo:00.43
Ai niin. Kannattaisi kokeillakin yle-dl komentoa päätteessä, koska se tulostaa näytille koko ajan mitä tapahtuu, tai miksi ei tapahdu.

ML
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: mazottaja - 16.09.14 - klo:10.11
Omaa koneeseen sain tämän toimimaa  Launchyllä  ja sen käskyrivin ajettua päätteessä
ja painasin entteriä niin ajeli asennuksen läpi ja pyyti salasanaa ja homma toimii
kun junan vessa. Lisäksi netistä latasin  Launchyllä  uuden version.
Kaverille tehtiin samanlailla ja ovelin että pääte ohjelmaa sai sen liitettyä
ja se ajoi sen läpi... sitten vilkutti dos päätteessä että anna salasana ja ei
anna kirjottaa mitään siihen.
Omassa asennukessa nousi ikkuna ylös johon pääkäyttäjän salasana ja sitten
enteriä ja asennun eteni ja näin toimii.
Mikä tuossa on sama ubuntu versio ja eri läppärit niin tuollaista tekee  ::)
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: ajaaskel - 16.09.14 - klo:10.35
Lainaus
...että anna salasana ja ei
anna kirjottaa mitään siihen.

Päätteessä ei näy salasanan kirjoitus mutta se menee silti perille kun painaa Enter: iä.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: mazottaja - 19.09.14 - klo:18.54
Juuri kuten edellä kerrottu. Salasanan ottaa ja ohjelma toimi pika asennus
ohjeilla hyvin  ;D
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: raimo - 16.03.15 - klo:22.42
Onko normaalia että yle-dl tekee latauksen aikana lukemattoman määrän, esim 885 kpl *FragXX -loppuisia tiedostoja lataushakemistoon,
jotka sitten kylläkin poistuvat kun lataus on valmis?
Tiedostoniminä on esim ec2c79437dc1064ef46b647ae168197b_0_5694a0b3320ce75e_Seg1-Frag62

Tämä ei minusta ole kovin "elegantti" tapa, eikö noiden soisi menevän johonkin väliaikaiseen paikkaan/hakemistoon? Jos nyt latauksen keskeyttää (Ctrl+C) tai se epäonnistuu esim netin katketessa on lataushakemistossa satoja turhia tiedostoja jotka on poistettava käsin samalla varoen että ei poista aikaisempia latauksia.

Näin ei tapahdu paketinhallinnasta asennetulla yle-dl versiolla, vaan paketinhallinnan ohi asennetulla uudella 2.6.0 (+AdobeHDS.php) versiolla, jota on pakko käyttää koska vanhempi versio ei lataa kaikkia Areenan videoita. Kubuntu 14.04 on käytössä.

Edit: sama homma youtube-dl kanssa, siis ilman AdobeHDS.php:ta, ja tuoltahan se näyttää latauksen aikana:
(http://i.imgur.com/HhsCWnus.png) (http://i.imgur.com/HhsCWnu.png)
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: nm - 22.03.15 - klo:19.55
Onko normaalia että yle-dl tekee latauksen aikana lukemattoman määrän, esim 885 kpl *FragXX -loppuisia tiedostoja lataushakemistoon,
jotka sitten kylläkin poistuvat kun lataus on valmis?
Tiedostoniminä on esim ec2c79437dc1064ef46b647ae168197b_0_5694a0b3320ce75e_Seg1-Frag62

Tämä ei minusta ole kovin "elegantti" tapa, eikö noiden soisi menevän johonkin väliaikaiseen paikkaan/hakemistoon? Jos nyt latauksen keskeyttää (Ctrl+C) tai se epäonnistuu esim netin katketessa on lataushakemistossa satoja turhia tiedostoja jotka on poistettava käsin samalla varoen että ei poista aikaisempia latauksia.

On normaalia, ja fragmenttien tallentamisen ideana on ymmärtääkseni juuri se, että latauksen katketessa sitä voidaan jatkaa helposti keskeytymiskohdasta sen sijaan, että aloitettaisiin uudestaan alusta. Vilkaisin youtube-dl:n koodia, ja tämän käyttäytymisen muuttaminen siistimmäksi vaatisi aika paljon perehtymistä ja aikaa.

Näin ei tapahdu paketinhallinnasta asennetulla yle-dl versiolla, vaan paketinhallinnan ohi asennetulla uudella 2.6.0 (+AdobeHDS.php) versiolla, jota on pakko käyttää koska vanhempi versio ei lataa kaikkia Areenan videoita.

Niin. AdobeHDS.php ja Youtube-dl ovat palikat, jotka tekevät näitä fragmenttitiedostoja. Yle-dl:llä ei ole siihen osaa eikä arpaa.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: raimo - 22.03.15 - klo:22.57
On normaalia, ja fragmenttien tallentamisen ideana on ymmärtääkseni juuri se, että latauksen katketessa sitä voidaan jatkaa helposti keskeytymiskohdasta sen sijaan, että aloitettaisiin uudestaan alusta. Vilkaisin youtube-dl:n koodia, ja tämän käyttäytymisen muuttaminen siistimmäksi vaatisi aika paljon perehtymistä ja aikaa.

Niin. AdobeHDS.php ja Youtube-dl ovat palikat, jotka tekevät näitä fragmenttitiedostoja. Yle-dl:llä ei ole siihen osaa eikä arpaa.

Okei, kiitos.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Illu - 30.03.15 - klo:08.10
Onkos muilla ollut ongelmia Areenalta katsomisen/kuuntelemisen aloittamisessa? Siis vaikkapa uutiset katsottavaksi, niin toisinaan mitään ei tapahdu "play-nuolta" painaessa vaan pitää katsottavaksi/kuultavaksi aiottu ohjelma valita uudelleen, jonka jälkeen toiston saa käynnistettyä. Ikään kuin joku vaihe haluaisi varmistaa katsojan aikeet. Olikohan sekavasti esitetty?
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: raimo - 30.03.15 - klo:09.46
Onkos muilla ollut ongelmia Areenalta katsomisen/kuuntelemisen aloittamisessa? Siis vaikkapa uutiset katsottavaksi, niin toisinaan mitään ei tapahdu "play-nuolta" painaessa vaan pitää katsottavaksi/kuultavaksi aiottu ohjelma valita uudelleen, jonka jälkeen toiston saa käynnistettyä. Ikään kuin joku vaihe haluaisi varmistaa katsojan aikeet. Olikohan sekavasti esitetty?

Kyllä on, minulla pitää sivu uudelleenladata että haluttu video lähtee pyörimään, tämä tapahtuu minulla muillakin yle.fi:n videoilla kuin Areenan. Selaimena Firefox ja Kubuntu 14.04. Aikaisemmin on toiminut OK, sanotaanko nyt että pari kuukautta sitten alkoi kiukkuilu.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: lauritx - 08.05.15 - klo:12.37
Onkos muilla ollut ongelmia Areenalta katsomisen/kuuntelemisen aloittamisessa? Siis vaikkapa uutiset katsottavaksi, niin toisinaan mitään ei tapahdu "play-nuolta" painaessa vaan pitää katsottavaksi/kuultavaksi aiottu ohjelma valita uudelleen, jonka jälkeen toiston saa käynnistettyä. Ikään kuin joku vaihe haluaisi varmistaa katsojan aikeet. Olikohan sekavasti esitetty?

Kyllä on, minulla pitää sivu uudelleenladata että haluttu video lähtee pyörimään, tämä tapahtuu minulla muillakin yle.fi:n videoilla kuin Areenan. Selaimena Firefox ja Kubuntu 14.04. Aikaisemmin on toiminut OK, sanotaanko nyt että pari kuukautta sitten alkoi kiukkuilu.
On sama juttu ja viime yönä jumitti molemmat selaimet chromiumin sekä firefoxin. Vika vain areenassa eli youtubet ja muut flassia käyttävät sivut toimii ok. Video nyki koko ajan ja lopulta jumitti koko selaimen ja sen myötä koneen. Aiemmin tollasta ei oo ollu.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: welmar - 09.05.15 - klo:17.25
Onkos muilla ollut ongelmia Areenalta katsomisen/kuuntelemisen aloittamisessa? Siis vaikkapa uutiset katsottavaksi, niin toisinaan mitään ei tapahdu "play-nuolta" painaessa vaan pitää katsottavaksi/kuultavaksi aiottu ohjelma valita uudelleen, jonka jälkeen toiston saa käynnistettyä. Ikään kuin joku vaihe haluaisi varmistaa katsojan aikeet. Olikohan sekavasti esitetty?

Kyllä on, minulla pitää sivu uudelleenladata että haluttu video lähtee pyörimään, tämä tapahtuu minulla muillakin yle.fi:n videoilla kuin Areenan. Selaimena Firefox ja Kubuntu 14.04. Aikaisemmin on toiminut OK, sanotaanko nyt että pari kuukautta sitten alkoi kiukkuilu.
On sama juttu ja viime yönä jumitti molemmat selaimet chromiumin sekä firefoxin. Vika vain areenassa eli youtubet ja muut flassia käyttävät sivut toimii ok. Video nyki koko ajan ja lopulta jumitti koko selaimen ja sen myötä koneen. Aiemmin tollasta ei oo ollu.
Areena ei toimi niin sujuvasti kuin muut flashvideot. Tabletilla huomaa eron selvästi kun varsinkin matkoilla areena ei pelaa niin youtube  ja muut toimii ok. Silloin kun Areena toimii niin kuvanlaatu tuntuu paremmalta kuin esim. Ruutu joten veikkaisin syytä jostain tosta suunnasta.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: lauritx - 10.05.15 - klo:14.26
Kokeilimpa ladata yle-dl ohjelmalla yhden videon niin tulee tosi hitaasti. Tuntuu että areenan palvelimissa on nyt vika.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: nm - 10.05.15 - klo:14.38
Kokeilimpa ladata yle-dl ohjelmalla yhden videon niin tulee tosi hitaasti. Tuntuu että areenan palvelimissa on nyt vika.

Ainakin Amélie latautuu normaalisti täällä Soneran verkossa. Suunnilleen 4 Mt/s eli 32 Mbit/s.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: lauritx - 10.05.15 - klo:18.03
Kokeilimpa ladata yle-dl ohjelmalla yhden videon niin tulee tosi hitaasti. Tuntuu että areenan palvelimissa on nyt vika.

Ainakin Amélie latautuu normaalisti täällä Soneran verkossa. Suunnilleen 4 Mt/s eli 32 Mbit/s.

Joo nyt tuntuu toimivan pätkimättä. Mutta esim viime yönä pätki ja jumitti selainta urakalla. Toivottavasti vaan väliaikainen juttu oli mikä tahansa.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Illu - 10.05.15 - klo:20.32
Mistähän johtuu, että Areenan (ainakin joidenkin) sivujen kohdalla joutuu päivittämään sivun ennen kuin voi kuunnella ohjelmaa? Esim. http://areena.yle.fi/1-2702640 vaatii sivun virkistyksen jotta sivun "play-nappi" toimii. Ongelma on molemmilla käytössä olevilla koneilla U12.04 ja U14.04, yhteydet kiinteä ja mobiili.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: nm - 10.05.15 - klo:20.42
Mistähän johtuu, että Areenan (ainakin joidenkin) sivujen kohdalla joutuu päivittämään sivun ennen kuin voi kuunnella ohjelmaa? Esim. http://areena.yle.fi/1-2702640 vaatii sivun virkistyksen jotta sivun "play-nappi" toimii. Ongelma on molemmilla käytössä olevilla koneilla U12.04 ja U14.04, yhteydet kiinteä ja mobiili.

Se taitaa jumittaa vain Linuxin vanhalla Flash Player 11.2:lla. Toimii ilman ylimääräisiä uudelleenlatauksia Chromen/Chromiumin PepperFlashilla ja Firefoxissa Pipelightin Flashilla.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: juyli - 10.05.15 - klo:23.34
Esim. http://areena.yle.fi/1-2702640 vaatii sivun virkistyksen jotta sivun "play-nappi" toimii.
Kyllä minulla toimii päätteellä ((Ubuntu 15.04 Vivid) ihan komennolla
Koodia: [Valitse]
firefox http://areena.yle.fi/1-2702640 aloittamalla kuuntelu -> näppäimellä ilman ongelmia (alt-f2).
Adobe tarjoaa Linux-jakeluille flash-version 11.02.xxxx, mutta tuo on tuettu ja tarjoaa viimeisimmät tietoturvapäivitykset myös Linux-jakeluihin.
Jos syystä tai toisesta haluat tallentaa Yle Areenan ohjelmia, on sillekin välineet.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: nm - 11.05.15 - klo:00.08
Kyllä minulla toimii päätteellä ((Ubuntu 15.04 Vivid) ihan komennolla
Koodia: [Valitse]
firefox http://areena.yle.fi/1-2702640 aloittamalla kuuntelu -> näppäimellä ilman ongelmia (alt-f2).

Tällä hetkellä tuntuu toimivan. Yleensä jumittaa aiemmin kuvatulla tavalla, kun olen käyttänyt Areenaa Flash 11.2:lla.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Illu - 11.05.15 - klo:21.21
Mistähän johtuu, että Areenan (ainakin joidenkin) sivujen kohdalla joutuu päivittämään sivun ennen kuin voi kuunnella ohjelmaa? Esim. http://areena.yle.fi/1-2702640 vaatii sivun virkistyksen jotta sivun "play-nappi" toimii. Ongelma on molemmilla käytössä olevilla koneilla U12.04 ja U14.04, yhteydet kiinteä ja mobiili.

Se taitaa jumittaa vain Linuxin vanhalla Flash Player 11.2:lla. Toimii ilman ylimääräisiä uudelleenlatauksia Chromen/Chromiumin PepperFlashilla ja Firefoxissa Pipelightin Flashilla.

Syy lienee sitten tuo versio: 11.2.202.457. Aika usein kuuntelu lähtee käyntiin heti, jos olen jo kuunnellut jonkin toisen ohjelman. Joku vipu siis kääntyy ensimmäisen ohjelman ensimmäisellä yrityksellä ja toisen ohjelman kohdalla toimiikin heti. Koitan pysytellä Firefoxissa, joten lataillaan sitten uudestaan toistaiseksi. Kai tuokin jossain vaiheessa korjaantuu kun ei isosta vaivasta ole kyse.

Areenan tallennukset kyllä onnistuvat hyvin.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: valtsy - 23.05.15 - klo:10.29
Mikähä mahtaa mättää kun koettaa areenasta tallentaa esim. http://areena.yle.fi/1-2782436 niin herjaa vaan

Lainaus
viihde@viihde:~/Videot/koe-eläinpuisto$ yle-dl http://areena.yle.fi/1-2394102
yle-dl 2.2.1: Download media files from Yle Areena and Elävä Arkisto
Copyright (C) 2009-2014 Antti Ajanki <antti.ajanki@iki.fi>, license: GPLv2
Can't read http://areena.yle.fi/1-2394102.json: HTTP Error 404: Not Found


vai eikä sitä van osaa ..kuukausi sitte pelas normaalisti
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: ajaaskel - 23.05.15 - klo:17.02
Näyttäisi vanhentuneen tuo yle-dl.  Tuolla on uudempi:

http://www.homelinuxpc.com/download/yle-dl_2.7.0-1_all.deb (http://www.homelinuxpc.com/download/yle-dl_2.7.0-1_all.deb)
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: valtsy - 23.05.15 - klo:22.50
Kiitos ..ja taas tulee koe-eläinpuistot koneelle talteen ..
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: olle - 27.07.15 - klo:17.36
Onko yle-dl/rtmpdumpissa optiota estää "alternative name"-lataus ? Siis allaolevan tilanteen estäminen, kun tiedosto on jo ladattu aiemmin ?

.
Koodia: [Valitse]
/euroopan/Euroopan taivaan alla: Kuuntele: Euroopan taivaan alla-2015-07-16T19:00:00+03:00.flv exists, trying an alternative name
Output file: ./euroopan/Euroopan taivaan alla: Kuuntele: Euroopan taivaan alla-2015-07-16T19:00:00+03:00-1.flv


Koodia: [Valitse]
--alternativename =no tms ???
vai onko tehtävä if-grep ???
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Hillosilmä - 17.08.15 - klo:13.48
Ensin tuohon käsiteltyyn toiston alkamiseen:
Olen havainnut ajoittain saman ilmiön. Käytän rinnalla Mäkkiä ja sitä sattuu yhtä lailla. Lienee joku Areenan pään säätö. Areenahan laajenee huikeaan tahtiin ja lienevät siirtymässä myös HTML5 systeemiin -josko liittyisi muutoksiin.

Sitten kysymykseen:
Asensin Ubuntun viimeisimmän LTS-version iMäkkiin missä Areenan kuvassa häiriötä:
Poikittaista juovaa/räpsyä (muistuttaa videonauhan räpsyä) tulee melko tiiviiseen, ja siten häiritsevään tahtiin. Tuubi ja ulkoiset videot toistuvat ongelmitta. Saman koneen Mäkkipuolella ei ongelmaa, ei myöskään samaisessa Ubuntun versiossa joka on Lenovon läppärissä. Kaikissa toisto päivitetyn Firefoxin kautta.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: nm - 18.08.15 - klo:01.04
Sitten kysymykseen:
Asensin Ubuntun viimeisimmän LTS-version iMäkkiin missä Areenan kuvassa häiriötä:
Poikittaista juovaa/räpsyä (muistuttaa videonauhan räpsyä) tulee melko tiiviiseen, ja siten häiritsevään tahtiin. Tuubi ja ulkoiset videot toistuvat ongelmitta. Saman koneen Mäkkipuolella ei ongelmaa, ei myöskään samaisessa Ubuntun versiossa joka on Lenovon läppärissä. Kaikissa toisto päivitetyn Firefoxin kautta.

Kuulostaa repeilyltä (tearing). Kohtalaisen yleinen ongelma Linuxissa, kun eri näytönohjainajurit ja ajuriversiot käyttäytyvät hieman eri tavalla ja erilaisia videotoistorajapintojakin on useita.

Mikä näytönohjain koneessa on ja mikä ajuri käytössä? Lisäajurien (löytyy Dashin haulla) kautta voisi asentaa suljetun ajurin, joka saattaa auttaa.

Toimiiko paremmin Chromella?
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: aapee - 19.10.15 - klo:20.07
Moikka..

Sama ongelma täälläkin. Olen yrittänyt saada toimimaan areenan lataajan, mutta epäonnistunut kerta toisensa jälkeen. Minulla on  ohjelmistohallinnassa youtube-dl ja yle-dl (2.7.0-1_all) Onnistuin nuo saamaan koneelleni. Mitä tämän jälkeen ??
Mulla on Linux Mint 17.2 64bit
Aika vähän vielä tästä linuxista kokemuksia  :-\

Olen yrittänyt katsoa ohjeita ja kirjoittaa komentokehoitteita mitä on opastettu, ei vaan ole onnistunut..

Ohjeita pyydän...
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: nm - 19.10.15 - klo:20.37
Sama ongelma täälläkin. Olen yrittänyt saada toimimaan areenan lataajan, mutta epäonnistunut kerta toisensa jälkeen. Minulla on  ohjelmistohallinnassa youtube-dl ja yle-dl (2.7.0-1_all) Onnistuin nuo saamaan koneelleni. Mitä tämän jälkeen ??
Mulla on Linux Mint 17.2 64bit
Aika vähän vielä tästä linuxista kokemuksia  :-\

Olen yrittänyt katsoa ohjeita ja kirjoittaa komentokehoitteita mitä on opastettu, ei vaan ole onnistunut..

Avaa pääte, kopioi sinne seuraava komento ja paina enteriä perään:

Koodia: [Valitse]
yle-dl http://areena.yle.fi/1-2761106
Mitä tuo sanoo? Kopioi listaus päätteestä tänne, niin tutkitaan.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: aapee - 19.10.15 - klo:21.11
yle-dl http://areena.yle.fi/1-2761106
yle-dl 2.7.0: Download media files from Yle Areena and Elävä Arkisto
Copyright (C) 2009-2015 Antti Ajanki <antti.ajanki@iki.fi>, license: GPLv2
Can't read http://areena.yle.fi/api/programs/v1/items.json?series=1-2761106&type=program&availability=ondemand&order=ondemand.publication.starttime%253Adesc&app_id=cb021459&app_key=fa6c26b3b3e617b7033c83c108417200&limit=25&offset=0&olang=fi: HTTP Error 500: Internal Server Error


  KSV Adobe HDS Downloader

Processing manifest info....                                                   
Quality Selection:                                                             
 Available: 1114 775 446 181
 Selected : 1114                                                               
Fragments Total: 151, First: 1, Start: 1, Parallel: 8                         
Downloading 151/151 fragments                                                 
Found 151 fragments                                                           
Finished
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: nm - 19.10.15 - klo:21.16
yle-dl http://areena.yle.fi/1-2761106
yle-dl 2.7.0: Download media files from Yle Areena and Elävä Arkisto
Copyright (C) 2009-2015 Antti Ajanki <antti.ajanki@iki.fi>, license: GPLv2
Can't read http://areena.yle.fi/api/programs/v1/items.json?series=1-2761106&type=program&availability=ondemand&order=ondemand.publication.starttime%253Adesc&app_id=cb021459&app_key=fa6c26b3b3e617b7033c83c108417200&limit=25&offset=0&olang=fi: HTTP Error 500: Internal Server Error


  KSV Adobe HDS Downloader

Processing manifest info....                                                   
Quality Selection:                                                             
 Available: 1114 775 446 181
 Selected : 1114                                                               
Fragments Total: 151, First: 1, Start: 1, Parallel: 8                         
Downloading 151/151 fragments                                                 
Found 151 fragments                                                           
Finished

Hyvin näkyy latautuneen. Nyt kotihakemistossasi on tiedosto Yle Uutiset-2015-10-18T20:30:00+03:00.flv
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: aapee - 19.10.15 - klo:21.42
Vielä...


Joudun vielä kiusaamaan sinua... Jouduin asentamaan uudestaan käyttöjärjestelmän koneeseeni. Linux Mint 17.2
Tuli eteen sama ongelma..

Youtube-dl on koneella, mutten saa yle-dl asennettua..Voitko ohjeistaa...

Kaikki taas kunnossa...
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: raimo - 25.10.15 - klo:13.58
Yle-dl + AdobeHDS:
Koodia: [Valitse]
KSV Adobe HDS Downloader
You have to install and enable the following extension(s) to continue: 'mcrypt'
Joo, no asennetaan vaikka yle-dl README.fi ohjeessa ei niin ohjeisteta.
Koodia: [Valitse]
sudo apt-get install mcrypt php5-mcrypt
Seuraus silti tympeä:
Koodia: [Valitse]
KSV Adobe HDS Downloader
You have to install and enable the following extension(s) to continue: 'mcrypt'

Mikä neuvoksi? youtube-dl kanssa toimii kyllä, mutta itkee kuitenkin tuota jokaisessa latauksessa.
yle-dl on versio 2.8.1 ja AdobeHDS on kai siellä missä pitääkin:
Koodia: [Valitse]
raimo@kone:~$ ls -l /usr/local/share/yle-dl/AdobeHDS.php
-rw-r--r-- 1 root root 93138 loka  25 13:31 /usr/local/share/yle-dl/AdobeHDS.php

edit: näemmä äsken tuli päivitys, versio on nyt 2.8.2 ja homma sama.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: nm - 25.10.15 - klo:17.58
Yle-dl + AdobeHDS:
Koodia: [Valitse]
KSV Adobe HDS Downloader
You have to install and enable the following extension(s) to continue: 'mcrypt'
Joo, no asennetaan vaikka yle-dl README.fi ohjeessa ei niin ohjeisteta.

mcrypt on Adobe HDS:n uusi vaatimus (https://github.com/K-S-V/Scripts/commit/ca7772e8b08edda870f5ee7314df9ef28be88007). Hetki sitten sitä ei tuettu eikä tarvittu, ja yle-dl:n dokumentaatiota ei ole päivitetty, koska muutosta ei ole huomattu / raportoitu.


Koodia: [Valitse]
sudo apt-get install mcrypt php5-mcrypt
Seuraus silti tympeä:
Koodia: [Valitse]
KSV Adobe HDS Downloader
You have to install and enable the following extension(s) to continue: 'mcrypt'

Laajennos pitää kytkeä erikseen käyttöön:

Koodia: [Valitse]
sudo php5enmod mcrypt
Tai vaihtoehtoisesti voit tehdä tarvittavan linkin manuaalisesti:

Koodia: [Valitse]
sudo ln -s /etc/php5/mods-available/mcrypt.ini /etc/php5/cli/conf.d/20-mcrypt.ini

Kannattaa raportoida asiasta Antille, niin dokumentaatio saadaan ajantasalle.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: raimo - 25.10.15 - klo:18.07
Yle-dl + AdobeHDS:
Koodia: [Valitse]
KSV Adobe HDS Downloader
You have to install and enable the following extension(s) to continue: 'mcrypt'
Joo, no asennetaan vaikka yle-dl README.fi ohjeessa ei niin ohjeisteta.

mcrypt on Adobe HDS:n uusi vaatimus (https://github.com/K-S-V/Scripts/commit/ca7772e8b08edda870f5ee7314df9ef28be88007). Hetki sitten sitä ei tuettu eikä tarvittu, ja yle-dl:n dokumentaatiota ei ole päivitetty, koska muutosta ei ole huomattu / raportoitu.


Koodia: [Valitse]
sudo apt-get install mcrypt php5-mcrypt
Seuraus silti tympeä:
Koodia: [Valitse]
KSV Adobe HDS Downloader
You have to install and enable the following extension(s) to continue: 'mcrypt'

Laajennos pitää kytkeä erikseen käyttöön:

Koodia: [Valitse]
sudo php5enmod mcrypt
Tai vaihtoehtoisesti voit tehdä tarvittavan linkin manuaalisesti:

Koodia: [Valitse]
sudo ln -s /etc/php5/mods-available/mcrypt.ini /etc/php5/cli/conf.d/20-mcrypt.ini

Kannattaa raportoida asiasta Antille, niin dokumentaatio saadaan ajantasalle.

Kiitos, nyt toimii. Rakennan Antille jonkinlaisen raportin, vaikken ymmärrä mistään mitään. :)
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: ajaaskel - 19.12.15 - klo:14.46
Kasasin yle-dl v2.9.0 deb-paketin:

http://www.homelinuxpc.com/download/yle-dl_2.9.0-1_all.deb (http://www.homelinuxpc.com/download/yle-dl_2.9.0-1_all.deb)

Siinä on mukana myös tuo uusi mcrypt-riippuvuus ja aktivointi.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Kurskin torpedo - 01.03.16 - klo:19.41
Asensin uudelleen ajaaskelin ohjeilla kun LAunchy ei ole toiminut pitkään aikaan.
http://www.homelinuxpc.com/download/Areenan_nauhoituksen_asennus.html
yle-dl:n ja launchyn vanhalle läppärilleni - ubuntu 14.04 ja Compaq Presario CQ71.

Areena minulla toimii suoraan selaimissa Firefox ja Chromium, Launchy ei kuitenkaan käynnistä ohjelmia VLC:ssä. VLC aukeaa mutta ei käynnistä ohjelmaa. Areenan linkki kyllä kopioituu VLC:n osoiteriville.
Päätteestä areenan ohjelmat tallentuvat yle-dl:n avulla moitteettomasti.

Katsomon osalta ei aukea VLC:n eikä myöskään tallennu ollenkaan. Eli lähinnä ongelmana on tuo Katsomo (vaikkei tämä Katsomo-ketju olekaan - voin kopioida tämän sinnekin).  Pitäisikö poistaa jotain vanhoja asennuksia ensin vaiko ... ?  Saanko Katsomon tallennuksen toimimaan päätteestä - sekin riittäisi hyvin.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: ajaaskel - 06.03.16 - klo:19.12
Tilanne on sikäli huono että se mikä ei toimi Katsomossa Launchy-menun kautta ei toimi johtuen muutoksista mitä ohjelman lähettäjä on tehnyt. 
Jos joku haluaa/ehtii/jaksaa sitä viritellä uuteen uskoon niin hyvä.  Skriptiä tulee nopeasti jos tekninen tausta selvitetty.

Toinen kiusa mikä on Areenan muuttumisen mukana (tahallisesti?) tullut on puuttuvat RSS-linkit. 
Puuttuvat RSS-napit tekevät automaattinauhurin AutoDL käyttökelvottomaksi joka tulkkasi näitä ja toimi ok jonkun vuoden jo. 
Siinäkin sama, "kiitokset" ohjelman lähettäjälle YLE: lle  RSS-linkkien puuttumisesta.
Samoin tämä, en voi nyt ottaa aikaa tämän kikkailuun jotain toista tietä.

 
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: vellu@vmach - 27.04.16 - klo:20.46
Onko tätä saatu toimimaan vielä 16.04:llä? Itsellä tulee vain valituksia php5:n puuttumisesta, jota ei pakettivarastosta löydy.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: raimo - 27.04.16 - klo:21.41
Onko tätä saatu toimimaan vielä 16.04:llä? Itsellä tulee vain valituksia php5:n puuttumisesta, jota ei pakettivarastosta löydy.

Tuntuisi toimivan php7:n kanssa, tämmöiset paketit asensin ja yle-dl 2.10.1 toimii OK.
Koodia: [Valitse]
sudo apt-get install php7.0-cli php7.0-curl php7.0-mcrypt php7.0-bcmath php7.0-xml
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: vellu@vmach - 27.04.16 - klo:21.56
Onko tätä saatu toimimaan vielä 16.04:llä? Itsellä tulee vain valituksia php5:n puuttumisesta, jota ei pakettivarastosta löydy.

Tuntuisi toimivan php7:n kanssa, tämmöiset paketit asensin ja yle-dl 2.10.1 toimii OK.
Koodia: [Valitse]
sudo apt-get install php7.0-cli php7.0-curl php7.0-mcrypt php7.0-bcmath php7.0-xml

Ei toiminut.
Koodia: [Valitse]
~/Downloads$ gdebi yle-dl_2.10.0-1_all.deb
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Reading state information... Done
This package is uninstallable
Dependency is not satisfiable: php5-cli
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: raimo - 27.04.16 - klo:22.06
Jep, vaatii tuon deb-paketin tekijältä toimenpiteitä riippuvuuksien korjaamiseksi.

Minä asensin suoraan valmistajan sivuilta manuaalisesti. https://aajanki.github.io/yle-dl/

Se on helppo homma purat tar.gz paketin johonkin, menet syntyneeseen hakemistoon ja komennat:
Koodia: [Valitse]
sudo make install
Noiden php7 pakettien lisäksi tarvitaan nämä, asenna ne siis ennen kuin ajat tuon sudo make install komennon.
Koodia: [Valitse]
sudo apt-get install rtmpdump python python-crypto
Paketissa oleva README.fi kertoo lisää.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: vellu@vmach - 27.04.16 - klo:23.04
Jep, vaatii tuon deb-paketin tekijältä toimenpiteitä riippuvuuksien korjaamiseksi.

Minä asensin suoraan valmistajan sivuilta manuaalisesti. https://aajanki.github.io/yle-dl/

Se on helppo homma purat tar.gz paketin johonkin, menet syntyneeseen hakemistoon ja komennat:
Koodia: [Valitse]
sudo make install
Noiden php7 pakettien lisäksi tarvitaan nämä, asenna ne siis ennen kuin ajat tuon sudo make install komennon.
Koodia: [Valitse]
sudo apt-get install rtmpdump python python-crypto
Paketissa oleva README.fi kertoo lisää.

Yep, yep. Tämä toimii. Toimiva .deb-paketti olisi kyllä käytännöllinen.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: mrl586 - 28.04.16 - klo:03.03
youtube-dl ei vaadi php:tä toimiakseen.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Olotila - 02.05.16 - klo:20.39
Minulle tulee
Failed to execute php /usr/local/share/yle-dl/AdobeHDS.php --manifest
Mitä tehdä?
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: raimo - 02.05.16 - klo:21.04
Minulle tulee
Failed to execute php /usr/local/share/yle-dl/AdobeHDS.php --manifest
Mitä tehdä?

Mitä sanoo
Koodia: [Valitse]
ls -l /usr/local/share/yle-dl/AdobeHDS.php
pitäisi tulla tämmöinen vastaus:
Lainaus
-rw-r--r-- 1 root root 93612 huhti 27 21:34 /usr/local/share/yle-dl/AdobeHDS.php
päiväys on tietenkin eri, mutta muuten.

Lisäksi tarkista että oikeat php7 paketit on asennettu
Koodia: [Valitse]
dpkg -l | grep php
Näkymät pitäisi olla tämänlaiset:
Koodia: [Valitse]
ii  php-common                                      1:35ubuntu6                                all          Common files for PHP packages
ii  php7.0-bcmath                                   7.0.4-7ubuntu2                             amd64        Bcmath module for PHP
ii  php7.0-cli                                      7.0.4-7ubuntu2                             amd64        command-line interpreter for the PHP scripting language
ii  php7.0-common                                   7.0.4-7ubuntu2                             amd64        documentation, examples and common module for PHP
ii  php7.0-curl                                     7.0.4-7ubuntu2                             amd64        CURL module for PHP
ii  php7.0-json                                     7.0.4-7ubuntu2                             amd64        JSON module for PHP
ii  php7.0-mcrypt                                   7.0.4-7ubuntu2                             amd64        libmcrypt module for PHP
ii  php7.0-opcache                                  7.0.4-7ubuntu2                             amd64        Zend OpCache module for PHP
ii  php7.0-readline                                 7.0.4-7ubuntu2                             amd64        readline module for PHP
ii  php7.0-xml                                      7.0.4-7ubuntu2                             amd64        DOM, SimpleXML, WDDX, XML, and XSL module for PHP
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Olotila - 02.05.16 - klo:21.19
Puuttui php, mutta nyt sanoo
You have to install and enable the following extension(s) to continue: 'bcmath', 'curl', 'mcrypt', 'SimpleXML'

Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: raimo - 02.05.16 - klo:22.00
Puuttui php, mutta nyt sanoo
You have to install and enable the following extension(s) to continue: 'bcmath', 'curl', 'mcrypt', 'SimpleXML'

Jos nuo PHP-moduli-paketit on asennettu niin sitten ne pitänee vielä ottaa käyttöön, minulla kyllä 16.04:ssä se tapahtui itsestään.
Mutta näin se menee manuaalisesti:
Koodia: [Valitse]
sudo phpenmod bcmath curl mcrypt simplexml
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Olotila - 02.05.16 - klo:22.24
Joo nyt rullaa, kiitos!
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: vellu@vmach - 28.04.17 - klo:04.15
Puuttui php, mutta nyt sanoo
You have to install and enable the following extension(s) to continue: 'bcmath', 'curl', 'mcrypt', 'SimpleXML'

Jos nuo PHP-moduli-paketit on asennettu niin sitten ne pitänee vielä ottaa käyttöön, minulla kyllä 16.04:ssä se tapahtui itsestään.
Mutta näin se menee manuaalisesti:
Koodia: [Valitse]
sudo phpenmod bcmath curl mcrypt simplexml

Ubuntu-Gnome 17.04 sanoo että:
Koodia: [Valitse]
$ sudo phpenmod bcmath curl mcrypt simplexml
WARNING: Module bcmath ini file doesn't exist under /etc/php/7.0/mods-available
WARNING: Module bcmath ini file doesn't exist under /etc/php/7.0/mods-available
WARNING: Module curl ini file doesn't exist under /etc/php/7.0/mods-available
WARNING: Module curl ini file doesn't exist under /etc/php/7.0/mods-available
WARNING: Module mcrypt ini file doesn't exist under /etc/php/7.0/mods-available
WARNING: Module mcrypt ini file doesn't exist under /etc/php/7.0/mods-available
WARNING: Module simplexml ini file doesn't exist under /etc/php/7.0/mods-available
WARNING: Module simplexml ini file doesn't exist under /etc/php/7.0/mods-available
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: mrl586 - 29.04.17 - klo:14.43
Oletko asentunut kyseiset moduulipaketit?
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: vellu@vmach - 29.04.17 - klo:16.43
Oletko asentunut kyseiset moduulipaketit?
Näköjään vain yrittänyt:
Koodia: [Valitse]
sudo apt install phpenmod bcmath curl mcrypt simplexm
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package phpenmod
E: Unable to locate package bcmath
E: Unable to locate package simplexm
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: raimo - 29.04.17 - klo:17.13
17.04:ssä näin asentuu noi, phpenmod ei ole asennettava paketti vaan tulee PHP:n mukana.
Koodia: [Valitse]
sudo apt install php-bcmath php-curl php-mcrypt php-xml
Vastaavassa tilanteessa kannattaa kokeilla etsiä oikeaa pakettia eri variaatioilla komennolla
Koodia: [Valitse]
apt-cache search HAKUSANAtai käyttää http://packages.ubuntu.com/ hakua, oikea jakelu pitää muistaa valita ennen hakua.

edit: sori, oli virhe, ei mcrypt vaan php-mcrypt.

Luin ketjua taaksepäin, ja nämäkin toimii:
Koodia: [Valitse]
sudo apt-get install php7.0-cli php7.0-curl php7.0-mcrypt php7.0-bcmath php7.0-xml
Jos asetustiedostohässäkkä edelleen jatkuu, kannattaa poistaa paketit apt-get purge vivulla, jolloin mahdolliset rikkonaiset tiedostot saa kyytiä ja asentaa sitten paketit uudelleen. Eli:
Koodia: [Valitse]
sudo apt-get purge php7.0-cli php7.0-curl php7.0-mcrypt php7.0-bcmath php7.0-xml
Koodia: [Valitse]
sudo apt-get autoremove
Koodia: [Valitse]
sudo apt-get install php7.0-cli php7.0-curl php7.0-mcrypt php7.0-bcmath php7.0-xml
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Johannez - 23.05.17 - klo:01.42
Moi,

Onko mahdollista saada ripattua linkin takaa löytyvää ensimmäistä videota "sarjan esittely ja tunnusmelodia"?

http://yle.fi/aihe/artikkeli/2012/11/16/hui-hai-hiisi

Yritin tarkkailla koodia ja en onnistunut löytämään mitään, jota voisin käyttää "yle areena" syötön kaltaisesti.

Kiitos,


Johannez
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: nm - 23.05.17 - klo:01.49
Moi,

Onko mahdollista saada ripattua linkin takaa löytyvää ensimmäistä videota "sarjan esittely ja tunnusmelodia"?

http://yle.fi/aihe/artikkeli/2012/11/16/hui-hai-hiisi

Onnistuu vaikkapa Video DownloadHelper -lisäosalla: https://addons.mozilla.org/fi/firefox/addon/video-downloadhelper/
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: AimoE - 18.06.17 - klo:15.47
Juuri julkaistu yle-dl 2.17 ei saa haetuksi DRM-suojattua ohjelmaa http://areena.yle.fi/1-1123191; tarkemmin: https://forum.ubuntu-fi.org/index.php?topic=52263.msg400184#msg400184
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Cultor - 18.06.17 - klo:16.56
Juuri julkaistu yle-dl 2.17 ei saa haetuksi DRM-suojattua ohjelmaa http://areena.yle.fi/1-1123191; tarkemmin: https://forum.ubuntu-fi.org/index.php?topic=52263.msg400184#msg400184

Toki saa, juuri latasin. Onnistui kokeilemillani kehitysversioilla myös. Kannattaa tarkistaa ffmpeg asennuksesi.
Koodia: [Valitse]
hessu@hessu-GX270:~/Videos$ yle-dl http://areena.yle.fi/1-1123191
yle-dl 2.17: Download media files from Yle Areena and Elävä Arkisto
Copyright (C) 2009-2017 Antti Ajanki <antti.ajanki@iki.fi>, license: GPLv3
Subtitles saved to Vastavirtaan__S01E01__Maan_tapa_1_2-2017-06-17T06_00_00+03_00.fin.srt
Output file: file:Vastavirtaan__S01E01__Maan_tapa_1_2-2017-06-17T06_00_00+03_00.ts
ffmpeg version 3.3.1 Copyright (c) 2000-2017 the FFmpeg developers
  built with gcc 4.8 (Ubuntu 4.8.4-2ubuntu1~14.04.3)
  configuration: --extra-libs=-ldl --prefix=/opt/ffmpeg --mandir=/usr/share/man --enable-avresample --disable-debug --enable-nonfree --enable-gpl --enable-version3 --enable-libopencore-amrnb --enable-libopencore-amrwb --disable-decoder=amrnb --disable-decoder=amrwb --enable-libpulse --enable-libfreetype --enable-gnutls --enable-libx264 --enable-libx265 --enable-libfdk-aac --enable-libvorbis --enable-libmp3lame --enable-libopus --enable-libvpx --enable-libspeex --enable-libass --enable-avisynth --enable-libsoxr --enable-libxvid --enable-libvidstab --enable-libwavpack --enable-nvenc
  libavutil      55. 58.100 / 55. 58.100
  libavcodec     57. 89.100 / 57. 89.100
  libavformat    57. 71.100 / 57. 71.100
  libavdevice    57.  6.100 / 57.  6.100
  libavfilter     6. 82.100 /  6. 82.100
  libavresample   3.  5.  0 /  3.  5.  0
  libswscale      4.  6.100 /  4.  6.100
  libswresample   2.  7.100 /  2.  7.100
  libpostproc    54.  5.100 / 54.  5.100
Input #0, hls,applehttp, from 'http://cdnapi.kaltura.com/p/1955031/sp/195503100/playManifest/entryId/1_59m0mbu4/flavorIds/0_zwcv2dsf/format/applehttp/protocol/http/a.m3u8?referrer=aHR0cDovL2FyZW5hbi55bGUuZmk=&playSessionId=11111111-1111-1111-1111-111111111111&clientTag=html5:v2.56&preferredBitrate=600&uiConfId=37558971':
  Duration: 00:53:30.09, start: 0.101000, bitrate: 0 kb/s
  Program 0
    Metadata:
      variant_bitrate : 4227072
    Stream #0:0: Video: h264 (High) ([27][0][0][0] / 0x001B), yuv420p, 1024x576 [SAR 1:1 DAR 16:9], 25 fps, 25 tbr, 90k tbn, 50 tbc
    Metadata:
      variant_bitrate : 4227072
    Stream #0:1: Audio: aac (LC) ([15][0][0][0] / 0x000F), 44100 Hz, stereo, fltp
    Metadata:
      variant_bitrate : 4227072
    Stream #0:2: Data: timed_id3 (ID3  / 0x20334449)
    Metadata:
      variant_bitrate : 4227072
Output #0, mpegts, to 'file:Vastavirtaan__S01E01__Maan_tapa_1_2-2017-06-17T06_00_00+03_00.ts':
  Metadata:
    encoder         : Lavf57.71.100
    Stream #0:0: Video: h264 (High) ([27][0][0][0] / 0x001B), yuv420p, 1024x576 [SAR 1:1 DAR 16:9], q=2-31, 25 fps, 25 tbr, 90k tbn, 90k tbc
    Metadata:
      variant_bitrate : 4227072
    Stream #0:1: Audio: aac (LC) ([15][0][0][0] / 0x000F), 44100 Hz, stereo, fltp
    Metadata:
      variant_bitrate : 4227072
Stream mapping:
  Stream #0:0 -> #0:0 (copy)
  Stream #0:1 -> #0:1 (copy)
Press [q] to stop, [?] for help
frame=   38 fps=0.0 q=-1.0 size=     924kB time=00:00:01.48 bitrate=5115.6kbits/frame=   51 fps= 48 q=-1.0 size=    1358kB time=00:00:02.00 bitrate=5563.3kbits/frame=   69 fps= 43 q=-1.0 size=    1813kB time=00:00:02.72 bitrate=5460.8kbits/frame=   93 fps= 44 q=-1.0 size=    2315kB time=00:00:03.68 bitrate=5152.4kbits/frame=  112 fps= 42 q=-1.0 size=    2662kB time=00:00:04.44 bitrate=4912.4kbits/frame=  138 fps= 43 q=-1.0 size=    3198kB time=00:00:05.48 bitrate=4780.7kbits/frame=  151 fps= 42 q=-1.0 Lsize=    3481kB time=00:00:06.00 bitrate=4752.6kbits/s speed=1.68x
video:3111kB audio:96kB subtitle:0kB other streams:0kB global headers:0kB muxing overhead: 8.538524%
Exiting normally, received signal 2.

Keskeytetty kuuden sekunnin pätkä toimi videosoittimessa normaalisti.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: jarmala - 19.06.17 - klo:00.37
No nyt ei toimi... Pitäisikö tuo versio 2.7.0 päivittää uudempaan vai onko vika tuolla ylen päässä?

Koodia: [Valitse]
ari@ari:~/avi$ yle-dl http://areena.yle.fi/1-4072204
yle-dl 2.7.0: Download media files from Yle Areena and Elävä Arkisto
Copyright (C) 2009-2015 Antti Ajanki <antti.ajanki@iki.fi>, license: GPLv2
Can't read http://areena.yle.fi/api/programs/v1/items.json?series=1-4072204&type=program&availability=ondemand&order=ondemand.publication.starttime%253Adesc&app_id=cb021459&app_key=fa6c26b3b3e617b7033c83c108417200&limit=25&offset=0&olang=fi: HTTP Error 401: Unauthorized
Subtitles saved to Doctor Who-2017-06-18T06:00:00+03:00.fin.srt

                            KSV Adobe HDS Downloader

Processing manifest info....                                                   
PHP Notice:  Undefined offset: 0 in /usr/local/share/yle-dl/AdobeHDS.php on line 534
Quality Selection:                                                             
 Available: 0
 Selected : 0                                                                 
PHP Warning:  unpack(): Type N: not enough input, need 4, have 0 in /usr/local/share/yle-dl/AdobeHDS.php on line 1401
Failed to parse bootstrap info                                                 
Can't read http://areena.yle.fi/api/programs/v1/items.json?series=1-4072204&type=program&availability=ondemand&order=ondemand.publication.starttime%253Adesc&app_id=cb021459&app_key=fa6c26b3b3e617b7033c83c108417200&limit=25&offset=0&olang=fi: HTTP Error 401: Unauthorized
Subtitles saved to Doctor Who-2017-06-18T06:00:00+03:00.fin.srt
Output file: Doctor Who-2017-06-18T06:00:00+03:00.flv
[download] Downloading f4m manifest
[download] Destination: Doctor Who-2017-06-18T06:00:00+03:00.flv
Traceback (most recent call last):
  File "/usr/local/bin/yle-dl", line 2010, in <module>
    main()
  File "/usr/local/bin/yle-dl", line 2006, in main
    sys.exit(dl.download_episodes(url, sfilt, rtmpdumpargs, destdir))
  File "/usr/local/bin/yle-dl", line 1603, in download_episodes
    return self._retry_call('download_episodes', *args, **kwargs)
  File "/usr/local/bin/yle-dl", line 1592, in _retry_call
    return self._retry_call(method_name, *args, **kwargs)
  File "/usr/local/bin/yle-dl", line 1590, in _retry_call
    res = method(*args, **kwargs)
  File "/usr/local/bin/yle-dl", line 1037, in download_episodes
    return self.process(download_clip, url, filters)
  File "/usr/local/bin/yle-dl", line 1070, in process
    res = self.process_single_episode(clipfunc, clipurl, filters)
  File "/usr/local/bin/yle-dl", line 1106, in process_single_episode
    return clipfunc(clip)
  File "/usr/local/bin/yle-dl", line 1035, in download_clip
    return downloader.save_stream()
  File "/usr/local/bin/yle-dl", line 1862, in save_stream
    if not f4mdl.download(outputfile, info):
  File "/usr/lib/python2.7/dist-packages/youtube_dl/downloader/common.py", line 290, in download
    return self.real_download(filename, info_dict)
  File "/usr/lib/python2.7/dist-packages/youtube_dl/downloader/f4m.py", line 240, in real_download
    bootstrap = base64.b64decode(doc.find(_add_ns('bootstrapInfo')).text)
AttributeError: 'NoneType' object has no attribute 'text'
ari@ari:~/avi$

T. Ari
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: nm - 19.06.17 - klo:00.57
No nyt ei toimi... Pitäisikö tuo versio 2.7.0 päivittää uudempaan vai onko vika tuolla ylen päässä?

Päivitä uusimpaan versioon (2.17) ja asenna ffmpeg. Ubuntu 14.04:ään sen saa vaikkapa tästä PPA:sta: https://launchpad.net/~mc3man/+archive/ubuntu/trusty-media
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: jarmala - 19.06.17 - klo:12.01

Päivitä uusimpaan versioon (2.17) ja asenna ffmpeg. Ubuntu 14.04:ään sen saa vaikkapa tästä PPA:sta: https://launchpad.net/~mc3man/+archive/ubuntu/trusty-media

Kiitos. Nyt toimii!
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Kullervo - 19.06.17 - klo:12.17
Koodia: [Valitse]
yle-dl https://areena.yle.fi/1-1123191Traceback (most recent call last):
  File "/usr/local/bin/yle-dl", line 46, in <module>
    from Crypto.Cipher import AES
ImportError: No module named Crypto.Cipher
Ubuntu 16.10 ja tuollaista pukkaa.

Muoks.
Eilen asennettu https://aajanki.github.io/yle-dl/ sivulta ladattu vakaa versio.
https://github.com/aajanki/yle-dl/tarball/2.17
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: nm - 19.06.17 - klo:12.25
Koodia: [Valitse]
yle-dl https://areena.yle.fi/1-1123191Traceback (most recent call last):
  File "/usr/local/bin/yle-dl", line 46, in <module>
    from Crypto.Cipher import AES
ImportError: No module named Crypto.Cipher
Ubuntu 16.10 ja tuollaista pukkaa.

python-crypto puuttuu. Asenna muutkin tarvittavat riippuvuudet, kuten asennusohjeessa (https://github.com/aajanki/yle-dl/blob/master/README.fi) (README.md / README.fi) neuvotaan:

Koodia: [Valitse]
sudo apt-get install rtmpdump python python-crypto php-cli php-curl php-mcrypt php-xml php-bcmath
sudo phpenmod mcrypt
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Kullervo - 19.06.17 - klo:12.32
Kiitos. Tuo README jäi tavaamatta sorry.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: jekku - 19.06.17 - klo:16.51
Kokeilin myös, tuota uudempaa (Debian 9)
yle-dl http://areena.yle.fi/1-2507784 -o monsuuni

Mutta ei suostunut.
No ei tietenkään, kun uudessakaan debianissa ei ole tarjolla ffmpeg:iä ;(

Koetin toisella koneella, vanhemmalla.
Se kiukuttelee:
Koodia: [Valitse]
[download] Destination: monsuuni
Traceback (most recent call last):
  File "/usr/local/bin/yle-dl", line 2025, in <module>
    main()
  File "/usr/local/bin/yle-dl", line 2021, in main
    sys.exit(dl.download_episodes(url, sfilt, rtmpdumpargs, destdir))
  File "/usr/local/bin/yle-dl", line 1600, in download_episodes
    return self._retry_call('download_episodes', *args, **kwargs)
  File "/usr/local/bin/yle-dl", line 1589, in _retry_call
    return self._retry_call(method_name, *args, **kwargs)
  File "/usr/local/bin/yle-dl", line 1587, in _retry_call
    res = method(*args, **kwargs)
  File "/usr/local/bin/yle-dl", line 1034, in download_episodes
    return self.process(download_clip, url, filters)
  File "/usr/local/bin/yle-dl", line 1067, in process
    res = self.process_single_episode(clipfunc, clipurl, filters)
  File "/usr/local/bin/yle-dl", line 1103, in process_single_episode
    return clipfunc(clip)
  File "/usr/local/bin/yle-dl", line 1032, in download_clip
    return downloader.save_stream()
  File "/usr/local/bin/yle-dl", line 1840, in save_stream
    return self._execute_youtube_dl(self.output_filename())
  File "/usr/local/bin/yle-dl", line 1870, in _execute_youtube_dl
    if not f4mdl.download(outputfile, info):
  File "/usr/lib/python2.7/dist-packages/youtube_dl/downloader/common.py", line 291, in download
    return self.real_download(filename, info_dict)
  File "/usr/lib/python2.7/dist-packages/youtube_dl/downloader/f4m.py", line 246, in real_download
    bootstrap = base64.b64decode(doc.find(_add_ns('bootstrapInfo')).text)
AttributeError: 'NoneType' object has no attribute 'text'

Sen sijaan
yle-dl http://areena.yle.fi/1-3186870 -o matteo-01
valutti hienosti.

Mikä noissa lie ero - ja mahtaakohan se ffmpeg olla jostain vielä saatavilla.

No, kokeillen vielä Ubuntu 16.04:llä kunhan saan sen käyntiin.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: nm - 19.06.17 - klo:16.59
Kokeilin myös, tuota uudempaa (Debian 9)
yle-dl http://areena.yle.fi/1-2507784 -o monsuuni

Tuo parametri "-o monsuuni" ei kyllä toimi nykyisellä yle-dl 2.17:lla. Siihen pitää lisätä ffmpegin ymmärtämä tiedostopääte:

Koodia: [Valitse]
yle-dl http://areena.yle.fi/1-2507784 -o monsuuni.mp4
Tai vaikka monsuuni.mkv, jos haluat toistaa videota latauksen aikana.

No ei tietenkään, kun uudessakaan debianissa ei ole tarjolla ffmpeg:iä ;(

Hmm, onhan se saatavilla stretchiin suoraan virallisista lähteistä: https://packages.debian.org/stretch/ffmpeg
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: jekku - 19.06.17 - klo:17.14
No niinhän onkin!
Koodia: [Valitse]
root@hpze:~# aptitude install ffmpeg
Paketin ffmpeg pyydetty versio 7:3.2.5-1 on jo asennettuna
Paketin ffmpeg pyydetty versio 7:3.2.5-1 on jo asennettuna
Mitään paketteja ei asenneta, päivitetä tai poisteta.
0 päivitettyä pakettia, 0 uutta asennusta, 0 poistettavaa ja 1 päivittämätöntä.

Katsoin huolimattomasti. (tai uskoin niin, koska motion ei osaa vieläkään vääntää videota, ainoastaan hillittömän määrän still-kuvia)

Ja virheilmoitus vaihtelee:
Koodia: [Valitse]
--8<--
yle-dl 2.17: Download media files from Yle Areena and Elävä Arkisto
Copyright (C) 2009-2017 Antti Ajanki <antti.ajanki@iki.fi>, license: GPLv3
Subtitles saved to monsuuni.fihh.srt
Output file: file:monsuuni
Failed to execute ffmpeg -y -i http://cdnapi.kaltura.com/p/1955031/sp/195503100/playManifest/entryId/1_39yiepb6/flavorIds/0_hculk2r0/format/applehttp/protocol/http/a.m3u8?referrer=aHR0cDovL2FyZW5hbi55bGUuZmk=&playSessionId=11111111-1111-1111-1111-111111111111&clientTag=html5:v2.56&preferredBitrate=600&uiConfId=37558971 -bsf:a aac_adtstoasc -vcodec copy -acodec copy file:monsuuni
No such file or directory

Subtitles saved to monsuuni.fihh.srt
--8<--

Output file: file:monsuuni
ffmpeg version 3.2.5-1 Copyright (c) 2000-2017 the FFmpeg developers
  built with gcc 6.3.0 (Debian 6.3.0-18) 20170516
  configuration: --prefix=/usr --extra-version=1 --toolchain=hardened --libdir=/usr/lib/x86_64-linux-gnu --incdir=/usr/include/x86_64-linux-gnu --enable-gpl --disable-stripping --enable-avresample --enable-avisynth --enable-gnutls --enable-ladspa --enable-libass --enable-libbluray --enable-libbs2b --enable-libcaca --enable-libcdio --enable-libebur128 --enable-libflite --enable-libfontconfig --enable-libfreetype --enable-libfribidi --enable-libgme --enable-libgsm --enable-libmp3lame --enable-libopenjpeg --enable-libopenmpt --enable-libopus --enable-libpulse --enable-librubberband --enable-libshine --enable-libsnappy --enable-libsoxr --enable-libspeex --enable-libssh --enable-libtheora --enable-libtwolame --enable-libvorbis --enable-libvpx --enable-libwavpack --enable-libwebp --enable-libx265 --enable-libxvid --enable-libzmq --enable-libzvbi --enable-omx --enable-openal --enable-opengl --enable-sdl2 --enable-libdc1394 --enable-libiec61883 --enable-chromaprint --enable-frei0r --enable-libopencv --enable-libx264 --enable-shared
  libavutil      55. 34.101 / 55. 34.101
  libavcodec     57. 64.101 / 57. 64.101
  libavformat    57. 56.101 / 57. 56.101
  libavdevice    57.  1.100 / 57.  1.100
  libavfilter     6. 65.100 /  6. 65.100
  libavresample   3.  1.  0 /  3.  1.  0
  libswscale      4.  2.100 /  4.  2.100
  libswresample   2.  3.100 /  2.  3.100
  libpostproc    54.  1.100 / 54.  1.100
Input #0, hls,applehttp, from 'http://cdnapi.kaltura.com/p/1955031/sp/195503100/playManifest/entryId/1_39yiepb6/flavorIds/0_hculk2r0/format/applehttp/protocol/http/a.m3u8?referrer=aHR0cDovL2FyZW5hbi55bGUuZmk=&playSessionId=11111111-1111-1111-1111-111111111111&clientTag=html5:v2.56&preferredBitrate=600&uiConfId=37558971':
  Duration: 00:51:26.89, start: 0.101000, bitrate: 0 kb/s
  Program 0
    Metadata:
      variant_bitrate : 4227072
    Stream #0:0: Video: h264 (High) ([27][0][0][0] / 0x001B), yuv420p, 1920x1080 [SAR 1:1 DAR 16:9], 25 fps, 25 tbr, 90k tbn, 50 tbc
    Metadata:
      variant_bitrate : 4227072
    Stream #0:1: Audio: aac (LC) ([15][0][0][0] / 0x000F), 44100 Hz, stereo, fltp
    Metadata:
      variant_bitrate : 4227072
    Stream #0:2: Data: timed_id3 (ID3  / 0x20334449)
    Metadata:
      variant_bitrate : 4227072
[NULL @ 0x5621dab4d620] Unable to find a suitable output format for 'file:monsuuni'
file:monsuuni: Invalid argument
--8<--


Nuo sillä uudella Debianilla

Pitääpä syynätä tarkemmin jos/kun helle menee ohi...
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: nm - 19.06.17 - klo:17.25
Koodia: [Valitse]
[NULL @ 0x5621dab4d620] Unable to find a suitable output format for 'file:monsuuni'
file:monsuuni: Invalid argument

Kuten sanoin, "-o monsuuni" ei enää toimi, vaan ffmpeg vaatii tiedostonimeen päätteen. Päätteet/formaatit mp4 ja mkv ovat sopivia Areenan videoille. MP4 on jonkin verran laajemmin tuettu, mutta Linuxin videosoittimilla mkv (Matroska) toimii ongelmitta, ja nykyisin monet erillissoittimetkin tukevat sitä. Mkv-tiedostoa voi toistaa jo latauksen aikana.

Siis näin:

Koodia: [Valitse]
yle-dl http://areena.yle.fi/1-2507784 -o monsuuni.mp4
tai näin:

Koodia: [Valitse]
yle-dl http://areena.yle.fi/1-2507784 -o monsuuni.mkv
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: jekku - 19.06.17 - klo:17.32
No se!

Ainakin tuo versio, monsuuni.mkv alkoi ryystää kamaa alas :)

Aika outoa että tiedostonimellä merkitysta - kuin parhaimpiin/pahimpiin DOS-aikoihin ;(

mplayer näyttää toistavankin vaikka vlc:llä näyttää menevän "hämmästyksen sormi kummastuksen suuhuh" - kuten muuan ex-kollegani tykkasi asian ilmaista.
 
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Kullervo - 19.06.17 - klo:17.52
Kuinka tuon yle-dl:n saa asennettua raspberry pi 3:n?
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: nm - 19.06.17 - klo:17.53
Aika outoa että tiedostonimellä merkitysta - kuin parhaimpiin/pahimpiin DOS-aikoihin ;(

No tuo on ffmpegin pikasyntaksi säiliömuodon valintaan. Vaihtoehtoisesti formaatin voi valita parametrilla -f mp4 tai -f matroska, minkä lisäksi joudut silti määrittämään tiedostopäätteen, jotta tiedosto olisi nimetty yhteensopivasti. Yle-dl ei kuitenkaan tällä hetkellä välitä formaattiparametreja tai muitakaan erityisvipuja ffmpegille.

Kyllähän formaatin määrääminen tiedostopäätteen perusteella on ihan normaali käytäntö kaikkialla, myös graafisissa ohjelmissa.


mplayer näyttää toistavankin vaikka vlc:llä näyttää menevän "hämmästyksen sormi kummastuksen suuhuh" - kuten muuan ex-kollegani tykkasi asian ilmaista.

VLC ei tosiaan taida vieläkään tykätä ffmpegillä kirjoitetuista MKV-tiedostoista. Näkyy olevan edelleen ongelmallinen kombinaatio uusimmillakin ohjelmaversioilla. Paras käyttää MP4-formaattia, jos ladattuja tiedostoja on tarkoitus säilyttää ja katsella erilaisissa ympäristöissä muilla kuin FFmpeg/libavformat-pohjaisilla soittimilla.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: nm - 19.06.17 - klo:18.04
Kuinka tuon yle-dl:n saa asennettua raspberry pi 3:n?

Onnistunee seuraamalla Debian Jessien ohjeistusta:

Lainaus
Asennus Debian Jessie (8.5)/Ubuntu 15.10 ja vanhemmat
-----------------------------------------------------

sudo apt-get install rtmpdump python python-crypto php5-cli php5-curl php5-mcrypt
sudo php5enmod mcrypt

sudo make install

Lisäksi tarvitset ffmpegin, joka onkin hankalampi juttu nykyisen Raspbianin kanssa. Kokeile sen sijaan avconvia, jonka pitäisi toimia tarpeeksi hyvin:

Koodia: [Valitse]
sudo apt-get install libav-tools

Käyttö onnistuu valitsimella --ffmpeg /usr/bin/avconv

Koodia: [Valitse]
yle-dl --ffmpeg /usr/bin/avconv http://areena.yle.fi/1-2507784
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: AimoE - 19.06.17 - klo:18.14
Tuo parametri "-o monsuuni" ei kyllä toimi nykyisellä yle-dl 2.17:lla. Siihen pitää lisätä ffmpegin ymmärtämä tiedostopääte:

Koodia: [Valitse]
yle-dl http://areena.yle.fi/1-2507784 -o monsuuni.mp4

Mikä herättää kysymyksen pitääkö joka ohjelman kanssa erikseen valita pääte kun edelleen on ohjelmia jotka ovat tarjolla vain .flv-muodossa, mutta onneksi tuo .mp4 kelpaa yle-dl-työkalulle; se vaihtaa päätteen .flv:ksi tarvittaessa eikä jätä väärää päätettä jäljelle. Tämä oli iso helpotus kun tein oman wrapperin joka muuntaa ladattujen tiedostojen nimet mielekkämpään muotoon. Scriptin ei tarvitse kysyä mitän, vaan se voi suoraan tökätä tuon .mp4:n kaikille.

Nyt kun vielä Yle yhdenmukaistaisi ohjelmien tiedot niin että saisin kaiken automatisoiduksi. Nimissä on vielä liikaa hajontaa. Eisimerkiksi sarjan Vastavirtaan jaksot haluan tietenkin ladata nimillä joissa Vastavirtaan on prefiksinä, mutta tarjolla on paljon ohjelmia joiden nimissä on ihan tarpeeton prefiksi, kuten Dokumenttiprojekti, tai Dok tai Kino Suomi. Ja sitten on kaikenlaista muuta jäynää. Jouduin vielä toistaiseksi tyytymään wrapperiin joka kysyy missä mudossa haluan ohjelman nimen. Tälllä hetkellä perustan sen siihen että yle-dl:n antamassa nimessä on ensin yksi tai useampi merkeillä ': ' erotettu osa ja stten aikaleima. Wrapperini erottaa osat ja kysyy mitkä niistä haluan poimia mukaan. Hankalaa mutta eipä tuota latausta niin hirveän usein tule tehtyä.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: nm - 19.06.17 - klo:18.43
Nyt kun vielä Yle yhdenmukaistaisi ohjelmien tiedot niin että saisin kaiken automatisoiduksi. Nimissä on vielä liikaa hajontaa. Eisimerkiksi sarjan Vastavirtaan jaksot haluan tietenkin ladata nimillä joissa Vastavirtaan on prefiksinä, mutta tarjolla on paljon ohjelmia joiden nimissä on ihan tarpeeton prefiksi, kuten Dokumenttiprojekti, tai Dok tai Kino Suomi.

Itse tekisin tuota varten sed-skriptin, jonka läpi kaikki nimet ajetaan:

fix_yle_naming.sed
Lainaus
# Sed script to clean up Yle program naming

s/^Kino [[:alpha:]]*: //
s/^Dokumenttiprojekti: //
s/^Dok: //

Koodia: [Valitse]
echo "Kino Suomi: Mies vailla menneisyyttä" | sed -f fix_yle_naming.sed
Lainaus
Mies vailla menneisyyttä

Tiedostoon on sitten helppo lisäillä uusia sääntöjä tarpeen mukaan.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Cultor - 07.08.17 - klo:21.15
VLC ei tosiaan taida vieläkään tykätä ffmpegillä kirjoitetuista MKV-tiedostoista. Näkyy olevan edelleen ongelmallinen kombinaatio uusimmillakin ohjelmaversioilla. Paras käyttää MP4-formaattia, jos ladattuja tiedostoja on tarkoitus säilyttää ja katsella erilaisissa ympäristöissä muilla kuin FFmpeg/libavformat-pohjaisilla soittimilla.

Vakaalla versiolla 2.22 (myös 2.21) ladattua html5-videota (mp4) voi katsoa kesken latauksen VLC:llä ja varmaan millä tahansa videosoittimella. Suorien tallennukseen yle-dl näyttää käyttävän AdobeHDS:ää.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: AimoE - 08.08.17 - klo:08.42
Vakaalla versiolla 2.22 (myös 2.21) ladattua html5-videota (mp4) voi katsoa kesken latauksen VLC:llä ja varmaan millä tahansa videosoittimella. Suorien tallennukseen yle-dl näyttää käyttävän AdobeHDS:ää.

Nyt kun paketissa ei enää ole makefile mukana, niin voisi vähän valaista miten asennus nyt tehdään Ubuntulla. Katsoin jo Readme-tiedoston ja ajoin ne asennukset jotka siellä neuvotaan, mutta kun yritin sudo pip install yle-dl -komentoa, niin systeemi sanoo ettei tunne pip-komentoa. Lisäksi ohje php.ini -tiedoston editoinnista on hämärä, koska se on kirjoitettu geneerisesti monelle käyttikselle.

Miten asennus tehdään Ubuntu16.04 LTS:lle?

Korjaus: pip -komento löytyy, mutta siitä tulee virheilmoitus:

Koodia: [Valitse]
You are using pip version 8.1.1, however version 9.0.1 is available.
You should consider upgrading via the 'pip install --upgrade pip' command.

kun tuon komennon suorittaa, niin asennus ilmeisesti onnistuu, vaikkakin ilmoitukset ovat mystisiä. En ole koskaan ennen ollut tekemisissä koko pip:n kanssa.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: raimo - 08.08.17 - klo:09.06
Vakaalla versiolla 2.22 (myös 2.21) ladattua html5-videota (mp4) voi katsoa kesken latauksen VLC:llä ja varmaan millä tahansa videosoittimella. Suorien tallennukseen yle-dl näyttää käyttävän AdobeHDS:ää.

Nyt kun paketissa ei enää ole makefile mukana, niin voisi vähän valaista miten asennus nyt tehdään Ubuntulla. Katsoin jo Readme-tiedoston ja ajoin ne asennukset jotka siellä neuvotaan, mutta kun yritin sudo pip install yle-dl -komentoa, niin systeemi sanoo ettei tunne pip-komentoa. Lisäksi ohje php.ini -tiedoston editoinnista on hämärä, koska se on kirjoitettu geneerisesti monelle käyttikselle.

Miten asennus tehdään Ubuntu16.04 LTS:lle?

Korjaus: pip -komento löytyy, mutta siitä tulee virheilmoitus:

Koodia: [Valitse]
You are using pip version 8.1.1, however version 9.0.1 is available.
You should consider upgrading via the 'pip install --upgrade pip' command.

kun tuon komennon suorittaa, niin asennus ilmeisesti onnistuu, vaikkakin ilmoitukset ovat mystisiä. En ole koskaan ennen ollut tekemisissä koko pip:n kanssa.

Minulla meni näin:
Koodia: [Valitse]
sudo apt-get install rtmpdump python python-pip python-setuptools python-crypto python-requests python-progress php-cli php-curl php-mcrypt php-xml php-bcmath
Koodia: [Valitse]
sudo phpenmod mcrypt
PIP valittaa tuon jälkeen uudemmasta versiosta, sen saa näin:
Koodia: [Valitse]
pip install --upgrade pip
Koodia: [Valitse]
sudo -H pip install yle-dlMinulla sudo vaati/ehdotti tuota -H vipua, en jaksa tonkia mitä se tekee kun asennus sen kanssa meni virheittä ja yle-dl toimii.

Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Cultor - 08.08.17 - klo:09.56
Yle-dl 2.22 readme.fi
Lainaus
Asenna yle-dl
-------------

Yksinkertainen tapa (ei vaadi lähdekoodien lataamista):

sudo pip install yle-dl

Vaihtoehtoinen tapa: lataa lähdekoodit ja aja lähdekoodihakemistossa:

sudo python setup.py install

Itse käytän jälkimmäistä tapaa, koska puukotan excludechars riviä ennen asennusta.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Illu - 08.08.17 - klo:21.42
Yle-dl 2.22 readme.fi
Lainaus
Asenna yle-dl
-------------

Yksinkertainen tapa (ei vaadi lähdekoodien lataamista):

sudo pip install yle-dl

Vaihtoehtoinen tapa: lataa lähdekoodit ja aja lähdekoodihakemistossa:

sudo python setup.py install

Itse käytän jälkimmäistä tapaa, koska puukotan excludechars riviä ennen asennusta.

Ja mulla ei tuo ensimmäinen toimikaan, jälkimmäinen kyllä.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: nm - 08.08.17 - klo:21.45
Yle-dl 2.22 readme.fi
Lainaus
Asenna yle-dl
-------------

Yksinkertainen tapa (ei vaadi lähdekoodien lataamista):

sudo pip install yle-dl

Vaihtoehtoinen tapa: lataa lähdekoodit ja aja lähdekoodihakemistossa:

sudo python setup.py install

Itse käytän jälkimmäistä tapaa, koska puukotan excludechars riviä ennen asennusta.

Ja mulla ei tuo ensimmäinen toimikaan, jälkimmäinen kyllä.

Asensitko paketin python-pip (muiden tarvittavien riippuvuuksien lisäksi)
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Illu - 08.08.17 - klo:21.55
Asensitko paketin python-pip (muiden tarvittavien riippuvuuksien lisäksi)

Käyn silloin tällöin kurkkaamassa, onko uutta yle-dl pakettia tullut. 2.20 oli ensimmäinen, joka ei asentunutkaan "sudo make jne." menetelmällä. Sitten hoksasin asennusohjeissa tuon pipin. Asensin sen ja 2.20 asentui. 2.21 ei asentunutkaan mutta Cultorin mainitsema
Koodia: [Valitse]
sudo python setup.py install hoiti homman. Ja nyt myös 2.22 versiolla. Ei kai tuolla lopulta mitään väliä ole, miten asentuu, kunhan toimii?
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: AimoE - 08.08.17 - klo:22.03
Ei kai tuolla lopulta mitään väliä ole, miten asentuu, kunhan toimii?

Olisi siitä kuitenkin voinut jotain mainita täällä foorumilla, ettei olisi tullut niin yllättäen, olisi voinut vähän varautua.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: nm - 08.08.17 - klo:22.13
Käyn silloin tällöin kurkkaamassa, onko uutta yle-dl pakettia tullut. 2.20 oli ensimmäinen, joka ei asentunutkaan "sudo make jne." menetelmällä. Sitten hoksasin asennusohjeissa tuon pipin. Asensin sen ja 2.20 asentui. 2.21 ei asentunutkaan

Asennettujen pakettien päivitys onnistuu pip installin vivulla --upgrade:

Koodia: [Valitse]
sudo pip install --upgrade yle-dl

Ei kai tuolla lopulta mitään väliä ole, miten asentuu, kunhan toimii?

Olisi siitä kuitenkin voinut jotain mainita täällä foorumilla, ettei olisi tullut niin yllättäen, olisi voinut vähän varautua.

Luulenpa, ettei Antilla ole aikaa ja intoa toimia ilmaisena tukipalveluna satunnaisilla foorumeilla.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Illu - 21.09.17 - klo:21.03
Mikähän nyt tökkii?
Koodia: [Valitse]
ilkka@kotikone:~$ yle-dl https://areena.yle.fi/1-4232503
Traceback (most recent call last):
  File "/usr/local/bin/yle-dl", line 5, in <module>
    from pkg_resources import load_entry_point
  File "/usr/lib/python2.7/dist-packages/pkg_resources.py", line 2749, in <module>
    working_set = WorkingSet._build_master()
  File "/usr/lib/python2.7/dist-packages/pkg_resources.py", line 444, in _build_master
    ws.require(__requires__)
  File "/usr/lib/python2.7/dist-packages/pkg_resources.py", line 725, in require
    needed = self.resolve(parse_requirements(requirements))
  File "/usr/lib/python2.7/dist-packages/pkg_resources.py", line 628, in resolve
    raise DistributionNotFound(req)
pkg_resources.DistributionNotFound: cryptography>=1.9

Lataus ei siis onnistu, käytössä yle-dl 2.23.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: nm - 22.09.17 - klo:00.02
Mikähän nyt tökkii?
Koodia: [Valitse]
pkg_resources.DistributionNotFound: cryptography>=1.9

Python-moduuli cryptography puuttuu. Se on riippuvuutena pyOpenSSL:lle, joka on uusimmassa yle-dl:n versiossa vaatimuksena, jos Python on vanhempi kuin 2.7.9: https://github.com/aajanki/yle-dl/commit/86091fca7142299f61ea25afcb4b67c192466892#diff-2eeaed663bd0d25b7e608891384b7298
Näin on esimerkiksi Ubuntu 14.04:ssä.

Jos ja kun jakelusi on Ubuntu 14.04 (tai Debian 8 ), varmista ensin että nämä paketit on asennettu:

Koodia: [Valitse]
sudo apt-get install rtmpdump python python-setuptools python-pip python-crypto python-requests python-lxml php5-cli php5-curl php5-mcrypt
ja cryptographyn kääntämiseen tarvittavat työkalut ja headerit:
Koodia: [Valitse]
sudo apt-get install build-essential libssl-dev libffi-dev python-dev
Asenna sitten yle-dl uudelleen. Sen pitäisi vetää cryptography ja muut tarvittavat moduulit mukanaan, kunhan niiden kääntäminen onnistuu:

Koodia: [Valitse]
sudo pip install --upgrade yle-dl
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Illu - 23.09.17 - klo:10.25
Juu, unohdin mainita jakelun Ubuntu 14.04. Pitää kokeilla nuo loitsut, kun viikonlopun päätteeksi taas olen kotosalla.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Illu - 24.09.17 - klo:18.00
Muut komennot sujuivat, mutta yle-dl päivitys ei.

Koodia: [Valitse]
ilkka@kotikone:~/temp$ sudo pip install --upgrade yle-dl
Requirement already up-to-date: yle-dl in /usr/local/lib/python2.7/dist-packages
Requirement already up-to-date: pycrypto in /usr/lib/python2.7/dist-packages (from yle-dl)
Requirement already up-to-date: requests in /usr/local/lib/python2.7/dist-packages (from yle-dl)
Requirement already up-to-date: progress in /usr/local/lib/python2.7/dist-packages (from yle-dl)
Downloading/unpacking lxml from https://pypi.python.org/packages/07/76/9f14811d3fb91ed7973a798ded15eda416070bbcb1aadc6a5af9d691d993/lxml-4.0.0.tar.gz#md5=c30d7e752cc909c1c0c40bd34153443a (from yle-dl)
  Downloading lxml-4.0.0.tar.gz (4.2MB): 4.2MB downloaded
  Running setup.py (path:/tmp/pip_build_root/lxml/setup.py) egg_info for package lxml
    Building lxml version 4.0.0.
    Building without Cython.
    ERROR: /bin/sh: 1: xslt-config: not found
   
    ** make sure the development packages of libxml2 and libxslt are installed **
   
    Using build configuration of libxslt
   
    warning: no previously-included files found matching '*.py'
Downloading/unpacking pyOpenSSL from https://pypi.python.org/packages/24/37/89bf12e53f1d27e8b2c8e5f8f9c7a958a3905f6916a9294a57a9d83fa165/pyOpenSSL-17.3.0-py2.py3-none-any.whl#md5=4217027ddfa4182d7f3b425d0b5eac92 (from yle-dl)
  Downloading pyOpenSSL-17.3.0-py2.py3-none-any.whl (51kB): 51kB downloaded
Requirement already up-to-date: ndg-httpsclient in /usr/local/lib/python2.7/dist-packages (from yle-dl)
Downloading/unpacking pyasn1 from https://pypi.python.org/packages/bf/56/47712763865a8639e6634e80405f6c758d4415620725896f412c464705f0/pyasn1-0.3.6-py2.py3-none-any.whl#md5=4bf6bae8225ccc04ba3e900b3798a0da (from yle-dl)
  Downloading pyasn1-0.3.6-py2.py3-none-any.whl (63kB): 63kB downloaded
Downloading/unpacking six>=1.5.2 from https://pypi.python.org/packages/67/4b/141a581104b1f6397bfa78ac9d43d8ad29a7ca43ea90a2d863fe3056e86a/six-1.11.0-py2.py3-none-any.whl#md5=866ab722be6bdfed6830f3179af65468 (from pyOpenSSL->yle-dl)
  Downloading six-1.11.0-py2.py3-none-any.whl
Downloading/unpacking cryptography>=1.9 (from pyOpenSSL->yle-dl)
  Downloading cryptography-2.0.3.tar.gz (427kB): 427kB downloaded
  Running setup.py (path:/tmp/pip_build_root/cryptography/setup.py) egg_info for package cryptography
   
    no previously-included directories found matching 'docs/_build'
    warning: no previously-included files matching '*' found under directory 'vectors'
Requirement already up-to-date: idna>=2.1 in /usr/local/lib/python2.7/dist-packages (from cryptography>=1.9->pyOpenSSL->yle-dl)
Downloading/unpacking asn1crypto>=0.21.0 (from cryptography>=1.9->pyOpenSSL->yle-dl)
  Downloading asn1crypto-0.23.0-py2.py3-none-any.whl (99kB): 99kB downloaded
Downloading/unpacking enum34 (from cryptography>=1.9->pyOpenSSL->yle-dl)
  Downloading enum34-1.1.6-py2-none-any.whl
Downloading/unpacking ipaddress (from cryptography>=1.9->pyOpenSSL->yle-dl)
  Downloading ipaddress-1.0.18-py2-none-any.whl
Downloading/unpacking cffi>=1.7 (from cryptography>=1.9->pyOpenSSL->yle-dl)
  Downloading cffi-1.11.0.tar.gz (434kB): 434kB downloaded
  Running setup.py (path:/tmp/pip_build_root/cffi/setup.py) egg_info for package cffi
   
Downloading/unpacking pycparser (from cffi>=1.7->cryptography>=1.9->pyOpenSSL->yle-dl)
  Downloading pycparser-2.18.tar.gz (245kB): 245kB downloaded
  Running setup.py (path:/tmp/pip_build_root/pycparser/setup.py) egg_info for package pycparser
   
    warning: no previously-included files matching 'yacctab.*' found under directory 'tests'
    warning: no previously-included files matching 'lextab.*' found under directory 'tests'
    warning: no previously-included files matching 'yacctab.*' found under directory 'examples'
    warning: no previously-included files matching 'lextab.*' found under directory 'examples'
Installing collected packages: lxml, pyOpenSSL, pyasn1, six, cryptography, asn1crypto, enum34, ipaddress, cffi, pycparser
  Found existing installation: lxml 3.3.3
    Not uninstalling lxml at /usr/lib/python2.7/dist-packages, owned by OS
  Running setup.py install for lxml
    Building lxml version 4.0.0.
    Building without Cython.
    ERROR: /bin/sh: 1: xslt-config: not found
   
    ** make sure the development packages of libxml2 and libxslt are installed **
   
    Using build configuration of libxslt
    building 'lxml.etree' extension
    x86_64-linux-gnu-gcc -pthread -fno-strict-aliasing -DNDEBUG -g -fwrapv -O2 -Wall -Wstrict-prototypes -fPIC -Isrc -Isrc/lxml/includes -I/usr/include/python2.7 -c src/lxml/etree.c -o build/temp.linux-x86_64-2.7/src/lxml/etree.o -w
    In file included from src/lxml/etree.c:572:0:
    src/lxml/includes/etree_defs.h:14:31: fatal error: libxml/xmlversion.h: Tiedostoa tai hakemistoa ei ole
     #include "libxml/xmlversion.h"
                                   ^
    compilation terminated.
    Compile failed: command 'x86_64-linux-gnu-gcc' failed with exit status 1
    cc -I/usr/include/libxml2 -c /tmp/xmlXPathInit48eVpU.c -o tmp/xmlXPathInit48eVpU.o
    /tmp/xmlXPathInit48eVpU.c:1:26: fatal error: libxml/xpath.h: Tiedostoa tai hakemistoa ei ole
     #include "libxml/xpath.h"
                              ^
    compilation terminated.
    *********************************************************************************
    Could not find function xmlCheckVersion in library libxml2. Is libxml2 installed?
    *********************************************************************************
    error: command 'x86_64-linux-gnu-gcc' failed with exit status 1
    Complete output from command /usr/bin/python -c "import setuptools, tokenize;__file__='/tmp/pip_build_root/lxml/setup.py';exec(compile(getattr(tokenize, 'open', open)(__file__).read().replace('\r\n', '\n'), __file__, 'exec'))" install --record /tmp/pip-J53QUc-record/install-record.txt --single-version-externally-managed --compile:
    Building lxml version 4.0.0.

Building without Cython.

ERROR: /bin/sh: 1: xslt-config: not found



** make sure the development packages of libxml2 and libxslt are installed **



Using build configuration of libxslt

running install

running build

running build_py

creating build

creating build/lib.linux-x86_64-2.7

creating build/lib.linux-x86_64-2.7/lxml

copying src/lxml/ElementInclude.py -> build/lib.linux-x86_64-2.7/lxml

copying src/lxml/__init__.py -> build/lib.linux-x86_64-2.7/lxml

copying src/lxml/sax.py -> build/lib.linux-x86_64-2.7/lxml

copying src/lxml/doctestcompare.py -> build/lib.linux-x86_64-2.7/lxml

copying src/lxml/cssselect.py -> build/lib.linux-x86_64-2.7/lxml

copying src/lxml/usedoctest.py -> build/lib.linux-x86_64-2.7/lxml

copying src/lxml/pyclasslookup.py -> build/lib.linux-x86_64-2.7/lxml

copying src/lxml/_elementpath.py -> build/lib.linux-x86_64-2.7/lxml

copying src/lxml/builder.py -> build/lib.linux-x86_64-2.7/lxml

creating build/lib.linux-x86_64-2.7/lxml/includes

copying src/lxml/includes/__init__.py -> build/lib.linux-x86_64-2.7/lxml/includes

creating build/lib.linux-x86_64-2.7/lxml/html

copying src/lxml/html/__init__.py -> build/lib.linux-x86_64-2.7/lxml/html

copying src/lxml/html/_diffcommand.py -> build/lib.linux-x86_64-2.7/lxml/html

copying src/lxml/html/html5parser.py -> build/lib.linux-x86_64-2.7/lxml/html

copying src/lxml/html/_html5builder.py -> build/lib.linux-x86_64-2.7/lxml/html

copying src/lxml/html/diff.py -> build/lib.linux-x86_64-2.7/lxml/html

copying src/lxml/html/clean.py -> build/lib.linux-x86_64-2.7/lxml/html

copying src/lxml/html/usedoctest.py -> build/lib.linux-x86_64-2.7/lxml/html

copying src/lxml/html/defs.py -> build/lib.linux-x86_64-2.7/lxml/html

copying src/lxml/html/ElementSoup.py -> build/lib.linux-x86_64-2.7/lxml/html

copying src/lxml/html/_setmixin.py -> build/lib.linux-x86_64-2.7/lxml/html

copying src/lxml/html/soupparser.py -> build/lib.linux-x86_64-2.7/lxml/html

copying src/lxml/html/formfill.py -> build/lib.linux-x86_64-2.7/lxml/html

copying src/lxml/html/builder.py -> build/lib.linux-x86_64-2.7/lxml/html

creating build/lib.linux-x86_64-2.7/lxml/isoschematron

copying src/lxml/isoschematron/__init__.py -> build/lib.linux-x86_64-2.7/lxml/isoschematron

copying src/lxml/etree.h -> build/lib.linux-x86_64-2.7/lxml

copying src/lxml/etree_api.h -> build/lib.linux-x86_64-2.7/lxml

copying src/lxml/lxml.etree.h -> build/lib.linux-x86_64-2.7/lxml

copying src/lxml/lxml.etree_api.h -> build/lib.linux-x86_64-2.7/lxml

copying src/lxml/includes/htmlparser.pxd -> build/lib.linux-x86_64-2.7/lxml/includes

copying src/lxml/includes/c14n.pxd -> build/lib.linux-x86_64-2.7/lxml/includes

copying src/lxml/includes/xmlschema.pxd -> build/lib.linux-x86_64-2.7/lxml/includes

copying src/lxml/includes/uri.pxd -> build/lib.linux-x86_64-2.7/lxml/includes

copying src/lxml/includes/dtdvalid.pxd -> build/lib.linux-x86_64-2.7/lxml/includes

copying src/lxml/includes/xmlerror.pxd -> build/lib.linux-x86_64-2.7/lxml/includes

copying src/lxml/includes/xpath.pxd -> build/lib.linux-x86_64-2.7/lxml/includes

copying src/lxml/includes/config.pxd -> build/lib.linux-x86_64-2.7/lxml/includes

copying src/lxml/includes/tree.pxd -> build/lib.linux-x86_64-2.7/lxml/includes

copying src/lxml/includes/xmlparser.pxd -> build/lib.linux-x86_64-2.7/lxml/includes

copying src/lxml/includes/etreepublic.pxd -> build/lib.linux-x86_64-2.7/lxml/includes

copying src/lxml/includes/__init__.pxd -> build/lib.linux-x86_64-2.7/lxml/includes

copying src/lxml/includes/relaxng.pxd -> build/lib.linux-x86_64-2.7/lxml/includes

copying src/lxml/includes/xinclude.pxd -> build/lib.linux-x86_64-2.7/lxml/includes

copying src/lxml/includes/schematron.pxd -> build/lib.linux-x86_64-2.7/lxml/includes

copying src/lxml/includes/xslt.pxd -> build/lib.linux-x86_64-2.7/lxml/includes

copying src/lxml/includes/lxml-version.h -> build/lib.linux-x86_64-2.7/lxml/includes

copying src/lxml/includes/etree_defs.h -> build/lib.linux-x86_64-2.7/lxml/includes

creating build/lib.linux-x86_64-2.7/lxml/isoschematron/resources

creating build/lib.linux-x86_64-2.7/lxml/isoschematron/resources/rng

copying src/lxml/isoschematron/resources/rng/iso-schematron.rng -> build/lib.linux-x86_64-2.7/lxml/isoschematron/resources/rng

creating build/lib.linux-x86_64-2.7/lxml/isoschematron/resources/xsl

copying src/lxml/isoschematron/resources/xsl/RNG2Schtrn.xsl -> build/lib.linux-x86_64-2.7/lxml/isoschematron/resources/xsl

copying src/lxml/isoschematron/resources/xsl/XSD2Schtrn.xsl -> build/lib.linux-x86_64-2.7/lxml/isoschematron/resources/xsl

creating build/lib.linux-x86_64-2.7/lxml/isoschematron/resources/xsl/iso-schematron-xslt1

copying src/lxml/isoschematron/resources/xsl/iso-schematron-xslt1/iso_svrl_for_xslt1.xsl -> build/lib.linux-x86_64-2.7/lxml/isoschematron/resources/xsl/iso-schematron-xslt1

copying src/lxml/isoschematron/resources/xsl/iso-schematron-xslt1/iso_schematron_skeleton_for_xslt1.xsl -> build/lib.linux-x86_64-2.7/lxml/isoschematron/resources/xsl/iso-schematron-xslt1

copying src/lxml/isoschematron/resources/xsl/iso-schematron-xslt1/iso_dsdl_include.xsl -> build/lib.linux-x86_64-2.7/lxml/isoschematron/resources/xsl/iso-schematron-xslt1

copying src/lxml/isoschematron/resources/xsl/iso-schematron-xslt1/iso_schematron_message.xsl -> build/lib.linux-x86_64-2.7/lxml/isoschematron/resources/xsl/iso-schematron-xslt1

copying src/lxml/isoschematron/resources/xsl/iso-schematron-xslt1/iso_abstract_expand.xsl -> build/lib.linux-x86_64-2.7/lxml/isoschematron/resources/xsl/iso-schematron-xslt1

copying src/lxml/isoschematron/resources/xsl/iso-schematron-xslt1/readme.txt -> build/lib.linux-x86_64-2.7/lxml/isoschematron/resources/xsl/iso-schematron-xslt1

running build_ext

building 'lxml.etree' extension

creating build/temp.linux-x86_64-2.7

creating build/temp.linux-x86_64-2.7/src

creating build/temp.linux-x86_64-2.7/src/lxml

x86_64-linux-gnu-gcc -pthread -fno-strict-aliasing -DNDEBUG -g -fwrapv -O2 -Wall -Wstrict-prototypes -fPIC -Isrc -Isrc/lxml/includes -I/usr/include/python2.7 -c src/lxml/etree.c -o build/temp.linux-x86_64-2.7/src/lxml/etree.o -w

In file included from src/lxml/etree.c:572:0:

src/lxml/includes/etree_defs.h:14:31: fatal error: libxml/xmlversion.h: Tiedostoa tai hakemistoa ei ole

 #include "libxml/xmlversion.h"

                               ^

compilation terminated.

Compile failed: command 'x86_64-linux-gnu-gcc' failed with exit status 1

creating tmp

cc -I/usr/include/libxml2 -c /tmp/xmlXPathInit48eVpU.c -o tmp/xmlXPathInit48eVpU.o

/tmp/xmlXPathInit48eVpU.c:1:26: fatal error: libxml/xpath.h: Tiedostoa tai hakemistoa ei ole

 #include "libxml/xpath.h"

                          ^

compilation terminated.

*********************************************************************************

Could not find function xmlCheckVersion in library libxml2. Is libxml2 installed?

*********************************************************************************

error: command 'x86_64-linux-gnu-gcc' failed with exit status 1

----------------------------------------
  Can't roll back lxml; was not uninstalled
Cleaning up...
Command /usr/bin/python -c "import setuptools, tokenize;__file__='/tmp/pip_build_root/lxml/setup.py';exec(compile(getattr(tokenize, 'open', open)(__file__).read().replace('\r\n', '\n'), __file__, 'exec'))" install --record /tmp/pip-J53QUc-record/install-record.txt --single-version-externally-managed --compile failed with error code 1 in /tmp/pip_build_root/lxml
Storing debug log for failure in /home/ilkka/.pip/pip.log
ilkka@kotikone:~/temp$ yle-dl
Traceback (most recent call last):
  File "/usr/local/bin/yle-dl", line 5, in <module>
    from pkg_resources import load_entry_point
  File "/usr/lib/python2.7/dist-packages/pkg_resources.py", line 2749, in <module>
    working_set = WorkingSet._build_master()
  File "/usr/lib/python2.7/dist-packages/pkg_resources.py", line 444, in _build_master
    ws.require(__requires__)
  File "/usr/lib/python2.7/dist-packages/pkg_resources.py", line 725, in require
    needed = self.resolve(parse_requirements(requirements))
  File "/usr/lib/python2.7/dist-packages/pkg_resources.py", line 628, in resolve
    raise DistributionNotFound(req)
pkg_resources.DistributionNotFound: cryptography>=1.9
ilkka@kotikone:~/temp$

Mitä nyt teen?
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: nm - 24.09.17 - klo:22.52
    ERROR: /bin/sh: 1: xslt-config: not found
   
    ** make sure the development packages of libxml2 and libxslt are installed **

Asenna paketit libxml2-dev ja libxslt1-dev:

Koodia: [Valitse]
sudo apt-get install libxml2-dev libxslt1-dev
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Illu - 25.09.17 - klo:18.57
No nyt toimii taas, kiitos!
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: ls - 10.10.17 - klo:23.16
Päivitys uusimpaan tökkii:

Koodia: [Valitse]
src/lxml/etree.c:91:20: fatal error: Python.h: Tiedostoa tai hakemistoa ei ole
Koko rimpsu:

Koodia: [Valitse]
sudo pip install --upgrade yle-dl
Requirement already up-to-date: yle-dl in /usr/local/lib/python2.7/dist-packages
Requirement already up-to-date: pycrypto in /usr/lib/python2.7/dist-packages (from yle-dl)
Downloading/unpacking requests from https://pypi.python.org/packages/49/df/50aa1999ab9bde74656c2919d9c0c085fd2b3775fd3eca826012bef76d8c/requests-2.18.4-py2.py3-none-any.whl#md5=eb9be71cc41fd73a51a7c9cd1adde5de (from yle-dl)
  Downloading requests-2.18.4-py2.py3-none-any.whl (88kB): 88kB downloaded
Requirement already up-to-date: progress in /usr/local/lib/python2.7/dist-packages (from yle-dl)
Downloading/unpacking lxml from https://pypi.python.org/packages/07/76/9f14811d3fb91ed7973a798ded15eda416070bbcb1aadc6a5af9d691d993/lxml-4.0.0.tar.gz#md5=c30d7e752cc909c1c0c40bd34153443a (from yle-dl)
  Downloading lxml-4.0.0.tar.gz (4.2MB): 4.2MB downloaded
  Running setup.py (path:/tmp/pip_build_root/lxml/setup.py) egg_info for package lxml
    Building lxml version 4.0.0.
    Building without Cython.
    Using build configuration of libxslt 1.1.28
   
    warning: no previously-included files found matching '*.py'
Downloading/unpacking pyOpenSSL from https://pypi.python.org/packages/24/37/89bf12e53f1d27e8b2c8e5f8f9c7a958a3905f6916a9294a57a9d83fa165/pyOpenSSL-17.3.0-py2.py3-none-any.whl#md5=4217027ddfa4182d7f3b425d0b5eac92 (from yle-dl)
  Downloading pyOpenSSL-17.3.0-py2.py3-none-any.whl (51kB): 51kB downloaded
Downloading/unpacking ndg-httpsclient from https://pypi.python.org/packages/64/05/3b7b745509609e4a756792610c4246350342ad12585d399b9290e04aa26f/ndg_httpsclient-0.4.3-py2-none-any.whl#md5=8a92688261dedbab38a7c99348254ac9 (from yle-dl)
  Downloading ndg_httpsclient-0.4.3-py2-none-any.whl
Downloading/unpacking pyasn1 from https://pypi.python.org/packages/31/fd/08e985cb75c39157cd066b709298c8d027c54a790bf9b265097c5444c336/pyasn1-0.3.7-py2.py3-none-any.whl#md5=c0e2903f40801aa7d533e0c206758c51 (from yle-dl)
  Downloading pyasn1-0.3.7-py2.py3-none-any.whl (63kB): 63kB downloaded
Requirement already up-to-date: certifi>=2017.4.17 in /usr/local/lib/python2.7/dist-packages (from requests->yle-dl)
Requirement already up-to-date: idna>=2.5,<2.7 in /usr/local/lib/python2.7/dist-packages (from requests->yle-dl)
Downloading/unpacking chardet>=3.0.2,<3.1.0 (from requests->yle-dl)
  Downloading chardet-3.0.4-py2.py3-none-any.whl (133kB): 133kB downloaded
Downloading/unpacking urllib3>=1.21.1,<1.23 (from requests->yle-dl)
  Downloading urllib3-1.22-py2.py3-none-any.whl (132kB): 132kB downloaded
Downloading/unpacking six>=1.5.2 from https://pypi.python.org/packages/67/4b/141a581104b1f6397bfa78ac9d43d8ad29a7ca43ea90a2d863fe3056e86a/six-1.11.0-py2.py3-none-any.whl#md5=866ab722be6bdfed6830f3179af65468 (from pyOpenSSL->yle-dl)
  Downloading six-1.11.0-py2.py3-none-any.whl
Downloading/unpacking cryptography>=1.9 (from pyOpenSSL->yle-dl)
  Downloading cryptography-2.0.3.tar.gz (427kB): 427kB downloaded
  Running setup.py (path:/tmp/pip_build_root/cryptography/setup.py) egg_info for package cryptography
   
    no previously-included directories found matching 'docs/_build'
    warning: no previously-included files matching '*' found under directory 'vectors'
Downloading/unpacking asn1crypto>=0.21.0 (from cryptography>=1.9->pyOpenSSL->yle-dl)
  Downloading asn1crypto-0.23.0-py2.py3-none-any.whl (99kB): 99kB downloaded
Downloading/unpacking enum34 (from cryptography>=1.9->pyOpenSSL->yle-dl)
  Downloading enum34-1.1.6-py2-none-any.whl
Downloading/unpacking ipaddress (from cryptography>=1.9->pyOpenSSL->yle-dl)
  Downloading ipaddress-1.0.18-py2-none-any.whl
Downloading/unpacking cffi>=1.7 (from cryptography>=1.9->pyOpenSSL->yle-dl)
  Downloading cffi-1.11.2.tar.gz (435kB): 435kB downloaded
  Running setup.py (path:/tmp/pip_build_root/cffi/setup.py) egg_info for package cffi
   
Downloading/unpacking pycparser (from cffi>=1.7->cryptography>=1.9->pyOpenSSL->yle-dl)
  Downloading pycparser-2.18.tar.gz (245kB): 245kB downloaded
  Running setup.py (path:/tmp/pip_build_root/pycparser/setup.py) egg_info for package pycparser
   
    warning: no previously-included files matching 'yacctab.*' found under directory 'tests'
    warning: no previously-included files matching 'lextab.*' found under directory 'tests'
    warning: no previously-included files matching 'yacctab.*' found under directory 'examples'
    warning: no previously-included files matching 'lextab.*' found under directory 'examples'
Installing collected packages: requests, lxml, pyOpenSSL, ndg-httpsclient, pyasn1, chardet, urllib3, six, cryptography, asn1crypto, enum34, ipaddress, cffi, pycparser
  Found existing installation: requests 2.2.1
    Not uninstalling requests at /usr/lib/python2.7/dist-packages, owned by OS
  Found existing installation: lxml 3.3.3
    Not uninstalling lxml at /usr/lib/python2.7/dist-packages, owned by OS
  Running setup.py install for lxml
    Building lxml version 4.0.0.
    Building without Cython.
    Using build configuration of libxslt 1.1.28
    building 'lxml.etree' extension
    x86_64-linux-gnu-gcc -pthread -fno-strict-aliasing -DNDEBUG -g -fwrapv -O2 -Wall -Wstrict-prototypes -fPIC -I/usr/include/libxml2 -Isrc -Isrc/lxml/includes -I/usr/include/python2.7 -c src/lxml/etree.c -o build/temp.linux-x86_64-2.7/src/lxml/etree.o -w
    src/lxml/etree.c:91:20: fatal error: Python.h: Tiedostoa tai hakemistoa ei ole
     #include "Python.h"
                        ^
    compilation terminated.
    Compile failed: command 'x86_64-linux-gnu-gcc' failed with exit status 1
    cc -I/usr/include/libxml2 -I/usr/include/libxml2 -c /tmp/xmlXPathInite5sCSA.c -o tmp/xmlXPathInite5sCSA.o
    cc tmp/xmlXPathInite5sCSA.o -lxml2 -o a.out
    error: command 'x86_64-linux-gnu-gcc' failed with exit status 1
    Complete output from command /usr/bin/python -c "import setuptools, tokenize;__file__='/tmp/pip_build_root/lxml/setup.py';exec(compile(getattr(tokenize, 'open', open)(__file__).read().replace('\r\n', '\n'), __file__, 'exec'))" install --record /tmp/pip-tFMrsp-record/install-record.txt --single-version-externally-managed --compile:
    Building lxml version 4.0.0.

Building without Cython.

Using build configuration of libxslt 1.1.28

running install

running build

running build_py

creating build

creating build/lib.linux-x86_64-2.7

creating build/lib.linux-x86_64-2.7/lxml

copying src/lxml/builder.py -> build/lib.linux-x86_64-2.7/lxml

copying src/lxml/usedoctest.py -> build/lib.linux-x86_64-2.7/lxml

copying src/lxml/doctestcompare.py -> build/lib.linux-x86_64-2.7/lxml

copying src/lxml/sax.py -> build/lib.linux-x86_64-2.7/lxml

copying src/lxml/pyclasslookup.py -> build/lib.linux-x86_64-2.7/lxml

copying src/lxml/ElementInclude.py -> build/lib.linux-x86_64-2.7/lxml

copying src/lxml/cssselect.py -> build/lib.linux-x86_64-2.7/lxml

copying src/lxml/__init__.py -> build/lib.linux-x86_64-2.7/lxml

copying src/lxml/_elementpath.py -> build/lib.linux-x86_64-2.7/lxml

creating build/lib.linux-x86_64-2.7/lxml/includes

copying src/lxml/includes/__init__.py -> build/lib.linux-x86_64-2.7/lxml/includes

creating build/lib.linux-x86_64-2.7/lxml/html

copying src/lxml/html/_setmixin.py -> build/lib.linux-x86_64-2.7/lxml/html

copying src/lxml/html/_html5builder.py -> build/lib.linux-x86_64-2.7/lxml/html

copying src/lxml/html/builder.py -> build/lib.linux-x86_64-2.7/lxml/html

copying src/lxml/html/ElementSoup.py -> build/lib.linux-x86_64-2.7/lxml/html

copying src/lxml/html/defs.py -> build/lib.linux-x86_64-2.7/lxml/html

copying src/lxml/html/clean.py -> build/lib.linux-x86_64-2.7/lxml/html

copying src/lxml/html/usedoctest.py -> build/lib.linux-x86_64-2.7/lxml/html

copying src/lxml/html/diff.py -> build/lib.linux-x86_64-2.7/lxml/html

copying src/lxml/html/formfill.py -> build/lib.linux-x86_64-2.7/lxml/html

copying src/lxml/html/__init__.py -> build/lib.linux-x86_64-2.7/lxml/html

copying src/lxml/html/_diffcommand.py -> build/lib.linux-x86_64-2.7/lxml/html

copying src/lxml/html/html5parser.py -> build/lib.linux-x86_64-2.7/lxml/html

copying src/lxml/html/soupparser.py -> build/lib.linux-x86_64-2.7/lxml/html

creating build/lib.linux-x86_64-2.7/lxml/isoschematron

copying src/lxml/isoschematron/__init__.py -> build/lib.linux-x86_64-2.7/lxml/isoschematron

copying src/lxml/etree.h -> build/lib.linux-x86_64-2.7/lxml

copying src/lxml/etree_api.h -> build/lib.linux-x86_64-2.7/lxml

copying src/lxml/lxml.etree.h -> build/lib.linux-x86_64-2.7/lxml

copying src/lxml/lxml.etree_api.h -> build/lib.linux-x86_64-2.7/lxml

copying src/lxml/includes/xmlerror.pxd -> build/lib.linux-x86_64-2.7/lxml/includes

copying src/lxml/includes/xslt.pxd -> build/lib.linux-x86_64-2.7/lxml/includes

copying src/lxml/includes/htmlparser.pxd -> build/lib.linux-x86_64-2.7/lxml/includes

copying src/lxml/includes/config.pxd -> build/lib.linux-x86_64-2.7/lxml/includes

copying src/lxml/includes/__init__.pxd -> build/lib.linux-x86_64-2.7/lxml/includes

copying src/lxml/includes/xmlschema.pxd -> build/lib.linux-x86_64-2.7/lxml/includes

copying src/lxml/includes/uri.pxd -> build/lib.linux-x86_64-2.7/lxml/includes

copying src/lxml/includes/relaxng.pxd -> build/lib.linux-x86_64-2.7/lxml/includes

copying src/lxml/includes/etreepublic.pxd -> build/lib.linux-x86_64-2.7/lxml/includes

copying src/lxml/includes/xpath.pxd -> build/lib.linux-x86_64-2.7/lxml/includes

copying src/lxml/includes/tree.pxd -> build/lib.linux-x86_64-2.7/lxml/includes

copying src/lxml/includes/c14n.pxd -> build/lib.linux-x86_64-2.7/lxml/includes

copying src/lxml/includes/dtdvalid.pxd -> build/lib.linux-x86_64-2.7/lxml/includes

copying src/lxml/includes/xmlparser.pxd -> build/lib.linux-x86_64-2.7/lxml/includes

copying src/lxml/includes/schematron.pxd -> build/lib.linux-x86_64-2.7/lxml/includes

copying src/lxml/includes/xinclude.pxd -> build/lib.linux-x86_64-2.7/lxml/includes

copying src/lxml/includes/etree_defs.h -> build/lib.linux-x86_64-2.7/lxml/includes

copying src/lxml/includes/lxml-version.h -> build/lib.linux-x86_64-2.7/lxml/includes

creating build/lib.linux-x86_64-2.7/lxml/isoschematron/resources

creating build/lib.linux-x86_64-2.7/lxml/isoschematron/resources/rng

copying src/lxml/isoschematron/resources/rng/iso-schematron.rng -> build/lib.linux-x86_64-2.7/lxml/isoschematron/resources/rng

creating build/lib.linux-x86_64-2.7/lxml/isoschematron/resources/xsl

copying src/lxml/isoschematron/resources/xsl/XSD2Schtrn.xsl -> build/lib.linux-x86_64-2.7/lxml/isoschematron/resources/xsl

copying src/lxml/isoschematron/resources/xsl/RNG2Schtrn.xsl -> build/lib.linux-x86_64-2.7/lxml/isoschematron/resources/xsl

creating build/lib.linux-x86_64-2.7/lxml/isoschematron/resources/xsl/iso-schematron-xslt1

copying src/lxml/isoschematron/resources/xsl/iso-schematron-xslt1/iso_dsdl_include.xsl -> build/lib.linux-x86_64-2.7/lxml/isoschematron/resources/xsl/iso-schematron-xslt1

copying src/lxml/isoschematron/resources/xsl/iso-schematron-xslt1/iso_schematron_skeleton_for_xslt1.xsl -> build/lib.linux-x86_64-2.7/lxml/isoschematron/resources/xsl/iso-schematron-xslt1

copying src/lxml/isoschematron/resources/xsl/iso-schematron-xslt1/iso_svrl_for_xslt1.xsl -> build/lib.linux-x86_64-2.7/lxml/isoschematron/resources/xsl/iso-schematron-xslt1

copying src/lxml/isoschematron/resources/xsl/iso-schematron-xslt1/iso_schematron_message.xsl -> build/lib.linux-x86_64-2.7/lxml/isoschematron/resources/xsl/iso-schematron-xslt1

copying src/lxml/isoschematron/resources/xsl/iso-schematron-xslt1/iso_abstract_expand.xsl -> build/lib.linux-x86_64-2.7/lxml/isoschematron/resources/xsl/iso-schematron-xslt1

copying src/lxml/isoschematron/resources/xsl/iso-schematron-xslt1/readme.txt -> build/lib.linux-x86_64-2.7/lxml/isoschematron/resources/xsl/iso-schematron-xslt1

running build_ext

building 'lxml.etree' extension

creating build/temp.linux-x86_64-2.7

creating build/temp.linux-x86_64-2.7/src

creating build/temp.linux-x86_64-2.7/src/lxml

x86_64-linux-gnu-gcc -pthread -fno-strict-aliasing -DNDEBUG -g -fwrapv -O2 -Wall -Wstrict-prototypes -fPIC -I/usr/include/libxml2 -Isrc -Isrc/lxml/includes -I/usr/include/python2.7 -c src/lxml/etree.c -o build/temp.linux-x86_64-2.7/src/lxml/etree.o -w

src/lxml/etree.c:91:20: fatal error: Python.h: Tiedostoa tai hakemistoa ei ole

 #include "Python.h"

                    ^

compilation terminated.

Compile failed: command 'x86_64-linux-gnu-gcc' failed with exit status 1

creating tmp

cc -I/usr/include/libxml2 -I/usr/include/libxml2 -c /tmp/xmlXPathInite5sCSA.c -o tmp/xmlXPathInite5sCSA.o

cc tmp/xmlXPathInite5sCSA.o -lxml2 -o a.out

error: command 'x86_64-linux-gnu-gcc' failed with exit status 1

----------------------------------------
  Can't roll back lxml; was not uninstalled
Cleaning up...
Command /usr/bin/python -c "import setuptools, tokenize;__file__='/tmp/pip_build_root/lxml/setup.py';exec(compile(getattr(tokenize, 'open', open)(__file__).read().replace('\r\n', '\n'), __file__, 'exec'))" install --record /tmp/pip-tFMrsp-record/install-record.txt --single-version-externally-managed --compile failed with error code 1 in /tmp/pip_build_root/lxml
Storing debug log for failure in /home/late/.pip/pip.log

Sain kyllä toimivan version 2.23 asennettua uudestaan lataamalla koodit, vaikka silloinkin tuli joku python.h-error.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: nm - 10.10.17 - klo:23.43
Päivitys uusimpaan tökkii:

Koodia: [Valitse]
src/lxml/etree.c:91:20: fatal error: Python.h: Tiedostoa tai hakemistoa ei ole

Asenna python-dev:

Koodia: [Valitse]
sudo apt-get install python-dev
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: ls - 11.10.17 - klo:01.59
Asenna python-dev:

Koodia: [Valitse]
sudo apt-get install python-dev

Joo, samaa valitusta ei enää tullut. Nyt asennus kesti todella kauan ja lopulta tuli virhe:

Koodia: [Valitse]
build/temp.linux-x86_64-2.7/_openssl.c:483:30: fatal error: openssl/opensslv.h: Tiedostoa tai hakemistoa ei ole
Asensin paketin libssl-dev, minkä jälkeen uusi yritys. Taas kesti kauan, mutta näytti onnistuvan. Yle-dl ei kuitenkaan käynnistynyt:

Koodia: [Valitse]
yle-dl
Traceback (most recent call last):
  File "/usr/local/bin/yle-dl", line 9, in <module>
    load_entry_point('yle-dl==2.25', 'console_scripts', 'yle-dl')()
  File "/usr/lib/python2.7/dist-packages/pkg_resources.py", line 351, in load_entry_point
    return get_distribution(dist).load_entry_point(group, name)
  File "/usr/lib/python2.7/dist-packages/pkg_resources.py", line 2363, in load_entry_point
    return ep.load()
  File "/usr/lib/python2.7/dist-packages/pkg_resources.py", line 2088, in load
    entry = __import__(self.module_name, globals(),globals(), ['__name__'])
  File "/usr/local/lib/python2.7/dist-packages/yledl/__init__.py", line 1, in <module>
    from yledl import download, StreamAction
  File "/usr/local/lib/python2.7/dist-packages/yledl/yledl.py", line 38, in <module>
    from downloaders import downloader_factory, StreamFilters, IOContext, \
  File "/usr/local/lib/python2.7/dist-packages/yledl/downloaders.py", line 26, in <module>
    from requests.packages.urllib3.util.retry import Retry
ImportError: No module named packages.urllib3.util.retry

Yritin vielä lähdekoodihakemiston kautta:

Koodia: [Valitse]
sudo python setup.py install
Asentui parissa sekunnissa ja käynnistyi, mutta valitti:

Koodia: [Valitse]
yle-dl https://areena.yle.fi/1-2534632
yle-dl 2.25: Download media files from Yle Areena and Elävä Arkisto
Copyright (C) 2009-2017 Antti Ajanki <antti.ajanki@iki.fi>, license: GPLv3
Subtitles saved to Varo vasentasi-2017-10-09T02:00:00+03:00.fin.srt
Output file: Varo vasentasi-2017-10-09T02:00:00+03:00.mp4
wget: tunnistamaton valitsin ”--show-progress”
Käyttö: wget [VALITSIN]... [VERKKO-OSOITE]...

Kirjoita ”wget --help” saadaksesi lisää valitsimia.

Pitäisikö kenties olla eri versio wget'istä? Mulla näytti olevan 1.15.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: jekku - 11.10.17 - klo:06.31
.....
Koodia: [Valitse]
yle-dl https://areena.yle.fi/1-2534632
yle-dl 2.25: Download media files from Yle Areena and Elävä Arkisto
Copyright (C) 2009-2017 Antti Ajanki <antti.ajanki@iki.fi>, license: GPLv3
Subtitles saved to Varo vasentasi-2017-10-09T02:00:00+03:00.fin.srt
Output file: Varo vasentasi-2017-10-09T02:00:00+03:00.mp4
wget: tunnistamaton valitsin ”--show-progress”
Käyttö: wget [VALITSIN]... [VERKKO-OSOITE]...

Kirjoita ”wget --help” saadaksesi lisää valitsimia.

Pitäisikö kenties olla eri versio wget'istä? Mulla näytti olevan 1.15.

Minulla on (ihan pakettivaraston versio)
Koodia: [Valitse]
~/tmp$ wget -V
GNU Wget 1.18 käännetty järjestelmään linux-gnu.

man wget kertoo
 
Koodia: [Valitse]
   --show-progress
           Force wget to display the progress bar in any verbosity.

           By default, wget only displays the progress bar in verbose mode.  One may however, want wget to display the
           progress bar on screen in conjunction with any other verbosity modes like --no-verbose or --quiet.  This is
           often a desired a property when invoking wget to download several small/large files.  In such a case, wget
           could simply be invoked with this parameter to get a much cleaner output on the screen.

           This option will also force the progress bar to be printed to stderr when used alongside the --logfile
           option.

ja hienosti toimii.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Cultor - 11.10.17 - klo:11.31
.....
Koodia: [Valitse]
yle-dl https://areena.yle.fi/1-2534632
yle-dl 2.25: Download media files from Yle Areena and Elävä Arkisto
Copyright (C) 2009-2017 Antti Ajanki <antti.ajanki@iki.fi>, license: GPLv3
Subtitles saved to Varo vasentasi-2017-10-09T02:00:00+03:00.fin.srt
Output file: Varo vasentasi-2017-10-09T02:00:00+03:00.mp4
wget: tunnistamaton valitsin ”--show-progress”
Käyttö: wget [VALITSIN]... [VERKKO-OSOITE]...

Kirjoita ”wget --help” saadaksesi lisää valitsimia.

Pitäisikö kenties olla eri versio wget'istä? Mulla näytti olevan 1.15.

Minulla on (ihan pakettivaraston versio)
Koodia: [Valitse]
~/tmp$ wget -V
GNU Wget 1.18 käännetty järjestelmään linux-gnu.

man wget kertoo
 
Koodia: [Valitse]
   --show-progress
           Force wget to display the progress bar in any verbosity.

           By default, wget only displays the progress bar in verbose mode.  One may however, want wget to display the
           progress bar on screen in conjunction with any other verbosity modes like --no-verbose or --quiet.  This is
           often a desired a property when invoking wget to download several small/large files.  In such a case, wget
           could simply be invoked with this parameter to get a much cleaner output on the screen.

           This option will also force the progress bar to be printed to stderr when used alongside the --logfile
           option.

ja hienosti toimii.
Mistä Wget 1.18 version saisi Ubuntu 14.04.5 LTS:ään? Täällä oli samanlaiset ongelmat, tosin wget 1.15 toimii nyt, kun poistin --show-progress vivun downloaders.py:stä.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: jekku - 11.10.17 - klo:11.50
----
Mistä Wget 1.18 version saisi Ubuntu 14.04.5 LTS:ään? Täällä oli samanlaiset ongelmat, tosin wget 1.15 toimii nyt, kun poistin --show-progress vivun downloaders.py:stä.

Jos toimii nykyisellään niin älä suotta muuta mitään. Kai pian on aika päivittää tuo 14.04 muutenkin?
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: ls - 11.10.17 - klo:13.56
Mistä Wget 1.18 version saisi Ubuntu 14.04.5 LTS:ään? Täällä oli samanlaiset ongelmat, tosin wget 1.15 toimii nyt, kun poistin --show-progress vivun downloaders.py:stä.

Kun poistin --show-progress-vivun, yle-dl ei jostain syystä käynnistynyt. Latasin wget 1.18:n : ftp://ftp.gnu.org/gnu/wget/wget-1.18.tar.gz (http://ftp://ftp.gnu.org/gnu/wget/wget-1.18.tar.gz)

Asensin:

Koodia: [Valitse]
./configure --with-ssl=openssl
make
sudo make install

Ilman tuota ssl-vipua olisi pitänyt asentaa jostain gnutls.

Nyt toimii taas.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: mrl586 - 11.10.17 - klo:14.35
Eiköhän uudemmalle Ubuntulle tarkoitettu wget:n versio ole mahdollista backportata käyttäjän toimesta vanhempiin Ubuntuihin?
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: nm - 11.10.17 - klo:15.51
Eiköhän uudemmalle Ubuntulle tarkoitettu wget:n versio ole mahdollista backportata käyttäjän toimesta vanhempiin Ubuntuihin?

Parempi paikata yle-dl:ää. Jos ei onnistu omatoimisesti, korjausta odotellessa voi vaikka käyttää yle-dl:n --verbose -valitsinta, joka poistaa tuon --show-progress -vivun wgetin komentoriviltä:

Koodia: [Valitse]
yle-dl --verbose https://areena.yle.fi/1-2534632
Toki tuon kanssa joutuu sietämään yle-dl:n DEBUG-viestejä latauksen alussa.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Cultor - 11.10.17 - klo:17.04
Mistä Wget 1.18 version saisi Ubuntu 14.04.5 LTS:ään? Täällä oli samanlaiset ongelmat, tosin wget 1.15 toimii nyt, kun poistin --show-progress vivun downloaders.py:stä.

Kun poistin --show-progress-vivun, yle-dl ei jostain syystä käynnistynyt. Latasin wget 1.18:n : ftp://ftp.gnu.org/gnu/wget/wget-1.18.tar.gz (http://ftp://ftp.gnu.org/gnu/wget/wget-1.18.tar.gz)
Niin, muokkasin lähdekoodia ja muutin myös --no-verbose vivun muotoon --verbose, että sain progress bar'in näkyviin. Sen jälkeen uusi asennus, ensin pip install --upgrade yle-dl, sen jälkeen python setup.py install.

Oletusasetuksilla (--verbose) wget tulostaa parikymmentä riviä, jotkut tosin niin pitkiä, etteivät kaikki kerralla mahdu qPuttyn 80x30 ikkunaan. Ei haittaa minua yhtään, koska kaikki oleellinen on koko latauksen ajan näkyvissä.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: ls - 11.10.17 - klo:21.50
Niin, muokkasin lähdekoodia ja muutin myös --no-verbose vivun muotoon --verbose, että sain progress bar'in näkyviin. Sen jälkeen uusi asennus, ensin pip install --upgrade yle-dl, sen jälkeen python setup.py install.

Oletusasetuksilla (--verbose) wget tulostaa parikymmentä riviä, jotkut tosin niin pitkiä, etteivät kaikki kerralla mahdu qPuttyn 80x30 ikkunaan. Ei haittaa minua yhtään, koska kaikki oleellinen on koko latauksen ajan näkyvissä.

Ok, mutta miksi tuossa välissä tarvitaan tuo pip asennus?
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Cultor - 12.10.17 - klo:12.32
Niin, muokkasin lähdekoodia ja muutin myös --no-verbose vivun muotoon --verbose, että sain progress bar'in näkyviin. Sen jälkeen uusi asennus, ensin pip install --upgrade yle-dl, sen jälkeen python setup.py install.

Oletusasetuksilla (--verbose) wget tulostaa parikymmentä riviä, jotkut tosin niin pitkiä, etteivät kaikki kerralla mahdu qPuttyn 80x30 ikkunaan. Ei haittaa minua yhtään, koska kaikki oleellinen on koko latauksen ajan näkyvissä.

Ok, mutta miksi tuossa välissä tarvitaan tuo pip asennus?

En saanut muuten toimimaan.

Antilla näkyy olevan korjaukset seuraavaan versioon työn alla, joten eiköhän se siitä ;- )
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: rs - 23.10.17 - klo:22.32
toimiikos muilla yle-dl hyvin vaihtelevalla nopeudella? aluksi tulee nopeasti 4mb/s mutta hetken päästä tipahtaa 150kb/s tms hyvin hitaaseen nopeuteen. välillä tulee myös "read error" jonka jälkeen se yrittää uudelleen ja jälleen nopeammin, kunnes hidastuu. käytössä on uusin versio 2.26 ja ongelma toistuu useilla videoilla. aikaisemmilla versioilla en ole vastaavaa havainnut
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: juyli - 24.10.17 - klo:18.57
toimiikos muilla yle-dl hyvin vaihtelevalla nopeudella?
Yhteysnopeuden muutokset johtunevat yle:n palvelimista sekä omista verkkoyhteyksistä.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Tomin - 24.10.17 - klo:19.06
toimiikos muilla yle-dl hyvin vaihtelevalla nopeudella?
Yhteysnopeuden muutokset johtunevat yle:n palvelimista sekä omista verkkoyhteyksistä.

Yle käyttää Akamain palveluja, joten vähän luulen, että tuskin johtuu Ylen omista palvelimista. Tuolla vähän lisää aiheesta ja ihan hyvä kuvakin: Näin Areenan jakelu toimii | Yle Areena | Blogit | yle.fi (https://yle.fi/aihe/artikkeli/2015/01/15/nain-areenan-jakelu-toimii). Tietysti en pysty sanomaan, miten ajantasainen tuo kirjoituksen sisältö on.

Ei ole nyt ihan äsken tullut käytettyä yle-dl:ää nyt, kun tuli tuo HTML5-soitin ja olen voinut hyvin selaimesta toistaa suoraan.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: juyli - 24.10.17 - klo:20.35
Ei ole nyt ihan äsken tullut käytettyä yle-dl:ää nyt, kun tuli tuo HTML5-soitin ja olen voinut hyvin selaimesta toistaa suoraan.
Enhän minäkään tuota yle-dl:ää käytä - enkä suosittele ketään käyttämäänkään ;) Mutta jos nettiyhteyttä ei ole - tai se on huono (hidas ja epävarma), on varsin ikävää katsella suoratoisto-ohjelmia verkossa.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: epiphone - 24.10.17 - klo:20.44
Ei ole nyt ihan äsken tullut käytettyä yle-dl:ää nyt, kun tuli tuo HTML5-soitin ja olen voinut hyvin selaimesta toistaa suoraan.

Minulla ei toimi videoiden toisto Yle Areenassa. Kokeiltu on; Vivaldi, Firefox, Chrome. Chromestakin on uusin versio käytössä.
Valittaa flashin puuttumista. :(
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Tomin - 24.10.17 - klo:20.45
Ei ole nyt ihan äsken tullut käytettyä yle-dl:ää nyt, kun tuli tuo HTML5-soitin ja olen voinut hyvin selaimesta toistaa suoraan.
Enhän minäkään tuota yle-dl:ää käytä - enkä suosittele ketään käyttämäänkään ;) Mutta jos nettiyhteyttä ei ole - tai se on huono (hidas ja epävarma), on varsin ikävää katsella suoratoisto-ohjelmia verkossa.

Joo näinhän se on ja siihen se on mainio. En minä näe syytä, miksi yle-dl:ä ei voisi käyttää. Huomautin tuosta lähinnä siksi etten oikein pysty vastaamaan rs:n kysymykseen.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Tomin - 24.10.17 - klo:20.46
Ei ole nyt ihan äsken tullut käytettyä yle-dl:ää nyt, kun tuli tuo HTML5-soitin ja olen voinut hyvin selaimesta toistaa suoraan.

Minulla ei toimi videoiden toisto Yle Areenassa. Kokeiltu on; Vivaldi, Firefox, Chrome. Chromestakin on uusin versio käytössä.
Valittaa flashin puuttumista. :(

Jaa-a. Itse käytän sitä Fedorassa Firefoxin kanssa ja ihan hyvin se on toiminut. En tiedä onko jo kaikki vanhempi sisältö saatavilla HTML5-soittimella, mutta Murdochin murhamysteerejä (https://areena.yle.fi/1-2152401) ainakin katselin viime viikolla ihan sujuvasti.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: epiphone - 24.10.17 - klo:20.57
Jaa-a. Itse käytän sitä Fedorassa Firefoxin kanssa ja ihan hyvin se on toiminut. En tiedä onko jo kaikki vanhempi sisältö saatavilla HTML5-soittimella, mutta Murdochin murhamysteerejä (https://areena.yle.fi/1-2152401) ainakin katselin viime viikolla ihan sujuvasti.

Mitä pitää tehdä selaimelle, jotta se näyttäisi HTML-5 sisällöt?
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Tomin - 24.10.17 - klo:21.02
Jaa-a. Itse käytän sitä Fedorassa Firefoxin kanssa ja ihan hyvin se on toiminut. En tiedä onko jo kaikki vanhempi sisältö saatavilla HTML5-soittimella, mutta Murdochin murhamysteerejä (https://areena.yle.fi/1-2152401) ainakin katselin viime viikolla ihan sujuvasti.

Mitä pitää tehdä selaimelle, jotta se näyttäisi HTML-5 sisällöt?

Pitäisi näyttää ihan normaalisti oletuksena. Koodekkituki voi olla paketoijasta riippuen vajaa. https://www.youtube.com/html5 on sen suhteen ehkä paras sivu tarkistaa ne. Widevine ei näytä olevan tässä vaatimuksena, joten vaikea mennä sanomaan missä vika on, jos kaikki koodekit ovat käytettävissä.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: epiphone - 24.10.17 - klo:21.08
Pitäisi näyttää ihan normaalisti oletuksena. Koodekkituki voi olla paketoijasta riippuen vajaa. https://www.youtube.com/html5 on sen suhteen ehkä paras sivu tarkistaa ne. Widevine ei näytä olevan tässä vaatimuksena, joten vaikea mennä sanomaan missä vika on, jos kaikki koodekit ovat käytettävissä.

Laitan tässä kuvakaappauksen Youtuben sivuilta. Vivaldi-selain käytössä. Kuvan pitäisi näkyä liitteenä. ;)
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Cultor - 24.10.17 - klo:21.15
Eiköhän se johdu kovasta kuormituksesta palvelimilla tai yhteyksissä. Täällä yleensä tulee 830-840 kB/s, eli se mitä nimellisnopeudeltaan 8 Mbs ADSL antaa. Viime perjantaina latasin Viimeinen tango Halifaxissa samaan aikaan, kun se tuli suorana ulos. Nopeus vaihteli paljon ja viidennen read errorin jälkeen wget heitti leikin kesken. Parin tunnin päästä tuli maksiminopeudella.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: rs - 24.10.17 - klo:21.16
Enhän minäkään tuota yle-dl:ää käytä - enkä suosittele ketään käyttämäänkään ;) Mutta jos nettiyhteyttä ei ole - tai se on huono (hidas ja epävarma), on varsin ikävää katsella suoratoisto-ohjelmia verkossa.

itse olen käyttänyt lähinnä sen takia että olen huomannut "vielä ehdit" osiossa kiinnostavan ohjelman, mutta en ole sitä sillä hetkellä ehtinyt katsomaan. ja nettiyhteytenä minulla on 100/100 joka toimii kyllä kaikessa muussa hyvin ja tasaisesti, joten en usko että se aiheuttaisi tuota mainitsemaani hidastumista ja latauksen keskeytymistä

asiasta kolmanteen... tuo uusi versio käyttää luultavasti oletuksena parasta kuvanlaatua? vanhassa versiossa se näkyi minkä se valitsi mutta uudessa, en ole nähnyt siitä mainintaa
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: nm - 24.10.17 - klo:21.18
Minulla ei toimi videoiden toisto Yle Areenassa. Kokeiltu on; Vivaldi, Firefox, Chrome. Chromestakin on uusin versio käytössä.
Valittaa flashin puuttumista. :(

Chromessa Flashin toimivuus on kiinni vain siitä, että Flash on oletuksena blokattu, tai sen suoritus pitää erikseen hyväksyä, mutta se ei ainakaan Areenassa toimi käyttäjäystävällisesti. Klikkaa osoitepalkissa i- tai lukkokuvaketta (Näytä sivuston tiedot) ja valitse sieltä Flash -> Salli aina tässä sivustossa

Vaihtoehtoisesti voit kytkeä Flashin päälle kaikkialla avaamalla selaimeen sivun chrome://settings/content/flash ja sieltä Anna sivustojen suorittaa Flash päälle ja Kysy ensin pois päältä. Tässä on kuitenkin riskinsä, jos ja kun Flashissa on tietoturva-aukkoja. Parempi sallia suoritus sivustokohtaisesti.

Chromiumissa ja Vivaldissa voi olla sama ongelma, jos ne ylipäänsä löytävät Flash Playerin Chromen hakemistosta. Jos eivät, pitäisi asentaa PepperFlash erikseen.

Firefoxissa riittää että paketti flashplugin-installer on asennettuna.

Koodia: [Valitse]
sudo apt-get install flashplugin-installer

Jaa-a. Itse käytän sitä Fedorassa Firefoxin kanssa ja ihan hyvin se on toiminut. En tiedä onko jo kaikki vanhempi sisältö saatavilla HTML5-soittimella, mutta Murdochin murhamysteerejä (https://areena.yle.fi/1-2152401) ainakin katselin viime viikolla ihan sujuvasti.

Mitä pitää tehdä selaimelle, jotta se näyttäisi HTML-5 sisällöt?

Tavallisesti ei tarvitse tehdä mitään. Selain näyttää HTML5-sisällöt vakioasetuksillaan, jos sellaista sisältöä on sivustolla tarjolla. Voit tarkistaa tuen tällä sivulla: https://www.youtube.com/html5
Jos tuolla näkyy jotain muuta kuin sinisiä laatikoita, selaimessa on jokin ongelma. Ensimmäiseksi kannattaa luoda uusi selainprofiili. Yleensä ongelmat ratkeavat jo sillä.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Cultor - 24.10.17 - klo:21.19
Ei ole nyt ihan äsken tullut käytettyä yle-dl:ää nyt, kun tuli tuo HTML5-soitin ja olen voinut hyvin selaimesta toistaa suoraan.

Minulla ei toimi videoiden toisto Yle Areenassa. Kokeiltu on; Vivaldi, Firefox, Chrome. Chromestakin on uusin versio käytössä.
Valittaa flashin puuttumista. :(

Jaa-a. Itse käytän sitä Fedorassa Firefoxin kanssa ja ihan hyvin se on toiminut. En tiedä onko jo kaikki vanhempi sisältö saatavilla HTML5-soittimella, mutta Murdochin murhamysteerejä (https://areena.yle.fi/1-2152401) ainakin katselin viime viikolla ihan sujuvasti.

Ennen kesäkuun puolta väliä Areenaan tulleet ovat flässillä, samoin esmes uutiset ja muut suorana lähetetyt.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Tomin - 24.10.17 - klo:21.26
Pitäisi näyttää ihan normaalisti oletuksena. Koodekkituki voi olla paketoijasta riippuen vajaa. https://www.youtube.com/html5 on sen suhteen ehkä paras sivu tarkistaa ne. Widevine ei näytä olevan tässä vaatimuksena, joten vaikea mennä sanomaan missä vika on, jos kaikki koodekit ovat käytettävissä.

Laitan tässä kuvakaappauksen Youtuben sivuilta. Vivaldi-selain käytössä. Kuvan pitäisi näkyä liitteenä. ;)

Syystä tai toisesta h.264 ei ole käytössä ja Areena haluaisi käyttää juurikin sitä. Jossain selaimen asetuksissa tai paketoinnissa vika.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: epiphone - 24.10.17 - klo:21.31

Chromessa Flashin toimivuus on kiinni vain siitä, että Flash on oletuksena blokattu, tai sen suoritus pitää erikseen hyväksyä, mutta se ei ainakaan Areenassa toimi käyttäjäystävällisesti. Klikkaa osoitepalkissa i- tai lukkokuvaketta (Näytä sivuston tiedot) ja valitse sieltä Flash -> Salli aina tässä sivustossa

Vaihtoehtoisesti voit kytkeä Flashin päälle kaikkialla avaamalla selaimeen sivun chrome://settings/content/flash ja sieltä Anna sivustojen suorittaa Flash päälle ja Kysy ensin pois päältä. Tässä on kuitenkin riskinsä, jos ja kun Flashissa on tietoturva-aukkoja. Parempi sallia suoritus sivustokohtaisesti.

Tämä ratkaisi asian nyt näkyy Ylen uutiset, kitos jälleen nm.

Edit: Nyt toimii siis Chromella, Vivaldi edelleen epiksessä.

Edit2: Nyt toimii Firefox, Vivaldi ei.

Edit3: Nyt toimii Chrome, Firefox ja Vivaldi. Kiitos kaikille neuvojille.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: retu - 13.12.17 - klo:07.02
Jos sattuu että yle-dl lakkaa toimimasta (mulla lakkasi eilen), tämän nykyversion saa päivitettyä komennolla:
Koodia: [Valitse]
sudo pip install -U yle-dl
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: rs - 29.12.17 - klo:13.06
saako muut mr. robot ohjelmaa ladattua yle-dl:llä? minulla herjaa 404, mistähän tuo mahtaa johtua?
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: nm - 29.12.17 - klo:13.34
saako muut mr. robot ohjelmaa ladattua yle-dl:llä? minulla herjaa 404, mistähän tuo mahtaa johtua?

Latautuu 404:stä huolimatta normaalisti yle-dl 2.30:llä ja ffmpeg 3.4:llä:

Koodia: [Valitse]
yle-dl https://areena.yle.fi/1-4246285
Koodia: [Valitse]
yle-dl 2.30: Download media files from Yle Areena and Elävä Arkisto
Copyright (C) 2009-2017 Antti Ajanki <antti.ajanki@iki.fi>, license: GPLv3
Subtitles saved to Mr. Robot: S03E03: Legacy.so-2017-12-25T23:35.fin.srt
Output file: Mr. Robot: S03E03: Legacy.so-2017-12-25T23:35.mp4
--2017-12-29 13:32:41--  https://cdnapisec.kaltura.com/p/1955031/sp/195503100/playManifest/entryId/1_41v8j9bv/flavorId/0_f7ri0rey/format/url/protocol/https/a.mp4?referrer=aHR0cHM6Ly9hcmVlbmEueWxlLmZp&playSessionId=11111111-1111-1111-1111-111111111111&clientTag=html5:v2.56&preferredBitrate=600&uiConfId=37558971
Selvitetään osoitetta cdnapisec.kaltura.com (cdnapisec.kaltura.com)... 2.19.12.96
Yhdistetään palvelimeen cdnapisec.kaltura.com (cdnapisec.kaltura.com)|2.19.12.96|:443... yhdistetty.
HTTP-pyyntö lähetetty, odotetaan vastausta... 302 Moved Temporarily
Sijainti: https://cfvod.kaltura.com/fhls/p/1955031/sp/195503100/serveFlavor/entryId/1_41v8j9bv/v/2/ev/6/flavorId/0_f7ri0rey/name/a.mp4/index.m3u8 [seurataan]
--2017-12-29 13:32:42--  https://cfvod.kaltura.com/fhls/p/1955031/sp/195503100/serveFlavor/entryId/1_41v8j9bv/v/2/ev/6/flavorId/0_f7ri0rey/name/a.mp4/index.m3u8
Selvitetään osoitetta cfvod.kaltura.com (cfvod.kaltura.com)... 13.32.111.171
Yhdistetään palvelimeen cfvod.kaltura.com (cfvod.kaltura.com)|13.32.111.171|:443... yhdistetty.
HTTP-pyyntö lähetetty, odotetaan vastausta... 404 Not Found
2017-12-29 13:32:42 VIRHE 404: Not Found.

Output file: Mr. Robot: S03E03: Legacy.so-2017-12-25T23:35.mp4
frame=   39 fps= 30 q=-1.0 size=     768kB time=00:00:01.52 bitrate=4139.3kbits/
frame=  101 fps= 41 q=-1.0 size=    1792kB time=00:00:04.00 bitrate=3670.1kbits/
frame=  116 fps= 32 q=-1.0 size=    2304kB time=00:00:04.60 bitrate=4103.2kbits/
frame=  181 fps= 44 q=-1.0 size=    3584kB time=00:00:07.20 bitrate=4077.8kbits/
frame=  299 fps= 64 q=-1.0 size=    5376kB time=00:00:11.92 bitrate=3694.7kbits/
[...]
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: rs - 29.12.17 - klo:14.19
joo nähtävästi tuolla 2.30 toimii. itselläni oli 2.26, jostain syystä en onnistunut päivittämään pipillä sitä (jäi tähän kohtaan jumiin ja muistin kulutus vain kasvoi kokoajan: Running setup.py bdist_wheel for lxml ... \). mutta sorsasta sain asennettua tuon uusimman
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: fpsg6 - 25.07.18 - klo:13.17
Joko yle areenan lataus toimii 18.04:llä? Jos toimii niin saisiko ohjeita,kiitos.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Eesaurus - 25.07.18 - klo:15.46
Onhan se toiminut kaiken aikaa. Alla olevalla ohjeella itselleni sen asensin ja hyvin tallentaa:

Koodia: [Valitse]
sudo apt install rtmpdump wget ffmpeg python3-dev python3-setuptools \
    python3-pip python3-crypto python3-requests python3-lxml python3-socks \
    php-cli php-curl php-xml php-bcmath python-pip
ja
Koodia: [Valitse]
sudo pip install yle-dl
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: fpsg6 - 26.07.18 - klo:10.53
Onhan se toiminut kaiken aikaa. Alla olevalla ohjeella itselleni sen asensin ja hyvin tallentaa:

Koodia: [Valitse]
sudo apt install rtmpdump wget ffmpeg python3-dev python3-setuptools \
    python3-pip python3-crypto python3-requests python3-lxml python3-socks \
    php-cli php-curl php-xml php-bcmath python-pip
ja
Koodia: [Valitse]
sudo pip install yle-dl

Toimii,kiitän.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Hajakenttä - 11.09.18 - klo:19.23
Mitä mahtaa puuttua kun Yle Areena tai muutkaan videoleikkeet Ylen sivuilta eivät aukea 18.04 Xubuntulla? "Jotain meni väärin" sanoo ilmoitus. Parole sanoo, että puuttuu HTML purkaja. Kuinka sen löytäisi?

17.10 vielä avasi ne ilman kikkailuja.

Xubuntu-restricted-extras on asennettu Synapticilla ilman vaikutusta tähän asiaan, se ei ollut asentunut Xubuntun asennuksen mukana.

Onneksi yle-dl toimii tuolla edellä olevalla loitsulla ihan hyvin taas, kiitos siitä.  :)
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: nm - 11.09.18 - klo:19.31
Mitä mahtaa puuttua kun Yle Areena tai muutkaan videoleikkeet Ylen sivuilta eivät aukea 18.04 Xubuntulla? "Jotain meni väärin" sanoo ilmoitus. Parole sanoo, että puuttuu HTML purkaja. Kuinka sen löytäisi?

Yritätkö siis avata niitä mediasoittimella selaimen sijaan, vai yrittääkö selain avata mediasoittimen? Mikä selain on käytössä?
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Hajakenttä - 11.09.18 - klo:20.23
Mitä mahtaa puuttua kun Yle Areena tai muutkaan videoleikkeet Ylen sivuilta eivät aukea 18.04 Xubuntulla? "Jotain meni väärin" sanoo ilmoitus. Parole sanoo, että puuttuu HTML purkaja. Kuinka sen löytäisi?

Yritätkö siis avata niitä mediasoittimella selaimen sijaan, vai yrittääkö selain avata mediasoittimen? Mikä selain on käytössä?

Molemmilla tavoilla. Selaimena on Firefox 62.0. Yleensä ei ole tarvinnut muuta kuin klikata hiirellä videoleikettä Ylen sivulla tai Areenassa ja video on alkanut juosta. Mielestäni se ei yritä avata mitään mediasoitinta vaan Foxi itse pyörittää ne videot. Nyt siitä tulee vain virheilmoitus "jotain meni väärin, yritä uudestaan" (englanniksi). Myös kopioimalla linkin osoite VLC:n 'avaa suoratoisto verkosta' menettelyllä on avannut aina hyvin videon toiston, mutta ei nyt. Parole on oletuksena ja sitäkin kokeilin samalla tavalla ja se ilmoittaa suomeksi, että HTML-purkaja puuttuu ja sen voi asentaa automaattisesti, mutta ei kuitenkaan asenna, vaikka pyydetään. Parolea en ole aikaisemmin muistaakseni kokeillut, VLC:tä vain.

Tuossa vieressä on edelleen Ubuntu 16.04, jossa Areena toimii ihan hyvin Firefox 62.0 selaimessa. Ja tässä samassa laitteessa toimi hyvin vielä 17.10 Xubuntussa, siis Firefoxilla. En ole ihan varma muistinko laittaa 18.04 asentaessa ne kaikki ruksit, kolmannen osapuolen lisäkkeet ym. mutta yleensä kyllä laitan ne.

PS:
Kokeilin myös edellisellä kernelillä, koska tänään tuli uusi, mutta tulos on sama. Tarkistin myös, että ei ole kytkettynä mitään selaimen lisäkkeitä, jotka voisivat estää esim. Kalturan toiminnan.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: nm - 11.09.18 - klo:20.57
Molemmilla tavoilla. Selaimena on Firefox 62.0. Yleensä ei ole tarvinnut muuta kuin klikata hiirellä videoleikettä Ylen sivulla tai Areenassa ja video on alkanut juosta.

Heitä linkki johonkin videoon, joka ei toimi. Areenassa ja Elävässä arkistossa on edelleen jonkin verran vanhaa Flash-sisältöä, joka vaatii paketin flashplugin-installer asentamisen, jotta videot näkyvät Firefoxissa. Sen pitäisi kyllä tulla xubuntu-restricted-extras-paketin mukana, mutta kannattaa varmistaa, että paketti on varmasti asentunut.

Koodia: [Valitse]
sudo apt install flashplugin-installer
VLC:stä en osaa sanoa. Omassa koneessani Ubuntu 14.04:ssä on sen verran vanha versio, että se ei ainakaan tue HTML5- tai Flash-videoita Ylen sivuilla. Voin kokeilla huomenna Ubuntu 18.04:ssä.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Hajakenttä - 11.09.18 - klo:21.44
Asensin kyllä flashplugin-installerin, mutta en nyt äkkiä löydä mitään kokeiltavaa sillä, eikä ole väliksikään. En ole pitkiin aikoihin sitä käyttänyt. Jos jokin videoleike jollainn lehden sivulla sitä tarvitsee, niin se kyllä pyytää sen asentamaan. Yleensä ohitan sellaiset tarpeettomana.

Areenalla ja Ylen sivuilla olevat videot antavat kaikki virheilmoituksen, kuvakaappaus ohessa, kuten tämä linkin pätkä.

https://areena.yle.fi/1-50007243
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: nm - 11.09.18 - klo:21.50
Hmm. Toimii kyllä minulla Firefox 62:lla, kuten muutkin Ylen videot. Millainen tietokone on kyseessä? 32- vai 64-bittinen järjestelmä? Onko suorittimessa SSE2-tuki? Mitä kertoo:

Koodia: [Valitse]
cat /proc/cpuinfo

Edit: Epiphonella ilmenee nähtävästi sama vika, mutta Vivaldissa: https://forum.ubuntu-fi.org/index.php?topic=53636.0

Kannattanee tehdä vikailmoitus Ylelle: https://palaute.yle.fi/
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Hajakenttä - 11.09.18 - klo:22.17
Dell Latitude ja 64-bittinen sekä kone, että Xubuntu. Flags kohdassa on myös SSE2. Vähän vanha, mutta ihan kelpo kotikone. On tämä tosiaan Areenaakin soittanut ihan hyvin entisellä 17.10:llä.

Myös VLC keljuilee siten, että piilohakemistossa oleva video ei lähde käyntiin omaltakaan SSD muistilta. Kun siirtää sen kotihakemistoon, tai tavalliseen alihkemistoon, vaikka videot, niin sitten lähtee. Ei ole ennen ollut tuota ilmiötä, eikä pahemmin haittaa.

Koodia: [Valitse]
timo@romupaja:~$ cat /proc/cpuinfo
processor : 0
vendor_id : GenuineIntel
cpu family : 6
model : 42
model name : Intel(R) Core(TM) i3-2310M CPU @ 2.10GHz
stepping : 7
microcode : 0x2e
cpu MHz : 798.222
cache size : 3072 KB
physical id : 0
siblings : 4
core id : 0
cpu cores : 2
apicid : 0
initial apicid : 0
fpu : yes
fpu_exception : yes
cpuid level : 13
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc cpuid aperfmperf pni pclmulqdq dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm pcid sse4_1 sse4_2 x2apic popcnt tsc_deadline_timer xsave avx lahf_lm epb pti ssbd ibrs ibpb stibp tpr_shadow vnmi flexpriority ept vpid xsaveopt dtherm arat pln pts flush_l1d
bugs : cpu_meltdown spectre_v1 spectre_v2 spec_store_bypass l1tf
bogomips : 4190.60
clflush size : 64
cache_alignment : 64
address sizes : 36 bits physical, 48 bits virtual
power management:

processor : 1
vendor_id : GenuineIntel
cpu family : 6
model : 42
model name : Intel(R) Core(TM) i3-2310M CPU @ 2.10GHz
stepping : 7
microcode : 0x2e
cpu MHz : 798.293
cache size : 3072 KB
physical id : 0
siblings : 4
core id : 1
cpu cores : 2
apicid : 2
initial apicid : 2
fpu : yes
fpu_exception : yes
cpuid level : 13
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc cpuid aperfmperf pni pclmulqdq dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm pcid sse4_1 sse4_2 x2apic popcnt tsc_deadline_timer xsave avx lahf_lm epb pti ssbd ibrs ibpb stibp tpr_shadow vnmi flexpriority ept vpid xsaveopt dtherm arat pln pts flush_l1d
bugs : cpu_meltdown spectre_v1 spectre_v2 spec_store_bypass l1tf
bogomips : 4190.60
clflush size : 64
cache_alignment : 64
address sizes : 36 bits physical, 48 bits virtual
power management:

processor : 2
vendor_id : GenuineIntel
cpu family : 6
model : 42
model name : Intel(R) Core(TM) i3-2310M CPU @ 2.10GHz
stepping : 7
microcode : 0x2e
cpu MHz : 798.149
cache size : 3072 KB
physical id : 0
siblings : 4
core id : 0
cpu cores : 2
apicid : 1
initial apicid : 1
fpu : yes
fpu_exception : yes
cpuid level : 13
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc cpuid aperfmperf pni pclmulqdq dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm pcid sse4_1 sse4_2 x2apic popcnt tsc_deadline_timer xsave avx lahf_lm epb pti ssbd ibrs ibpb stibp tpr_shadow vnmi flexpriority ept vpid xsaveopt dtherm arat pln pts flush_l1d
bugs : cpu_meltdown spectre_v1 spectre_v2 spec_store_bypass l1tf
bogomips : 4190.60
clflush size : 64
cache_alignment : 64
address sizes : 36 bits physical, 48 bits virtual
power management:

processor : 3
vendor_id : GenuineIntel
cpu family : 6
model : 42
model name : Intel(R) Core(TM) i3-2310M CPU @ 2.10GHz
stepping : 7
microcode : 0x2e
cpu MHz : 798.241
cache size : 3072 KB
physical id : 0
siblings : 4
core id : 1
cpu cores : 2
apicid : 3
initial apicid : 3
fpu : yes
fpu_exception : yes
cpuid level : 13
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc cpuid aperfmperf pni pclmulqdq dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm pcid sse4_1 sse4_2 x2apic popcnt tsc_deadline_timer xsave avx lahf_lm epb pti ssbd ibrs ibpb stibp tpr_shadow vnmi flexpriority ept vpid xsaveopt dtherm arat pln pts flush_l1d
bugs : cpu_meltdown spectre_v1 spectre_v2 spec_store_bypass l1tf
bogomips : 4190.60
clflush size : 64
cache_alignment : 64
address sizes : 36 bits physical, 48 bits virtual
power management:

timo@romupaja:~$
 
[code]timo@romupaja:~$ cat /proc/cpuinfo
processor : 0
vendor_id : GenuineIntel
cpu family : 6
model : 42
model name : Intel(R) Core(TM) i3-2310M CPU @ 2.10GHz
stepping : 7
microcode : 0x2e
cpu MHz : 798.222
cache size : 3072 KB
physical id : 0
siblings : 4
core id : 0
cpu cores : 2
apicid : 0
initial apicid : 0
fpu : yes
fpu_exception : yes
cpuid level : 13
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc cpuid aperfmperf pni pclmulqdq dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm pcid sse4_1 sse4_2 x2apic popcnt tsc_deadline_timer xsave avx lahf_lm epb pti ssbd ibrs ibpb stibp tpr_shadow vnmi flexpriority ept vpid xsaveopt dtherm arat pln pts flush_l1d
bugs : cpu_meltdown spectre_v1 spectre_v2 spec_store_bypass l1tf
bogomips : 4190.60
clflush size : 64
cache_alignment : 64
address sizes : 36 bits physical, 48 bits virtual
power management:

processor : 1
vendor_id : GenuineIntel
cpu family : 6
model : 42
model name : Intel(R) Core(TM) i3-2310M CPU @ 2.10GHz
stepping : 7
microcode : 0x2e
cpu MHz : 798.293
cache size : 3072 KB
physical id : 0
siblings : 4
core id : 1
cpu cores : 2
apicid : 2
initial apicid : 2
fpu : yes
fpu_exception : yes
cpuid level : 13
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc cpuid aperfmperf pni pclmulqdq dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm pcid sse4_1 sse4_2 x2apic popcnt tsc_deadline_timer xsave avx lahf_lm epb pti ssbd ibrs ibpb stibp tpr_shadow vnmi flexpriority ept vpid xsaveopt dtherm arat pln pts flush_l1d
bugs : cpu_meltdown spectre_v1 spectre_v2 spec_store_bypass l1tf
bogomips : 4190.60
clflush size : 64
cache_alignment : 64
address sizes : 36 bits physical, 48 bits virtual
power management:

processor : 2
vendor_id : GenuineIntel
cpu family : 6
model : 42
model name : Intel(R) Core(TM) i3-2310M CPU @ 2.10GHz
stepping : 7
microcode : 0x2e
cpu MHz : 798.149
cache size : 3072 KB
physical id : 0
siblings : 4
core id : 0
cpu cores : 2
apicid : 1
initial apicid : 1
fpu : yes
fpu_exception : yes
cpuid level : 13
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc cpuid aperfmperf pni pclmulqdq dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm pcid sse4_1 sse4_2 x2apic popcnt tsc_deadline_timer xsave avx lahf_lm epb pti ssbd ibrs ibpb stibp tpr_shadow vnmi flexpriority ept vpid xsaveopt dtherm arat pln pts flush_l1d
bugs : cpu_meltdown spectre_v1 spectre_v2 spec_store_bypass l1tf
bogomips : 4190.60
clflush size : 64
cache_alignment : 64
address sizes : 36 bits physical, 48 bits virtual
power management:

processor : 3
vendor_id : GenuineIntel
cpu family : 6
model : 42
model name : Intel(R) Core(TM) i3-2310M CPU @ 2.10GHz
stepping : 7
microcode : 0x2e
cpu MHz : 798.241
cache size : 3072 KB
physical id : 0
siblings : 4
core id : 1
cpu cores : 2
apicid : 3
initial apicid : 3
fpu : yes
fpu_exception : yes
cpuid level : 13
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc cpuid aperfmperf pni pclmulqdq dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm pcid sse4_1 sse4_2 x2apic popcnt tsc_deadline_timer xsave avx lahf_lm epb pti ssbd ibrs ibpb stibp tpr_shadow vnmi flexpriority ept vpid xsaveopt dtherm arat pln pts flush_l1d
bugs : cpu_meltdown spectre_v1 spectre_v2 spec_store_bypass l1tf
bogomips : 4190.60
clflush size : 64
cache_alignment : 64
address sizes : 36 bits physical, 48 bits virtual
power management:

timo@romupaja:~$
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: nm - 11.09.18 - klo:22.20
Joo, ei ole prosessorista kiinni. Uudella selainprofiililla voisi kokeilla myös. Tai jollain toisella selaimella.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Hajakenttä - 11.09.18 - klo:23.45
Joo, ei ole prosessorista kiinni. Uudella selainprofiililla voisi kokeilla myös. Tai jollain toisella selaimella.

 Näin näyttäisi tosiaan olevan. Kokeilin parilla toisella selaimella. Firefox-esr on myös Quantum, mutta pari pykälää vanhempi 60.4 ja sama vaiva on silläkin, ei toimi video. Löytyi stten kevyen tuntuinen selain omasta ohjelmavarastosta. Se on siellä nimellä Gnomen verkkoselain. Kertoo olevansa vanhastaan tunnettu nimellä Epiphany. Pyörittää Ylen Areenan videoita ihan moitteettomasti, ainakin näin pikaisesti muutamia kokeilemalla.  Se saa siis toimia Ylen osalla selaimen virassa, ja tuntuu se muutenkin ihan näppärältä.

Kiitos avusta... ;)
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Hajakenttä - 12.09.18 - klo:12.45
Jatkan vielä hiukan kun tuli tarvetta katsoa opetusvideota erään moottorivalmistajan sivuilta ja sekään ei Firefoxilla toimi. Sekin on selvää HTML5 mallia, eikä mitään flashia, eikä sillä ole mitään tekemistaä Ylen kanssa, ja näkyy mainiosti juuri tuolla Gnomen selaimella, eli Epiphanylla. Syyttävä sormi kääntyy nyt kohti Mozillaa ja selaimen ja 18.04 Ubuntun epäsovitusta. Xubuntu 17.10 vielä näytti hyvin kaikki videot. Myös 16.04 LTS Ubuntu näyttää tällä uusimmalla Firefoxilla videota ihan hyvin.

Syyttävä sormi voisi osoittaa myös 18.04 jakelua/uusinta kerneliä, koska striimaus verkon yli takkuaa pahasti myös Rytmilaatikolla ja VLC:llä. Mainitakoon vielä, että juuri Rytmilaatikolla ja VLC:llä striimaan Ylen radio-ohjelmaa vahvistimeen Xubuntu 14.04 jakelulla mainiosti. (Täällä raukoilla rajoilla ei antennista saa edes radio-ohjelmaa tältä Yleltä, jota me oikein korvamerkityllä verolla rahoitamme.)

EDIT:
Unohtui vielä mainita, että Youtube näkyy hyvin Bionicilla, mutta ei Vimeo.  :o
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Cultor - 13.09.18 - klo:10.15
Jäljet johtavat Ylen sylttytehtaalle.
https://yle.fi/aihe/artikkeli/2018/09/12/uusi-soitin-helpottaa-areenan-kayttoa

Helpottaa todella, ei tarvitse selaimella katsoa ollenkaan. Mikään video ei ei Yleltä näy enää. Ei tuolla paljon väliä ole, yle-dl hoitaa homman.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: raimo - 13.09.18 - klo:10.26
Jäljet johtavat Ylen sylttytehtaalle.
https://yle.fi/aihe/artikkeli/2018/09/12/uusi-soitin-helpottaa-areenan-kayttoa

Helpottaa todella, ei tarvitse selaimella katsoa ollenkaan. Mikään video ei ei Yleltä näy enää. Ei tuolla paljon väliä ole, yle-dl hoitaa homman.

Google Chromella toimii ongelmitta.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: salai - 13.09.18 - klo:11.10
Jäljet johtavat Ylen sylttytehtaalle.
https://yle.fi/aihe/artikkeli/2018/09/12/uusi-soitin-helpottaa-areenan-kayttoa

Helpottaa todella, ei tarvitse selaimella katsoa ollenkaan. Mikään video ei ei Yleltä näy enää. Ei tuolla paljon väliä ole, yle-dl hoitaa homman.
En minä ole huomannut mitään ongelmia. Ubuntu 18.04-pohjainen Peppermint 9, kerneli 4.15.0-34, selain Firefox 62.0. Näyttäisivät (ainakin uudemmat videot) toimivan, vaikka Flashin ottaa pois käytöstä
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Hajakenttä - 13.09.18 - klo:12.23
Mutta... Miten saadaan Areena ja Vimeo näkymään Bionicilla?

Vivaldille näkyy riittäneen jonkin koodekin asentaminen. Mikä se olisi Firefoxille?

Yle on kehittänyt omiansa videosoittimeen, mitä lie muutettu Vimeoon? Kaikki muu HTML video näkyy toimivan Foxilla ja Bionicilla. Saahan nämä toimimaan muilla selaimilla, mutta onko se nyt ihan sivistynyttä, hyppiä selaimesta toiseen sen mukaan mitä sivuja tahtoo.

Vaimo ei anna asentaa 18.04 Ubuntua "kun ei se ole valmis", 16.04 toimii hyvin.

Ehkä hyvät ihmiset korjaavat koodia kunhan ehtivät. Äiti opetti, että kun Timo kiltisti odottaa niin Timo sitten saa. Yleensä on saanut.
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: juylii - 14.09.18 - klo:01.33
Mutta... Miten saadaan Areena ja Vimeo näkymään Bionicilla?
Yle Areena toimii kuten ennenkin täysin ongelmitta eri selainversioilla.
Vimeoon en ole tutustunut - mikä sitten lieneekään?
Otsikko: Vs: Näin saat toimimaan: YLE Areena ja Elävä arkisto
Kirjoitti: Hajakenttä - 19.09.18 - klo:19.59
Joo, ei ole prosessorista kiinni. Uudella selainprofiililla voisi kokeilla myös. Tai jollain toisella selaimella.

Kiukun hiukan tyynnyttyä jatkoin harjoitusta. Nimesin toiselle nimelle Firefox asetustiedostojen kansion ja asensin uudestaan koko Firefoxin ja sehän alkoi toimia. Tai siis Ylen ja Vimeon videot alkoivat toimia.

Tämä ongelma siis tuli ratkaistuksi pienellä huolellisuudella. Kiitos avusta.  :)